bookview-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118
  1. Summary: BookView is a NDTP client.
  2. Summary(ja): BookView - NDTP クライアント
  3. Name: bookview
  4. Version: 3.2.1
  5. Release: 1%{?_dist_release}
  6. Source: ftp://ftp.sra.co.jp/pub/net/ndtp/bookview/%{name}-%{version}.tar.gz
  7. Source1: %{name}-redhat.tar.gz
  8. License: GPL
  9. Group: Applications/Text
  10. Url: http://www.sra.co.jp/people/m-kasahr/bookview/
  11. Buildarch: noarch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. Requires: tcl >= 8.0.5_jp
  14. Requires: tk >= 8.0.5_jp
  15. BuildRequires: tcl >= 8.4
  16. BuildRequires: tk >= 8.4
  17. %define tkpath %{_datadir}/tk8.4
  18. %define appsdir /etc/X11/applnk
  19. %define docpath %{_docdir}/%{name}-%{version}
  20. %description
  21. BookView is a NDTP (Network Dictionary Transfer Protocol) client
  22. written in Tcl /Tk. It requires Tcl/Tk8.0jp or Tcl/Tk8.3 and higher
  23. (`jp' means `Japanized version').
  24. #'
  25. %description -l ja
  26. BookView は CD-ROM 書籍を読むための、Tcl/Tkで書かれた NDTP
  27. (Network Dictionary Transfer Protocol) クライアントです。
  28. 動作させるには Tcl/Tk8.0jp あるいは Tcl/Tk8.3 以上が必要です。
  29. %prep
  30. rm -rf $RPM_BUILD_ROOT
  31. %setup -q -a 1
  32. %build
  33. ./configure --prefix=%{_prefix} \
  34. --sysconfdir=/etc/%{name} \
  35. --infodir=%{_infodir}
  36. make
  37. %install
  38. make DESTDIR=$RPM_BUILD_ROOT install
  39. install -d $RPM_BUILD_ROOT/etc/%{name}
  40. install -m 644 %{name}.conf $RPM_BUILD_ROOT/etc/%{name}
  41. install -d $RPM_BUILD_ROOT%{_datadir}/pixmaps
  42. install -m 644 *.xpm $RPM_BUILD_ROOT%{_datadir}/pixmaps
  43. install -d $RPM_BUILD_ROOT%{appsdir}/Applications
  44. install -m 644 *.desktop $RPM_BUILD_ROOT%{appsdir}/Applications
  45. echo "Categories=Application;Utility;" >> \
  46. $RPM_BUILD_ROOT%{appsdir}/Applications/BookView.desktop
  47. %clean
  48. rm -rf $RPM_BUILD_ROOT
  49. %post
  50. if [ -x /bin/grep -a -f /etc/services ] ; then
  51. grep -q "^ndtp" /etc/services || \
  52. echo "ndtp 2010/tcp # added by bookview RPM" >> /etc/services
  53. fi
  54. if [ -f %{tkpath}/kinput.tcl -a -x /bin/grep -a -x /bin/sed ]; then
  55. if ! grep -q 'set KIStart .*<Shift-space>' %{tkpath}/kinput.tcl; then
  56. cat %{tkpath}/kinput.tcl | \
  57. sed 's/set KIStart "/set KIStart "<Shift-space> /' \
  58. > %{tkpath}/kinput.tmp
  59. mv %{tkpath}/kinput.tcl %{tkpath}/kinput.tcl.rpmsave
  60. echo Original file is saved as %{tkpath}/kinput.tcl.rpmsave
  61. mv %{tkpath}/kinput.tmp %{tkpath}/kinput.tcl
  62. fi
  63. fi
  64. %files
  65. %defattr(-,root,root)
  66. %doc [ACNR]*
  67. %{_bindir}/*
  68. %dir /etc/%{name}
  69. %config(missingok) /etc/%{name}/*
  70. %{_datadir}/bookview/*
  71. %{_datadir}/pixmaps/*.xpm
  72. %config(missingok) %{appsdir}/Applications/*.desktop
  73. %changelog
  74. * Tue Feb 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  75. - update to 3.2.1
  76. - add BuildRequires: tk
  77. * Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-1vl5
  78. - applied new versioning policy, spec in utf-8
  79. * Sun Dec 5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-0vl3
  80. - fixed .desktop
  81. * Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-0vl2
  82. - fixed spec file encoding (it was utf-8...)
  83. - fixed Group to Applications/Text
  84. * Wed Jun 25 2003 Masaki Shinomiya <shino@pos.to> 3.2-0vl1
  85. - new upstream release supports Tcl/Tk-8.3 and higher
  86. - noarch, omit documents for install
  87. - buildrequire tcl >= 8.4 to prevent to rebuild on Vine 2.x
  88. -
  89. - if you want to use this version on Vine 2.x,
  90. - just install noarch.rpm build with tcl >= 8.4.
  91. - it may works.
  92. * Sat Jun 14 2003 Masaki Shinomiya <shino@pos.to> 3.1.1-0vl1
  93. - post install script to modify services and kinput.tcl
  94. - configure with specifying sysconfdir and infdir
  95. - files, add luncher, description ja, requires, bookview.conf
  96. - requires, buildprereq
  97. * Sun May 20 2001 UECHI Yasumasa <uh@u.dhis.portside.net>
  98. - 1st release