brltty-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631
  1. %define pkg_version 5.2
  2. %define api_version 0.6.3
  3. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  4. %{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
  5. %{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
  6. %{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
  7. #define _exec_prefix %{nil}
  8. #define _libdir /%{_lib}
  9. # with speech dispatcher iff on Fedora:
  10. %define with_speech_dispatcher 1
  11. %define with_ocaml 1
  12. Name: brltty
  13. Version: %{pkg_version}
  14. Release: 3%{?_dist_release}
  15. Summary: Braille display driver for Linux/Unix
  16. License: GPLv2+
  17. Group: System Environment/Daemons
  18. URL: http://mielke.cc/brltty/
  19. Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.xz
  20. Patch4: brltty-loadLibrary.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: bluez-libs-devel
  23. BuildRequires: byacc
  24. BuildRequires: gettext
  25. BuildRequires: glibc-kernheaders
  26. # work around a bug in the install process:
  27. Requires(post): coreutils
  28. %description
  29. BRLTTY is a background process (daemon) which provides
  30. access to the Linux/Unix console (when in text mode)
  31. for a blind person using a refreshable braille display.
  32. It drives the braille display and provides complete
  33. screen review functionality.
  34. %if %{with_speech_dispatcher}
  35. BRLTTY can also work with speech synthetizers; if you want to use it with
  36. Speech Dispatcher, please install also package %{name}-speech-dispatcher.
  37. %package speech-dispatcher
  38. Summary: Speech Dispatcher driver for BRLTTY
  39. Group: System Environment/Daemons
  40. License: GPLv2+
  41. BuildRequires: speech-dispatcher-devel
  42. Requires: %{name} = %{pkg_version}-%{release}
  43. %description speech-dispatcher
  44. This package provides the Speech Dispatcher driver for BRLTTY.
  45. %endif
  46. %package docs
  47. Summary: Documentation for BRLTTY
  48. Summary(ja): BRLTTY のドキュメント
  49. Group: Documentation
  50. License: GPLv2+
  51. Requires: %{name} = %{pkg_version}-%{release}
  52. BuildArch: noarch
  53. %description docs
  54. This package provides the documentation for BRLTTY.
  55. %package xw
  56. Summary: XWindow driver for BRLTTY
  57. Group: System Environment/Daemons
  58. License: GPLv2+
  59. BuildRequires: libSM-devel
  60. BuildRequires: libICE-devel
  61. BuildRequires: libX11-devel
  62. BuildRequires: libXaw-devel
  63. BuildRequires: libXext-devel
  64. BuildRequires: libXt-devel
  65. BuildRequires: libXtst-devel
  66. Requires: %{name} = %{pkg_version}-%{release}
  67. %description xw
  68. This package provides the XWindow driver for BRLTTY.
  69. %package at-spi
  70. Summary: AtSpi driver for BRLTTY
  71. Group: System Environment/Daemons
  72. # The data files are licensed under LGPLv2+, see the README file.
  73. License: GPLv2+ and LGPLv2+
  74. BuildRequires: at-spi-devel
  75. Requires: %{name} = %{pkg_version}-%{release}
  76. %description at-spi
  77. This package provides the AtSpi driver for BRLTTY.
  78. %package -n brlapi
  79. Summary: Appliation Programming Interface for BRLTTY
  80. Summary(ja): BRLTTY の API
  81. Version: %{api_version}
  82. Group: Applications/System
  83. License: LGPLv2+
  84. Requires: %{name} = %{pkg_version}-%{release}
  85. %description -n brlapi
  86. This package provides the run-time support for the Application
  87. Programming Interface to BRLTTY.
  88. Install this package if you have an application which directly accesses
  89. a refreshable braille display.
  90. %package -n brlapi-devel
  91. Summary: Headers, static archive, and documentation for BrlAPI
  92. Summary(ja): BrlAPI の開発用ファイル
  93. Version: %{api_version}
  94. Group: Development/Libraries
  95. License: LGPLv2+
  96. Requires: brlapi = %{api_version}-%{release}
  97. %description -n brlapi-devel
  98. This package provides the header files, static archive, shared object
  99. linker reference, and reference documentation for BrlAPI (the
  100. Application Programming Interface to BRLTTY). It enables the
  101. implementation of applications which take direct advantage of a
  102. refreshable braille display in order to present information in ways
  103. which are more appropriate for blind users and/or to provide user
  104. interfaces which are more specifically atuned to their needs.
  105. Install this package if you are developing or maintaining an application
  106. which directly accesses a refreshable braille display.
  107. %package -n tcl-brlapi
  108. Summary: Tcl binding for BrlAPI
  109. Summary(ja): BrlAPI の Tcl バインディング
  110. Version: %{api_version}
  111. Group: Development/Libraries
  112. License: LGPLv2+
  113. BuildRequires: tcl-devel
  114. Requires: brlapi = %{api_version}-%{release}
  115. %description -n tcl-brlapi
  116. This package provides the Tcl binding for BrlAPI.
  117. %package -n python-brlapi
  118. Summary: Python binding for BrlAPI
  119. Summary(ja): BrlAPI の Python バインディング
  120. Version: %{api_version}
  121. Group: Development/Libraries
  122. License: LGPLv2+
  123. BuildRequires: Cython
  124. BuildRequires: python-devel
  125. BuildRequires: python-setuptools
  126. Requires: brlapi = %{api_version}-%{release}
  127. %description -n python-brlapi
  128. This package provides the Python binding for BrlAPI.
  129. %package -n python3-brlapi
  130. Summary: Python 3 binding for BrlAPI
  131. Summary(ja): BrlAPI の Python バインディング
  132. Version: %{api_version}
  133. Group: Development/Libraries
  134. License: LGPLv2+
  135. Requires: brlapi = %{api_version}-%{release}
  136. BuildRequires: Cython
  137. BuildRequires: python3-devel
  138. %description -n python3-brlapi
  139. This package provides the Python 3 binding for BrlAPI.
  140. %package -n brlapi-java
  141. Summary: Java binding for BrlAPI
  142. Summary(ja): BrlAPI の Java バインディング
  143. Version: %{api_version}
  144. Group: Development/Libraries
  145. License: LGPLv2+
  146. Requires: brlapi = %{api_version}-%{release}
  147. ## temporary work around, java-devel is not resolved consistently acrss archs
  148. BuildRequires: java-devel
  149. #BuildRequires: java-1.5.0-gcj-devel
  150. %description -n brlapi-java
  151. This package provides the Java binding for BrlAPI.
  152. %if %{with_ocaml}
  153. %package -n ocaml-brlapi
  154. Summary: OCaml binding for BrlAPI
  155. Summary(ja): BrlAPI の OCaml バインディング
  156. Version: %{api_version}
  157. Group: Development/Libraries
  158. License: LGPLv2+
  159. Requires: brlapi = %{api_version}-%{release}
  160. BuildRequires: ocaml
  161. BuildRequires: ocaml-findlib
  162. %description -n ocaml-brlapi
  163. This package provides the OCaml binding for BrlAPI.
  164. %endif
  165. %define version %{pkg_version}
  166. %prep
  167. %setup -q
  168. %patch4 -p1 -b .loadLibrary
  169. #patch5 -p1
  170. # Make a copy of the source tree for building the Python 3 module
  171. rm -rf ../python3
  172. cp -a . ../python3
  173. %build
  174. # If MAKEFLAGS=-jN is set it would break local builds.
  175. unset MAKEFLAGS
  176. # Add the openjdk include directories to CPPFLAGS
  177. for i in -I/usr/lib/jvm/java/include{,/linux}; do
  178. java_inc="$java_inc $i"
  179. done
  180. export CPPFLAGS="$java_inc"
  181. export CFLAGS="%{optflags} -I%{_includedir}/speech-dispatcher -fno-strict-aliasing"
  182. export CXXFLAGS="%{optflags} -I%{_includedir}/speech-dispatcher -fno-strict-aliasing"
  183. # there is no curses packages in BuildRequires, so the package builds
  184. # without them in mock; let's express this decision explicitly
  185. configure_opts=" \
  186. --disable-stripping \
  187. --without-curses \
  188. %if %{with_speech_dispatcher}
  189. --with-speechd=%{_prefix} \
  190. %endif
  191. --with-install-root=$RPM_BUILD_ROOT \
  192. JAVA_JAR_DIR=%{_jnidir} \
  193. JAVA_JNI_DIR=%{_libdir}/brltty \
  194. JAVA_JNI=yes"
  195. # First build everything with Python 2 support
  196. %configure $configure_opts PYTHON=%{__python}
  197. # Parallel build seems broken, thus disabling it
  198. make
  199. # ... and then do it again for the Python 3 module
  200. pushd ../python3
  201. %configure $configure_opts PYTHON=%{_bindir}/python3
  202. # Parallel build seems broken, thus disabling it
  203. make
  204. popd
  205. find . \( -path ./doc -o -path ./Documents \) -prune -o \
  206. \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o \
  207. -name '*.sgml' -o -name '*.patch' -o \
  208. \( -path './Bootdisks/*' -type f -perm /ugo=x \) \) -print |
  209. while read file; do
  210. mkdir -p doc/${file%/*} && cp -rp $file doc/$file || exit 1
  211. done
  212. find . -name '*.sgml' |
  213. while read file; do
  214. iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
  215. done
  216. find . -name '*.txt' |
  217. while read file; do
  218. iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
  219. done
  220. find . -name 'README*' |
  221. while read file; do
  222. iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
  223. done
  224. # backup Documents
  225. cp -a Documents Documents.buildsnap
  226. %install
  227. rm -rf $RPM_BUILD_ROOT
  228. rm -rf Documents
  229. cp -a Documents.buildsnap Documents
  230. %if %{with_ocaml}
  231. mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
  232. %endif
  233. make install JAVA_JAR_DIR=%{_jnidir} \
  234. JAVA_JNI_DIR=%{_libdir}/brltty \
  235. JAVA_JNI=yes
  236. pushd ../python3
  237. make install JAVA_JAR_DIR=%{_jnidir} \
  238. JAVA_JNI_DIR=%{_libdir}/brltty \
  239. JAVA_JNI=yes
  240. popd
  241. rm -rf ../python3
  242. install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT%{_mandir}/man5
  243. install -m 644 Documents/brltty.conf ${RPM_BUILD_ROOT}%{_sysconfdir}
  244. echo ".so man1/brltty.1" > $RPM_BUILD_ROOT%{_mandir}/man5/brltty.conf.5
  245. # clean up the manuals:
  246. rm Documents/Manual-*/*/{*.mk,*.made,Makefile*}
  247. mv Documents/BrlAPIref/{html,BrlAPIref}
  248. # Don't want static lib
  249. rm -rf $RPM_BUILD_ROOT%{_libdir}/libbrlapi.a
  250. # ghost brlapi.key
  251. touch $RPM_BUILD_ROOT%{_sysconfdir}/brlapi.key
  252. # disable xbrlapi gdm autostart, there is already orca
  253. rm -f $RPM_BUILD_ROOT%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
  254. # handle locales
  255. %find_lang %{name}
  256. %clean
  257. rm -rf $RPM_BUILD_ROOT
  258. %post
  259. devices="/dev/vcsa /dev/vcsa0 /dev/vcc/a"
  260. install=true
  261. for device in ${devices}
  262. do
  263. if [ -c "${device}" ]
  264. then
  265. install=false
  266. break
  267. fi
  268. done
  269. if $install
  270. then
  271. device="$(set -- ${devices} && echo "${1}")"
  272. mkdir -p "${device%/*}"
  273. mknod -m o= "${device}" c 7 128
  274. chmod 660 "${device}"
  275. chown root.tty "${device}"
  276. fi
  277. exit 0
  278. %pre -n brlapi
  279. getent group brlapi >/dev/null || groupadd -r brlapi >/dev/null
  280. %post -n brlapi
  281. if [ ! -e %{_sysconfdir}/brlapi.key ]; then
  282. mcookie > %{_sysconfdir}/brlapi.key
  283. chgrp brlapi %{_sysconfdir}/brlapi.key
  284. chmod 0640 %{_sysconfdir}/brlapi.key
  285. fi
  286. /sbin/ldconfig
  287. %postun -n brlapi -p /sbin/ldconfig
  288. %files -f %{name}.lang
  289. %defattr(-,root,root)
  290. %doc LICENSE-GPL LICENSE-LGPL
  291. %config(noreplace) %{_sysconfdir}/brltty.conf
  292. %{_sysconfdir}/brltty/
  293. %{_bindir}/brltty
  294. %{_bindir}/brltty-*
  295. %{_libdir}/brltty/
  296. %exclude %{_libdir}/brltty/libbrlttybba.so
  297. %exclude %{_libdir}/brltty/libbrlttybxw.so
  298. %exclude %{_libdir}/brltty/libbrlapi_java.so
  299. %if %{with_speech_dispatcher}
  300. %exclude %{_libdir}/brltty/libbrlttyssd.so
  301. %endif
  302. %exclude %{_libdir}/brltty/libbrlttyxas.so
  303. %{_mandir}/man[15]/brltty.*
  304. %if %{with_speech_dispatcher}
  305. %files speech-dispatcher
  306. %defattr(-,root,root)
  307. %doc Drivers/Speech/SpeechDispatcher/README
  308. %{_libdir}/brltty/libbrlttyssd.so
  309. %endif
  310. %files docs
  311. %defattr(-,root,root)
  312. %doc Documents/ChangeLog Documents/TODO
  313. %doc Documents/Manual-BRLTTY/
  314. %doc doc/*
  315. %files xw
  316. %defattr(-,root,root)
  317. %doc Drivers/Braille/XWindow/README
  318. %{_libdir}/brltty/libbrlttybxw.so
  319. %files at-spi
  320. %defattr(-,root,root)
  321. %{_libdir}/brltty/libbrlttyxas.so
  322. %files -n brlapi
  323. %defattr(-,root,root)
  324. %doc Drivers/Braille/XWindow/README
  325. %doc Documents/Manual-BrlAPI/
  326. %ghost %{_sysconfdir}/brlapi.key
  327. %{_bindir}/vstp
  328. %{_bindir}/eutp
  329. %{_bindir}/xbrlapi
  330. %{_libdir}/brltty/libbrlttybba.so
  331. %{_libdir}/libbrlapi.so.*
  332. %{_mandir}/man1/xbrlapi.*
  333. %{_mandir}/man1/vstp.*
  334. %{_mandir}/man1/eutp.*
  335. %files -n brlapi-devel
  336. %defattr(-,root,root)
  337. %doc Documents/BrlAPIref/BrlAPIref/
  338. %{_libdir}/libbrlapi.so
  339. %{_includedir}/brltty
  340. %{_includedir}/brlapi*.h
  341. %{_mandir}/man3/brlapi_*.3*
  342. %files -n tcl-brlapi
  343. %defattr(-,root,root)
  344. %{_libdir}/tcl%{tcl_version}/brlapi-%{api_version}
  345. %files -n python-brlapi
  346. %defattr(-,root,root)
  347. %{python_sitearch}/brlapi.so
  348. %{python_sitearch}/Brlapi-%{api_version}-py%{pyver}.egg-info
  349. %files -n python3-brlapi
  350. %defattr(-,root,root)
  351. %{python3_sitearch}/brlapi.cpython-*.so
  352. %{python3_sitearch}/Brlapi-%{api_version}-*.egg-info
  353. %files -n brlapi-java
  354. %defattr(-,root,root)
  355. %{_libdir}/brltty/libbrlapi_java.so
  356. %{_jnidir}/brlapi.jar
  357. %if %{with_ocaml}
  358. %files -n ocaml-brlapi
  359. %defattr(-,root,root)
  360. %{_libdir}/ocaml/brlapi/
  361. %{_libdir}/ocaml/stublibs/
  362. %endif
  363. %changelog
  364. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-3
  365. - rebuild with python3-3.5.2
  366. * Wed Apr 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-2
  367. - add BuildRequires: python3-devel
  368. - create python3-brlapi subpackage
  369. * Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.2-1
  370. - updated to 5.2
  371. - added speech-dispatcher, doc, and ocaml subpackages
  372. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2-2
  373. - rebuild with python-2.7.2
  374. * Fri Nov 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2-1
  375. - initial build for Vine Linux
  376. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2-4
  377. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  378. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 4.2-3
  379. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  380. * Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-2
  381. - rework parallel patch slightly and reapply
  382. * Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-1
  383. - update to 4.2
  384. - drop static lib (bz 556041)
  385. - fix undefined S_ISCHR call
  386. * Wed Jan 20 2010 Stepan Kasal <skasal@redhat.com> - 4.1-5
  387. - requires(post): coreutils to work around an installator bug
  388. - Resolves: #540437
  389. * Wed Jan 13 2010 Stepan Kasal <skasal@redhat.com> - 4.1-4
  390. - limit building against speech-dispatcher to Fedora
  391. - Resolves: rhbz#553795
  392. * Sun Nov 1 2009 Stepan Kasal <skasal@redhat.com> - 4.1-3
  393. - build the TTY driver (it was disabled since it first appered in 3.7.2-1)
  394. - build with speech-dispatcher, packed into a separate sub-package
  395. * Fri Oct 30 2009 Stepan Kasal <skasal@redhat.com> - 4.1-2
  396. - move data-directory back to default: /etc/brltty
  397. - move brltty to /bin and /lib, so that it can be used to repair the system
  398. without /usr mounted (#276181)
  399. - move vstp and libbrlttybba.so to brlapi
  400. - brltty no longer requires brlapi
  401. - brlapi now requires brltty from the same build
  402. * Wed Oct 28 2009 Stepan Kasal <skasal@redhat.com> - 4.1-1
  403. - new upstream version
  404. - use --disable-stripping instead of make variable override
  405. - install the default brltty-pm.conf to docdir only (#526168)
  406. - remove the duplicate copies of rhmkboot and rhmkroot from docdir
  407. - patch configure so that the dirs in summary are not garbled:
  408. brltty-autoconf-quote.patch
  409. - move data-directory to ${datadir}/brltty
  410. * Tue Oct 20 2009 Stepan Kasal <skasal@redhat.com> - 4.0-2
  411. - escape rpm macros in the rpm change log
  412. - add requires to bind subpackages from one build together
  413. * Wed Oct 7 2009 Stepan Kasal <skasal@redhat.com> - 4.0-1
  414. - new upstream version
  415. - drop upstreamed patches; ./autogen not needed anymore
  416. - pack the xbrlapi server; move its man page to brlapi package
  417. - add man-page for brltty.conf (#526168)
  418. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-6
  419. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  420. * Tue May 12 2009 Stepan Kasal <skasal@redhat.com> - 3.10-5
  421. - rebuild after java-1.5.0-gcj rebuild
  422. * Thu Apr 30 2009 Stepan Kasal <skasal@redhat.com> - 3.10-4
  423. - own the tcl subdirectory (#474032)
  424. - set CPPFLAGS to java include dirs, so that the java bindings build with
  425. any java implementation (#498964)
  426. - add --without-curses; there is no curses package BuildRequired anyway
  427. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-3
  428. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  429. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.10-2
  430. - Rebuild for Python 2.6
  431. * Sat Sep 13 2008 Stepan Kasal <skasal@redhat.com> - 3.10-1
  432. - new upstream release
  433. - drop brltty-3.9-java-svn.patch, brltty-3.9-tcl85path.patch,
  434. and brltty-3.9-pyxfix.patch, they are upstream
  435. - fix BuildRoot
  436. - fix many sub-packages' Requires on brlapi
  437. * Wed Sep 10 2008 Stepan Kasal <skasal@redhat.com> - 3.9-3
  438. - add brltty-3.9-autoconf.patch to fix to build with Autoconf 2.62
  439. - add brltty-3.9-parallel.patch to fix race condition with parallel make
  440. - add brltty-3.9-pyxfix.patch to fix build with current pyrex
  441. - Summary lines shall not end with a dot
  442. * Thu Feb 28 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-2.2
  443. - glibc build fixes
  444. - applied java reorganisations from svn
  445. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.9-2.1
  446. - Autorebuild for GCC 4.3
  447. * Wed Jan 09 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-1.1
  448. - specfile update to comply with tcl packaging guidelines
  449. * Mon Jan 07 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-1
  450. - update to latest upstream (3.9)
  451. * Tue Sep 18 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-2.svn3231
  452. - update to r3231 from svn
  453. - added java binding subpackage
  454. * Wed Aug 29 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-2.svn3231
  455. - update to r3231 from svn
  456. * Tue Aug 21 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-1
  457. - update to latest upstream
  458. - added the at-spi driver, tcl and python bindings
  459. - fixed the license tags
  460. * Mon Mar 05 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-3
  461. - added the XWindow driver
  462. - build fix for newer byacc
  463. * Tue Jan 30 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-2.1
  464. - quiet postinstall scriptlet, really fixes #224570
  465. * Tue Jan 30 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-2
  466. - failsafe postinstall script, fixes #224570
  467. - makefile fix - debuginfo extraction now works
  468. * Thu Jan 25 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-1.1
  469. - fix building with newer kernel-headers (#224149)
  470. * Wed Jul 12 2006 Petr Rockai <prockai@redhat.com> - 3.7.2-1
  471. - upgrade to latest upstream version
  472. - split off brlapi and brlapi-devel packages
  473. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.2-12.1
  474. - rebuild
  475. * Sun Jul 02 2006 Florian La Roche <laroche@redhat.com>
  476. - for the post script require coreutils
  477. * Mon Jun 05 2006 Jesse Keating <jkeating@redhat.com> - 3.2-11
  478. - Added byacc BuildRequires, removed prereq, coreutils is always there
  479. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.2-10.2.1
  480. - bump again for double-long bug on ppc(64)
  481. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.2-10.2
  482. - rebuilt for new gcc4.1 snapshot and glibc changes
  483. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  484. - rebuilt
  485. * Wed Mar 16 2005 Bill Nottingham <notting@redhat.com> 3.2-10
  486. - rebuild
  487. * Fri Nov 26 2004 Florian La Roche <laroche@redhat.com>
  488. - add a %%clean into .spec
  489. * Thu Oct 14 2004 Adrian Havill <havill@redhat.com> 3.2-5
  490. - chmod a-x for conf file (#116244)
  491. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  492. - rebuilt
  493. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  494. - rebuilt
  495. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  496. - rebuilt
  497. * Tue Sep 30 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  498. - prereq coreutils for mknod/chown/chmod
  499. * Mon Jul 07 2003 Adrian Havill <havill@redhat.com> 3.2-2
  500. - changed spec "Copyright" to "License"
  501. - use %%configure macro, %%{_libdir} for non-ia32 archs
  502. - removed unnecessary set and unset, assumed/default spec headers
  503. - fixed unpackaged man page, duplicate /bin and /lib entries
  504. - use plain install vs scripts for non-i386 buildsys