btparse-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. %define libname libbtparse
  2. Name: btparse
  3. Version: 0.35
  4. Release: 2%{?_dist_release}
  5. Summary: Tool for parsing and processing BibTeX data files
  6. Summary(ja): BibTeX ファイルを解析処理するツール
  7. License: GPLv2
  8. Distribution: Vine Linux
  9. Group: Applications/Publishing
  10. Source: http://search.cpan.org/CPAN/authors/id/A/AM/AMBS/btparse/%{name}-%{version}.tar.gz
  11. URL: http://search.cpan.org/~ambs/btparse/
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. ## BuildRequires:
  14. ## Requires:
  15. %description
  16. btparse is a C library for parsing and processing BibTeX files. It provides a
  17. lexical scanner and LR parser (constructed by PCCTS), both of which are
  18. efficient and offer good error detection and recovery; a set of functions for
  19. traversing the AST (abstract syntax tree) generated by the parser; and utility
  20. functions for manipulating strings according to BibTeX conventions. (Note that
  21. nothing in the library assumes that you're using BibTeX files for their
  22. original purpose of bibliographic data for scholarly publications; you could
  23. use the file format for any conceivable purpose that fits it. However, there is
  24. some code in the library that is really only appropriate for use with strings
  25. meant to be processed in the same way that BibTeX itself does. This is all
  26. entirely optional, though.)
  27. Note that the interface provided by btparse, while complete, is fairly
  28. low-level. If you have more sophisticated needs, you might be interested my
  29. Text::BibTeX module for Perl 5 (available on CPAN).
  30. %description -l ja
  31. BibTeXファイルを解析処理するツールです.
  32. %package -n %{libname}
  33. Summary: C library for parsing and processing BibTeX data files
  34. Summary(ja): BibTeX ファイルを解析処理する C ライブラリ
  35. Group: System Environment/Libraries
  36. %description -n %{libname}
  37. btparse is a C library for parsing and processing BibTeX files. It provides a
  38. lexical scanner and LR parser (constructed by PCCTS), both of which are
  39. efficient and offer good error detection and recovery; a set of functions for
  40. traversing the AST (abstract syntax tree) generated by the parser; and utility
  41. functions for manipulating strings according to BibTeX conventions. (Note that
  42. nothing in the library assumes that you're using BibTeX files for their
  43. original purpose of bibliographic data for scholarly publications; you could
  44. use the file format for any conceivable purpose that fits it. However, there is
  45. some code in the library that is really only appropriate for use with strings
  46. meant to be processed in the same way that BibTeX itself does. This is all
  47. entirely optional, though.)
  48. Note that the interface provided by btparse, while complete, is fairly
  49. low-level. If you have more sophisticated needs, you might be interested my
  50. Text::BibTeX module for Perl 5 (available on CPAN).
  51. %description -l ja
  52. BibTeX ファイルを解析処理する C ライブラリです.
  53. %package -n %{libname}-devel
  54. Summary: Headers for developing programs that will use %{name}
  55. Summary(ja): %{name} のヘッダファイル
  56. Group: Development/Libraries
  57. Requires: %{libname} = %{version}
  58. Provides: %{name}-devel = %{version}-%{release}
  59. Provides: lib%{name}-devel = %{version}-%{release}
  60. %description -n %{libname}-devel
  61. This package contains the headers that programmers will need to develop
  62. applications which will use %{name}.
  63. %prep
  64. %setup -q
  65. %build
  66. %configure --disable-static
  67. %{__make}
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. %makeinstall
  71. %{__install} -d -m 755 %{buildroot}%{_datadir}/%{name}
  72. %{__install} -m 644 tests/data/* %{buildroot}%{_datadir}/%{name}
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %post -n %{libname} -p /sbin/ldconfig
  76. %postun -n %{libname} -p /sbin/ldconfig
  77. %files
  78. %defattr(-,root,root)
  79. %doc COPYING ChangeLog INSTALL README TODO
  80. %{_bindir}/*
  81. %files -n %{libname}
  82. %defattr (-,root,root)
  83. %{_libdir}/lib*.so.*
  84. %files -n %{libname}-devel
  85. %defattr (-,root,root)
  86. %{_includedir}/*
  87. #%{_libdir}/lib*.a
  88. %exclude %{_libdir}/lib*.la
  89. %{_libdir}/lib*.so
  90. %{_libdir}/pkgconfig/*.pc
  91. %{_mandir}/*/*
  92. %{_datadir}/%{name}
  93. # %{_libdir}/pkgconfig/%{name}.pc
  94. %changelog
  95. * Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.35-2
  96. - remove %%{_libdir}/lib*.a from %%files -n libbtparse-devel
  97. * Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 0.35-1vl5
  98. - applied new versioning policy, spec in utf-8
  99. - excluded *.la
  100. * Tue Nov 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.35-0vl1
  101. - new upstream release
  102. - updated URL
  103. * Wed Jun 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.34-0vl2
  104. - rebuilt for VineSeed(plus)
  105. - changed Group
  106. * Mon Oct 31 2005 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  107. - Initial package for VineLinux3.2