bzip2-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A file compression utility.
  3. Summary(ja): ファイル圧縮ユーティリティ
  4. Name: bzip2
  5. Version: 1.0.8
  6. Release: 1%{?_dist_release}
  7. License: BSD
  8. Group: Applications/Archiving
  9. URL: http://www.bzip.org/
  10. Source0: https://sourceware.org/pub/bzip2/%{name}-%{version}.tar.gz
  11. Source1: bzip2.pc
  12. Patch0: bzip2-saneso.patch
  13. Patch1: bzip2-cflags.patch
  14. Patch2: bzip2-ldflags.patch
  15. # P2 implements a progress counter (in %). It also
  16. # display the percentage of the original file the new file is (size).
  17. # URL: http://www.vanheusden.com/Linux/bzip2-1.0.2.diff.gz
  18. Patch10: bzip2-1.0.2.diff.bz2
  19. # security patch(es)
  20. # none
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: texinfo
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. %description
  26. Bzip2 is a freely available, patent-free, high quality data compressor.
  27. Bzip2 compresses files to within 10 to 15 percent of the capabilities
  28. of the best techniques available. However, bzip2 has the added benefit
  29. of being approximately two times faster at compression and six times
  30. faster at decompression than those techniques. Bzip2 is not the
  31. fastest compression utility, but it does strike a balance between speed
  32. and compression capability.
  33. Install bzip2 if you need a compression utility.
  34. %package devel
  35. Summary: Header files and libraries for developing apps which will use bzip2.
  36. Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. %description devel
  40. Header files and a static library of bzip2 functions, for developing apps
  41. which will use the library.
  42. ## to build compat32 for x86_64 architecture support
  43. %package -n compat32-%{name}
  44. Summary: A file compression utility.
  45. Summary(ja): ファイル圧縮ユーティリティ
  46. Group: System Environment/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. %description -n compat32-%{name}
  49. Bzip2 is a freely available, patent-free, high quality data compressor.
  50. Bzip2 compresses files to within 10 to 15 percent of the capabilities
  51. of the best techniques available. However, bzip2 has the added benefit
  52. of being approximately two times faster at compression and six times
  53. faster at decompression than those techniques. Bzip2 is not the
  54. fastest compression utility, but it does strike a balance between speed
  55. and compression capability.
  56. Install bzip2 if you need a compression utility.
  57. %package -n compat32-%{name}-devel
  58. Summary: Header files and libraries for developing apps which will use bzip2.
  59. Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
  60. Group: Development/Libraries
  61. Requires: compat32-%{name} = %{version}-%{release}
  62. Requires: %{name}-devel = %{version}-%{release}
  63. %description -n compat32-%{name}-devel
  64. Header files and a static library of bzip2 functions, for developing apps
  65. which will use the library.
  66. %prep
  67. %setup -q
  68. %patch0 -p1
  69. %patch1 -p1
  70. %patch2 -p1
  71. %patch10 -p1
  72. cp -a %{SOURCE1} .
  73. sed -i "s|^libdir=|libdir=%{_libdir}|" bzip2.pc
  74. %build
  75. make -f Makefile-libbz2_so \
  76. CC="%{__cc}" \
  77. AR="%{__ar}" \
  78. RANLIB="%{__ranlib}" \
  79. CFLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -fpic -fPIC" \
  80. LDFLAGS="" \
  81. %{?_smp_mflags} all
  82. rm -f *.o
  83. make \
  84. CC="%{__cc}" \
  85. AR="%{__ar}" \
  86. RANLIB="%{__ranlib}" \
  87. CFLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64" \
  88. LDFLAGS="" \
  89. %{?_smp_mflags} all
  90. %install
  91. rm -rf %{buildroot}
  92. chmod 644 bzlib.h
  93. mkdir -p %{buildroot}{%{_bindir},%{_mandir}/man1,%{_libdir}/pkgconfig,%{_includedir}}
  94. cp -p bzlib.h %{buildroot}%{_includedir}
  95. install -m 755 libbz2.so.* %{buildroot}%{_libdir}
  96. #install -m 644 libbz2.a %{buildroot}%{_libdir}
  97. install -m 644 bzip2.pc %{buildroot}%{_libdir}/pkgconfig/bzip2.pc
  98. install -m 755 bzip2-shared %{buildroot}%{_bindir}/bzip2
  99. install -m 755 bzip2recover bzgrep bzdiff bzmore %{buildroot}%{_bindir}/
  100. cp -p bzip2.1 bzdiff.1 bzgrep.1 bzmore.1 %{buildroot}%{_mandir}/man1/
  101. ln -s bzip2 %{buildroot}%{_bindir}/bunzip2
  102. ln -s bzip2 %{buildroot}%{_bindir}/bzcat
  103. ln -s bzdiff %{buildroot}%{_bindir}/bzcmp
  104. ln -s bzmore %{buildroot}%{_bindir}/bzless
  105. ln -s bzgrep %{buildroot}%{_bindir}/bzegrep
  106. ln -s bzgrep %{buildroot}%{_bindir}/bzfgrep
  107. ln -s libbz2.so.%{library_version} %{buildroot}%{_libdir}/libbz2.so.1
  108. ln -s libbz2.so.1 %{buildroot}%{_libdir}/libbz2.so
  109. ln -s bzip2.1 %{buildroot}%{_mandir}/man1/bzip2recover.1
  110. ln -s bzip2.1 %{buildroot}%{_mandir}/man1/bunzip2.1
  111. ln -s bzip2.1 %{buildroot}%{_mandir}/man1/bzcat.1
  112. ln -s bzdiff.1 %{buildroot}%{_mandir}/man1/bzcmp.1
  113. ln -s bzmore.1 %{buildroot}%{_mandir}/man1/bzless.1
  114. ln -s bzgrep.1 %{buildroot}%{_mandir}/man1/bzegrep.1
  115. ln -s bzgrep.1 %{buildroot}%{_mandir}/man1/bzfgrep.1
  116. %post -p /sbin/ldconfig
  117. %postun -p /sbin/ldconfig
  118. %post -n compat32-%{name} -p /sbin/ldconfig
  119. %postun -n compat32-%{name} -p /sbin/ldconfig
  120. %clean
  121. rm -rf %{buildroot}
  122. %files
  123. %defattr(-,root,root)
  124. %{!?_licensedir:%global license %%doc}
  125. %license COPYING
  126. %doc CHANGES README
  127. %{_bindir}/*
  128. %{_mandir}/*/*
  129. %{_libdir}/*so.*
  130. %files devel
  131. %defattr(-,root,root)
  132. %{_includedir}/*
  133. %{_libdir}/*so
  134. %{_libdir}/pkgconfig/*
  135. ## to build compat32 for x86_64 architecture support
  136. %if %{build_compat32}
  137. %files -n compat32-%{name}
  138. %defattr(-,root,root)
  139. %{_libdir}/*so.*
  140. %files -n compat32-%{name}-devel
  141. %defattr(-,root,root)
  142. %{_libdir}/*so
  143. %{_libdir}/pkgconfig/*
  144. %endif
  145. %changelog
  146. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.8-1
  147. - new upstream release.
  148. - dropped Patch0-3 and 1000.
  149. - imported Patch0-2 from rawhide.
  150. * Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.6-4
  151. - fixed %%files.
  152. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.6-3
  153. - added Patch1000 to fix CVE-2016-3189.
  154. * Wed Jan 1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.6-2
  155. - rebuilt with new vineseed toolchain
  156. * Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  157. - update to 1.0.6
  158. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.5-5vl6
  159. - build on current VineSeed
  160. - update URL and Source0 tags URL
  161. * Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
  162. - rebuild with new toolchain
  163. * Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-3
  164. - updated Patch0: bzip2-1.0.5-autoconflibtoolize.patch
  165. - removed unneccesary %if !%{build_compat32} case condition
  166. * Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
  167. - spec in utf-8
  168. - remove static library
  169. * Thu Mar 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-1
  170. - new upstream release with security fix
  171. - drop old patches (patch3-6) which are included in new release
  172. - build under new versioning policy
  173. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
  174. - changed Group to Applications/Archiving
  175. - changed compat32-bzip2 Group to System Environment/Libraries
  176. * Tue Feb 21 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl1
  177. - new upstream release
  178. - add Patch3-6 from Fedora Core (includes CAN-2005-0758/0953)
  179. * Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl5
  180. - fixed %%postun (missing to build as scriptlet by invalid comment)
  181. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl4
  182. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  183. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
  184. - added compat32- packages for x86_64 architecture support
  185. - changed autoconf-2.13 to current autoconf
  186. * Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.2-0vl2
  187. - added patch 1 from Rawhide 1.0.2-8
  188. - added patch 2 from Mandrake 1.0.2-14mdk
  189. * Sun Sep 29 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.0.2-0vl1
  190. - previous patch is so incomplete that "bzip2 -f" fails.
  191. instead, update the source which fixes this and other bugs.
  192. * Fri May 24 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  193. - fix race condition.
  194. * Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  195. - 1.0.1-3vl2
  196. - added Japanese summary
  197. - rebuilt under new %%{_mandir} definition
  198. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.0.1-3vl1
  199. - build on Vine Linux with gcc-2.95.3
  200. - partially used rpmmacros
  201. * Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
  202. - new URL and source location
  203. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  204. - automatic rebuild
  205. * Sat Jul 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  206. - 1.0.1
  207. - ported my patch
  208. * Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
  209. - FHS packaging to build on solaris2.5.1.
  210. - remove config.cache from autoconf patch.
  211. - sparc: use %%configure, but not the m4 macros.
  212. * Tue Jun 06 2000 Trond Eivind Glomsr <teg@redhat.com>
  213. - Use %%configure, %%makeinstall, %%{_manpath} and %%{_tmpdir}
  214. * Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
  215. - 1.0.0 - ported my 1.0pre8 libtoolizedautoconf patch
  216. * Tue May 16 2000 Trond Eivind Glomsr <teg@redhat.com>
  217. - use soft links, not hardlinks, for binaries
  218. - mv .so to devel
  219. * Mon May 15 2000 Trond Eivind Glomsr <teg@redhat.com>
  220. - autoconfed and libtoolized package
  221. - fixed Copyright (it's BSD, not GPL)
  222. - dumped bzless (less works fine with bz2-files)
  223. - rewrote build and install parts
  224. - separated main package and devel package
  225. * Mon May 8 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  226. - 1.0pre8
  227. * Fri Apr 14 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  228. - Add bzgrep (a version of zgrep hacked to do bzip2)
  229. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  230. - handle compressed manpages
  231. * Fri Dec 31 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
  232. - 0.9.5d
  233. - Update download URL, add URL: tag in header
  234. * Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
  235. - upgrade to 0.9.5c.
  236. * Mon Aug 9 1999 Bill Nottingham <notting@redhat.com>
  237. - install actual bzip2 binary, not libtool cruft.
  238. * Sun Aug 8 1999 Jeff Johnson <jbj@redhat.com>
  239. - run ldconfig to get shared library.
  240. * Mon Aug 2 1999 Jeff Johnson <jbj@redhat.com>
  241. - create shared libbz1.so.* library.
  242. * Sun Apr 4 1999 Jeff Johnson <jbj@redhat.com>
  243. - update to bzip2-0.9.0c.
  244. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  245. - auto rebuild in the new build environment (release 4)
  246. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  247. - build against glibc 2.1
  248. * Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
  249. - force compilation with egcs to avoid gcc optimization bug (thank God
  250. we haven't been beaten by it)
  251. * Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
  252. - version 0.9.0b
  253. * Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
  254. - updated to 0.9.0
  255. * Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
  256. - first build for Manhattan