cairo-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441
  1. %bcond_with check
  2. Summary: Cairo - multi-platform 2D graphics library.
  3. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  4. Name: cairo
  5. Version: 1.16.0
  6. Release: 2%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPL/MPL
  11. URL: https://cairographics.org/
  12. Source0: https://cairographics.org/releases/%{name}-%{version}.tar.xz
  13. # don't use serverside gradients, most drivers don't handle those and are
  14. # really slow, should workaround performances issues for ati, nouveau and nvidia
  15. # https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  16. Patch1: cairo-1.10.0-dont_use_server_side_gradients.patch
  17. # https://gitlab.freedesktop.org/cairo/cairo/merge_requests/1
  18. Patch4: 0001-Set-default-LCD-filter-to-FreeType-s-default.patch
  19. # https://gitlab.freedesktop.org/cairo/cairo/merge_requests/5
  20. Patch5: 0001-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch
  21. # https://github.com/matthiasclasen/cairo/commit/79ad01724161502e8d9d2bd384ff1f0174e5df6e
  22. Patch6: cairo-composite_color_glyphs.patch
  23. # security fixes
  24. Patch1000: CVE-2020-35492.patch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. BuildRequires: pkgconfig
  27. BuildRequires: pixman-devel
  28. BuildRequires: glib2-devel
  29. BuildRequires: libpng-devel
  30. BuildRequires: freetype2-devel
  31. BuildRequires: fontconfig-devel
  32. BuildRequires: libX11-devel
  33. BuildRequires: libXrender-devel
  34. BuildRequires: gtk-doc
  35. BuildRequires: librsvg2-devel
  36. BuildRequires: mesa-libGL-devel
  37. BuildRequires: mesa-libEGL-devel
  38. BuildRequires: git
  39. BuildConflicts: XOrg-compat70-devel
  40. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  41. %description
  42. Cairo provides anti-aliased vector-based rendering for X. Paths
  43. consist of line segments and cubic splines and can be rendered at any
  44. width with various join and cap styles. All colors may be specified
  45. with optional translucence (opacity/alpha) and combined using the
  46. extended Porter/Duff compositing algebra as found in the X Render
  47. Extension.
  48. Cairo exports a stateful rendering API similar in spirit to the path
  49. construction, text, and painting operators of PostScript, (with the
  50. significant addition of translucence in the imaging model). When
  51. complete, the API is intended to support the complete imaging model of
  52. PDF 1.4.
  53. Cairo relies on the Xc library for backend rendering. Xc provides an
  54. abstract interface for rendering to multiple target types. As of this
  55. writing, Xc allows Cairo to target X drawables as well as generic
  56. image buffers. Future backends such as PostScript, PDF, and perhaps
  57. OpenGL are currently being planned.
  58. %package -n compat32-%{name}
  59. Summary: Cairo - multi-platform 2D graphics library.
  60. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  61. Group: system,legacy
  62. Requires: %{name} = %{version}
  63. %description -n compat32-%{name}
  64. Cairo provides anti-aliased vector-based rendering for X. Paths
  65. consist of line segments and cubic splines and can be rendered at any
  66. width with various join and cap styles. All colors may be specified
  67. with optional translucence (opacity/alpha) and combined using the
  68. extended Porter/Duff compositing algebra as found in the X Render
  69. Extension.
  70. Cairo exports a stateful rendering API similar in spirit to the path
  71. construction, text, and painting operators of PostScript, (with the
  72. significant addition of translucence in the imaging model). When
  73. complete, the API is intended to support the complete imaging model of
  74. PDF 1.4.
  75. Cairo relies on the Xc library for backend rendering. Xc provides an
  76. abstract interface for rendering to multiple target types. As of this
  77. writing, Xc allows Cairo to target X drawables as well as generic
  78. image buffers. Future backends such as PostScript, PDF, and perhaps
  79. OpenGL are currently being planned.
  80. %package devel
  81. Summary: Development files for Cairo library.
  82. Summary(ja): Cairo ライブラリの開発用ファイル
  83. Group: programming
  84. Provides: lib%{name}-devel = %{version}-%{release}
  85. Requires: %{name} = %{version}
  86. Requires: libpng-devel
  87. Requires: freetype2-devel
  88. Requires: fontconfig-devel
  89. Requires: libX11-devel
  90. Requires: libXrender-devel
  91. Requires: pixman-devel
  92. Requires: glib2-devel
  93. Requires: mesa-libEGL-devel
  94. %description devel
  95. Development files for Cairo library.
  96. %package tools
  97. Summary: Development tools for cairo
  98. Group: programming
  99. %description tools
  100. Cairo is a 2D graphics library designed to provide high-quality display
  101. and print output.
  102. This package contains tools for working with the cairo graphics library.
  103. * cairo-trace: Record cairo library calls for later playback
  104. %debug_package
  105. %prep
  106. %autosetup -S git -p1
  107. ./autogen.sh
  108. %build
  109. %configure --disable-static \
  110. --enable-gtk-doc \
  111. --enable-xlib \
  112. --enable-ft \
  113. --enable-ps \
  114. --enable-pdf \
  115. --enable-svg \
  116. --enable-tee \
  117. --enable-gobject \
  118. --enable-gl
  119. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  120. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  121. make %{?_smp_mflags}
  122. %install
  123. %makeinstall
  124. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  125. %if %{with check}
  126. %check
  127. make check
  128. %endif
  129. %files
  130. %defattr(-,root,root,-)
  131. %license COPYING COPYING-*
  132. %doc AUTHORS BUGS ChangeLog NEWS README
  133. %{_libdir}/lib*.so.*
  134. %files devel
  135. %defattr(-,root,root,-)
  136. %{_libdir}/lib*.so
  137. %{_includedir}/*
  138. %{_libdir}/pkgconfig/*.pc
  139. #{_libdir}/lib*.a
  140. %{_datadir}/gtk-doc/html/cairo
  141. %files tools
  142. %defattr(-,root,root,-)
  143. %{_bindir}/cairo-trace
  144. %{_bindir}/cairo-sphinx
  145. %{_libdir}/cairo
  146. %if %{build_compat32}
  147. %files -n compat32-%{name}
  148. %defattr(-,root,root,-)
  149. %{_libdir}/lib*.so.*
  150. %endif
  151. %changelog
  152. * Fri Mar 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  153. - imported Patch1000 from upstream to fix CVE-2020-35492.
  154. - dropped ldconfig scriptlets.
  155. * Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  156. - new upstream release.
  157. - imported Patch4-6 from rawhide.
  158. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.12-1
  159. - new upstream release.
  160. * Sun Dec 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.6-1
  161. - new upstream release
  162. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-2
  163. - fix spec file
  164. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
  165. - new upstream release
  166. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-2
  167. - remove *.la files
  168. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
  169. - new upstream release
  170. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.18-1
  171. - new upstream release
  172. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-2
  173. - rebuild with libpng-1.6.12
  174. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-1
  175. - new upstream release
  176. * Sat May 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.14-2
  177. - remove hardcoded libdir and runpath from libtool
  178. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
  179. - new upstream release
  180. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
  181. - new upstream release
  182. * Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
  183. - new upstream release
  184. * Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
  185. - new upstream release
  186. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-2
  187. - add Requires: mesa-libEGL-devel
  188. * Sat Jul 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
  189. - new upstream release
  190. - Enable OpenGL backend
  191. - add BR: librsvg2-devel, mesa-libGL-devel, mesa-libEGL-devel
  192. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  193. - new upstream release
  194. * Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
  195. - enable tee support
  196. - add configure options specifically
  197. - disable static library
  198. * Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  199. - new upstream release
  200. - add BuildRequires: glib2-devel
  201. - add Requires: glib2-devel (devel package)
  202. * Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  203. - add patch1 from ubuntu to fix performance regressions
  204. - don't use serverside gradients, most drivers don't handle those and are
  205. really slow, should workaround performances issues for ati, nouveau and nvidia
  206. https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  207. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  208. - new upstream release
  209. - add tools sub package
  210. * Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
  211. - add BuildRequires: fontconfig-devel
  212. - add Requires: fontconfig-devel (devel package)
  213. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
  214. - build with rpm-4.8.1-1 for pkg-config file
  215. * Tue Mar 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
  216. - new upstream release
  217. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  218. - new upstream release
  219. * Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
  220. - applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
  221. - added BuildRequires: gtk-doc
  222. * Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
  223. - new upstream release
  224. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
  225. - new upstream release
  226. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  227. - new upstream release
  228. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  229. - new upstream release
  230. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
  231. - new upstream release
  232. * Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
  233. - add Requires: pixman-devel to -devel
  234. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
  235. - rebuilt with xorg-x11 7.3
  236. - spec in UTF-8
  237. * Thu May 1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
  238. - new upstream release
  239. - removed lib*.la from devel package
  240. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
  241. - used %%{?_dist_release}
  242. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
  243. - new upstream release
  244. * Sun Dec 9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
  245. - new upstream release
  246. * Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
  247. - new upstream release
  248. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  249. - new upstream release
  250. - remove BuildRequires: pango-devel, gtk2-devel
  251. (these are only needed for testing)
  252. * Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
  253. - upstream release
  254. - Patch30 and Patch40 is skipped (not working correctly)
  255. but held in src.rpm
  256. - add BUGS, ROADMAP to %%doc
  257. - add BuildRequires: pango-devel, gtk2-devel
  258. * Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
  259. - rebuild without XOrg-compat70-devel
  260. - add BuildConflicts: XOrg-compat70-devel
  261. * Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
  262. - new upstream release
  263. - remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
  264. * Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
  265. - added Patch40 for 15bpp problem
  266. * Tue Sep 5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
  267. - added ad-hoc Patch30 for 16bpp problem
  268. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  269. - new upstream release
  270. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  271. - new upstream release
  272. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
  273. - new upstream release
  274. * Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
  275. - added compat32- package for x86_64 architecture support
  276. * Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
  277. - added x86_64 architecture support
  278. * Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
  279. - add Patch20 to fix broken desktop rendering on xorg-x11-6.9
  280. - add X.Org 6.9.0 (6090000) to blacklist
  281. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  282. - new upstream release
  283. * Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
  284. - update Patch10
  285. * Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
  286. - add Patch10 to use embedded bitmap font if available.
  287. (controllable by "embeddedbitmap" in fontconfig)
  288. * Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
  289. - rebuild with new fontconfig
  290. * Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
  291. - add Requires: libpng-devel, XOrg-devel, freetype2-devel
  292. to devel package instead of BuildRequires (typo)
  293. - add Japanese summaries
  294. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
  295. - new upstream release
  296. - remove libpixman dependency (which is now included in cairo)
  297. - obsoletes libpixman <= 0.1.6
  298. - add more BuildRequires
  299. * Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
  300. - new upstream version
  301. * Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
  302. - new upstream version
  303. - fixed License (http://cairographics.org/introduction)
  304. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
  305. - new upstream version
  306. - include gtk-doc files
  307. * Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
  308. - new upstream version
  309. - add Requires: libpixman
  310. * Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
  311. - new upstream version (cairo-0.2.0)
  312. * Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
  313. - rebuilt for VineLinux
  314. * Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
  315. - 0.1.23
  316. - reenable libtoolize
  317. * Wed May 5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
  318. - fix devel provides
  319. - drop redundant buildrequires
  320. - requires new pixman
  321. - autoconf 2.5 macro
  322. - New release 0.1.22
  323. * Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
  324. - build with X11
  325. * Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
  326. - 0.1.17
  327. - provides cairo
  328. - drop patch, use --disable-xlib
  329. - buildrequires
  330. - don't run libtoolize
  331. * Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
  332. - initial mandrake package