calibre-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: calibre
  3. Version: 2.62.0
  4. Release: 2%{?_dist_release}
  5. Summary: E-book converter and library management
  6. Group: Applications/Multimedia
  7. License: GPLv3
  8. URL: http://calibre-ebook.com/
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. # SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  12. # Upstream packages some unfree fonts which we cannot redistribute.
  13. # While we're at it, also delete the liberation fonts which we already have.
  14. #
  15. # Download the upstream tarball and invoke this script while in the tarball's
  16. # directory:
  17. # ./generate-tarball.sh %{version}
  18. Source0: %{name}-%{version}-nofonts.tar.xz
  19. Source1: generate-tarball.sh
  20. Source2: calibre-mount-helper
  21. Source3: calibre-gui.appdata.xml
  22. #
  23. # Disable auto update from inside the app
  24. #
  25. Patch1: %{name}-no-update.patch
  26. #
  27. # Do not display multiple apps in desktop files, only the main app
  28. # This is so gnome-software only 'sees' calibre once.
  29. #
  30. Patch3: calibre-nodisplay.patch
  31. BuildRequires: python >= 2.7.1
  32. BuildRequires: python-devel >= 2.7.1
  33. BuildRequires: python-setuptools >= 2.7.1
  34. BuildRequires: python-setuptools
  35. BuildRequires: python-qt5-devel
  36. BuildRequires: python-qt5
  37. BuildRequires: python-qt5-webkit
  38. BuildRequires: podofo-devel >= 0.8.2
  39. BuildRequires: desktop-file-utils
  40. BuildRequires: python-mechanize
  41. BuildRequires: python-lxml
  42. BuildRequires: python-dateutil
  43. BuildRequires: python-imaging
  44. BuildRequires: xdg-utils >= 1.0.2
  45. BuildRequires: python-BeautifulSoup >= 3.0.5
  46. BuildRequires: chmlib-devel >= 0.40
  47. BuildRequires: python-cssutils >= 0.9.6
  48. BuildRequires: sqlite3-devel
  49. BuildRequires: libicu-devel >= 4.4
  50. BuildRequires: libpng-devel
  51. BuildRequires: libmtp-devel
  52. BuildRequires: qt5-qtbase-devel
  53. #BuildRequires: web-assets-devel
  54. BuildRequires: qt5-qtbase-static
  55. BuildRequires: libXrender-devel
  56. BuildRequires: qt5-qtwebkit-devel
  57. BuildRequires: openssl-devel
  58. # calibre installer is so smart that it check for the presence of the
  59. # directory (and then installs in the wrong place)
  60. BuildRequires: bash-completion
  61. BuildRequires: python-apsw
  62. BuildRequires: glib2-devel
  63. BuildRequires: fontconfig-devel
  64. BuildRequires: libinput-devel
  65. BuildRequires: libxkbcommon-devel
  66. %{?pyqt5_requires}
  67. # once ^^ %%pyqt5_requires is everywhere, can drop python-qt5 dep below -- rex
  68. # Add hard dep to specific qtbase pkg, see build message below -- rex
  69. # Project MESSAGE: This project is using private headers and will therefore be tied to this specific Qt module build version.
  70. # Project MESSAGE: Running this project against other versions of the Qt modules may crash at any arbitrary point.
  71. # Project MESSAGE: This is not a bug, but a result of using Qt internals. You have been warned!
  72. BuildRequires: qt5-qtbase-private-devel
  73. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  74. Requires: python-qt5
  75. Requires: python-qt5-webkit
  76. Requires: qt5-qtwebkit
  77. Requires: qt5-qtsvg
  78. Requires: qt5-qtsensors
  79. Requires: python-cherrypy
  80. Requires: python-cssutils
  81. Requires: odfpy
  82. Requires: python-lxml
  83. Requires: python-imaging
  84. Requires: python-mechanize
  85. Requires: python-dateutil
  86. Requires: python-genshi
  87. Requires: python-BeautifulSoup
  88. Requires: poppler-utils
  89. #Requires: python-feedparser
  90. Requires: python-netifaces
  91. Requires: python-dns
  92. Requires: python-apsw
  93. Requires: python-psutil
  94. Requires: python-pygments > 2.0.1
  95. Requires: optipng
  96. #Requires: python-cssselect
  97. #Requires: mathjax
  98. ## vine
  99. Requires: TrueType-liberation
  100. %description
  101. Calibre is meant to be a complete e-library solution. It includes library
  102. management, format conversion, news feeds to ebook conversion as well as
  103. e-book reader sync features.
  104. Calibre is primarily a ebook cataloging program. It manages your ebook
  105. collection for you. It is designed around the concept of the logical book,
  106. i.e. a single entry in the database that may correspond to ebooks in several
  107. formats. It also supports conversion to and from a dozen different ebook
  108. formats.
  109. Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
  110. RTF, TXT, PDF and LRS.
  111. %prep
  112. %setup -q
  113. # don't check for new upstream version (that's what packagers do)
  114. %patch1 -p1 -b .no-update
  115. # Hide individual launchers for ebook-edit, ebook-viewer and lrfviewer as they
  116. # are all accessible in the main calibre GUI.
  117. %patch3 -p1 -b .nodisplay
  118. # dos2unix newline conversion
  119. sed -i 's/\r//' src/calibre/web/feeds/recipes/*
  120. # remove shebangs
  121. sed -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
  122. sed -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
  123. sed -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
  124. sed -i -e '/^#!\//, 1d' src/calibre/*.py
  125. sed -i -e '/^#!\//, 1d' src/templite/*.py
  126. sed -i -e '/^#!\//, 1d' resources/default_tweaks.py
  127. sed -i -e '/^#!\//, 1d' resources/catalog/section_list_templates.py
  128. chmod -x src/calibre/*/*/*/*.py \
  129. src/calibre/*/*/*.py \
  130. src/calibre/*/*.py \
  131. src/calibre/*.py
  132. rm -rvf resources/viewer/mathjax
  133. %build
  134. OVERRIDE_CFLAGS="%{optflags}" python setup.py build
  135. %install
  136. %__rm -rf %{buildroot}
  137. %__mkdir -p %{buildroot}%{_datadir}
  138. # create directories for xdg-utils
  139. mkdir -p %{buildroot}%{_datadir}/icons
  140. mkdir -p %{buildroot}%{_datadir}/icons/hicolor
  141. mkdir -p %{buildroot}%{_datadir}/packages
  142. mkdir -p %{buildroot}%{_datadir}/mime
  143. mkdir -p %{buildroot}%{_datadir}/mime/packages
  144. mkdir -p %{buildroot}%{_datadir}/applications
  145. mkdir -p %{buildroot}%{_datadir}/desktop-directories
  146. # create directory for gnome software data
  147. mkdir -p %{buildroot}%{_datadir}/appdata
  148. # create directory for calibre environment module
  149. # the install script assumes it's there.
  150. mkdir -p %{buildroot}%{python_sitelib}
  151. # create directory for completion files, so calibre knows where
  152. # to install them
  153. mkdir -p %{buildroot}%{_datadir}/bash-completion/completions
  154. mkdir -p %{buildroot}%{_datadir}/zsh/site-functions
  155. XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
  156. XDG_UTILS_INSTALL_MODE="system" \
  157. LIBPATH="%{_libdir}" \
  158. python setup.py install --root=%{buildroot}%{_prefix} \
  159. --prefix=%{_prefix} \
  160. --libdir=%{_libdir} \
  161. --staging-libdir=%{buildroot}%{_libdir} \
  162. --staging-sharedir=%{buildroot}%{_datadir}
  163. # remove shebang from init_calibre.py here because
  164. # it just got spawned by the install script
  165. sed -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
  166. # icons
  167. mkdir -p %{buildroot}%{_datadir}/pixmaps/
  168. cp -p resources/images/library.png \
  169. %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
  170. cp -p resources/images/viewer.png \
  171. %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
  172. cp -p resources/images/tweak.png \
  173. %{buildroot}%{_datadir}/pixmaps/calibre-ebook-edit.png
  174. # every file is empty here
  175. find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f -print -delete
  176. # packages aren't allowed to register mimetypes like this
  177. rm -f %{buildroot}%{_datadir}/applications/defaults.list
  178. rm -f %{buildroot}%{_datadir}/applications/mimeinfo.cache
  179. rm -f %{buildroot}%{_datadir}/mime/application/*.xml
  180. rm -f %{buildroot}%{_datadir}/mime/text/*.xml
  181. desktop-file-validate \
  182. %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
  183. desktop-file-validate \
  184. %{buildroot}%{_datadir}/applications/calibre-gui.desktop
  185. desktop-file-validate \
  186. %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
  187. # mimetype icon for lrf
  188. rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
  189. mkdir -p %{buildroot}%{_datadir}/icons/hicolor/scalable
  190. mkdir -p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
  191. mkdir -p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
  192. cp -p resources/images/mimetypes/lrf.png \
  193. %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
  194. cp -p resources/images/viewer.png \
  195. %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
  196. # these are provided as separate packages
  197. rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,encutils,cssutils}
  198. rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
  199. rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
  200. # rm empty feedparser files.
  201. rm -rf %{buildroot}%{_libdir}/%{name}/%{name}/web/feeds/feedparser.*
  202. ln -s %{python_sitelib}/feedparser.py \
  203. %{buildroot}%{_libdir}/%{name}/%{name}/web/feeds/feedparser.py
  204. ln -s %{python_sitelib}/feedparser.pyc \
  205. %{buildroot}%{_libdir}/%{name}/%{name}/web/feeds/feedparser.pyc
  206. ln -s %{python_sitelib}/feedparser.pyo \
  207. %{buildroot}%{_libdir}/%{name}/%{name}/web/feeds/feedparser.pyo
  208. for f in %{_datadir}/fonts/TrueType-liberation/*; do
  209. ln -s $f %{buildroot}%{_datadir}/%{name}/fonts/liberation/
  210. done
  211. # delete locales, calibre stores them in a zip file now
  212. rm -rf %{buildroot}%{_datadir}/%{name}/localization/locales/
  213. rm -f %{buildroot}%{_bindir}/%{name}-uninstall
  214. cp -p %{SOURCE2} %{buildroot}%{_bindir}/calibre-mount-helper
  215. cp -p %{SOURCE3} %{buildroot}%{_datadir}/appdata/
  216. %clean
  217. %{__rm} -rf %{buildroot}
  218. %post
  219. update-desktop-database &> /dev/null ||:
  220. update-mime-database %{_datadir}/mime &> /dev/null || :
  221. touch --no-create %{_datadir}/icons/hicolor || :
  222. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  223. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  224. fi
  225. %postun
  226. update-desktop-database &> /dev/null ||:
  227. update-mime-database %{_datadir}/mime &> /dev/null || :
  228. touch --no-create %{_datadir}/icons/hicolor || :
  229. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  230. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  231. fi
  232. %files
  233. %defattr(-,root,root,-)
  234. %license COPYRIGHT LICENSE
  235. %doc Changelog.yaml
  236. %{_bindir}/calibre
  237. %{_bindir}/calibre-complete
  238. %{_bindir}/calibre-customize
  239. %{_bindir}/calibre-debug
  240. %{_bindir}/calibre-parallel
  241. %{_bindir}/calibre-server
  242. %{_bindir}/calibre-smtp
  243. %{_bindir}/calibre-mount-helper
  244. %{_bindir}/calibredb
  245. %{_bindir}/ebook-convert
  246. %{_bindir}/ebook-device
  247. %{_bindir}/ebook-meta
  248. %{_bindir}/ebook-viewer
  249. %{_bindir}/fetch-ebook-metadata
  250. %{_bindir}/lrf2lrs
  251. %{_bindir}/lrfviewer
  252. %{_bindir}/lrs2lrf
  253. %{_bindir}/markdown-calibre
  254. %{_bindir}/web2disk
  255. %{_bindir}/ebook-polish
  256. %{_bindir}/ebook-edit
  257. %{_libdir}/%{name}
  258. %{_datadir}/%{name}
  259. %{_datadir}/pixmaps/*
  260. %{_datadir}/applications/*.desktop
  261. %{_datadir}/mime/packages/*
  262. %{_datadir}/icons/hicolor/*/mimetypes/*
  263. %{_datadir}/icons/hicolor/*/apps/*
  264. %{python_sitelib}/init_calibre.py*
  265. %{_datadir}/bash-completion/completions/%{name}
  266. %{_datadir}/zsh/site-functions/_%{name}
  267. %{_datadir}/appdata/calibre*.appdata.xml
  268. %changelog
  269. * Sat Jan 27 2018 Toshiaki Ara <ara_t@384.jp> 2.62.0-2
  270. - rebuild under current VineSeed
  271. * Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.62.0-1
  272. - new upstream release.
  273. * Sun Aug 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.50-2
  274. - rebuild with ImageMagick-6.8.6.8
  275. - add Patch3 (calibre-0.8.50-poppler-0.20.x.patch)
  276. * Tue May 8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.50-1
  277. - new upstream release
  278. - BuildRequires: qt4-devel >= 4.8.0
  279. - BuildRequires: PyQt4-devel >= 4.9.1
  280. * Fri Mar 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.44-1
  281. - new upstream release
  282. * Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.41-1
  283. - new upstream release
  284. * Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.50-2
  285. - rebuild with ImageMagick-6.7.5.10
  286. * Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.50-1
  287. - new upstream release
  288. * Sat Feb 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.46-1
  289. - new upstream release
  290. * Thu Feb 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.44-1
  291. - new upstream release
  292. * Fri Feb 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.42-1
  293. - new upstream release
  294. * Fri Jan 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.40-1
  295. - new upstream release
  296. * Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
  297. - new upstream release
  298. * Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
  299. - new upstream release
  300. * Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
  301. - new upstream release
  302. - added BuildRequires: libicu-devel
  303. * Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
  304. - new upstream release
  305. * Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
  306. - new upstream release
  307. * Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
  308. - new upstream release
  309. * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
  310. - Update to 0.7.24
  311. * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
  312. - Update to 0.7.23
  313. - Fix up mount helper with our own local script.
  314. - Change files to list binaries so missing ones can more easily be noted.
  315. * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
  316. - Update to 0.7.22
  317. * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
  318. - Update to 0.7.21
  319. * Wed Sep 29 2010 jkeating - 0.7.20-2
  320. - Rebuilt for gcc bug 634757
  321. * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
  322. - Update to 0.7.20
  323. * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
  324. - Rebuild for new ImageMagick
  325. * Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
  326. - new upstream release
  327. - Fix svg/png changes.
  328. * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
  329. - Fix svg/png changes.
  330. * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
  331. - Update to 0.7.18
  332. - Require > 0.9.6 cssutils
  333. * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
  334. - Update to 0.7.17
  335. * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
  336. - Update to 0.7.16
  337. * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
  338. - initial build based on Fedora development
  339. * Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
  340. - Update to 0.7.15
  341. * Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
  342. - rebuild (poppler)
  343. * Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
  344. - Update to 0.7.14
  345. * Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
  346. - Update to 0.7.13
  347. * Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
  348. - Update to 0.7.12
  349. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
  350. - Update to 0.7.11
  351. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
  352. - Rebuilt for python2.7
  353. * Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
  354. - Update to 0.7.10
  355. * Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
  356. - Update to 0.7.9
  357. * Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
  358. - Update to 0.7.8
  359. - build tar.xz instead of tar.bz2
  360. * Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
  361. - Update to 0.7.7
  362. * Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
  363. - Update to 0.7.6
  364. * Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
  365. - Update to 0.7.5
  366. * Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
  367. - Update to 0.7.4
  368. * Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
  369. - rebuilt with podofo 0.8.1
  370. * Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
  371. - Update to 0.7.1
  372. - Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
  373. * Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
  374. - Update to 0.7.0
  375. * Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
  376. - Update to 0.6.55
  377. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
  378. - Update to 0.6.54
  379. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
  380. - Update to 0.6.53
  381. * Wed May 5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
  382. - Rebuild against new poppler
  383. * Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
  384. - new upstream release 0.6.47
  385. - new chmlib requirement
  386. - create directory for calibre's environment module
  387. - use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
  388. - remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
  389. * Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
  390. - new upstream release 0.6.42
  391. - remove shebang from default_tweaks.py
  392. * Mon Feb 1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
  393. - new upstream release 0.6.37
  394. * Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
  395. - new upstream release 0.6.36
  396. - fixed a cssprofiles issue with loading the profiles
  397. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
  398. - added -cssprofiles patch to cvs
  399. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
  400. - remove python-cssutils 0.9.6 dependency
  401. * Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
  402. - new upstream release
  403. - fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
  404. - removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
  405. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
  406. - fix for package tagged without adding new patch to cvs
  407. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
  408. - new upstream release 0.6.32
  409. - project website has changed
  410. - added python-BeautifulSoup BuildRequire
  411. - new patch to fix full buildpath in binary files
  412. * Sun Dec 6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
  413. - New upstream version
  414. - Regenerated no-update patch because of code relocation
  415. * Wed Dec 2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
  416. - New upstream release
  417. * Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
  418. - New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
  419. * Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
  420. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
  421. - patch to stop checking for new upstream version
  422. * Sat Nov 7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
  423. - new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
  424. - added python-BeautifulSoup requirement
  425. * Wed Nov 4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
  426. - new upstream version:
  427. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
  428. - upstream now ships correct .desktop files
  429. - fixed missing dependency: PyQt4
  430. - fixed calibre-gui icon
  431. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
  432. - removed unfree fonts from source package
  433. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
  434. - readability enhancements
  435. - added python-genshi requires
  436. - removed libwmf require since ImageMagick provides libwmf-lite as a
  437. dependency and that's what we actually need
  438. * Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
  439. - new upstream version:
  440. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
  441. - delete fonts, calibre can find the system fonts
  442. - specify libdir as an install option, so calibre will link properly
  443. even on 64bit
  444. * Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
  445. - updated requires list
  446. - new upstream release
  447. - can override CFLAGS now
  448. - removed trac and genshi duplicates
  449. - use xdg env variables to do desktop integration in the buildroot
  450. - added xdg-utils buildrequire
  451. - install udev rules in /usr/lib even on 64bit and don't own the whole dir
  452. - removed wrongly used Version field from .desktop files
  453. * Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
  454. - mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
  455. - removed unneeded INSTALL file
  456. - marked bash completion file as config(noreplace) and take ownership of the dir
  457. * Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
  458. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
  459. - the install process changed significantly
  460. - locales were added
  461. * Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
  462. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
  463. - minor path fixes
  464. - rearranged files section
  465. * Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
  466. - handle desktop files
  467. - don't compress manpages and don't list them as duplicates
  468. - added lrfviewer icon
  469. * Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
  470. - Initial RPM release