choqok-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. %if %{?_dist_release} != "vl5"
  2. %define kde KDE
  3. %else
  4. %define kde KDE4
  5. %endif
  6. Summary: Choqok %{kde} Micro-Blogging Client
  7. Summary(ja): %{kde} マイクロブログクライアント
  8. Name: choqok
  9. Version: 1.3
  10. Release: 2%{?_dist_release}
  11. License: GPLv3
  12. Group: Applications/Internet
  13. URL: http://choqok.gnufolks.org/
  14. Source0: http://choqok.gnufolks.org/pkgs/%{name}-%{version}.tar.bz2
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: cmake >= 2.6
  17. BuildRequires: desktop-file-utils
  18. BuildRequires: kdelibs4-devel
  19. BuildRequires: gettext
  20. BuildRequires: qjson-devel
  21. BuildRequires: qoauth-devel
  22. BuildRequires: attica-devel
  23. BuildRequires: soprano-devel
  24. %if %{?_dist_release} != "vl5"
  25. BuildRequires: libindicate-qt-devel
  26. %endif
  27. Requires: %{name}-libs = %{version}-%{release}
  28. %description
  29. A Free/Open Source micro-blogging client for %{kde}.
  30. The name comes from an ancient Persian word, which means Sparrow!
  31. Choqok currently supports Twitter.com and Identi.ca services.
  32. %package libs
  33. Summary: Runtime libraries for %{name}
  34. Summary(ja): %{name} のランタイムライブラリ
  35. Group: System Environment/Libraries
  36. # Requires: %{name} = %{version}-%{release}
  37. # for kwallet, among other goodies
  38. Requires: kdebase-runtime
  39. %description libs
  40. %{summary}
  41. %package devel
  42. Summary: Development files for %{name}
  43. Summary(ja): %{name} の開発用ファイル
  44. Group: Development/Libraries
  45. Requires: %{name}-libs = %{version}-%{release}
  46. Requires: kdelibs4-devel
  47. %description devel
  48. %{summary}
  49. %prep
  50. %setup -q
  51. %build
  52. mkdir -p %{_target_platform}
  53. pushd %{_target_platform}
  54. PATH=$PATH:%{_prefix}/kerberos/bin \
  55. %cmake \
  56. -DCMAKE_BUILD_TYPE=release \
  57. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  58. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  59. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  60. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  61. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  62. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  63. ..
  64. popd
  65. make %{?_smp_mflags} -C %{_target_platform}
  66. %install
  67. rm -rf %{buildroot}
  68. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  69. %find_lang %{name}
  70. %check
  71. desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/choqok.desktop
  72. %clean
  73. rm -rf %{buildroot}
  74. %post
  75. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  76. %postun
  77. if [ $1 -eq 0 ] ; then
  78. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  79. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  80. fi
  81. %posttrans
  82. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  83. %files -f %{name}.lang
  84. %defattr(-,root,root,-)
  85. %doc COPYING README AUTHORS changelog TODO
  86. %{_bindir}/choqok
  87. %{_libdir}/kde4/choqok_*.so
  88. %{_libdir}/kde4/kcm_choqok_*.so
  89. %{_libdir}/kde4/konqchoqokplugin.so
  90. %{_datadir}/icons/hicolor/*/actions/retweet.png
  91. %{_datadir}/icons/hicolor/*/apps/*.png
  92. %{_datadir}/applications/kde4/choqok.desktop
  93. %{_datadir}/config.kcfg/*.kcfg
  94. %{_datadir}/kde4/services/choqok_*.desktop
  95. %{_datadir}/kde4/apps/choqok
  96. %{_datadir}/kde4/apps/choqok_*/*.rc
  97. %{_datadir}/kde4/apps/dbus-1/services/*
  98. %{_datadir}/kde4/apps/khtml/kpartplugins/*
  99. %{_datadir}/kde4/services/ServiceMenus/*.desktop
  100. %{_datadir}/kde4/servicetypes/choqok*.desktop
  101. %doc %{_docdir}/HTML/*
  102. %files libs
  103. %defattr(-,root,root,-)
  104. %{_libdir}/lib*.so.*
  105. %files devel
  106. %defattr(-,root,root,-)
  107. %{_includedir}/kde4/choqok
  108. %{_libdir}/lib*.so
  109. %{_datadir}/kde4/apps/cmake/*
  110. %changelog
  111. * Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> - 1.3-2
  112. - rebuild with gcc-5.4.0
  113. * Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3-1
  114. - new upstream release
  115. * Fri Feb 03 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 1.2-1
  116. - new upstream release
  117. - added BR: soprano-devel
  118. * Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0-1
  119. - new upstream release
  120. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.98-1
  121. - new upstream release
  122. - added BR: qjson-devel, qoauth-devel
  123. * Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.55-15
  124. - initial build for Vine Linux
  125. * Tue Mar 09 2010 Tejas Dinkar <tejas@gja.in> - 0.9.55-14
  126. - Add dependency from -libs to choqok
  127. * Tue Mar 09 2010 Rex Dieter <rdieter@fedoraprojecdt.org> - 0.9.55-13
  128. - Requires: kdebase-runtime (not kdeutils)
  129. * Tue Mar 09 2010 Tejas Dinkar <tejas@gja.in> - 0.9.55-12
  130. - choqok 1.0-beta
  131. * Wed Sep 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.6.6-9
  132. - add icon/desktop-file scriptlets
  133. * Sun Aug 16 2009 Tejas Dinkar <tejas@gja.in> - 0.6.6-8
  134. - Added Dependency on kdeutils
  135. - Choqok 0.6.6 is out
  136. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-8
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  138. * Sun Jun 14 2009 Tejas Dinkar <tejas@gja.in> - 0.6.1-7
  139. - Choqok 0.6.1 is out with the below two patches
  140. * Sat Jun 13 2009 Tejas Dinkar <tejas@gja.in> - 0.6-6
  141. - Fixed the inreplyto (via patch)
  142. * Sat Jun 13 2009 Tejas Dinkar <tejas@gja.in> - 0.6-5
  143. - Fixed the twitpocalypse (via patch)
  144. * Wed May 27 2009 Tejas Dinkar <tejas@gja.in> - 0.6-4
  145. - Changed to 0.6
  146. * Fri Apr 10 2009 Tejas Dinkar <tejas@gja.in> - 0.5-3
  147. - Added the TweetAll patch, remove this by 0.6
  148. * Fri Mar 27 2009 Tejas Dinkar <tejas@gja.in> - 0.5-2
  149. - Added AUTHORS changelog and TODO to doc
  150. * Fri Mar 27 2009 Tejas Dinkar <tejas@gja.in> - 0.5-1
  151. - Initial Version for Fedora