clearsilver-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158
  1. %bcond_with ruby
  2. %define name clearsilver
  3. %define version 0.10.5
  4. %define release 12%{_dist_release}
  5. Summary: A fast, powerful, and language-neutral HTML template system.
  6. Summary(ja): 高速、パワフルで言語中立なHTMLテンプレートシステム
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. License: Neotonic ClearSilver Software License
  11. Group: Applications/Text
  12. URL: http://clearsilver.net/
  13. Source0: http://clearsilver.net/downloads/%{name}-%{version}.tar.gz
  14. Patch0: clearsilver-0.10.5-conf.patch
  15. Patch1: clearsilver-0.10.5-regression.patch
  16. Patch2: clearsilver-0.10.5-CVE-2011-4357.patch
  17. Patch3: clearsilver-ruby-1.9.patch
  18. Patch4: clearsilver-ruby-2.2.patch
  19. # GCC 5 compatibility, bug #1190760
  20. Patch5: clearsilver-0.10.5-gcc5.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: perl
  23. BuildRequires: python-devel
  24. %if %{with ruby}
  25. BuildRequires: ruby
  26. BuildRequires: ruby-devel >= 1.9.3
  27. %endif
  28. BuildRequires: zlib-devel
  29. BuildRequires: libxcrypt-devel
  30. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  31. Provides: ruby(clearsilver)
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. %description
  35. ClearSilver is a fast, powerful, and language-neutral template system.
  36. It is designed to make it easy to create template driven static or
  37. dynamic websites.
  38. %description -l ja
  39. Clearsilver は高速、強力で言語中立なテンプレートシステムです。
  40. テンプレート駆動の静的あるいは動的な Web サイトの構築を
  41. 容易にすることを目指して設計されています。
  42. %prep
  43. %setup -q
  44. %patch0 -p1 -b .conf
  45. %patch1 -p1
  46. %patch2 -p1
  47. %if %{with ruby}
  48. %patch3 -p1
  49. %patch4 -p1
  50. %endif
  51. %patch5 -p2
  52. touch configure
  53. perl -pi -e 's/python_versions="2\.5/python_versions="2.7 2.6 2.5/' configure
  54. sed -i 's|/neo/opt/bin/python|%{__python}|' python/examples/*/*.py
  55. sed -i 's|PYTHON_SITE = @PYTHON_SITE@|PYTHON_SITE = %{python_sitearch}|' rules.mk.in
  56. sed -i -r 's|(\$\(RUBY\) install.rb config) (--.*)|\1 --rb-dir="$(DESTDIR)%{ruby_vendorlibdir}" --so-dir="$(DESTDIR)%{ruby_vendorarchdir}" \2|' ruby/Makefile
  57. find python/examples -type f | xargs chmod -x
  58. %build
  59. %configure \
  60. %if ! %{with ruby}
  61. --disable-ruby \
  62. %endif
  63. --disable-csharp
  64. %ifarch x86_64
  65. perl -pi -e 's/^(TARGETS =.+) test/$1/' cs/Makefile
  66. %endif
  67. %__make %{_smp_mflags}
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. make DESTDIR=${RPM_BUILD_ROOT} install
  71. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  72. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  73. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  74. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  75. chmod -R u+w $RPM_BUILD_ROOT/*
  76. %clean
  77. rm -rf $RPM_BUILD_ROOT
  78. %files
  79. %defattr(-,root,root)
  80. %doc CS_LICENSE INSTALL LICENSE README README.python
  81. %{_bindir}/*
  82. %{_includedir}/ClearSilver/
  83. %{perl_sitearch}/*.pm
  84. %{perl_sitearch}/auto/ClearSilver/
  85. %{python_sitearch}/*.so
  86. %if %{with ruby}
  87. %{ruby_vendorarchdir}/*.so
  88. %{ruby_vendorlibdir}/*.rb
  89. %endif
  90. %{_libdir}/*.a
  91. %{_mandir}/man*/*.gz
  92. %changelog
  93. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-12
  94. - rebuilt with perl-5.26.
  95. - added BR:libxcrypt-devel.
  96. * Tue Dec 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-11
  97. - added Patch5 for gcc5.
  98. - disabled ruby stuff.
  99. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.5-10
  100. - rebuild with ruby-2.2.3
  101. - add Patch4 (clearsilver-ruby-2.2.patch) from fedora
  102. * Wed Dec 17 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.5-9
  103. - rebuilt with perl 5.16.3 and ruby 2.1.5
  104. * Sun Dec 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-8
  105. - rebuilt with ruby-2.0.0.353.
  106. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.5-7
  107. - rebuild with ruby-1.9.3
  108. - add patch3 to build with ruby-1.9
  109. - add patch2 for CVE-2011-4357
  110. * Sat Feb 25 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-6
  111. - rebuilt with python-2.7.
  112. * Sun May 15 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-5
  113. - rebuilt with perl-5.12.3 and python-2.6.
  114. * Mon Jun 22 2009 Shu KONNO <owa@bg.wakwak.com> 0.10.5-4
  115. - applied new versioning policy, spec in utf-8
  116. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.5-3
  117. - rebuilt with python-2.5.2
  118. - added clearsilver-0.10.5-conf.patch
  119. * Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-2
  120. - rebuilt with perl-5.10.0.
  121. * Mon Apr 28 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-1
  122. - x86_64: make to skip testing.
  123. * Fri Nov 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.5-0vl4
  124. - add --disable-csharp for configure script
  125. * Tue Aug 28 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.10.5-0vl2
  126. - initial build for Vine Linux