cluster-glue-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327
  1. %global gname haclient
  2. %global uname hacluster
  3. %global nogroup nobody
  4. # When downloading directly from Mercurial, it will automatically add this prefix
  5. # Invoking 'hg archive' wont but you can add one with: hg archive -t tgz -p "Reusable-Cluster-Components-" -r $upstreamversion $upstreamversion.tar.gz
  6. %global specversion 1
  7. %global upstreamprefix Reusable-Cluster-Components-
  8. %global upstreamversion aa1f9dee2793
  9. # Keep around for when/if required
  10. #global alphatag %{upstreamversion}.hg
  11. Name: cluster-glue
  12. Summary: Reusable cluster components
  13. Summary(ja): 再利用可能なクラスタコンポーネント
  14. Version: 1.0.2
  15. Release: 4%{?_dist_release}
  16. License: GPLv2+ and LGPLv2+
  17. Url: http://linux-ha.org/wiki/Cluster_Glue
  18. Group: System Environment/Base
  19. Source0: http://hg.linux-ha.org/glue/archive/%{upstreamversion}.tar.bz2
  20. Provides: stonith = 3.0.0-1
  21. Provides: pils = 3.0.0-1
  22. Obsoletes: stonith < 3.0.0-1
  23. Obsoletes: pils < 3.0.0-1
  24. ## Setup/build bits
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  26. # Build dependencies
  27. Requires: perl-TimeDate
  28. BuildRequires: automake autoconf libtool pkgconfig chrpath libtool-ltdl-devel
  29. BuildRequires: bzip2-devel glib2-devel python-devel libxml2-devel
  30. BuildRequires: libuuid-devel
  31. # For documentation
  32. BuildRequires: libxslt docbook-style-xsl
  33. # For additional Stonith plugins
  34. BuildRequires: net-snmp-devel OpenIPMI-devel openhpi-devel curl-devel
  35. %if 0%{?fedora} > 11 || 0%{?rhel} > 5
  36. BuildRequires: libuuid-devel
  37. %else
  38. BuildRequires: e2fsprogs-devel
  39. %endif
  40. %prep
  41. %setup -q -n %{upstreamprefix}%{upstreamversion}
  42. ./autogen.sh
  43. %{configure} CFLAGS="${CFLAGS} $(echo '%{optflags}')" \
  44. --enable-fatal-warnings=no \
  45. --localstatedir=%{_var} \
  46. --with-daemon-group=%{gname} \
  47. --with-daemon-user=%{uname}
  48. %build
  49. make %{_smp_mflags}
  50. %install
  51. rm -rf %{buildroot}
  52. make install DESTDIR=%{buildroot}
  53. ## tree fix up
  54. # Dont package static libs
  55. find %{buildroot} -name '*.a' -exec rm {} \;
  56. find %{buildroot} -name '*.la' -exec rm {} \;
  57. # Don't package things we wont support
  58. rm -f %{buildroot}/%{_libdir}/stonith/plugins/stonith2/rhcs.*
  59. %clean
  60. rm -rf %{buildroot}
  61. # cluster-glue
  62. %description
  63. A collection of common tools that are useful for writing cluster managers
  64. such as Pacemaker.
  65. Provides a local resource manager that understands the OCF and LSB
  66. standards, and an interface to common STONITH devices.
  67. %files
  68. %defattr(-,root,root)
  69. %{_sbindir}/ha_logger
  70. %{_sbindir}/hb_report
  71. %{_sbindir}/lrmadmin
  72. %{_sbindir}/meatclient
  73. %{_sbindir}/sbd
  74. %{_sbindir}/stonith
  75. %{_sysconfdir}/init.d/logd
  76. %dir %{_libdir}/heartbeat
  77. %dir %{_libdir}/heartbeat/plugins
  78. %dir %{_libdir}/heartbeat/plugins/RAExec
  79. %dir %{_libdir}/heartbeat/plugins/InterfaceMgr
  80. %{_libdir}/heartbeat/lrmd
  81. %{_libdir}/heartbeat/ha_logd
  82. %{_libdir}/heartbeat/plugins/RAExec/*.so
  83. %{_libdir}/heartbeat/plugins/InterfaceMgr/*.so
  84. %dir %{_libdir}/stonith
  85. %dir %{_libdir}/stonith/plugins
  86. %dir %{_libdir}/stonith/plugins/stonith2
  87. %{_datadir}/cluster-glue/ha_log.sh
  88. %{_libdir}/stonith/plugins/external
  89. %{_libdir}/stonith/plugins/stonith2/*.so
  90. %{_libdir}/stonith/plugins/stonith2/*.py*
  91. %{_libdir}/stonith/plugins/xen0-ha-dom0-stonith-helper
  92. %dir %{_datadir}/cluster-glue
  93. %{_datadir}/cluster-glue/ha_cf_support.sh
  94. %{_datadir}/cluster-glue/openais_conf_support.sh
  95. %{_datadir}/cluster-glue/utillib.sh
  96. %{_datadir}/cluster-glue/combine-logs.pl
  97. %dir %{_var}/lib/heartbeat
  98. %dir %{_var}/lib/heartbeat/cores
  99. %dir %attr (0700, root, root) %{_var}/lib/heartbeat/cores/root
  100. %dir %attr (0700, nobody, %{nogroup}) %{_var}/lib/heartbeat/cores/nobody
  101. %dir %attr (0700, %{uname}, %{gname}) %{_var}/lib/heartbeat/cores/%{uname}
  102. %doc %{_datadir}/doc/cluster-glue/stonith
  103. %doc %{_mandir}/man1/*
  104. %doc %{_mandir}/man8/*
  105. %doc AUTHORS
  106. %doc COPYING
  107. # cluster-glue-libs
  108. %package -n cluster-glue-libs
  109. Summary: Reusable cluster libraries
  110. Summary(ja): Reusable cluster libraries
  111. Group: Development/Libraries
  112. Requires: %{name} = %{version}-%{release}
  113. %description -n cluster-glue-libs
  114. A collection of libraries that are useful for writing cluster managers
  115. such as Pacemaker.
  116. %pre
  117. getent group %{gname} >/dev/null || groupadd -r %{gname}
  118. getent passwd %{uname} >/dev/null || \
  119. useradd -r -g %{gname} -d %{_var}/lib/heartbeat/cores/hacluster -s /sbin/nologin \
  120. -c "heartbeat user" %{uname}
  121. exit 0
  122. %post -n cluster-glue-libs -p /sbin/ldconfig
  123. %postun -n cluster-glue-libs -p /sbin/ldconfig
  124. %files -n cluster-glue-libs
  125. %defattr(-,root,root)
  126. %{_libdir}/lib*.so.*
  127. %doc AUTHORS
  128. %doc COPYING.LIB
  129. # cluster-glue-libs-devel
  130. %package -n cluster-glue-libs-devel
  131. Summary: Headers and libraries for writing cluster managers
  132. Summary(ja): Headers and libraries for writing cluster managers
  133. Group: Development/Libraries
  134. Requires: cluster-glue-libs = %{version}-%{release}
  135. %description -n cluster-glue-libs-devel
  136. Headers and shared libraries for a useful for writing cluster managers
  137. such as Pacemaker.
  138. %files -n cluster-glue-libs-devel
  139. %defattr(-,root,root)
  140. %dir %{_libdir}/heartbeat
  141. %dir %{_libdir}/heartbeat/plugins
  142. %dir %{_libdir}/heartbeat/plugins/test
  143. %dir %{_datadir}/cluster-glue
  144. %{_libdir}/lib*.so
  145. %{_libdir}/heartbeat/ipctest
  146. %{_libdir}/heartbeat/ipctransientclient
  147. %{_libdir}/heartbeat/ipctransientserver
  148. %{_libdir}/heartbeat/transient-test.sh
  149. %{_libdir}/heartbeat/base64_md5_test
  150. %{_libdir}/heartbeat/logtest
  151. %{_includedir}/clplumbing
  152. %{_includedir}/heartbeat
  153. %{_includedir}/stonith
  154. %{_includedir}/pils
  155. %{_datadir}/cluster-glue/lrmtest
  156. %{_libdir}/heartbeat/plugins/test/test.so
  157. %doc AUTHORS
  158. %doc COPYING
  159. %doc COPYING.LIB
  160. %changelog
  161. * Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-4
  162. - rebuild with net-snmp-5.7.1
  163. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-3
  164. - rebuild with openssl-1.0.0d
  165. - add BuildRequires: libuuid-devel
  166. * Mon Jul 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  167. - Obsoletes/Provides: stonith, pils
  168. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  169. - initial build for Vine Linux
  170. * Mon Jan 11 2010 Andrew Beekhof <andrew@beekhof.net> - 1.0.2-1
  171. - Suppress unsupported stonith plugins
  172. - Update to latest upstream release: aa1f9dee2793
  173. + High: stonith: add ha_log.sh for external plugins (LF 1971)
  174. + High: stonith: external plugins log using ha_log.sh (LF 2294)
  175. + High: stonith: external/dracmc-telnet: new stonith plugin for Dell Drac/MC Blade Enclosure and Cyclades terminal server
  176. + High: stonith: external/riloe: workaround for the iLO double close of RIBCL element (bnc#553340)
  177. + High: stonith: external: log messages immediately on manage and status calls
  178. + High: stonith: external: log output of plugins (bnc#548699,553340)
  179. + Medium: LRM: lrmd: log outcome of monitor once an hour
  180. + Medium: LRM: lrmd: remove operation history on client unregister and flushing all operations (LF 2161)
  181. + Medium: LRM: lrmd: restore reset scheduler for children (bnc#551971, lf#2296)
  182. + Medium: LRM: raexec: close the logd fd too when executing agents (LF 2267)
  183. + Medium: Tools: hb_report: add -V (version) option and add support for corosync
  184. + Medium: external STONITH plugins: remove dependency on .ocf-shellfuncs (LF2249)
  185. + Medium: stonith: cyclades: fix for support for newer PM10 firmware (LF 1938)
  186. + Medium: stonith: external/ipmi: add explanation on reset and power off (LF 2071)
  187. + Medium: stonith: external/riloe: make sure that host is turned on after power off/on reset (LF 2282)
  188. + Medium: stonith: meatclient: add -w option to wait until it can connect
  189. + Medium: stonith: print complete metadata for -m (LF 2279)
  190. + Medium: stonith: stonith: add -m option to display metadata
  191. * Mon Nov 23 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.12.b79635605337.hg
  192. - Correctly select libuuid for building on rhel >=6
  193. * Mon Oct 12 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.11.b79635605337.hg
  194. - Add install dependancy on perl-TimeDate for hb_report
  195. - Update to upstream version b79635605337
  196. + Build: fix defines for pacemaker-pygui compatibility.
  197. + High: Tools: hb_report: log/events combining
  198. + High: doc: new README for wti_mpc
  199. + High: hb_report: add man page hb_report.8
  200. + High: hb_report: extract important events from the logs
  201. + High: stonith: external/ibmrsa-telnet: add support for later RSA cards
  202. + High: stonith: wti_mpc: support for MIB versions 1 and 3
  203. + Logd: Start/stop priorities are not created by configure
  204. + Med: sbd: Fix definition of size_t.
  205. + Med: sbd: Nodename comparison should be case insensitive (bnc#534445)
  206. + Med: wti_nps: add support for internet power switch model (bnc#539912)
  207. + Medium (LF 2194): LRM: fix return code on RA exec failure
  208. + Medium: Tools: hb_report: add -v option (debugging)
  209. + Medium: Tools: hb_report: options -C and -D are obsoleted
  210. + ha_logd: Fix a compile error/warning.
  211. + hb_report: report corosync packages too.
  212. + sbd: Accept -h (bnc#529574)
  213. + sbd: really fix the sector_size type.
  214. * Fri Oct 9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0-0.10.d97b9dea436e.hg.1
  215. - rebuild with new net-snmp
  216. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-0.9.d97b9dea436e.hg.1
  217. - rebuilt with new openssl
  218. * Mon Aug 17 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.9.d97b9dea436e.hg
  219. - Include relevant provides: and obsoletes: directives for heartbeat
  220. - Update the tarball from upstream to version d97b9dea436e
  221. + Include license files
  222. + Fix error messages in autogen.sh
  223. + High (bnc#501723): Tools: hb_report: collect archived logs too
  224. + Medium: clplumbing: check input when creating IPC channels
  225. + Medium (bnc#510299): stonith: set G_SLICE to always-malloc to avoid bad interaction with the threaded openhpi
  226. + Med: hb_report: report on more packages and with more state.
  227. + The -E option to lrmadmin does not take an argument
  228. + Provide a default value for docdir and ensure it is expanded
  229. + Low: clplumbing: fix a potential resource leak in cl_random (bnc#525393).
  230. + Med: hb_report: Include dlm_tool debugging information if available.
  231. + hb_report: Include more possible error output.
  232. + Medium: logd: add init script and example configuration file.
  233. + High: logd: Fix init script. Remove apphbd references.
  234. + logd: configuration file is optional.
  235. + logd: print status on finished operations.
  236. + High: sbd: actually install the binary.
  237. + Medium: stonith: remove references to heartbeat artifacts.
  238. + High: hb_report: define HA_NOARCHBIN
  239. + hb_report: correct syntax error.
  240. + hb_report: Include details about more packages even.
  241. + hb_report: report corosync packages too.
  242. * Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 1.0-0.8.75cab275433e.hg
  243. - Use bzipped upstream tarball.
  244. * Tue Jul 28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.7.75cab275433e.hg
  245. - Add a leading zero to the revision when alphatag is used
  246. * Tue Jul 28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.6.75cab275433e.hg
  247. - Incorporate results of Fedora review
  248. - Use global instead of define
  249. - Remove unused rpm variable
  250. - Remove redundant configure options
  251. - Change version to 1.0.0 pre-release and include Mercurial tag in version
  252. * Mon Jul 27 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-5
  253. - Use linux-ha.org for Source0
  254. - Remove Requires: $name from -devel as its implied
  255. - Instead of 'daemon', use the user and group from Heartbeat and create it
  256. if necessary
  257. * Fri Jul 24 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-4
  258. - Update the tarball from upstream to version 75cab275433e
  259. - Include an AUTHORS and license file in each package
  260. - Change the library package name to cluster-glue-libs to be more
  261. Fedora compliant
  262. * Mon Jul 20 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-3
  263. - Package the project AUTHORS file
  264. - Have Source0 reference the upstream Mercurial repo
  265. * Tue Jul 14 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-2
  266. - More cleanups
  267. * Fri Jul 3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.9-1
  268. - Fedora-ize the spec file
  269. * Fri Jun 5 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-0
  270. - Initial checkin