clutter-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412
  1. Summary: Open Source software library for creating rich graphical user interfaces
  2. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  3. Name: clutter
  4. Version: 1.26.4
  5. Release: 2%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: LGPLv2+
  10. URL: https://www.clutter-project.org/
  11. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  12. Source: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: gobject-introspection
  15. # FIXME to remove when all the bits have been merged into their
  16. # libraries
  17. BuildRequires: glib2-devel
  18. BuildRequires: gdk-pixbuf2-devel
  19. BuildRequires: atk-devel
  20. BuildRequires: gtk3-devel
  21. BuildRequires: pkgconfig
  22. BuildRequires: cairo-devel
  23. BuildRequires: pango-devel
  24. BuildRequires: libXdamage-devel
  25. BuildRequires: libXcomposite-devel
  26. BuildRequires: libXi-devel
  27. BuildRequires: mesa-libGL-devel
  28. BuildRequires: mesa-libEGL-devel
  29. BuildRequires: gettext
  30. BuildRequires: gtk-doc
  31. BuildRequires: gobject-introspection-devel >= 0.9.5
  32. BuildRequires: json-glib-devel
  33. BuildRequires: cogl-devel >= 1.20.0
  34. BuildRequires: libinput-devel
  35. BuildRequires: libxkbcommon-devel
  36. BuildRequires: eudev-libudev-devel
  37. BuildRequires: libgudev-devel
  38. BuildRequires: pkgconfig(wayland-client)
  39. BuildRequires: pkgconfig(wayland-cursor)
  40. BuildRequires: pkgconfig(wayland-server)
  41. BuildRequires: pkgconfig(xkbcommon)
  42. %description
  43. Clutter is an open source software library for creating fast,
  44. visually rich graphical user interfaces. The most obvious example
  45. of potential usage is in media center type applications.
  46. We hope however it can be used for a lot more.
  47. %description -l ja
  48. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  49. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  50. しかしながら、我々はいろいろな分野で使用されることを願っています。
  51. %package devel
  52. Summary: Clutter development environment
  53. Summary(ja): Clutterの開発環境
  54. Group: programming
  55. Requires: %{name} = %{version}-%{release}
  56. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
  57. Requires: mesa-libGL-devel
  58. Requires: mesa-libEGL-devel
  59. Requires: gobject-introspection-devel
  60. Requires: json-glib-devel
  61. Requires: libXcomposite-devel
  62. Requires: libXi-devel
  63. %description devel
  64. Header files and libraries for building a extension library for the
  65. clutter
  66. %package docs
  67. Summary: Documentation for %{name}
  68. Summary(ja): %{name}用のドキュメント
  69. Group: documentation
  70. Provides: %{name}-doc = %{version}-%{release}
  71. BuildArch: noarch
  72. %description docs
  73. Clutter is an open source software library for creating fast,
  74. visually rich graphical user interfaces. The most obvious example
  75. of potential usage is in media center type applications.
  76. We hope however it can be used for a lot more.
  77. This package contains documentation for clutter.
  78. %debug_package
  79. %prep
  80. %setup -q
  81. %build
  82. # gobject introspection does not work with LTO. There is an effort to fix this
  83. # in the appropriate project upstreams, so hopefully LTO can be enabled someday
  84. # Disable LTO.
  85. %define _lto_cflags %{nil}
  86. %configure \
  87. --disable-static \
  88. --disable-silent-rules \
  89. --enable-introspection=yes \
  90. --enable-xinput \
  91. --enable-x11-backend \
  92. --enable-gdk-backend \
  93. --enable-egl-backend \
  94. --enable-evdev-input \
  95. --enable-wayland-backend \
  96. --enable-wayland-compositor
  97. make %{?_smp_mflags} V=1
  98. %install
  99. rm -rf $RPM_BUILD_ROOT
  100. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  101. #Remove libtool archives.
  102. find %{buildroot} -name '*.la' -delete
  103. %find_lang %{name}-1.0
  104. %files -f %{name}-1.0.lang
  105. %defattr(-,root,root,-)
  106. %license COPYING
  107. %doc AUTHORS NEWS README
  108. %{_libdir}/*.so.*
  109. %{_libdir}/girepository-1.0/*.typelib
  110. %files devel
  111. %defattr(-, root, root)
  112. %doc ChangeLog
  113. %{_includedir}/clutter-1.0
  114. %{_libdir}/*.so
  115. %{_libdir}/pkgconfig/*.pc
  116. %{_datadir}/gir-1.0/*.gir
  117. %{_datadir}/clutter-1.0
  118. %files docs
  119. %defattr(-, root, root)
  120. %{_datadir}/gtk-doc/html/clutter
  121. %changelog
  122. * Sun Mar 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.4-2
  123. - rebuilt with wayland.
  124. - dropped ldconfig scriptlets.
  125. - dropped Patch0.
  126. * Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.4-1
  127. - new upstream release.
  128. * Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.2-2
  129. - disabled gdk backend.
  130. * Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.2-1
  131. - new upstream release.
  132. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.0-1
  133. - new upstream release
  134. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.24.2-1
  135. - new upstream release
  136. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.4-1
  137. - new upstream release
  138. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.2-1
  139. - new upstream release
  140. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
  141. - new upstream release
  142. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
  143. - new upstream release
  144. - add BuildRequires: mesa-libEGL-devel
  145. * Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
  146. - new upstream release
  147. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
  148. - new upstream release
  149. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
  150. - new upstream release
  151. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
  152. - new upstream release
  153. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
  154. - new upstream release
  155. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
  156. - new upstream release
  157. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
  158. - new upstream release
  159. * Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
  160. - new upstream release
  161. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  162. - new upstream release
  163. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  164. - new upstream release
  165. * Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  166. - new upstream release
  167. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  168. - new upstream release
  169. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
  170. - new upstream release
  171. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  172. - new upstream release
  173. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
  174. - new upstream release
  175. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  176. - new upstream release
  177. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  178. - new upstream release
  179. - add Requires: libXcomposite-devel, libXi-devel (-devel package)
  180. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
  181. - new upstream release
  182. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
  183. - new upstream release
  184. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
  185. - new upstream release
  186. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
  187. - new upstream release
  188. - add BuildRequires: cogl-devel
  189. - add "BuildArch: noarch" to doc sub package
  190. - add Patch0 (clutter-fixdso.patch)
  191. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  192. - new upstream release
  193. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  194. - new upstream release
  195. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  196. - new upstream release
  197. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
  198. - new upstream release
  199. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  200. - new upstream release
  201. - change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
  202. - add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
  203. - drop Patch0
  204. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  205. - new upstream release
  206. - drop Patch1
  207. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  208. - new upstream release
  209. - add BuildRequires: json-glib-devel
  210. - delete Requires: gir-repository
  211. - delete BuildRequires: gir-repository-devel
  212. - add Requires: json-glib-devel (devel package)
  213. - add Patch0, Patch1
  214. - fix %build
  215. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  216. - rebuild with rpm-4.8.1 for pkg-config file
  217. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  218. - new upstream release
  219. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  220. - new upstream release
  221. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  222. - new upstream release
  223. - add configure option (--enable-xinput)
  224. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  225. - new upstream release
  226. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  227. - new upstream release
  228. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  229. - new upstream release
  230. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  231. - new upstream release
  232. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  233. - new upstream release
  234. - build for Vine Linux
  235. - add Summary(ja)
  236. - fix BuildRoot
  237. - remove Obsolete and Provides
  238. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  239. - Update to 1.0.6
  240. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  241. - Update to 1.0.4, update gobject-introspection requirement
  242. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  243. - Update to 1.0.2
  244. * Sat Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  245. - Move ChangeLog to -devel to save some space
  246. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  247. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  248. onto the live cd
  249. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  250. - Update to 1.0.0
  251. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  252. - fix bz #507389
  253. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  254. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  255. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  256. - Update to 0.9.8
  257. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  258. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  259. introspection support to clutter (#512260)
  260. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  261. - Update to 0.9.6
  262. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  263. - Update to 0.9.4
  264. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  265. - Update to 0.9.2
  266. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  267. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  268. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  269. - Remove noarch from doc subpackage
  270. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  271. - Added gtk-doc for cogl
  272. - Created doc subpackage
  273. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  274. - Update to 0.8.6
  275. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  276. - Update to 0.8.2
  277. - Removed clutter-0.8.0-clutter-fixed.patch
  278. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  279. - Update to 0.8.0
  280. - Added clutter-0.8.0-clutter-fixed.patch
  281. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  282. - Update to 0.6.4
  283. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  284. - Update to 0.6.2
  285. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  286. - Update to 0.6.0
  287. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  288. - Autorebuild for GCC 4.3
  289. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  290. - Update to 0.4.2
  291. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  292. - Update to 0.4.1
  293. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  294. - Update to 0.3.1
  295. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  296. - Update to 0.2.3
  297. * Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  298. - Changed buildrequires and requires
  299. * Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  300. - Fix .spec
  301. * Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  302. - Fix .spec
  303. * Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  304. - Initial RPM release