cmigemo-vl.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108
  1. %define srcdate 20110227
  2. %define srcname cmigemo-default-src
  3. %define use_git 1
  4. %define githash 5e5f9810
  5. Summary: C implementation of migemo
  6. Summary(ja): Migemo の C 言語による実装
  7. Name: cmigemo
  8. Version: 1.3e
  9. %if %{use_git}
  10. Release: 2.git%{githash}%{?_dist_release}
  11. Source0: %{name}-git%{githash}.tar.gz
  12. %else
  13. Release: 1%{?_dist_release}
  14. Source0: http://cmigemo.googlecode.com/files/%{srcname}-%{srcdate}.zip
  15. %endif
  16. Patch0: cmigemo-include-fix.patch
  17. Patch2: cmigemo-git_no-http.patch
  18. License: MIT/distributable (see README files for detail)
  19. Group: System Environment/Libraries
  20. URL: http://www.kaoriya.net/software/cmigemo
  21. #Requires:
  22. BuildRequires: ctags
  23. BuildRequires: unzip
  24. BuildRequires: nkf
  25. #BuildRequires: curl
  26. BuildRequires: skkdic
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: kazutaka
  31. %description
  32. C/Migemo is a C implementation of Migemo(Ruby/Migemo).
  33. With this library, It is possible to implement incremantal search
  34. function for japanese using roman letter input.
  35. %description -l ja
  36. C/MigemoはMigemo(Ruby/Migemo)をC言語で実装したものです。C/Migemo
  37. ライブラリを利用するソフトウェアは「ローマ字のまま日本語を(インク
  38. リメンタルに)検索する」機能を持つことが可能になります。
  39. %prep
  40. %if %{use_git}
  41. %setup -q -n %{name}-git%{githash}
  42. %else
  43. %setup -q -n %{srcname}
  44. %endif
  45. %patch0 -p1 -b .include
  46. %patch2 -p1 -b .no-http
  47. # fix execution bit for configure
  48. %{__chmod} +x ./configure
  49. %build
  50. %configure --prefix=$RPM_BUILD_ROOT/%{_prefix}
  51. %{__make} gcc
  52. %{__make} gcc-dict
  53. %install
  54. %{__rm} -rf $RPM_BUILD_ROOT
  55. %{__make} gcc-install DESTDIR=$RPM_BUILD_ROOT
  56. # fix library install location for x86_64
  57. %ifarch x86_64
  58. %{__mv} $RPM_BUILD_ROOT/%{_prefix}/lib/ $RPM_BUILD_ROOT/%{_prefix}/lib64
  59. %endif
  60. # remove unnecessary files
  61. %{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/migemo/cp932/
  62. %{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/migemo/euc-jp/
  63. %{__rm} -rf $RPM_BUILD_ROOT/%{_prefix}/doc/migemo/README_j.txt
  64. %post -p /sbin/ldconfig
  65. %postun -p /sbin/ldconfig
  66. %clean
  67. %{__rm} -rf $RPM_BUILD_ROOT
  68. %files
  69. %defattr(-,root,root)
  70. %doc README.txt doc/
  71. %{_bindir}/%{name}
  72. %{_includedir}/migemo.h
  73. %{_libdir}/libmigemo*
  74. %{_datadir}/migemo/
  75. %changelog
  76. * Sun Jan 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.3e-2.git5e5f9810
  77. - update to Git 5e5f9810
  78. - drop unneccesary UTF-8 dictionary patch (Patch1)
  79. - add no HTTP patch (Patch2)
  80. - add BuildRequires: skkdic
  81. * Mon Jun 20 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 1.3e-1
  82. - initial build for Vine Linux