cogl-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219
  1. Name: cogl
  2. Version: 1.22.8
  3. Release: 2%{?_dist_release}
  4. Summary: A small open source library for using 3D graphics hardware to draw pretty pictures
  5. Group: system
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: LGPLv2+
  9. URL: https://www.clutter-project.org/
  10. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  11. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  12. # Vaguely related to https://bugzilla.gnome.org/show_bug.cgi?id=772419
  13. # but on the 1.22 branch, and the static inline in the header is gross
  14. # ajax promises he'll clean this up.
  15. Patch0: 0001-egl-Use-eglGetPlatformDisplay-not-eglGetDisplay.patch
  16. # "GL_ARB_shader_texture_lod" is used to do lod biased texturing. It
  17. # make achieve faster blurring of images instead of using large blur radius.
  18. Patch1: 0002-add-GL_ARB_shader_texture_lod-support.patch
  19. # "copy_sub_image" is used to implement feature similar with kwin blur
  20. # effect by being abel to copy partial of framebuffer contents as texture
  21. # and do post blurring.
  22. Patch2: 0003-texture-support-copy_sub_image.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: gobject-introspection-devel
  25. BuildRequires: libXcomposite-devel
  26. BuildRequires: libXrandr-devel
  27. BuildRequires: mesa-libGL-devel
  28. BuildRequires: mesa-libEGL-devel
  29. BuildRequires: mesa-libgbm-devel
  30. BuildRequires: pango-devel
  31. BuildRequires: gdk-pixbuf2-devel
  32. BuildRequires: gstreamer1-plugins-base-devel
  33. BuildRequires: gtk-doc
  34. BuildRequires: pkgconfig(wayland-server)
  35. BuildRequires: pkgconfig(wayland-client)
  36. BuildRequires: pkgconfig(wayland-cursor)
  37. BuildRequires: pkgconfig(wayland-egl)
  38. %description
  39. Cogl is a small open source library for using 3D graphics hardware to draw
  40. pretty pictures. The API departs from the flat state machine style of
  41. OpenGL and is designed to make it easy to write orthogonal components that
  42. can render without stepping on each others toes.
  43. %package devel
  44. Summary: Development tools for cogl
  45. Summary(ja): cogl の開発環境
  46. Group: programming
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: pkgconfig
  49. %description devel
  50. Header files and libraries for building a extension library for the
  51. cogl.
  52. %package gstreamer
  53. Summary: Cogl GStreamer library
  54. Summary(ja): cogl gstreamer ライブラリ
  55. Group: system
  56. Requires: %{name} = %{version}-%{release}
  57. %description gstreamer
  58. %{summary}
  59. %package docs
  60. Summary: Documentation for cogl
  61. Summary(ja): cogl 用のドキュメント
  62. Group: documentation
  63. Provides: %{name}-doc = %{version}-%{release}
  64. BuildArch: noarch
  65. %description docs
  66. This package contains documentation for cogl.
  67. %debug_package
  68. %prep
  69. %autosetup -p1
  70. %build
  71. %configure \
  72. --enable-gtk-doc \
  73. --disable-static \
  74. --enable-cairo=yes \
  75. --enable-gdk-pixbuf=yes \
  76. --enable-cogl-gst=yes \
  77. --enable-cogl-pango=yes \
  78. --enable-glx=yes \
  79. --enable-introspection=yes \
  80. --enable-kms-egl-platform=yes \
  81. --enable-xlib-egl-platform=yes \
  82. --enable-wayland-egl-platform \
  83. --enable-wayland-egl-server
  84. make %{_smp_mflags} V=1
  85. %install
  86. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  87. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  88. %find_lang %{name}
  89. %files -f %{name}.lang
  90. %defattr(-,root,root,-)
  91. %license COPYING
  92. %doc ChangeLog AUTHORS NEWS README
  93. %{_libdir}/*.so.*
  94. %{_libdir}/girepository-1.0/*.typelib
  95. %{_datadir}/%{name}/examples-data/crate.jpg
  96. %files devel
  97. %defattr(-,root,root,-)
  98. %{_includedir}/cogl
  99. %{_libdir}/*.so
  100. %{_libdir}/pkgconfig/*.pc
  101. %{_datadir}/gir-1.0/*.gir
  102. %files gstreamer
  103. %defattr(-,root,root,-)
  104. %{_libdir}/gstreamer-1.0/libgstcogl.so
  105. %files docs
  106. %defattr(-,root,root,-)
  107. %{_datadir}/gtk-doc/html/cogl
  108. %{_datadir}/gtk-doc/html/cogl-gst
  109. %{_datadir}/gtk-doc/html/cogl-2.0-experimental
  110. %changelog
  111. * Sun Mar 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.8-2
  112. - rebuilt with wayland.
  113. - dropped ldconfig scriptlets.
  114. - imported Patch0-2 from rawhdie.
  115. * Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.8-1
  116. - new upstream release.
  117. - dropped Patch0: fixed in upstream.
  118. * Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.2-1
  119. - new upstream release.
  120. - added Patch0.
  121. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
  122. - new upstream release
  123. - remove Patch0
  124. * Wed May 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-2
  125. - add Patch0 (cogl-1.20.0-git20150508.patch)
  126. - add BuildRequires: mesa-libgbm-devel
  127. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
  128. - new upstream release
  129. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
  130. - new upstream release
  131. - add BuildRequires: mesa-libEGL-devel
  132. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
  133. - new upstream release
  134. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
  135. - new upstream release
  136. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-2
  137. - rebuild with VineSeed environment
  138. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
  139. - new upstream release
  140. - add BuildRequire: gstreamer1-plugins-base-devel
  141. * Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
  142. - new upstream release
  143. - add BuildRequires: libXrandr-devel
  144. * Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  145. - new upstream release
  146. * Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  147. - new upstream release
  148. - remove Patch0 (04_fix_crash_on_free.patch)
  149. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
  150. - new upstream release
  151. * Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
  152. - add Patch0 (04_fix_crash_on_free.patch)
  153. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  154. - new upstream release
  155. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  156. - new upstream release
  157. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  158. - new upstream release
  159. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.8-1
  160. - new upstream release
  161. - remove Patch0
  162. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
  163. - new upstream release
  164. - add Patch0 (cogl-1.7.6-configure.patch)
  165. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
  166. - initial build for Vine Linux