color-mate-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1 | grep -v "is not")
  2. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  3. Summary: colorize emacsens' window
  4. Name: color-mate
  5. Version: 10.6.4
  6. Release: 1%{?_dist_release}
  7. Group: Applications/Editors/Emacs
  8. License: distributable
  9. Url: http://www.netlab.is.tsukuba.ac.jp/~yokota/izumi/color_mate/
  10. Source0: color-mate-%{version}.tar.gz
  11. Source1: cm_select.sh
  12. Source2: emacs-color.sh
  13. Patch0: color-mate-fontset.patch
  14. Patch1: color-mate-10.6.3-color-mate-fontset-emacs.patch
  15. Patch2: color-mate-10.6.3-color-mate-fontset-xemacs.patch
  16. Patch3: color-mate-face-nound.patch
  17. Patch4: color-mate-SunnyDay-LCD.patch
  18. Patch5: color-mate-10.6.3-tail.patch
  19. Source10: color-mate-install.sh
  20. Source11: color-mate-remove.sh
  21. BuildArch: noarch
  22. Buildroot: %{_tmppath}/%{name}-%{version}-root
  23. Requires: emacsen
  24. BuildRequires: emacsen-common
  25. %prereq_ge emacsen-common
  26. Requires(post): make
  27. Obsoletes: color-mate-emacs, color-mate-xemacs
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. %description
  31. Color-Mate is a colorize tool for emacs/xemacs.
  32. %description -l ja
  33. Color-Mate とは、 emacs/xemacs のカラー表示機能を使ってXウィンドウ版
  34. emacs/xemacs 画面を見やすくするものです。
  35. %prep
  36. %setup -q
  37. %patch0 -p0
  38. %patch1 -p1
  39. %patch2 -p1
  40. %patch3 -p0
  41. %patch4 -p1
  42. %patch5 -p1
  43. %build
  44. #just adding annoying file to the rpm filelist
  45. ./configure
  46. %install
  47. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  48. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/color-mate
  49. #mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/install
  50. #mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/remove
  51. mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/install
  52. mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/remove
  53. # install el files
  54. cp -ar Makefile* configure* *.el *.pl install-sh* kanakan-cursor contrib theme/\
  55. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/color-mate
  56. # install contrib
  57. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  58. install -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_bindir}/cm_select
  59. install -m 755 %{SOURCE2} ${RPM_BUILD_ROOT}%{_bindir}/emacs-color
  60. # pushd ${RPM_BUILD_ROOT}%{_bindir}/
  61. # ln -s emacs-color xemacs-color
  62. # popd
  63. # prepare docs
  64. mv contrib/README README.cm_select
  65. ## install script (bytecompile el and install elc, remove elc)
  66. %_installemacsenscript color-mate %{SOURCE10}
  67. %_removeemacsenscript color-mate %{SOURCE11}
  68. %clean
  69. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  70. %post
  71. ## bytecompile el and install elc
  72. if [ "$1" = 2 ] ; then
  73. %_emacsenPackageRemove color-mate
  74. fi
  75. %_addemacsenlist color-mate
  76. %_emacsenPackageInstall color-mate
  77. %preun
  78. if [ "$1" = 0 ] ; then
  79. %_emacsenPackageRemove color-mate
  80. %_removeemacsenlist color-mate
  81. fi
  82. %files
  83. %defattr(-,root,root)
  84. %doc Q_and_A.color-mate QuickStart.color-mate README.color-mate*
  85. %doc Customize* ChangeLog Dot*
  86. %doc kanakan-cursor/org-doc/* kanakan-cursor/README* contrib/
  87. %{_bindir}/cm_select
  88. %{_bindir}/emacs-color
  89. #%{_bindir}/xemacs-color
  90. %{_datadir}/emacs/site-lisp/color-mate/
  91. #/usr/lib/emacsen-common/packages/*/*
  92. %{emacsen_pkgdir}/*/*
  93. %changelog
  94. * Fri Apr 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 10.6.4-1
  95. - new upstream release
  96. - dropped supporting xemacs
  97. * Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 10.6.3-1vl5
  98. - applied new versioning policy, spec in utf-8
  99. - added macro %%emacsen_pkgdir
  100. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.6.3-0vl3
  101. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  102. * Sun Aug 13 2006 IWAI, Masaharu <iwai@alib.jp> 10.6.3-0vl2
  103. - update color-mate-install.sh for Emacs 22
  104. - using Licenes tag
  105. - add tail option patch ( Patch5 )
  106. * Wed Apr 9 2003 IWAI Masaharu <iwai@alib.jp> 10.6.3-0vl1
  107. - version up to 10.6.3
  108. - update color-mate-fontset-emacs.patch (Patch1)
  109. - update color-mate-fontset-xemacs.patch (Patch2)
  110. * Fri Mar 29 2002 Jun Nishii <jun@vinelinux.org> 10.1.1-0vl8
  111. - fix color-mate-{install,remove}.sh
  112. * Fri Mar 29 2002 Jun Nishii <jun@vinelinux.org> 10.1.1-0vl7
  113. - install missing .X files
  114. - use symlink for color-xemacs
  115. - update cm_select
  116. * Sun Dec 16 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.1.1-0vl6
  117. - install script (SOURCE10) modified a little
  118. * Sun Dec 16 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.1.1-0vl5
  119. - emacsen-common aware
  120. * Sun Dec 03 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  121. - 10.1.1-0vl4
  122. - fixed description
  123. - added BuildRequires and %%{emacs} / %%{xemacs} for each package to be
  124. built on anti-BuildRequired host (both set to be 1 by default).
  125. - cp -a for egg-cursor.el to work around with emacs's murmur :-)
  126. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  127. - 10.1.1-0vl3
  128. - with egg-cursor
  129. * Wed Sep 20 2000 Jun Nishii <jun@vinelinux.org>
  130. - 10.1.1-0vl2
  131. - modify emacs-color
  132. * Fri Sep 15 2000 Jun Nishii <jun@vinelinux.org>
  133. - 9.1.1-0vl1
  134. - enable to set default fontset in .emacs
  135. - obsletes SunnyDay-LCD 12
  136. - added cm_select in bins
  137. - added emacs-color, xemacs-color
  138. * Mon Sep 11 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  139. - 10.0.1-8
  140. - added SunnyDay-LCD 12 dots fontset theme
  141. * Fri Feb 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  142. - 10.0.1-7
  143. - added %defattr(-,root,root)
  144. - added %clean section
  145. * Wed Jan 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  146. - 10.0.1-6
  147. - fixed SunnyDay-LCD.el for "wrong type argument" problem
  148. * Fri Dec 3 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  149. - 10.0.1-5
  150. - %files xemacs section modified for correct load-path
  151. to /usr/lib/xemacs/site-packages/lisp/color-mate
  152. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  153. - change Group to Applications/Editors/EmacsLisp
  154. * Wed Nov 17 1999 Jun NISHII <jun@vinelinux.org>
  155. - build for Vine-2.0