compiler-rt-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: LLVM "compiler-rt" runtime libraries
  6. Summary(ja): LLVM "compiler-rt" ランタイムライブラリ
  7. Name: compiler-rt
  8. Version: 12.0.1
  9. Release: 1%{?_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: NCSA
  14. URL: https://llvm.org/
  15. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
  16. # patches
  17. Patch0: 0001-PATCH-compiler-rt-Workaround-libstdc-limitation-wrt..patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: cmake
  20. BuildRequires: ninja
  21. BuildRequires: python3
  22. BuildRequires: python3-devel
  23. BuildRequires: llvm-devel = %{version}
  24. BuildRequires: llvm-static = %{version}
  25. Requires: clang = %{version}-%{release}
  26. # LLVM is not supported on PPC64
  27. # http://llvm.org/bugs/show_bug.cgi?id=3729
  28. ExcludeArch: ppc64
  29. %description
  30. The compiler-rt project is a part of the LLVM project. It provides
  31. implementation of the low-level target-specific hooks required by
  32. code generation, sanitizer runtimes and profiling library for code
  33. instrumentation, and Blocks C language extension.
  34. %debug_package
  35. %prep
  36. %autosetup -n compiler-rt-%{version}.src -p2
  37. pathfix%{python3_version}.py -i %{__python3} -pn lib/hwasan/scripts/hwasan_symbolize
  38. %build
  39. %cmake \
  40. -GNinja \
  41. -DCMAKE_BUILD_TYPE=Release \
  42. -DCMAKE_INSTALL_RPATH=";" \
  43. %if 0%{?__isa_bits} == 64
  44. -DLLVM_LIBDIR_SUFFIX=64 \
  45. %else
  46. -DLLVM_LIBDIR_SUFFIX= \
  47. %endif
  48. -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
  49. %cmake_build
  50. %install
  51. rm -rf %{buildroot}
  52. %cmake_install
  53. # compiler-rt
  54. # move sanitizer lists to better place
  55. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/share
  56. mv -v %{buildroot}%{_datadir}/*list.txt %{buildroot}%{_libdir}/clang/%{version}/share/
  57. # move sanitizer libs to better place
  58. %global libclang_rt_installdir lib/linux
  59. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib
  60. mv -v %{buildroot}%{_prefix}/%{libclang_rt_installdir}/*clang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
  61. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib/linux/
  62. pushd %{buildroot}%{_libdir}/clang/%{version}/lib
  63. for i in *.a *.so
  64. do
  65. ln -s ../$i linux/$i
  66. done
  67. %if %{with test}
  68. %check
  69. #cmake_build --target check-compiler-rt
  70. %endif
  71. %clean
  72. rm -rf %{buildroot}
  73. %files
  74. %license LICENSE.TXT
  75. %{_includedir}/*
  76. %{_libdir}/clang/%{version}/lib/*
  77. %{_libdir}/clang/%{version}/share/*
  78. %ifarch x86_64 aarch64
  79. %{_bindir}/hwasan_symbolize
  80. %endif
  81. %changelog
  82. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  83. - new upstream release.
  84. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  85. - devided compiler-rt from llvm.
  86. - new upstream release.
  87. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  88. - enabled to build utils.
  89. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  90. - new upstream release.
  91. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  92. - new upstream release.
  93. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  94. - rebuilt with libffi-3.3.
  95. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  96. - new upstream release.
  97. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  98. - new upstream release.
  99. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  100. - dropped all patches.
  101. - switched build-system to ninja.
  102. - switched python to python3.
  103. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  104. - new upstream release.
  105. - added OpenMP.
  106. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  107. - fixed %%files.
  108. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  109. - new upstream release.
  110. - dropped Patch0, 4, 5, 100 and 200.
  111. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  112. - renamed a subpackage "llvm-libs".
  113. - added a subpackage "lld".
  114. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  115. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  116. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  117. - new upstream release.
  118. - dropped Patch1 and 2: fixed in upstream.
  119. - imported Patch0, 3-5, 100 and 200 from rawhide.
  120. - disabled Patch1002: no longer needed?
  121. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  122. - new upstream release.
  123. - switched to cmake.
  124. - disable ocaml binding as default.
  125. - updated Patch1000 and 1002.
  126. - disabled Patch1000 as default.
  127. - cleanup patches.
  128. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  129. - rebuild with gcc-5.4.0
  130. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  131. - new upstream release
  132. - added BR: ocaml-ctypes
  133. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  134. - new upstream release
  135. - dropt Patch 1, 201 and 1001
  136. - updated Patch 1000
  137. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  138. - updated to 3.5.1
  139. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  140. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  141. - obsoleted clang-doc
  142. - built with ocaml 4.02.1
  143. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  144. - fix <BTS:2832>
  145. - fix configure option "--with-c-include-dirs"
  146. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  147. - update Patch1001: clang-3.5.0-driver-lib64.patch
  148. - update Patch1002: clang-3.5.0-driver-vine.patch
  149. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  150. - update to 3.5.0
  151. - remove Patch11 (clang-hardfloat-hack.patch)
  152. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  153. - rebuild with libffi-3.0.13
  154. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  155. - update to 3.3
  156. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  157. - ld.gold (patch1000,1001)
  158. - add /%{_lib} to ld search path
  159. - add support *-vine-linux gcc (patch1002)
  160. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  161. - update to 3.1
  162. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  163. - updated to 3.0 release
  164. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  165. - added patch 2-4 to support -O4 link-time optimization
  166. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  167. - disable -fno-var-tracking-assignments on ppc
  168. (seems like gcc-4.4.5 still doesn't support this)
  169. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  170. - new upstream release
  171. - add BR: libffi-devel
  172. - add R: libffi-devel to -devel
  173. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  174. - initial build for Vine Linux
  175. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  176. - Update to final 2.7 release
  177. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  178. - Update to first 2.7 pre-release
  179. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  180. - Update to 2.6 pre-release2
  181. - -devel subpackage now virtually provides -static
  182. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  183. - Disable var tracking assignments on PPC
  184. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  185. - Don't adjust clang include dir; files there are noarch (bz#521893)
  186. - Enable clang unit tests
  187. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  188. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  189. - Package Clang's static analyzer tools
  190. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  191. - PIC is now enabled by default; explicitly disable on %%{ix86}
  192. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  193. - First 2.6 prerelease
  194. - Enable Clang front-end
  195. - Enable debuginfo generation
  196. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  197. - Disable assertions (needed by OpenGTL, bz#521261)
  198. - Align spec file with upstream build instructions
  199. - Enable unit tests
  200. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  201. - Only disable PIC on %%ix86; ppc actually needs it
  202. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  203. - Disable use of position-independent code on 32-bit platforms
  204. (buggy in LLVM <= 2.5)
  205. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  206. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  207. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  208. - Remove build scripts; they require the build directory to work
  209. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  210. - Update to 2.5
  211. - Package build scripts (bug #457881)
  212. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  213. - Patched build process for the OCaml binding
  214. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  215. - Update to 2.4
  216. - Package Ocaml binding
  217. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  218. - Add dependency on groff
  219. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  220. - LLVM 2.3
  221. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  222. - fix license tags
  223. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  224. - Fix compilation problems with gcc 4.3
  225. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  226. - Autorebuild for GCC 4.3
  227. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  228. - Fix review comments
  229. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  230. - Initial version