compiz-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855
  1. # build with kde4
  2. %bcond_with kde
  3. %define dialogversion 0.7.18
  4. %define kde_dialogversion 0.0.5
  5. %define core_plugins blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
  6. %define mate_plugins annotate glib svg gnomecompat
  7. # List of plugins passed to ./configure. The order is important
  8. %define plugins core,glib,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
  9. Summary: OpenGL window and compositing manager
  10. Summary(ja): OpenGL ウィンドウ・コンポジットマネージャ
  11. Name: compiz
  12. URL: http://www.go-compiz.org
  13. License: X11/MIT/GPL
  14. Group: User Interface/Desktops
  15. Version: 0.8.8
  16. Release: 8%{?_dist_release}
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. # libdrm is not available on these arches
  19. ExcludeArch: s390 s390x ppc64
  20. Requires: xorg-x11-server-Xorg
  21. Requires: mesa-libGL
  22. Requires(post,postun): desktop-file-utils
  23. Requires(post,postun): gtk2
  24. BuildRequires: mesa-libGLU-devel
  25. BuildRequires: libdrm-devel
  26. BuildRequires: libwnck-devel
  27. BuildRequires: libX11-devel
  28. BuildRequires: libXcomposite-devel
  29. BuildRequires: libXdamage-devel
  30. BuildRequires: libXext-devel
  31. BuildRequires: libXfixes-devel
  32. BuildRequires: libXmu-devel
  33. BuildRequires: libXrandr-devel
  34. BuildRequires: libXrender-devel
  35. BuildRequires: libXt-devel
  36. BuildRequires: libSM-devel
  37. BuildRequires: dbus-devel
  38. BuildRequires: dbus-glib-devel
  39. BuildRequires: fuse-devel
  40. BuildRequires: gnome-desktop-devel >= 2.30.0
  41. BuildRequires: libglade2-devel
  42. BuildRequires: librsvg2-devel
  43. BuildRequires: libxslt-devel
  44. BuildRequires: marco-devel
  45. BuildRequires: mate-control-center-devel
  46. BuildRequires: desktop-file-utils
  47. BuildRequires: intltool >= 0.35
  48. BuildRequires: gettext
  49. %if %{with kde}
  50. BuildRequires: kdebase-workspace-devel
  51. BUildRequires: dbus-qt-devel
  52. %endif
  53. Conflicts: control-center < 2.32.1-2
  54. # Make sure that former beryl users still have bling
  55. Obsoletes: beryl-core
  56. Obsoletes: %{name}-gnome < 0.8.8-7
  57. Source0: http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
  58. Source1: desktop-effects-%{dialogversion}.tar.bz2
  59. Source2: kde-desktop-effects-%{kde_dialogversion}.tar.bz2
  60. # Sources from fedora
  61. #Source11: compiz-gtk
  62. #Source12: compiz-gtk.desktop
  63. #Source13: compiz-gnome.desktop
  64. #Source14: compiz-gnome.session
  65. # Patches from fedora
  66. Patch102: desktop-effects-0.7.17-wall-plugin.patch
  67. Patch103: composite-cube-logo.patch
  68. Patch111: gconf-core-plugin-loopfix.patch
  69. # Make sure configuration plugins never get unloaded
  70. Patch123: compiz-0.7.8-pin-initial-plugins.patch
  71. # Patches from ubuntu
  72. Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
  73. Patch1150: 015_optional-fbo.patch
  74. Patch1160: 016_call_glxwaitx_before_drawing.patch
  75. Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
  76. Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
  77. Patch1490: 049-damage-report-non-empty.patch
  78. Patch1600: 060_move_checks_to_compiz.patch
  79. # Patches from upstream
  80. Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
  81. Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
  82. # Vine default options
  83. Patch3000: compiz-0.8.6-vine-default.patch
  84. Patch3001: compiz-mate.patch
  85. Vendor: Project Vine
  86. Distribution: Vine Linux
  87. %description
  88. Compiz is one of the first OpenGL-accelerated compositing window
  89. managers for the X Window System. The integration allows it to perform
  90. compositing effects in window management, such as a minimization
  91. effect and a cube workspace. Compiz is an OpenGL compositing manager
  92. that use Compiz use EXT_texture_from_pixmap OpenGL extension for
  93. binding redirected top-level windows to texture objects.
  94. %package devel
  95. Summary: Development packages for compiz
  96. Summary(ja): compiz の開発パッケージ
  97. Group: Development/Libraries
  98. Requires: compiz = %{version}-%{release}
  99. Requires: pkgconfig
  100. Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
  101. Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
  102. Requires: libxslt-devel startup-notification-devel
  103. %description devel
  104. The compiz-devel package includes the header files,
  105. and developer docs for the compiz package.
  106. Install compiz-devel if you want to develop plugins for the compiz
  107. windows and compositing manager.
  108. %package mate
  109. Summary: Compiz mate integration bits
  110. Summary(ja): Compiz mate integration bits
  111. Group: User Interface/Desktops
  112. Requires: mate-session-manager
  113. Requires: marco
  114. Requires: libwnck
  115. Requires: glx-utils
  116. Requires: %{name} = %{version}
  117. %description mate
  118. The compiz-mate package contains gtk-window-decorator,
  119. and other mate integration related stuff.
  120. %if %{with kde}
  121. %package kde
  122. Summary: Compiz kde integration bits
  123. Summary(ja): Compiz kde integration bits
  124. Group: User Interface/Desktops
  125. Requires: %{name} = %{version}
  126. Requires: compiz-manager
  127. Obsoletes: beryl-kde
  128. %description kde
  129. The compiz-kde package contains kde-window-decorator,
  130. and other kde integration related stuff.
  131. %endif
  132. %prep
  133. %setup -q -T -b1 -n desktop-effects-%{dialogversion}
  134. #%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
  135. %setup -q
  136. pushd ../desktop-effects-%{dialogversion}
  137. %patch102 -p1 -b .wall-plugin
  138. popd
  139. %patch103 -p1 -b .composite-cube-logo
  140. %patch111 -p1 -b .gconf-core-loop
  141. ## %patch123 -p1 -b .initial-plugins
  142. # ubuntu patch
  143. %patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
  144. %patch1150 -p1 -b .disable-fbo
  145. %patch1160 -p1 -b .call_glxwaitx_before_drawing
  146. %patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
  147. %patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
  148. %patch1490 -p1 -b .damage-report-non-empty
  149. %patch1600 -p1 -b .move-check-to-compiz
  150. # upstream patch
  151. #%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
  152. #%patch2010 -p1 -b .fix-pixmap-size-calculation
  153. # vine patch
  154. %patch3000 -p1 -b .vine-default
  155. %patch3001 -p1 -b .mate
  156. %build
  157. rm -rf $RPM_BUILD_ROOT
  158. CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
  159. export CPPFLAGS
  160. #needed to find kde4 libs
  161. #LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
  162. #export LDFLAGS
  163. #libtoolize
  164. autoreconf -if
  165. %configure \
  166. %{?with_kde: --enable-kde4 } \
  167. %{!?with_kde: --disable-kde4 } \
  168. --disable-kde \
  169. --disable-gconf \
  170. --enable-dbus \
  171. --enable-librsvg \
  172. --enable-gtk \
  173. --enable-marco \
  174. --enable-mate \
  175. --with-default-plugins=%{plugins} \
  176. --enable-gnome-keybindings
  177. make LIBTOOL=/usr/bin/libtool %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
  178. # desktop-effects
  179. cd ../desktop-effects-%{dialogversion}
  180. %configure
  181. %install
  182. rm -rf $RPM_BUILD_ROOT
  183. make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
  184. echo INSTALLING DESKTOP EFFECTS
  185. pushd ../desktop-effects-%{dialogversion}
  186. make LIBTOOL=/usr/bin/libtool LIBS=-lX11 DESTDIR=$RPM_BUILD_ROOT install || exit 1
  187. #desktop-file-install --vendor vine --delete-original \
  188. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  189. # $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  190. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  191. popd
  192. %if %{with kde}
  193. # kde-desktop-effects
  194. echo INSTALLING KDE DESKTOP EFFECTS
  195. pushd ../kde-desktop-effects-%{kde_dialogversion}
  196. cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
  197. mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  198. cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  199. iconlist="16 24 32 36 48 96"
  200. for i in $iconlist; do
  201. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
  202. cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
  203. done
  204. desktop-file-install --vendor="" \
  205. --dir=%{buildroot}%{_datadir}/applications/kde \
  206. kde-desktop-effects.desktop
  207. popd
  208. %endif
  209. %if !%{with kde}
  210. rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
  211. %endif
  212. #install -m 0755 %{SOURCE11} $RPM_BUILD_ROOT%{_bindir}
  213. #desktop-file-install --vendor="" \
  214. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  215. # %{SOURCE12}
  216. # set up an X session
  217. #mkdir -p $RPM_BUILD_ROOT%{_datadir}/xsessions
  218. #install %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/xsessions
  219. #mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
  220. #install %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
  221. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  222. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
  223. %find_lang compiz
  224. %find_lang desktop-effects
  225. cat compiz.lang > core-files.txt
  226. cat desktop-effects.lang > mate-files.txt
  227. for f in %{core_plugins}; do
  228. echo %{_libdir}/compiz/lib$f.so
  229. echo %{_datadir}/compiz/$f.xml
  230. done >> core-files.txt
  231. for f in %{mate_plugins}; do
  232. echo %{_libdir}/compiz/lib$f.so
  233. echo %{_datadir}/compiz/$f.xml
  234. done >> mate-files.txt
  235. rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/gconf.xml
  236. %post
  237. /sbin/ldconfig
  238. update-desktop-database -q %{_datadir}/applications
  239. %postun
  240. /sbin/ldconfig
  241. update-desktop-database -q %{_datadir}/applications
  242. %post mate
  243. update-desktop-database -q %{_datadir}/applications
  244. touch --no-create %{_datadir}/icons/hicolor
  245. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  246. %postun mate
  247. update-desktop-database -q %{_datadir}/applications
  248. touch --no-create %{_datadir}/icons/hicolor
  249. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  250. %if %{with kde}
  251. %post kde
  252. update-desktop-database -q %{_datadir}/applications/kde
  253. touch --no-create %{_datadir}/icons/hicolor
  254. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  255. %postun kde
  256. update-desktop-database -q %{_datadir}/applications
  257. touch --no-create %{_datadir}/icons/hicolor
  258. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  259. %endif
  260. %clean
  261. rm -rf $RPM_BUILD_ROOT
  262. %files -f core-files.txt
  263. %defattr(-, root, root)
  264. %doc AUTHORS ChangeLog COPYING* README TODO
  265. %{_bindir}/compiz
  266. %{_libdir}/libdecoration.so.*
  267. %dir %{_libdir}/compiz
  268. %dir %{_datadir}/compiz
  269. %{_datadir}/applications/compiz.desktop
  270. %{_datadir}/compiz/*.png
  271. %{_datadir}/compiz/core.xml
  272. %files mate -f mate-files.txt
  273. %defattr(-, root, root)
  274. %{_bindir}/gtk-window-decorator
  275. %{_bindir}/desktop-effects
  276. %{_libdir}/window-manager-settings/libcompiz.so
  277. %{_datadir}/compiz/desktop-effects.glade
  278. %{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
  279. %{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
  280. %{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
  281. %{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
  282. %{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
  283. %{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
  284. %{_datadir}/mate/wm-properties/compiz-wm.desktop
  285. %{_datadir}/mate-control-center/keybindings/50-compiz-desktop-key.xml
  286. %{_datadir}/mate-control-center/keybindings/50-compiz-key.xml
  287. %if %{with kde}
  288. %files kde
  289. %defattr(-, root, root)
  290. %{_bindir}/kde4-window-decorator
  291. %{_docdir}/compiz-kde-%{version}
  292. %{_bindir}/kde-desktop-effects.sh
  293. %{_datadir}/applications/kde/kde-desktop-effects.desktop
  294. %{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
  295. %{_datadir}/compiz/kconfig.xml
  296. %endif
  297. %files devel
  298. %defattr(-, root, root)
  299. %{_libdir}/pkgconfig/compiz.pc
  300. %{_libdir}/pkgconfig/libdecoration.pc
  301. %{_libdir}/pkgconfig/compiz-cube.pc
  302. %{_libdir}/pkgconfig/compiz-scale.pc
  303. %{_includedir}/compiz
  304. %{_libdir}/libdecoration.so
  305. %changelog
  306. * Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-8
  307. - add compiz.desktop
  308. * Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-7
  309. - add Patch3001 (compiz-mate.patch)
  310. - add BuildRequires: marco-devel, mate-control-center-devel
  311. - remove BuildRequires: GConf2-devel, control-center-devel, metacity-devel
  312. - create %%{name}-mate subpackage
  313. - remove %%{name}-gnome subpackage
  314. * Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-6
  315. - rebuild with VineSeed environment
  316. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-5
  317. - rebuild with VineSeed environment
  318. * Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-4
  319. - remove follow files
  320. Source11 (compiz-gtk)
  321. Source12 (compiz-gtk.desktop)
  322. Source13 (compiz-gnome.desktop)
  323. Source14 (compiz-gnome.session)
  324. * Mon Mar 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.8-3
  325. - remove SandyBridge chipset from blacklist
  326. - add BR: dbus-glib-devel
  327. * Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-2
  328. - add Source files from Fedora
  329. Source11 (compiz-gtk)
  330. Source12 (compiz-gtk.desktop)
  331. Source13 (compiz-gnome.desktop)
  332. Source14 (compiz-gnome.session)
  333. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-1
  334. - new upstream release
  335. - add BuildRequires: libxslt-devel, libglade2-devel
  336. - drop Patch2000,2010
  337. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
  338. - add Patch3000
  339. - disable Sync to vblank
  340. - increase drop-shadow radius
  341. - set default decorator to gtk-window-decorator
  342. - change default daces in cube plugin
  343. - use "smart" placement mode
  344. * Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
  345. - drop compiz-gtk
  346. - add Conflicts: control-center < 2.32.1-2
  347. * Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
  348. - rebuild with mesa-7.10.1
  349. - add cherry picked ubuntu patch
  350. - Patch1150: add --no-fbo option
  351. - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
  352. - Patch1160: call glxwaitx before drawing
  353. - Patch1170: always unredirect screensaver on nvidia
  354. - Patch1490: damage report non empty
  355. - Patch1600: move check to compiz
  356. - add upstream patch
  357. - Patch2000: replace gdk_draw_drawable with cairo equivalents
  358. - Patch2010: fix pixmap size calculation
  359. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
  360. - rebuild with rpm-4.8.1 for pkg-config file
  361. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  362. - new upstream release (build on GNOME-2.30)
  363. - drop Patch123, Patch300
  364. * Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
  365. - rebuild with mesa-7.6
  366. - add Patch300 to build with gconf-2.28
  367. * Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
  368. - disable glib plugin in compiz-gtk
  369. - use direct rendering on virtualbox video adaptor.
  370. * Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
  371. - add Requires: glx-utils to compiz-gnome
  372. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  373. - new upstream release
  374. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
  375. - re-enable metacity decoration on gtk-window-decorator
  376. - BR: metacity-devel instead of metacity
  377. * Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
  378. - fix pre/post scripts for speeding up gconf schema installation
  379. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
  380. - add ccp compiz option to compiz-gtk
  381. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
  382. - remove desktop-effect.desktop
  383. - we use gnome-appearance-properties integrated version.
  384. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
  385. - add Patch121,122 from upstream fix.
  386. - add Patch123: make sure configuration plugins never get unloaded
  387. - add Patch124: memleak fix from upstream
  388. - add Patch125: make the terminal keybind work
  389. - add Patch120,126,127 for kde42
  390. - add Patch128: gwd fix from upstream
  391. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
  392. - rebuild with gnome-desktop-2.26.0
  393. * Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
  394. - add compiz-gtk scripts and desktop file from fedora
  395. * Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
  396. - new upstream release
  397. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
  398. - rebuild with gnome-desktop-2.24.0
  399. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
  400. - new upstream release
  401. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
  402. - new upstream release
  403. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
  404. - initial build for Vine Linux
  405. * Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
  406. - Fix gconf plugin loop RH #438794, patch based on
  407. older one from Guillaume Seguin
  408. - Add core to default plugin list
  409. * Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
  410. - Reword kde-desktop-effects messages to mention Compiz by name (#438883)
  411. * Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
  412. - Update to 0.7.2
  413. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
  414. - Autorebuild for GCC 4.3
  415. * Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
  416. - Update to desktop-effects version 0.7.17 which include more
  417. translations and move desktop-effects translations to compiz-gnome.
  418. - Fix spelling in beryl-core obsoletes.
  419. * Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
  420. - Update buildrequires (kwd uses the kde3 api)
  421. * Tue Nov 6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
  422. - Fix a typo in description of the main package.
  423. - All descriptions should end with a dot (unlike the summary line)
  424. * Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
  425. - Include kde-desktop-effects in kde subpackage
  426. * Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
  427. - Obsolete berly-core
  428. * Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
  429. - 0.6.2
  430. * Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
  431. - Disable scale corner initiate and install a GNOME key config entry.
  432. * Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
  433. - 0.6.0 final
  434. - always-restack-windows-on-map
  435. * Tue Oct 9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
  436. - Make compiz behave with gnome-terminal (#304051)
  437. * Fri Oct 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
  438. - Also install gwd.schemas (#319621)
  439. * Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
  440. - Update to more recent 0.6 branch snapshot (fixes #253575).
  441. * Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
  442. - compiz-gnome: install core schema so it actually works
  443. - remove unnecessary gconf stuff from %%install
  444. * Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
  445. - Make compiz-gnome Obsolete the older compiz package so yum/anaconda
  446. will pull it in (thans to Adel Gadllah).
  447. * Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
  448. - Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
  449. up dialog.
  450. - Fix broken gconf install and uninstall rules.
  451. - Pick up shadowman logo for RHEL builds (#232398).
  452. * Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
  453. - Add more-sm-junk.patch so we set SM restart style to
  454. SmRestartIfRunning on exit (#247163, #245971).
  455. - Add Requires to compiz-devel (#253407).
  456. - Update to desktop-effects 0.7.6, which terminates decorator when
  457. switching to metacity or on compiz failure (#215247, #215032).
  458. * Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
  459. - Split into gnome and kde subpackages
  460. - Minor cleanups
  461. * Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
  462. - Reorder plugin list to avoid 'place' getting removed on startup.
  463. - Add run-command-key.patch to put the run command key in the GNOME
  464. keyboard shortcut dialog (#213576).
  465. - Drop a bunch of obsolete patches.
  466. - Bump mesa-libGL and X server requires to fix TFP bugs for
  467. power-of-two textures (#251935).
  468. - Rebase fedora-logo and composite-cube-logo patch.
  469. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
  470. - Build with desktop-effects so we don't pick up metacity work spaces.
  471. Fixes #250568.
  472. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
  473. - Build git snapshot from fedora branch at
  474. git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
  475. branch.
  476. - Fixes #237486.
  477. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
  478. - Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
  479. 'glib' on the command line too.
  480. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
  481. - Move xml meta data files to main package.
  482. * Thu Aug 9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
  483. - Update to 0.5.2.
  484. - Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
  485. with LIBGL_ALWAYS_INDIRECT set.
  486. * Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
  487. - Update to 0.5.0
  488. * Tue Jun 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
  489. - Update to 0.4.0
  490. * Mon Jun 4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
  491. - Rebuild against new libwnck
  492. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
  493. - Don't install INSTALL
  494. * Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
  495. - Update metacity build requires to metacity-devel.
  496. * Wed Apr 4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
  497. - Fix typo in ./configure option.
  498. * Wed Apr 4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
  499. - Add place and clone plugins to default plugin list.
  500. * Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
  501. - Update URL (#208214).
  502. - Require at least metacity 2.18 (#232831).
  503. - Add close-session.patch to deregister from SM when replaced (#229113).
  504. * Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
  505. - Explicitly disable KDE parts (#234128).
  506. * Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
  507. - Fix some directory ownership issues (#233825)
  508. - Small spec cleanups
  509. * Tue Feb 6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
  510. - Require gnome-session > 2.16 so it starts gtk-window-decorator.
  511. - Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
  512. * Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
  513. - Update to 0.3.6, update patches.
  514. - Drop autotool build requires.
  515. - Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
  516. - Add libdecoration.so
  517. - Update to desktop-effects-0.7.0, which spawns the right decorator
  518. and plays nicely with unknown plugins.
  519. * Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
  520. - Update the fedora logo patch (#217224)
  521. * Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  522. - Update to 0.3.4
  523. * Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
  524. - Use cow by default, bug 208044
  525. * Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  526. - Update to 0.3.2
  527. - Drop upstreamed patches
  528. - Work with new metacity theme api
  529. * Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
  530. - Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
  531. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  532. - Add buildrequires on intltool
  533. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  534. - Build
  535. * Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
  536. - Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
  537. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
  538. - Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
  539. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
  540. - Change default plugin list to not include the plane plugin. (Bug 208448).
  541. - Change default keybinding for shrink to be Pause (Bug 206187).
  542. * Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
  543. - Add patch to show a menu when the window icon is clicked. (Bug 201629).
  544. * Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
  545. - Add restart.patch to make compiz ask the session manager to restart it
  546. if it crashes (bug 200280).
  547. * Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
  548. - Change plane.patch to not do cyclical window movement in dimensions
  549. where the desktop has size 1 (bug 207263).
  550. * Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
  551. - Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
  552. * Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
  553. - Change .plane patch to
  554. (a) not set the background color to pink in the plane plugin.
  555. (b) allow workspaces with horizontal sizes less then 4.
  556. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
  557. - Change plane patch to correctly initialize the screen size to the
  558. defaults (bug 206088).
  559. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  560. - Run update-desktop-database and gtk-update-icon-cache in post. Add icons
  561. to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
  562. directories before attempting to install to them).
  563. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  564. - Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
  565. that the new version has icons.
  566. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  567. - Add patch to fix mispositioning of window decorator event windows (bug 201624)
  568. * Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
  569. - Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
  570. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  571. - Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
  572. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  573. - Add patch to fix thumbnail sorting (bug 201605)
  574. * Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
  575. - Add patch to fix double clicking (bug 201783).
  576. * Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
  577. - Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
  578. * Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
  579. - Fix plane.patch to draw correctly when no timeout is running. (206088).
  580. * Wed Sep 6 2006 Kristian H淡gsberg <krh@redhat.com>
  581. - Update fbconfig-depth-fix.patch to also skip fbconfigs without
  582. corresponding visuals.
  583. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
  584. - Make number of vertical size configurable
  585. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
  586. - Fix vertical viewport support in the plane patch.
  587. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
  588. - Upgrade to 0.6.61 of the dialog
  589. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  590. - Add libtool to BuildRequires
  591. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  592. - Add automake and autoconf to BuildRequires
  593. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  594. - Add a patch to put viewports on a plane.
  595. * Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
  596. - Drop gl-include-inferiors.patch now that compiz uses COW and the X
  597. server evicts offscreen pixmaps automatically on
  598. GLX_EXT_texture_from_pixmap usage.
  599. * Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
  600. - Add cow.patch to make compiz use the composite overlay window.
  601. * Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
  602. - Rebase to desktop-effects 0.6.41
  603. * Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
  604. - Rebase to desktop-effects 0.6.19 and drop
  605. desktop-effects-0.6.1-delete-session.patch
  606. * Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
  607. - Add patch from upstream to also use sync protocol for override
  608. redirect windows (sync-override-redirect-windows.patch).
  609. * Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
  610. - Rebase to latest upstream changes which has the rest of the bindings
  611. rewrite. Add resize-move-keybindings.patch to make move and resize
  612. bindings work like metacity.
  613. - Add back scale plugin.
  614. * Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
  615. - Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
  616. - unlink session file on changing wms (bug 201473)
  617. * Thu Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
  618. - Add Requires: gnome-session 2.15.4-3
  619. * Thu Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  620. - New version of dialog box. Macro the version number.
  621. * Wed Aug 2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  622. - Add 'desktop effects' dialog box.
  623. * Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
  624. - Add libwnck requires.
  625. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
  626. - Bump and build for fc5 AIGLX repo.
  627. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
  628. - Fix gconf hooks.
  629. * Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
  630. - Require system-logos instead.
  631. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
  632. - Bump version to work around tagging weirdness.
  633. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
  634. - Add devel package and require redhat-logos instead of fedora-logos (#199757).
  635. * Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
  636. - Add workaround for AIGLX throttling problem.
  637. * Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
  638. - Drop scale plugin from snapshot.
  639. * Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
  640. - Don't build on s390
  641. * Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
  642. - Do some changes forced upon us by package review
  643. * Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
  644. - Use sane numbering scheme.
  645. * Fri Jul 7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
  646. - Drop the fullscreen hardcode patch and require X server that has
  647. GLX_MESA_copy_sub_buffer.
  648. * Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
  649. - Unbreak --replace.
  650. * Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
  651. - Add Requires, fix start-compiz.sh.
  652. * Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
  653. - Spec file for compiz, borrowing bits and pieces from Alphonse Van
  654. Assches spec file (#192432).