cpdf-vl.spec 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. %define pkg_name cpdf
  2. %define pkg_version 2.3
  3. # %define patchlevel 1
  4. %define pkg_release 1%{?_dist_release}
  5. Summary: Command Line Tools allow you to manipulate existing PDF files
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. # Version: %{pkg_version}.p%{patchlevel}
  9. Release: %{pkg_release}
  10. License: Coherent Graphics Ltd Non-Commercial Use License Agreement
  11. Group: Applications/Publishing
  12. URL: http://community.coherentpdf.com/
  13. Source0: cpdf-source-%{pkg_version}.tar.gz
  14. # Source0: cpdf-source-%{pkg_version}-patchlevel%{patchlevel}.tar.gz
  15. BuildRequires: readline-devel
  16. BuildRequires: ocaml
  17. BuildRequires: ocaml-findlib
  18. BuildRequires: ocaml-camlpdf = %{pkg_version}
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. The Coherent PDF Command Line Tools allow you to manipulate
  23. existing PDF files in a variety of ways.
  24. For example:
  25. - Merge PDF files together, or split them apart Encrypt and decrypt
  26. - Scale, crop and rotate pages
  27. - Read and set document info and metadata
  28. - Copy, add or remove bookmarks
  29. - Stamp logos, text, dates, page numbers
  30. - Add or remove attachments
  31. - Losslessly compress PDF files
  32. [caution]
  33. Now we're releasing them for free, under a special not-for-commercial-use
  34. license If you like the tools and want to use them commercially,
  35. or need support, licenses are available from Coherent Graphics Ltd.
  36. #'
  37. %description -l ja
  38. Coherent PDF は PDF ファイルを操作するためのコマンドラインツールです。
  39. [注意1]
  40. このアプリケーションは「非商用に限り」フリーで使用できます。
  41. 詳しくは LICENCE を参照して下さい。
  42. %package libs
  43. Summary: OCaml library for Coherent PDF
  44. Group: Development/Languages
  45. Requires: ocaml
  46. Requires: ocaml-findlib
  47. Requires: ocaml-camlpdf = %{pkg_version}
  48. %description libs
  49. %{summary}
  50. %prep
  51. %{__rm} -rf ${RPM_BUILD_ROOT}
  52. %setup -q -n %{name}-source-%{pkg_version}
  53. # %setup -q -n %{name}-source-%{pkg_version}-patchlevel%{patchlevel}
  54. %build
  55. LDFLAGS="-ltinfo" %{__make}
  56. %install
  57. # for binary
  58. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_bindir}
  59. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
  60. %{__cp} cpdf ${RPM_BUILD_ROOT}%{_bindir}
  61. %{__cp} cpdf.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
  62. # for libs
  63. INSTALLDIR=${RPM_BUILD_ROOT}%{_libdir}/ocaml
  64. %{__mkdir_p} ${INSTALLDIR}
  65. %{__make} install \
  66. OCAMLFIND_INSTFLAGS="-destdir ${INSTALLDIR}"
  67. %clean
  68. %{__rm} -rf ${RPM_BUILD_ROOT}
  69. %post libs
  70. echo "%{_libdir}/ocaml/%{pkg_name}" >> %{_libdir}/ocaml/ld.conf
  71. %preun libs
  72. %{__perl} -pi -e "s|^%{_libdir}/ocaml/%{pkg_name}\n$||" \
  73. %{_libdir}/ocaml/ld.conf
  74. %files
  75. %doc doc/cpdf/html
  76. %doc Changes LICENSE cpdfmanual.pdf
  77. %{_bindir}/cpdf
  78. %{_mandir}/man1/*
  79. %files libs
  80. %{_libdir}/ocaml/cpdf
  81. %changelog
  82. * Sun Oct 06 2019 Toshiaki Ara <ara_t@384.jp> 2.3-1
  83. - update to 2.3
  84. * Sun Apr 15 2018 Toshiaki Ara <ara_t@384.jp> 2.2-pachlevel1
  85. - initial build for Vine Linux