cpio-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %ifos linux
  2. %define _bindir /bin
  3. %define _libexecdir /sbin
  4. %endif
  5. Summary: A GNU archiving program.
  6. Summary(ja): GNU アーカイブプログラム
  7. Name: cpio
  8. Version: 2.13
  9. Release: 2%{?_dist_release}
  10. Group: system,accessories
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: GPLv3
  14. URL: https://www.gnu.org/software/cpio/cpio.html
  15. Source: https://ftp.gnu.org/gnu/cpio/cpio-%{version}.tar.bz2
  16. Source1: cpio.1
  17. # We use SVR4 portable format as default.
  18. Patch1: cpio-2.9-rh.patch
  19. # fix warn_if_file_changed() and set exit code to 1 when cpio fails to store
  20. # file > 4GB (#183224)
  21. # http://lists.gnu.org/archive/html/bug-cpio/2006-11/msg00000.html
  22. Patch2: cpio-2.13-exitCode.patch
  23. # Support major/minor device numbers over 127 (bz#450109)
  24. # http://lists.gnu.org/archive/html/bug-cpio/2008-07/msg00000.html
  25. Patch3: cpio-2.13-dev_number.patch
  26. # Define default remote shell as /usr/bin/ssh (#452904)
  27. Patch4: cpio-2.9.90-defaultremoteshell.patch
  28. # Fix segfault with nonexisting file with patternnames (#567022)
  29. # http://savannah.gnu.org/bugs/index.php?28954
  30. # We have slightly different solution than upstream.
  31. Patch5: cpio-2.10-patternnamesigsegv.patch
  32. # Fix bad file name splitting while creating ustar archive (#866467)
  33. # (fix backported from tar's source)
  34. Patch7: cpio-2.10-longnames-split.patch
  35. # Cpio does Sum32 checksum, not CRC (downstream)
  36. Patch8: cpio-2.11-crc-fips-nit.patch
  37. # Fix multiple definition of `program_name'
  38. Patch9: cpio-2.13-mutiple-definition.patch
  39. # Revert fix for CVE-2015-1197 (#1797163)
  40. # reverts upstream commit 45b0ee2b4
  41. Patch10: cpio-2.13-revert-CVE-2015-1197-fix.patch
  42. # Extract: retain times for symlinks
  43. # downstream patch (#1486364)
  44. # https://www.mail-archive.com/bug-cpio@gnu.org/msg00605.html
  45. Patch11: cpio-2.11-retain-symlink-times.patch
  46. # Properly drop priviledges for remote command
  47. # http://git.savannah.gnu.org/cgit/paxutils.git/commit/?id=d247e3c2809a37b6d0c3067251d96bb7f12555e7
  48. Patch12: cpio-2.13-reset-gid-uid.patch
  49. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  50. BuildRequires: texinfo autoconf gettext
  51. Requires(post): /sbin/install-info
  52. Requires(preun): /sbin/install-info
  53. %description
  54. GNU cpio copies files into or out of a cpio or tar archive. Archives
  55. are files which contain a collection of other files plus information
  56. about them, such as their file name, owner, timestamps, and access
  57. permissions. The archive can be another file on the disk, a magnetic
  58. tape, or a pipe. GNU cpio supports the following archive formats: binary,
  59. old ASCII, new ASCII, crc, HPUX binary, HPUX old ASCII, old tar and POSIX.1
  60. tar. By default, cpio creates binary format archives, so that they are
  61. compatible with older cpio programs. When it is extracting files from
  62. archives, cpio automatically recognizes which kind of archive it is reading
  63. and can read archives created on machines with a different byte-order.
  64. Install cpio if you need a program to manage file archives.
  65. %description -l ja
  66. GNU cpio は cpio アーカイブ或いは tar アーカイブにファイルをコピーしたり
  67. 取り出したりするプログラムです.アーカイブというのは,(1つ以上の)ファイルと
  68. その情報(ファイル名,オーナー,更新日付,パーミッション等)がまとめられた
  69. 1つのファイルのことです.アーカイブはディスク上のファイル,磁気テープ,
  70. 或いはパイプであっても構いません.
  71. GNU cpio がサポートしているアーカイブ形式は以下の通りです:
  72. バイナリ, old ASCII, new ASCII, crc, HPUX バイナリ, HPUX old ASCII,
  73. old tar, POSIX.1 tar
  74. デフォルトでは cpio はバイナリ形式のアーカイブを作成します.
  75. これは古いバージョンの cpio との互換性の為です.
  76. アーカイブを展開する場合は,cpio はアーカイブの形式を自動認識しますし,
  77. バイトオーダの異なる機械で作成されたアーカイブを読むことも可能です.
  78. ファイルアーカイブを扱うプログラムが必要なら,cpio をインストールして下さい.
  79. %debug_package
  80. %prep
  81. %autosetup -p1
  82. autoreconf -vif
  83. %build
  84. export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -pedantic -fno-strict-aliasing -Wall $CFLAGS"
  85. %configure
  86. %make_build
  87. (cd po && make update-gmo)
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. %make_install
  91. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  92. rm -f $RPM_BUILD_ROOT/sbin/rmt
  93. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/*.1*
  94. install -c -p -m 0644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_mandir}/man1
  95. %find_lang %{name}
  96. %check
  97. rm -f ${RPM_BUILD_ROOT}/test/testsuite
  98. make check || {
  99. echo "### TESTSUITE.LOG ###"
  100. cat tests/testsuite.log
  101. exit 1
  102. }
  103. %clean
  104. rm -rf $RPM_BUILD_ROOT
  105. %post
  106. /sbin/install-info %{_infodir}/cpio.info.gz %{_infodir}/dir
  107. %preun
  108. if [ $1 = 0 ]; then
  109. /sbin/install-info --delete %{_infodir}/cpio.info.gz %{_infodir}/dir
  110. fi
  111. %files -f %{name}.lang
  112. %defattr(-,root,root)
  113. %license COPYING
  114. %doc AUTHORS NEWS README THANKS TODO
  115. %{_bindir}/*
  116. %{_mandir}/man*/*
  117. %{_infodir}/*.info*
  118. %changelog
  119. * Tue Aug 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.13-2
  120. - imported Patch11 and 12 from rawhide.
  121. * Tue Feb 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.13-1
  122. - updated to 2.13.
  123. - dropped all patches.
  124. - imported Patch1-10 from rawhide.
  125. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12-1
  126. - update to 2.12
  127. - update Patch2 (cpio-2.12-rh.patch)
  128. - remove Patch7 (cpio-2.11-gets.patch)
  129. - remove Patch100 (cpio-2.11-CVE-2014-9112.patch)
  130. * Sun Jan 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.11-3
  131. - reflected security fix based on Vine Linux/6.2
  132. * Tue Dec 23 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.11-2
  133. - add patch100 for fix CVE-2014-9112 (cpio's list_file())
  134. this patch is from fc21, thanks.
  135. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.11-2
  136. - rebuild with VineSeed environment
  137. - add Patch7 (cpio-2.11-gets.patch)
  138. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.11-1
  139. - new upstream release
  140. - rebuilt with current VineSeed
  141. * Fri Jan 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10-1
  142. - new upstream release
  143. * Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.90-1vl5
  144. - new upstream from alpha version
  145. - applied new versioning policy
  146. - spec in UTF-8
  147. - added Patch5 and 6 from FC
  148. * Fri Jul 18 2008 Kamil Dudka <kdudka@redhat.com> 2.9.90-2
  149. - Support major/minor device numbers over 127 (bz#450109)
  150. * Mon Mar 03 2008 Radek Brich <rbrich@redhat.com> 2.9-7
  151. - fix -dir_perm patch to restore permissions correctly even
  152. in passthrough mode -- revert affected code to cpio 2.8 state
  153. (bz#430835)
  154. * Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9-1vl1
  155. - new upstream release
  156. * Sat Apr 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6-5vl1
  157. - based on Fedora development 2.6-5
  158. * Mon Jan 24 2005 Peter Vrabec <pvrabec@redhat.com>
  159. - insecure file creation (#145721)
  160. * Mon Jan 17 2005 Peter Vrabec <pvrabec@redhat.com>
  161. - fix symlinks pack (#145225)
  162. * Fri Jan 14 2005 Peter Vrabec <pvrabec@redhat.com>
  163. - new fixed version of lfs patch (#144688)
  164. * Tue Nov 09 2004 Peter Vrabec <pvrabec@redhat.com>
  165. - fixed "cpio -oH ustar (or tar) saves bad mtime date after Jan 10 2004" (#114580)
  166. * Mon Nov 01 2004 Peter Vrabec <pvrabec@redhat.com>
  167. - support large files > 2GB (#105617)
  168. * Wed Dec 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.5-1vl1
  169. - based on 2.5-1 from rawhide and built for Vine Linux
  170. - added Japanese summary and description
  171. * Mon Nov 18 2002 Jeff Johnson <jbj@redhat.com> 2.5-1
  172. - update 2.5, restack and consolidate patches.
  173. - don't apply (but include for now) freebsd and #56346 patches.
  174. - add url (#54598).
  175. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 2.4.2-30
  176. - rebuild from CVS.
  177. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  178. - automated rebuild
  179. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  180. - automated rebuild
  181. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  182. - automated rebuild
  183. * Thu Nov 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.2-25
  184. - Fix up extraction of multiply linked files when the first link is
  185. excluded (Bug #56346)
  186. * Mon Oct 1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.2-24
  187. - Merge and adapt patches from FreeBSD, this should fix FIFO handling
  188. * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  189. - Add and adapt Debian patch (pl36), fixes #45285 and a couple of other issues
  190. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  191. - Bump release + rebuild.
  192. * Tue Aug 8 2000 Jeff Johnson <jbj@redhat.com>
  193. - update man page with decription of -c behavior (#10581).
  194. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  195. - automatic rebuild
  196. * Thu Jun 29 2000 Preston Brown <pbrown@redhat.com>
  197. - patch from HJ Lu for better error codes upon exit
  198. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  199. - FHS packaging.
  200. * Wed Feb 9 2000 Jeff Johnson <jbj@redhat.com>
  201. - missing defattr.
  202. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  203. - handle compressed manpages
  204. * Fri Dec 17 1999 Jeff Johnson <jbj@redhat.com>
  205. - revert the stdout patch (#3358), restoring original GNU cpio behavior
  206. (#6376, #7538), the patch was dumb.
  207. * Tue Aug 31 1999 Jeff Johnson <jbj@redhat.com>
  208. - fix infinite loop unpacking empty files with hard links (#4208).
  209. - stdout should contain progress information (#3358).
  210. * Sun Mar 21 1999 Crstian Gafton <gafton@redhat.com>
  211. - auto rebuild in the new build environment (release 12)
  212. * Sat Dec 5 1998 Jeff Johnson <jbj@redhat.com>
  213. - longlong dev wrong with "-o -H odc" headers (formerly "-oc").
  214. * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
  215. - patch to compile on glibc 2.1, where strdup is a macro
  216. * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
  217. - Fiddle bindir/libexecdir to get RH install correct.
  218. - Don't include /sbin/rmt -- use the rmt from dump package.
  219. - Don't include /bin/mt -- use the mt from mt-st package.
  220. - Add prereq's
  221. * Tue Jun 30 1998 Jeff Johnson <jbj@redhat.com>
  222. - fix '-c' to duplicate svr4 behavior (problem #438)
  223. - install support programs & info pages
  224. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  225. - translations modified for de, fr, tr
  226. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  227. - added BuildRoot
  228. - removed "(used by RPM)" comment in Summary
  229. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  230. - built against glibc
  231. - no longer statically linked as RPM doesn't use cpio for unpacking packages