cronie-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509
  1. %bcond_with systemd
  2. %bcond_with selinux
  3. %bcond_without pam
  4. %bcond_without audit
  5. %bcond_without inotify
  6. Summary: Cron daemon for executing programs at set times
  7. Name: cronie
  8. Version: 1.5.5
  9. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  10. Group: system
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: iwaim
  14. License: MIT and BSD and ISC and GPLv2+
  15. URL: https://github.com/cronie-crond/cronie
  16. Source0: https://github.com/cronie-crond/cronie/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
  17. # from cronie 1.4.8 tarball
  18. Source1: cronie.init
  19. Requires: dailyjobs
  20. Conflicts: vixie-cron
  21. %if %{with selinux}
  22. Requires: libselinux >= 2.0.64
  23. BuildRequires: libselinux-devel >= 2.0.64
  24. %endif
  25. %if %{with pam}
  26. Requires: pam >= 1.0.1
  27. BuildRequires: pam-devel >= 1.0.1
  28. %endif
  29. %if %{with audit}
  30. BuildRequires: audit-libs-devel >= 1.4.1
  31. %endif
  32. %if %{with systemd}
  33. BuildRequires: systemd
  34. %{?systemd_requires}
  35. %else
  36. Requires(post): chkconfig
  37. Requires(preun): chkconfig
  38. %endif
  39. Requires(post): coreutils sed
  40. Obsoletes: vixie-cron <= 3.0.1
  41. %description
  42. Cronie contains the standard UNIX daemon crond that runs specified programs at
  43. scheduled times and related tools. It is a fork of the original vixie-cron and
  44. has security and configuration enhancements like the ability to use pam and
  45. SELinux.
  46. %package anacron
  47. Summary: Utility for running regular jobs
  48. Requires: crontabs
  49. Group: system
  50. Provides: dailyjobs
  51. Provides: anacron = 2.4
  52. Obsoletes: anacron <= 2.3
  53. Requires(post): coreutils
  54. Requires: %{name} = %{version}-%{release}
  55. %description anacron
  56. Anacron is part of cronie that is used for running jobs with regular
  57. periodicity which do not have exact time of day of execution.
  58. The default settings of anacron execute the daily, weekly, and monthly
  59. jobs, but anacron allows setting arbitrary periodicity of jobs.
  60. Using anacron allows running the periodic jobs even if the system is often
  61. powered off and it also allows randomizing the time of the job execution
  62. for better utilization of resources shared among multiple systems.
  63. %package noanacron
  64. Summary: Utility for running simple regular jobs in old cron style
  65. Group: system
  66. Provides: dailyjobs
  67. Requires: crontabs
  68. Requires: %{name} = %{version}-%{release}
  69. %description noanacron
  70. Old style of running {hourly,daily,weekly,monthly}.jobs without anacron. No
  71. extra features.
  72. %prep
  73. %setup -q
  74. %build
  75. %configure \
  76. %if %{with pam}
  77. --with-pam \
  78. %endif
  79. %if %{with selinux}
  80. --with-selinux \
  81. %endif
  82. %if %{with audit}
  83. --with-audit \
  84. %endif
  85. %if %{with inotify}
  86. --with-inotify \
  87. %endif
  88. --enable-anacron \
  89. --enable-pie \
  90. --enable-relro
  91. make %{?_smp_mflags}
  92. %install
  93. make install DESTDIR=$RPM_BUILD_ROOT DESTMAN=$RPM_BUILD_ROOT%{_mandir}
  94. mkdir -pm700 $RPM_BUILD_ROOT%{_localstatedir}/spool/cron
  95. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
  96. mkdir -pm755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/
  97. %if ! %{with pam}
  98. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/crond
  99. %endif
  100. install -m 600 crond.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/crond
  101. touch $RPM_BUILD_ROOT%{_sysconfdir}/cron.deny
  102. install -m 600 contrib/anacrontab $RPM_BUILD_ROOT%{_sysconfdir}/anacrontab
  103. install -c -m755 contrib/0hourly $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/0hourly
  104. mkdir -pm 700 $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
  105. install -c -m755 contrib/0anacron $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/0anacron
  106. mkdir -p $RPM_BUILD_ROOT/var/spool/anacron
  107. touch $RPM_BUILD_ROOT/var/spool/anacron/cron.daily
  108. touch $RPM_BUILD_ROOT/var/spool/anacron/cron.weekly
  109. touch $RPM_BUILD_ROOT/var/spool/anacron/cron.monthly
  110. # noanacron package
  111. install -m 644 contrib/dailyjobs $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/dailyjobs
  112. %if %{with systemd}
  113. # install systemd initscript
  114. mkdir -p $RPM_BUILD_ROOT%{_unitdir}
  115. install -m 644 contrib/cronie.systemd $RPM_BUILD_ROOT%{_unitdir}/crond.service
  116. %else
  117. # install initscript
  118. mkdir -p $RPM_BUILD_ROOT%{_initddir}
  119. install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/crond
  120. %endif
  121. %post
  122. # run after an installation
  123. %if %{with systemd}
  124. %systemd_post crond.service
  125. %else
  126. /sbin/chkconfig --add crond
  127. %endif
  128. %post anacron
  129. [ -e /var/spool/anacron/cron.daily ] || touch /var/spool/anacron/cron.daily
  130. [ -e /var/spool/anacron/cron.weekly ] || touch /var/spool/anacron/cron.weekly
  131. [ -e /var/spool/anacron/cron.monthly ] || touch /var/spool/anacron/cron.monthly
  132. %preun
  133. # run before a package is removed
  134. %if %{with systemd}
  135. %systemd_preun crond.service
  136. %else
  137. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  138. /sbin/service crond stop >/dev/null 2>&1
  139. /sbin/chkconfig --del crond
  140. fi
  141. %endif
  142. %postun
  143. # run after a package is removed
  144. %if %{with systemd}
  145. %systemd_postun_with_restart crond.service
  146. %else
  147. if [ "$1" -ge "1" ]; then
  148. /sbin/service crond condrestart >/dev/null 2>&1 || :
  149. fi
  150. %endif
  151. %triggerpostun -- vixie-cron
  152. %if %{with systemd}
  153. %systemd_postun_with_restart crond.service
  154. %else
  155. /sbin/chkconfig --add crond
  156. %endif
  157. %files
  158. %license COPYING*
  159. %doc AUTHORS INSTALL README ChangeLog
  160. %attr(755,root,root) %{_sbindir}/crond
  161. %attr(4755,root,root) %{_bindir}/crontab
  162. %attr(755,root,root) %{_bindir}/cronnext
  163. %{_mandir}/man8/crond.*
  164. %{_mandir}/man8/cron.*
  165. %{_mandir}/man5/crontab.*
  166. %{_mandir}/man1/crontab.*
  167. %{_mandir}/man1/cronnext.*
  168. %dir %{_localstatedir}/spool/cron
  169. %dir %{_sysconfdir}/cron.d
  170. %if %{with pam}
  171. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/pam.d/crond
  172. %endif
  173. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/crond
  174. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/cron.deny
  175. %attr(0644,root,root) %{_sysconfdir}/cron.d/0hourly
  176. %if %{with systemd}
  177. %{_unitdir}/crond.service
  178. %else
  179. %attr(0755,root,root) %{_initddir}/crond
  180. %endif
  181. %files anacron
  182. %{_sbindir}/anacron
  183. %attr(0755,root,root) %{_sysconfdir}/cron.hourly/0anacron
  184. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/anacrontab
  185. %dir /var/spool/anacron
  186. %ghost %verify(not md5 size mtime) /var/spool/anacron/cron.daily
  187. %ghost %verify(not md5 size mtime) /var/spool/anacron/cron.weekly
  188. %ghost %verify(not md5 size mtime) /var/spool/anacron/cron.monthly
  189. %{_mandir}/man5/anacrontab.*
  190. %{_mandir}/man8/anacron.*
  191. %files noanacron
  192. %attr(0644,root,root) %{_sysconfdir}/cron.d/dailyjobs
  193. %changelog
  194. * Sun Aug 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.5-2
  195. - added systemd support (disabled as default).
  196. * Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.5-1
  197. - new upstream release.
  198. - dropped all patches.
  199. * Mon Sep 11 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.1-1
  200. - new upstream release.
  201. - dropped Patch0.
  202. - imported Patch0 and Patch1 from rawhide.
  203. * Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.0-1
  204. - new upstream release.
  205. - dropped all patches.
  206. - imported Patch0 from rawhide.
  207. - added O:vixie-cron.
  208. * Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-2
  209. - run chkconfig for vixie-cron in triggerpostun script
  210. * Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-1
  211. - initial build for Vine Linux
  212. * Mon Jan 27 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-11
  213. - now it's work even on ppc64, all checks working correctly
  214. - Related: rhbz#1031384
  215. * Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 1.4.11-10
  216. - Mass rebuild 2014-01-24
  217. * Wed Jan 22 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-9
  218. - fix coverity warnings about dead code. Incorrect checking of values.
  219. - Related: rhbz#1031384
  220. * Mon Jan 20 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-8
  221. - anacron do not execute jobs run from command line
  222. - Related: rhbz#1031384
  223. * Wed Jan 08 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-7
  224. - anacron segfaults with certain config data
  225. - Resolves: rhbz#1031384
  226. * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.4.11-6
  227. - Mass rebuild 2013-12-27
  228. * Tue Oct 15 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-5
  229. - Cronie doesn't work when is executed as stand alone without systemd (for
  230. debuging issues)
  231. - Fix another permission, hopefully all now.
  232. - Resolves: rhbz#1012420, rhbz#1015567
  233. * Fri Sep 13 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-4
  234. - fix permission on configuration files, same as rhbz#706979
  235. * Fri Aug 30 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-3
  236. - 919290 systemd script use "KillMode=process"
  237. - Fcntl locking has different semantics than flock. Prefer flock.
  238. - 49225e172d156531ca142518d2638350752e373a
  239. - Pull PAM environment variables also from session modules.
  240. - c8e7d1b43c86a85441cb09cf7e08090f3ec1f384
  241. * Mon Jul 22 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-2
  242. - scriptlets are not created correctly if systemd is not in BR 986698
  243. - remove sub-package sysvinit, which is not needed anymore
  244. - update license, anacron is under GPLv2+
  245. * Thu Jul 18 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-1
  246. - new release 1.4.11 (contains previous bug fixes from 1.4.10-5)
  247. * Tue Jun 11 2013 Tomáš Mráz <tmraz@redhat.com> - 1.4.10-5
  248. - add support for RANDOM_DELAY - delaying job startups
  249. - pass some environment variables to processes (LANG, etc.) (#969761)
  250. - do not use putenv() with string literals (#971516)
  251. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.10-4
  252. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  253. * Wed Jan 2 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-3
  254. - change configuration files to 644
  255. - change 6755 to 4755 for crontab binary
  256. * Tue Nov 27 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-1
  257. - New release 1.4.10
  258. * Thu Nov 22 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.9-1
  259. - New release 1.4.9
  260. * Wed Sep 05 2012 Václav Pavlín <vpavlin@redhat.com> - 1.4.8-13
  261. - Scriptlets replaced with new systemd macros (#850070)
  262. * Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-12
  263. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  264. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-11
  265. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  266. * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-10
  267. - Rebuilt for glibc bug#747377
  268. * Tue Oct 25 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-9
  269. - make crond run a little bit later in the boot process (#747759)
  270. * Mon Oct 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-8
  271. - change triggerun to fix 735802 during upgrade
  272. * Wed Jul 27 2011 Karsten Hopp <karsten@redhat.com> 1.4.8-7
  273. - rebuild again, ppc still had the broken rpm in the buildroots
  274. * Thu Jul 21 2011 Rex Dieter <rdieter@fedoraproject.org> 1.4.8-6
  275. - rebuild (broken rpm in buildroot)
  276. * Thu Jul 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-5
  277. - fix permission of init.d/crond
  278. * Thu Jun 30 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-4
  279. - drop the without systemd build condition
  280. - add the chkconfig readding trigger to the sysvinit subpackage
  281. * Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-3
  282. - start crond after auditd
  283. * Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-2
  284. - fix inotify support to not leak fds (#717505)
  285. * Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-1
  286. - update to 1.4.8
  287. - create sub-package sysvinit for initscript
  288. * Mon May 9 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-3
  289. - missing requirement on systemd-sysv for scriptlets
  290. * Thu May 05 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.7-2
  291. - use only systemd units with systemd
  292. - add trigger for restart on glibc, libselinux or pam upgrades (#699189)
  293. * Tue Mar 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-1
  294. - new release 1.4.7
  295. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-9
  296. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  297. * Mon Jan 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-8
  298. - enable crond even with systemctl
  299. * Thu Dec 16 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-7
  300. - 663193 rewritten selinux support
  301. * Wed Dec 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-6
  302. - apply selinux patch from dwalsh
  303. * Fri Dec 10 2010 Tomas Mraz <tmraz@redhat.com> - 1.4.6-5
  304. - do not lock jobs that fall out of allowed range - 661966
  305. * Thu Dec 02 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-4
  306. - fix post (thanks plautrba for review)
  307. * Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-3
  308. - systemd init script 617320
  309. * Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-2
  310. - fix typos in man pages
  311. * Fri Oct 22 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-1
  312. - update to 1.4.6
  313. * Fri Aug 13 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-4
  314. - 623908 fix fd leak in anacron, which caused denail of prelink
  315. and others
  316. * Mon Aug 9 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-2
  317. - remove sendmail from requirements. If it's not installed, it will
  318. log into (r)syslog.
  319. * Mon Aug 2 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-1
  320. - update to new release
  321. * Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.4-1
  322. - update to new release
  323. * Mon Feb 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-3
  324. - 564894 FTBFS DSOLinking
  325. * Thu Nov 5 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-2
  326. - 533189 pam needs add a line and selinux needs defined one function
  327. * Fri Oct 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-1
  328. - 531963 and 532482 creating noanacron package
  329. * Mon Oct 19 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-2
  330. - 529632 service crond stop returns appropriate value
  331. * Mon Oct 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-1
  332. - new release
  333. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-3
  334. - rebuilt with new audit
  335. * Fri Aug 14 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-2
  336. - create the anacron timestamps in correct post script
  337. * Fri Aug 14 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.1-1
  338. - update to 1.4.1
  339. - create and own /var/spool/anacron/cron.{daily,weekly,monthly} to
  340. remove false warning about non existent files
  341. - Resolves: 517398
  342. * Wed Aug 5 2009 Tomas Mraz <tmraz@redhat.com> - 1.4-4
  343. - 515762 move anacron provides and obsoletes to the anacron subpackage
  344. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-3
  345. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  346. * Mon Jul 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4-2
  347. - merge cronie and anacron in new release of cronie
  348. - obsolete/provide anacron in spec
  349. * Thu Jun 18 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-2
  350. - 506560 check return value of access
  351. * Mon Apr 27 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-1
  352. - new release
  353. * Fri Apr 24 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-8
  354. - 496973 close file descriptors after exec
  355. * Mon Mar 9 2009 Tomas Mraz <tmraz@redhat.com> - 1.2-7
  356. - rebuild
  357. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-6
  358. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  359. * Tue Dec 23 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-5
  360. - 477100 NO_FOLLOW was removed, reload after change in symlinked
  361. crontab is needed, man updated.
  362. * Fri Oct 24 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-4
  363. - update init script
  364. * Thu Sep 25 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-3
  365. - add sendmail file into requirement, cause it's needed some MTA
  366. * Thu Sep 18 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-2
  367. - 462252 /etc/sysconfig/crond does not need to be executable
  368. * Thu Jun 26 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-1
  369. - update to 1.2
  370. * Tue Jun 17 2008 Tomas Mraz <tmraz@redhat.com> - 1.1-3
  371. - fix setting keycreate context
  372. - unify logging a bit
  373. - cleanup some warnings and fix a typo in TZ code
  374. - 450993 improve and fix inotify support
  375. * Wed Jun 4 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-2
  376. - 49864 upgrade/update problem. Syntax error in spec.
  377. * Wed May 28 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-1
  378. - release 1.1
  379. * Tue May 20 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-6
  380. - 446360 check for lock didn't call chkconfig
  381. * Tue Feb 12 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-5
  382. - upgrade from less than cronie-1.0-4 didn't add chkconfig
  383. * Wed Feb 6 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-4
  384. - 431366 after reboot wasn't cron in chkconfig
  385. * Tue Feb 5 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-3
  386. - 431366 trigger part => after update from vixie-cron on cronie will
  387. be daemon running.
  388. * Wed Jan 30 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-2
  389. - change the provides on higher version than obsoletes
  390. * Tue Jan 8 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-1
  391. - packaging cronie
  392. - thank's for help with packaging to my reviewers