curl-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  3. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  4. Name: curl
  5. Version: 7.78.0
  6. Release: 1%{?_dist_release}
  7. Group: internet
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: MIT
  12. URL: https://curl.haxx.se/
  13. Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
  14. # patch making libcurl multilib ready
  15. Patch101: 0101-curl-7.73.0-multilib.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: brotli-devel
  18. BuildRequires: gnutls-devel
  19. BuildRequires: libidn2-devel
  20. BuildRequires: libnghttp2-devel
  21. BuildRequires: libpsl-devel
  22. BuildRequires: libssh2-devel
  23. BuildRequires: openldap-devel
  24. BuildRequires: openssh-server
  25. BuildRequires: openssh-clients
  26. BuildRequires: openssl-devel
  27. BuildRequires: pkgconfig
  28. BuildRequires: zlib-devel
  29. Requires: ca-certificates
  30. %description
  31. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  32. Dict servers, using any of the supported protocols. cURL is designed
  33. to work without user interaction or any kind of interactivity. cURL
  34. offers many useful capabilities, like proxy support, user
  35. authentication, FTP upload, HTTP post, and file transfer resume.
  36. %package devel
  37. Summary: Files needed for building applications with libcurl.
  38. Group: programming
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: openssl-devel libidn-devel zlib-devel
  41. %description devel
  42. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  43. Dict servers, using any of the supported protocols. The curl-devel
  44. package includes files needed for developing applications which can
  45. use cURL's capabilities internally.
  46. #'
  47. ## to build compat32 for x86_64 architecture support
  48. %package -n compat32-%{name}
  49. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  50. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  51. Group: system,legacy
  52. %description -n compat32-%{name}
  53. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  54. Dict servers, using any of the supported protocols. cURL is designed
  55. to work without user interaction or any kind of interactivity. cURL
  56. offers many useful capabilities, like proxy support, user
  57. authentication, FTP upload, HTTP post, and file transfer resume.
  58. %package -n compat32-%{name}-devel
  59. Summary: Files needed for building applications with libcurl.
  60. Group: programming,legacy
  61. %description -n compat32-%{name}-devel
  62. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  63. Dict servers, using any of the supported protocols. The curl-devel
  64. package includes files needed for developing applications which can
  65. use cURL's capabilities internally.
  66. #'
  67. %debug_package
  68. %prep
  69. %setup -q
  70. %autopatch -p1
  71. # disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
  72. # with errno 98: Address already in use' in Koji environment), and test 1801
  73. # <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
  74. # and test 1900, which is flaky and covers a deprecated feature of libcurl
  75. # <https://github.com/curl/curl/pull/2705>
  76. printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
  77. # disable test 1319 on ppc64 (server times out)
  78. %ifarch ppc64
  79. echo "1319" >> tests/data/DISABLED
  80. %endif
  81. # temporarily disable test 582 on s390x (client times out)
  82. %ifarch s390x
  83. echo "582" >> tests/data/DISABLED
  84. %endif
  85. # adapt test 323 for updated OpenSSL
  86. sed -e 's/^35$/35,52/' -i tests/data/test323
  87. # use localhost6 instead of ip6-localhost in the curl test-suite
  88. (
  89. # avoid glob expansion in the trace output of `bash -x`
  90. { set +x; } 2>/dev/null
  91. cmd="sed -e 's|ip6-localhost|localhost6|' -i tests/data/test[0-9]*"
  92. printf "+ %s\n" "$cmd" >&2
  93. eval "$cmd"
  94. )
  95. # regenerate the configure script and Makefile.in files
  96. autoreconf -fiv
  97. %build
  98. %configure \
  99. --disable-static \
  100. --enable-hidden-symbols \
  101. --enable-ipv6 \
  102. --enable-ldap \
  103. --enable-ldaps \
  104. --enable-threaded-resolver \
  105. --with-brotli \
  106. --with-libidn2 \
  107. --with-libpsl \
  108. --with-libssh2 \
  109. --with-nghttp2 \
  110. --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  111. %{nil}
  112. make %{?_smp_mflags}
  113. %install
  114. rm -rf $RPM_BUILD_ROOT
  115. make DESTDIR=$RPM_BUILD_ROOT install
  116. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  117. %clean
  118. rm -rf $RPM_BUILD_ROOT
  119. %files
  120. %defattr(-,root,root)
  121. %{!?_licensedir:%global license %%doc}
  122. %license COPYING
  123. %doc CHANGES README
  124. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  125. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  126. %doc docs/TheArtOfHttpScripting docs/TODO
  127. %{_bindir}/curl
  128. #{_datadir}/curl/*
  129. %{_libdir}/*.so.*
  130. %{_mandir}/man1/*.1*
  131. %files devel
  132. %defattr(-,root,root)
  133. %{_bindir}/curl-config
  134. %{_includedir}/curl
  135. %{_libdir}/*.so
  136. %{_libdir}/pkgconfig/*.pc
  137. %{_mandir}/man1/curl-config.1*
  138. %{_mandir}/man3/*
  139. %{_datadir}/aclocal/libcurl.m4
  140. ## to build compat32 for x86_64 architecture support
  141. %if %{build_compat32}
  142. %files -n compat32-%{name}
  143. %defattr(-,root,root)
  144. %{_libdir}/*.so.*
  145. %files -n compat32-%{name}-devel
  146. %defattr(-,root,root)
  147. %{_libdir}/*.so
  148. %endif
  149. %changelog
  150. * Thu Jul 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.78.0-1
  151. - new upstream release.
  152. - dropped Patch102 and 105.
  153. * Wed Jun 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.77.0-1
  154. - new upstream release.
  155. * Wed Apr 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.76.1-1
  156. - new upstream release.
  157. * Wed Apr 07 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.76.0-1
  158. - new upstream release.
  159. - dropped ldconfig scriptlets.
  160. - dropped Patch2, 102-104.
  161. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.75.0-1
  162. - new upstream release.
  163. * Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.74.0-1
  164. - new upstream release.
  165. * Tue Nov 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.73.0-1
  166. - new upstream release.
  167. - updated Patch0101 and Patch0104.
  168. * Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.71.1-1
  169. - new upstream release.
  170. * Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.70.0-1
  171. - new upstream release.
  172. * Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
  173. - new upstream release.
  174. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
  175. - new upstream release.
  176. - dropped Patch1 and 2: fixed in upstream.
  177. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
  178. - new upstream release.
  179. - updated patches.
  180. - imported Patch1, 103 and 105 from rawhide.
  181. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
  182. - new upstream release.
  183. - imported patches from rawhide.
  184. * Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
  185. - new upstream release.
  186. - imported Patch1 and 103 from rawhide.
  187. * Wed Feb 7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
  188. - new upstream release with security fix
  189. - update patch101
  190. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
  191. - new upstream release.
  192. - updated Patch101-104.
  193. - dropped Patch107.
  194. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
  195. - new upstream release.
  196. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
  197. - new upstream release.
  198. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
  199. - new upstream release.
  200. * Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
  201. - new upstream release.
  202. - disabled HTTP/2 on Vine6.
  203. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
  204. - added HTTP/2 support.
  205. * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
  206. - new upstream release with security fix.
  207. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  208. - new upstream release.
  209. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  210. - new upstream release
  211. - built with openssl 1.0.2g
  212. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  213. - new upstream release with security fix .
  214. - removed Patch108 (fixed in upstream).
  215. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  216. - new upstream release with security fix
  217. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  218. - new upstream release
  219. - add libcurl.m4 to -devel package
  220. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  221. - new upstream release
  222. - import upstream/fedora patches
  223. - disable libssh2 on Vine Linux 6
  224. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  225. - new upstream reelase
  226. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  227. - update to 7.28.0
  228. - add configure options
  229. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  230. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  231. - use ca-certificates package
  232. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  233. - R: ca-certificates
  234. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  235. - new upstream release
  236. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  237. - add patch100 for fix CVE-2011-2192 (gssapi)
  238. - add Vendor/Distri tags
  239. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  240. - rebuild with openssl-1.0.0c
  241. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  242. - rebuilt with rpm-4.8.1 for pkg-config
  243. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  244. - new upstream release
  245. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  246. - new upstream release with security fix
  247. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  248. - added compat32 subpackages
  249. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  250. - new upstream release
  251. - use "_smp_mflags" flag
  252. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  253. - rebuild with openldap-2.4.11
  254. - add BR: openldap-devel
  255. - remove static library
  256. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  257. - new upstream release with security fix (CVE-2009-0037)
  258. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  259. - new upstream release
  260. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  261. - new upstream release
  262. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  263. - new upstream release
  264. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  265. - new upstream release
  266. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  267. - new upstream release
  268. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  269. - rebuilt with openssl-0.9.8e
  270. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  271. - new upstream release
  272. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  273. - new upstream release
  274. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  275. - new upstream release
  276. - add pkgconfig file to devel package
  277. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  278. - new upstream release
  279. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  280. - new upstream release
  281. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  282. - new upstream release
  283. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  284. - added libidn, zlib in Requires
  285. - added libidn-devel, zlib-devel in BuildPrereq
  286. - added zlib-devel in curl-devel's Requires
  287. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  288. - added openssl-devel, libidn-devel in curl-devel's Requires
  289. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  290. - new upstream release
  291. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  292. - new upstream release
  293. - rebuild with openssl-0.9.7d
  294. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  295. - upstream release
  296. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  297. - add %%{_datadir}/curl/* to %%files section
  298. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  299. - source upgrade
  300. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  301. - source upgrade
  302. - add PreReq: ldconfig
  303. - add %%{_libdir}/*.la to %%files devel section
  304. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  305. - build for VineSeed
  306. - add Requires: openssl
  307. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  308. - automated rebuild
  309. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  310. - 7.9.2
  311. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  312. - include curl-config in curl-devel
  313. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  314. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  315. - added openssl-devel build req
  316. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  317. - built for the distro
  318. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  319. - upgrade to curl-7.7.2.
  320. - enable IPv6.
  321. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  322. - rebuilt against openssl-0.9.6-1
  323. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  324. - fixed mising ldconfigs
  325. - updated to 7.5.2, bug fixes
  326. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  327. - updated to 7.5.1
  328. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  329. - update to 7.4.1 to fix bug #20337, problems with curl -c
  330. - not using patch anymore, it's included in the new source. Keeping
  331. for reference
  332. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  333. - fix bogus req in -devel package
  334. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  335. - devel package needed defattr so that root owns the files
  336. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  337. - update to 7.3
  338. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  339. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  340. - enable SSL support
  341. - fix packager tag
  342. - move buildroot to %%{_tmppath}
  343. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  344. - fixed vendor tag for bug #15028
  345. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  346. - rebuilt
  347. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  348. - workaround alpha build problems with optimizations
  349. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  350. - rebuilt
  351. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  352. - put man pages in correct place
  353. - use %%makeinstall
  354. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  355. - updated to 6.5.2
  356. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  357. - updated sources to 6.2
  358. - gzip man page
  359. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  360. - changed group
  361. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  362. - changelog started
  363. - general cleanups, changed prefix to /usr, added manpage to files section
  364. - including in Powertools