db46-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
  3. %define java_arches %{ix86} alpha ia64 ppc s390 s390x sparc sparcv9 x86_64
  4. ##VINE##
  5. %undefine java_arches
  6. %define __soversion 4.6
  7. %define _libdb_a libdb-%{__soversion}.a
  8. %define _libcxx_a libdb_cxx-%{__soversion}.a
  9. Summary: The Berkeley DB database library (version 4) for C
  10. Name: db46
  11. Version: 4.6.21
  12. Release: 8%{?_dist_release}
  13. Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
  14. Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
  15. Patch1: http://www.oracle.com/technology/products/berkeley-db/xml/update/4.6.21/patch.4.6.21.1
  16. Patch2: db-4.3.29-sparc64.patch
  17. Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
  18. Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
  19. Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
  20. Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
  21. Patch14: db-1.85-errno.patch
  22. Patch20: db-4.6.18-glibc.patch
  23. Patch22: db-4.5.20-jni-include-dir.patch
  24. URL: http://www.oracle.com/database/berkeley-db/
  25. License: BSD-style
  26. Group: System Environment/Libraries
  27. Obsoletes: db1, db2, db3
  28. BuildRequires: perl, libtool, ed, tcl >= 8.4.4
  29. #BuildRequires: util-linux-ng
  30. %ifarch %{java_arches}
  31. BuildRequires: gcc-java
  32. BuildRequires: java-1.5.0-gcj
  33. BuildRequires: java-1.5.0-gcj-devel
  34. %endif
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  36. %description
  37. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  38. provides embedded database support for both traditional and
  39. client/server applications. The Berkeley DB includes B+tree, Extended
  40. Linear Hashing, Fixed and Variable-length record access methods,
  41. transactions, locking, logging, shared memory caching, and database
  42. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  43. used by many applications, including Python and Perl, so this should
  44. be installed on all systems.
  45. %package -n compat32-%{name}
  46. Summary: The Berkeley DB database library (version 4) for C.
  47. Group: System Environment/Libraries
  48. Requires: db4 = %{version}-%{release}
  49. %description -n compat32-%{name}
  50. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  51. provides embedded database support for both traditional and
  52. client/server applications. The Berkeley DB includes B+tree, Extended
  53. Linear Hashing, Fixed and Variable-length record access methods,
  54. transactions, locking, logging, shared memory caching, and database
  55. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  56. used by many applications, including Python and Perl, so this should
  57. be installed on all systems.
  58. %package cxx
  59. Summary: The Berkeley DB database library (version 4) for C++
  60. Group: System Environment/Libraries
  61. %description cxx
  62. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  63. provides embedded database support for both traditional and
  64. client/server applications. The Berkeley DB includes B+tree, Extended
  65. Linear Hashing, Fixed and Variable-length record access methods,
  66. transactions, locking, logging, shared memory caching, and database
  67. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  68. used by many applications, including Python and Perl, so this should
  69. be installed on all systems.
  70. %package -n compat32-%{name}-cxx
  71. Summary: The Berkeley DB database library (version 4) for C++
  72. Group: System Environment/Libraries
  73. %description -n compat32-%{name}-cxx
  74. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  75. provides embedded database support for both traditional and
  76. client/server applications. The Berkeley DB includes B+tree, Extended
  77. Linear Hashing, Fixed and Variable-length record access methods,
  78. transactions, locking, logging, shared memory caching, and database
  79. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  80. used by many applications, including Python and Perl, so this should
  81. be installed on all systems.
  82. %package utils
  83. Summary: Command line tools for managing Berkeley DB (version 4) databases
  84. Group: Applications/System
  85. Requires: db4 = %{version}-%{release}
  86. Obsoletes: db1-utils, db2-utils, db3-utils
  87. %description utils
  88. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  89. provides embedded database support for both traditional and
  90. client/server applications. Berkeley DB includes B+tree, Extended
  91. Linear Hashing, Fixed and Variable-length record access methods,
  92. transactions, locking, logging, shared memory caching, and database
  93. recovery. DB supports C, C++, Java and Perl APIs.
  94. %package devel
  95. Summary: C development files for the Berkeley DB (version 4) library
  96. Group: Development/Libraries
  97. Requires: db4 = %{version}-%{release}
  98. Obsoletes: db1-devel, db2-devel, db3-devel
  99. %description devel
  100. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  101. provides embedded database support for both traditional and
  102. client/server applications. This package contains the header files,
  103. libraries, and documentation for building programs which use the
  104. Berkeley DB.
  105. %package -n compat32-%{name}-devel
  106. Summary: Development files for the Berkeley DB (version 4) library.
  107. Group: Development/Libraries
  108. Requires: compat32-%{name} = %{version}-%{release}
  109. Requires: %{name}-devel = %{version}-%{release}
  110. %description -n compat32-%{name}-devel
  111. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  112. provides embedded database support for both traditional and
  113. client/server applications. This package contains the header files,
  114. libraries, and documentation for building programs which use the
  115. Berkeley DB.
  116. %package tcl
  117. Summary: Development files for using the Berkeley DB (version 4) with tcl
  118. Group: Development/Libraries
  119. Requires: %{name} = %{version}-%{release}
  120. %description tcl
  121. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  122. provides embedded database support for both traditional and
  123. client/server applications. This package contains the libraries
  124. for building programs which use the Berkeley DB in Tcl.
  125. %package -n compat32-%{name}-tcl
  126. Summary: Development files for using the Berkeley DB (version 4) with tcl.
  127. Group: Development/Libraries
  128. Requires: compat32-%{name} = %{version}-%{release}
  129. Requires: %{name}-tcl = %{version}-%{release}
  130. %description -n compat32-%{name}-tcl
  131. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  132. provides embedded database support for both traditional and
  133. client/server applications. This package contains the libraries
  134. for building programs which use the Berkeley DB in Tcl.
  135. %package java
  136. Summary: Development files for using the Berkeley DB (version 4) with Java
  137. Group: Development/Libraries
  138. Requires: %{name} = %{version}-%{release}
  139. %description java
  140. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  141. provides embedded database support for both traditional and
  142. client/server applications. This package contains the libraries
  143. for building programs which use the Berkeley DB in Java.
  144. %prep
  145. %setup -q -n db-%{version} -a 1
  146. %patch1 -p0 -b .4.6.21.1
  147. %patch2 -p1 -b .sparc64
  148. pushd dist
  149. #libtoolize --copy --force
  150. #cat %{_datadir}/aclocal/libtool.m4 >> aclocal.m4
  151. popd
  152. pushd db.1.85/PORT/linux
  153. %patch10 -p0 -b .1.1
  154. popd
  155. pushd db.1.85
  156. %patch11 -p0 -b .1.2
  157. %patch12 -p0 -b .1.3
  158. %patch13 -p0 -b .1.4
  159. %patch14 -p1 -b .errno
  160. popd
  161. %patch20 -p1 -b .glibc
  162. %patch22 -p1 -b .4.5.20.jni
  163. # Remove tags files which we don't need.
  164. find . -name tags | xargs rm -f
  165. # Define a shell function for fixing HREF references in the docs, which
  166. # would otherwise break when we split the docs up into subpackages.
  167. fixup_href() {
  168. for doc in $@ ; do
  169. chmod u+w ${doc}
  170. sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
  171. -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
  172. -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
  173. -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
  174. -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
  175. -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
  176. -e 's,="../java/,="../../%{name}-devel-%{version}/java/,g' \
  177. -e 's,="java/,="../%{name}-devel-%{version}/java/,g' \
  178. -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
  179. -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
  180. -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
  181. -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
  182. -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
  183. -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
  184. -e 's,="../images/,="../../%{name}-devel-%{version}/images/,g' \
  185. -e 's,="images/,="../%{name}-devel-%{version}/images/,g' \
  186. -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
  187. -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
  188. touch -r ${doc} ${doc}.new
  189. cat ${doc}.new > ${doc}
  190. touch -r ${doc}.new ${doc}
  191. rm -f ${doc}.new
  192. done
  193. }
  194. set +x # XXX painful to watch
  195. # Fix all of the HTML files.
  196. fixup_href `find . -name "*.html"`
  197. set -x # XXX painful to watch
  198. cd dist
  199. #./s_config
  200. %build
  201. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"; export CFLAGS
  202. # Build the old db-185 libraries.
  203. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  204. build() {
  205. test -d dist/$1 || mkdir dist/$1
  206. # Static link db_dump185 with old db-185 libraries.
  207. /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
  208. /bin/sh libtool --mode=link %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  209. pushd dist/$1
  210. ln -sf ../configure .
  211. # XXX --enable-diagnostic should be disabled for production (but is
  212. # useful).
  213. # XXX --enable-debug_{r,w}op should be disabled for production.
  214. %configure -C \
  215. --enable-compat185 --enable-dump185 \
  216. --enable-shared --enable-static --enable-rpc \
  217. --enable-tcl --with-tcl=%{_libdir} \
  218. --enable-cxx \
  219. %ifarch %{java_arches}
  220. --enable-java \
  221. %else
  222. --disable-java \
  223. %endif
  224. --enable-test \
  225. # --enable-diagnostic \
  226. # --enable-debug --enable-debug_rop --enable-debug_wop \
  227. # Remove libtool predep_objects and postdep_objects wonkiness so that
  228. # building without -nostdlib doesn't include them twice. Because we
  229. # already link with g++, weird stuff happens if you don't let the
  230. # compiler handle this.
  231. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  232. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  233. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  234. make %{?_smp_mflags}
  235. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  236. LDBJ=./.libs/libdb_java-%{__soversion}.la
  237. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  238. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  239. fi
  240. popd
  241. }
  242. build dist-tls
  243. %install
  244. rm -rf ${RPM_BUILD_ROOT}
  245. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  246. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  247. %makeinstall -C dist/dist-tls
  248. # XXX Nuke non-versioned archives and symlinks
  249. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a}
  250. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb-4.so
  251. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_cxx-4.so
  252. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl-4.so
  253. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl.so
  254. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  255. # Move the main shared library from /usr/lib* to /lib* directory.
  256. if [ "%{_libdir}" != "/%{_lib}" ]; then
  257. mkdir -p $RPM_BUILD_ROOT/%{_lib}/
  258. mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
  259. # Leave relative symlinks in %{_libdir}.
  260. touch $RPM_BUILD_ROOT/rootfile
  261. root=..
  262. while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
  263. root=${root}/..
  264. done
  265. rm $RPM_BUILD_ROOT/rootfile
  266. ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb.so
  267. ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/
  268. ln -sf libdb_cxx-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb_cxx.so
  269. fi
  270. # Move the header files to a subdirectory, in case we're deploying on a
  271. # system with multiple versions of DB installed.
  272. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/db4
  273. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/db4/
  274. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  275. for i in db.h db_cxx.h db_185.h; do
  276. ln -s db4/$i ${RPM_BUILD_ROOT}%{_includedir}
  277. done
  278. %ifarch %{java_arches}
  279. # Move java jar file to the correct place
  280. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  281. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  282. %endif
  283. # Eliminate installed doco
  284. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  285. # XXX Avoid Permission denied. strip when building as non-root.
  286. chmod u+w ${RPM_BUILD_ROOT}%{_bindir}
  287. %clean
  288. rm -rf ${RPM_BUILD_ROOT}
  289. %post -p /sbin/ldconfig
  290. %postun -p /sbin/ldconfig
  291. %post -n compat32-%{name} -p /sbin/ldconfig
  292. %postun -n compat32-%{name} -p /sbin/ldconfig
  293. %files
  294. %defattr(-,root,root)
  295. %doc LICENSE README
  296. /%{_lib}/libdb-%{__soversion}.so
  297. %{_libdir}/libdb-%{__soversion}.so
  298. %if %{build_compat32}
  299. %files -n compat32-%{name}
  300. %defattr(-,root,root)
  301. /%{_lib}/libdb-%{__soversion}.so
  302. %{_libdir}/libdb-%{__soversion}.so
  303. %endif
  304. %changelog
  305. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6.21-8
  306. - rebuilt with gcc-4.4.3-3 on ppc
  307. * Mon Feb 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.21-7
  308. - rename to db46 to build as compatibility package
  309. * Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.6.21-6
  310. - initial build of db-4.6.21 on Vine Linux
  311. - temporarily commented out "libtoolize" and "s_config" lines
  312. until Vine's autotools get updated (maybe?)
  313. * Fri Apr 3 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-5
  314. - add upstream patch to fix a race condition between checkpoint
  315. and DB->close which can result in the checkpoint thread self-deadlocking
  316. * Mon Mar 10 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-4
  317. - don't list headers twice in filelist (#436701)
  318. * Mon Feb 25 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-3
  319. - manual rebuild because of gcc-4.3 (#434185)
  320. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.6.21-2
  321. - Autorebuild for GCC 4.3
  322. * Thu Oct 11 2007 Jindrich Novy <jnovy@redhat.com> 4.6.21-1
  323. - update to 4.6.21
  324. - own %%{_includedir}/db4 (#274251)
  325. * Mon Sep 3 2007 Jindrich Novy <jnovy@redhat.com> 4.6.19-1
  326. - update to 4.6.19 (#273461)
  327. * Thu Aug 29 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-2
  328. - rebuild for BuildID
  329. - BR util-linux-ng
  330. * Mon Jul 30 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-1
  331. - update to 4.6.18
  332. - drop upstream patches for 4.5.20 and gcj patch
  333. - remove nptl-abi-note.S, useless as we are definitely
  334. running kernel >= 2.4.20 (#245416)
  335. - move C++ stuff to subpackages to reduce dependency bloat (#220484)
  336. - package db_codegen
  337. - correct open() calls so that new db4 compiles with the new glibc
  338. * Sat Mar 24 2007 Thomas Fitzsimmons <fitzsim@redhat.com> 4.5.20-5
  339. - Require java-1.5.0-gcj and java-1.5.0-gcj-devel for build.
  340. * Mon Dec 4 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-4
  341. - apply upstream patches for 4.5.20
  342. (Java API <-> core API related fixes)
  343. * Fri Dec 1 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-3
  344. - temporarily remove ppc64 from java arches
  345. * Sun Nov 26 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-2
  346. - sync db4 and compat-db licenses to BSD-style as the result of
  347. consultation with legal department
  348. - fix some rpmlint warnings
  349. * Fri Nov 10 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-1
  350. - update to db-4.5.20 (#198038)
  351. - fix BuildRoot
  352. - drop .64bit patch
  353. - patch/source URLs now point to correct location
  354. * Tue Sep 12 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-9
  355. - rebuild
  356. * Wed Sep 6 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-8
  357. - revert the previous fix, it crashes OOo help
  358. * Sun Sep 3 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-7.fc6
  359. - fix memleak caused by SET_TXN macro in xa_db.c, when opening
  360. database created with DB_XA_CREATE flag (#204920)
  361. * Wed Jul 19 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-6
  362. - fix sparc64 build (#199358)
  363. * Mon Jul 17 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-5
  364. - rebuild because of gnu_hash
  365. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-4.1
  366. - rebuild
  367. * Fri Mar 24 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-4
  368. - drop useless java, lfs patches
  369. * Mon Mar 13 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-3
  370. - apply x86_64 fix from Henrik Nordstrom (#184588)
  371. - don't nuke non-versioned archives twice
  372. * Wed Feb 15 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-2
  373. - don't package /usr/share/doc/images in the main db4 package
  374. and move it to db4-devel (#33328)
  375. - make db4 LFS capable (#33849)
  376. - move db4-devel, db4-tcl, db4-java to Development/Libraries
  377. group instead of System Environment/Libraries (#54320)
  378. - BuildPrereq -> BuildRequires
  379. - don't use RPM_SOURCE_DIR
  380. - Obsoletes db3, db2
  381. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2.1
  382. - bump again for double-long bug on ppc(64)
  383. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2
  384. - rebuilt for new gcc4.1 snapshot and glibc changes
  385. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  386. - rebuilt
  387. * Fri Oct 07 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.29-1
  388. - New upstream release
  389. * Fri Sep 30 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-4
  390. - Re-enable java for ppc64
  391. * Wed Sep 21 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-3
  392. - Add fno-strict-aliasing for java (#168965)
  393. * Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-2
  394. - no java for ppc64 for now (#166657)
  395. * Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-1
  396. - FC5 is nptl only (derived from jbj's spec)
  397. - upgrade to 4.3.28
  398. * Thu Jul 14 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-5
  399. - re-enable db4-java
  400. * Tue May 17 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-4
  401. - /usr/lib/tls/ix86 dirs (#151371)
  402. * Mon Apr 25 2005 Bill Nottingham <notting@redhat.com> 4.3.27-3
  403. - add libdb_cxx.so link (#149191)
  404. * Fri Mar 4 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-2
  405. - rebuild with gcc4.
  406. * Sat Jan 1 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-1
  407. - upgrade to 4.3.27.
  408. * Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 4.3.21-1
  409. - upgrade to 4.3.21, no db4-java for the moment again again.
  410. * Tue Sep 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.2.52-6
  411. - on %%{ix86} systems, make the availability of an NPTL-requiring libdb match
  412. the availability of an NPTL libpthread in glibc > 2.3.3-48
  413. - run ldconfig in db4-java's %%post/%%postun
  414. - when building java support, assume that libgcj is equivalent enough to 1.3
  415. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  416. - rebuilt
  417. * Mon Jun 7 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-4
  418. - remove dangling symlinks (#123721 et al).
  419. - remove db_cxx.so and db_tcl.so symlinks, versioned equivs exist.
  420. - apply 2 patches from sleepycat.
  421. - resurrect db4-java using sun jvm-1.4.2.
  422. - cripple autoconf sufficiently to build db4-java with gcj, without jvm.
  423. - check javac first, gcj34 next, then gcj-ssa, finally gcj.
  424. - add ed build dependency (#125180).
  425. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  426. - rebuilt
  427. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  428. - rebuilt
  429. * Fri Jan 16 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-2
  430. - fix: automake *.lo wrapper, not elf, files included in *.a (#113572).
  431. * Thu Dec 11 2003 Jeff Johnson <jbj@jbj.org> 4.2.52-1
  432. - upgrade to db-4.2.52, no db4-java for the moment.
  433. * Fri Nov 28 2003 Paul Nasrat <pauln@truemesh.com> 4.2.41-0.2
  434. - Add build requires tcl-devel
  435. * Fri Oct 24 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-14
  436. - symlink from %%{_libdir}/tls/libdb-4.1.so to the copy in /%%{_lib}/tls, so
  437. that the run-time linker can find the right copy for of apps which use an
  438. RPATH to point at %%{_libdir}/libdb-4.1.so
  439. * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-13
  440. - add another section to the ABI note for the TLS libdb so that it's marked as
  441. not needing an executable stack (from Arjan Van de Ven)
  442. * Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com>
  443. - build both with and without support for shared mutex locks, which require NPTL
  444. - make behavior wrt where we put libdb the same for all OSs
  445. - revert changes making tcl optional - nesting %%if tcl and %%ifarch nptl
  446. doesn't work
  447. - fix dangling HREFs in utility docs (pointed to main docs dir, while they're
  448. actually in the -utils docs dir)
  449. - run ldconfig when installing/removing the -utils subpackage, as it contains
  450. shared libraries
  451. * Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-11
  452. - fix multiple-inclusion problem of startup files when building shlibs without
  453. the -nostdlib flag
  454. * Tue Oct 14 2003 Nalin Dahyabhai <nalin@redhat.com>
  455. - link shared libraries without -nostdlib, which created an unresolvable dep
  456. on a hidden symbol
  457. * Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  458. - allow compiling without tcl dependency
  459. * Sat Sep 20 2003 Jeff Johnson <jbj@jbj.org> 4.2.42-0.1
  460. - update to 4.2.42.
  461. - build in build_unix subdir.
  462. - eliminate --enable-dump185, db_dump185.c no longer compiles for libdb*.
  463. - create db4-tcl sub-pkg to isolate libtcl dependencies.
  464. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-9
  465. - rebuild
  466. * Tue Aug 19 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-8
  467. - add missing tcl-devel buildrequires (#101814)
  468. * Tue Jul 15 2003 Joe Orton <jorton@redhat.com> 4.1.25-7
  469. - rebuild
  470. * Fri Jun 27 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-6
  471. - build with libtool-1.5, which can't recognize the .so in libfoo*.so atm.
  472. - whack out libtool predep_objects wonkiness.
  473. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-5
  474. - rebuild.
  475. * Tue Jun 24 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-4
  476. - hack out O_DIRECT support in db4 for now.
  477. * Tue Jun 24 2003 Nalin Dahyabhai <nalin@redhat.com>
  478. - replace libtool.ac with current libtool.m4 so that running libtoolize doesn't
  479. cause a mismatch
  480. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  481. - rebuilt
  482. * Wed Jun 4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-2
  483. - change configure to only warn if JNI includes aren't found, assuming that
  484. the C compiler can find them
  485. - remove build requirement on jdkgcj -- gcj is sufficient
  486. * Mon May 5 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-1
  487. - upgrade to 4.1.25, crypto version.
  488. - enable posix mutexes using nptl on all arches.
  489. * Mon Mar 3 2003 Thoams Woerner <twoerner@redhat.com> 4.0.14-21
  490. - enabled db4-java for x86_64
  491. * Wed Feb 5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-20
  492. - add dynamic libdb-4.0.so link back to %%{_libdir} so that dynamically
  493. linking with -ldb-4.0 will work again
  494. * Tue Feb 4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-19
  495. - rebuild to use link the shared object with the same libraries we use
  496. for the bundled utils, should pull in libpthread when needed
  497. - move libdb.so from /%%{_lib} to %%{_libdir} where the linker can find it
  498. * Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-18
  499. - add java for s390x
  500. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.0.14-17
  501. - rebuilt
  502. * Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-16
  503. - add java for s390
  504. * Tue Oct 8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-15
  505. - add java bits back in for x86 boxes
  506. * Fri Sep 20 2002 Than Ngo <than@redhat.com> 4.0.14-14.1
  507. - Added better fix for s390/s390x/x86_64
  508. * Thu Sep 05 2002 Arjan van de Ven
  509. - remove java bits for x86-64
  510. * Tue Aug 27 2002 Jeff Johnson <jbj@redhat.com> 4.0.14-14
  511. - include libdb_tcl-4.1.a library.
  512. - obsolete db1 packages.
  513. * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-13
  514. - include patch to avoid db_recover (#70362)
  515. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
  516. - rebuilt with gcc-3.2 (we hope)
  517. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-11
  518. - own %%{_includedir}/%{name}
  519. * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.0.14-10
  520. - build using gcc-3.2-0.1
  521. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  522. - automated rebuild
  523. * Wed Jun 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.0.14-8
  524. - Add java bindings
  525. - Fix C++ bindings
  526. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  527. - automated rebuild
  528. * Thu May 9 2002 Jeff Johnson <jbj@redhat.com>
  529. - re-enable db.h symlink creation, db_util names, and db[23]-devel obsoletes.
  530. - make sure that -ldb is functional.
  531. * Thu Feb 21 2002 Jeff Johnson <jbj@redhat.com>
  532. - avoid db_util name collisions with multiple versions installed.
  533. * Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-3
  534. - remove relocatability stuffs
  535. - swallow a local copy of db1 and build db185_dump statically with it, to
  536. remove the build dependency and simplify bootstrapping new arches
  537. * Mon Jan 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-2
  538. - have subpackages obsolete their db3 counterparts, because they conflict anyway
  539. * Tue Jan 8 2002 Jeff Johnson <jbj@redhat.com> db4-4.0.14-1
  540. - upgrade to 4.0.14.
  541. * Sun Aug 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  542. - fix dangling docs symlinks
  543. - fix dangling doc HREFs (#33328)
  544. - apply the two patches listed at http://www.sleepycat.com/update/3.2.9/patch.3.2.9.html
  545. * Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
  546. - turn off --enable-debug
  547. * Thu May 10 2001 Than Ngo <than@redhat.com>
  548. - fixed to build on s390x
  549. * Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
  550. - update to 3.2.9.
  551. * Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
  552. - rebuild to remove 777 directories.
  553. * Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
  554. - don't build with --enable-diagnostic.
  555. - add build prereq on tcl.
  556. - default value for %%_lib macro if not found.
  557. * Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
  558. - add /usr/lib/libdb-3.1.so symlink to %%files.
  559. - remove dangling tags symlink from examples.
  560. * Mon Oct 9 2000 Jeff Johnson <jbj@redhat.com>
  561. - rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
  562. - turn off --enable-diagnostic for performance.
  563. * Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
  564. - update to 3.1.17.
  565. - disable posix mutexes Yet Again.
  566. * Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
  567. - add c++ and posix mutex support.
  568. * Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
  569. - put nss_db into a separate package
  570. * Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
  571. - rebuild to cope with glibc locale binary incompatibility, again
  572. * Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
  573. - remove redundant strip of libnss_db* that is nuking symbols.
  574. - change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
  575. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  576. - summaries from specspo.
  577. - all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
  578. * Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
  579. - temporarily build nss_db in this package, should be moved
  580. into separate nss_db package soon
  581. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  582. - rebuild to cope with glibc locale binary incompatibility
  583. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  584. - automatic rebuild
  585. * Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
  586. - upgrade to 3.1.14.
  587. - create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
  588. - FHS packaging.
  589. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  590. - disable tcl Yet Again, base packages cannot depend on libtcl.so.
  591. * Sat Jun 3 2000 Jeff Johnson <jbj@redhat.com>
  592. - enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
  593. * Tue May 30 2000 Matt Wilson <msw@redhat.com>
  594. - include /lib/libdb.so in the devel package
  595. * Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
  596. - put in "System Environment/Libraries" per msw instructions.
  597. * Tue May 9 2000 Jeff Johnson <jbj@redhat.com>
  598. - install shared library in /lib, not /usr/lib.
  599. - move API docs to db3-devel.
  600. * Mon May 8 2000 Jeff Johnson <jbj@redhat.com>
  601. - don't rename db_* to db3_*.
  602. * Tue May 2 2000 Jeff Johnson <jbj@redhat.com>
  603. - disable --enable-test --enable-debug_rop --enable-debug_wop.
  604. - disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
  605. problems.
  606. * Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
  607. - add 3.0.55.1 alignment patch.
  608. - add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
  609. - add --enable-tcl (needed -lpthreads).
  610. * Sat Apr 1 2000 Jeff Johnson <jbj@redhat.com>
  611. - add --enable-debug_{r,w}op for now.
  612. - add variable to set shm perms.
  613. * Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
  614. - update to 3.0.55
  615. * Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
  616. - Add --enable-cxx to configure.
  617. * Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
  618. - Create.