extra-cmake-modules-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. %bcond_without bootstrap
  2. # uncomment to enable bootstrap mode
  3. %if %{with bootstrap}
  4. %define bootstrap 1
  5. %endif
  6. %if !0%{?bootstrap}
  7. %global docs 1
  8. %global tests 1
  9. %endif
  10. Name: extra-cmake-modules
  11. Summary: Additional modules for CMake build system
  12. Version: 5.23.0
  13. Release: 3%{?_dist_release}
  14. License: BSD
  15. URL: https://quickgit.kde.org/?p=extra-cmake-modules.git
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %global versiondir %(echo %{version} | cut -d. -f1-2)
  19. %global revision %(echo %{version} | cut -d. -f3)
  20. %if %{revision} >= 50
  21. %global stable unstable
  22. %else
  23. %global stable stable
  24. %endif
  25. Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{name}-%{version}.tar.xz
  26. BuildArch: noarch
  27. BuildRequires: cmake
  28. #BuildRequires: kf5-rpm-macros
  29. #Requires: kf5-rpm-macros
  30. %if 0%{?docs}
  31. # qcollectiongenerator
  32. BuildRequires: qt5-qttools-devel
  33. # sphinx-build
  34. BuildRequires: python2-sphinx
  35. %endif
  36. %description
  37. Additional modules for CMake build system needed by KDE Frameworks.
  38. %prep
  39. %autosetup -p1
  40. %build
  41. mkdir %{_target_platform}
  42. pushd %{_target_platform}
  43. CFLAGS="${CFLAGS:-%optflags}"; export CFLAGS;
  44. CXXFLAGS="${CXXFLAGS:-%optflags}"; export CXXFLAGS;
  45. FFLAGS="${FFLAGS:-%optflags%{?_fmoddir: -I%_fmoddir}}"; export FFLAGS;
  46. %{?__global_ldflags:LDFLAGS="${LDFLAGS:-%__global_ldflags}"; export LDFLAGS;}
  47. cmake .. \
  48. -DCMAKE_VERBOSE_MAKEFILE=ON \
  49. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  50. -DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \
  51. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
  52. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  53. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  54. -DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
  55. %if "%{?_lib}" == "lib64"
  56. %{?_cmake_lib_suffix64} \
  57. %endif
  58. %{?_cmake_skip_rpath} \
  59. -DBUILD_SHARED_LIBS:BOOL=ON \
  60. -DBUILD_TESTING:BOOL=%{?tests:ON}%{!?tests:OFF}
  61. popd
  62. make %{?_smp_mflags} -C %{_target_platform}
  63. %install
  64. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  65. %check
  66. %if 0%{?tests}
  67. export CTEST_OUTPUT_ON_FAILURE=1
  68. make test ARGS="--output-on-failure --timeout 300" -C %{_target_platform}
  69. %endif
  70. %files
  71. %doc README.rst
  72. %license COPYING-CMAKE-SCRIPTS
  73. %{_datadir}/ECM/
  74. %if 0%{?docs}
  75. %{_docdir}/ECM/html/
  76. %{_mandir}/man7/ecm*.7*
  77. %endif
  78. %changelog
  79. * Sun Jul 3 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.23.0-3
  80. - initial build for Vine Linux.
  81. * Tue Jun 07 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.23.0-2
  82. - support bootstrap, add docs/tests
  83. * Tue Jun 07 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.23.0-1
  84. - 5.23.0, relax kf5-rpm-macros dep
  85. * Mon May 16 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.22.0-1
  86. - KDE Frameworks 5.22.0
  87. * Mon Apr 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.21.0-2
  88. - Update URL
  89. * Mon Apr 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.21.0-1
  90. - KDE Frameworks 5.21.0
  91. * Mon Mar 14 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.20.0-1
  92. - KDE Frameworks 5.20.0
  93. * Thu Feb 11 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.19.0-1
  94. - KDE Frameworks 5.19.0
  95. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.18.0-3
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  97. * Thu Jan 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.18.0-2
  98. - use kf5-rpm-macros, update URL, use %%license
  99. * Sun Jan 03 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.18.0-1
  100. - KDE Frameworks 5.18.0
  101. * Sun Dec 13 2015 Helio Chissini de Castro <helio@kde.org> - 5.17.0-2
  102. - Adapt epel cmake3 changes
  103. * Tue Dec 08 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.17.0-1
  104. - KDE Frameworks 5.17.0
  105. * Sun Nov 08 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.16.0-1
  106. - KDE Frameworks 5.16.0
  107. * Thu Oct 08 2015 Daniel Vrátil <dvratil@redhat.com> - 5.15.0-1
  108. - KDE Frameworks 5.15.0
  109. * Wed Sep 16 2015 Daniel Vrátil <dvratil@redhat.com> - 5.14.0-1
  110. - KDE Frameworks 5.14.0
  111. * Wed Aug 19 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-1
  112. - KDE Frameworks 5.13.0
  113. * Wed Aug 19 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-1
  114. - KDE Frameworks 5.13.0
  115. * Tue Aug 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-0.1
  116. - KDE Frameworks 5.13
  117. * Thu Jul 09 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.12.0-1
  118. - 5.12.0, update URL (to reference projects.kde.org), .spec cosmetics
  119. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.11.0-2
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  121. * Wed Jun 10 2015 Daniel Vrátil <dvratil@redhat.com> - 5.11.0-1
  122. - KDE Frameworks 5.11.0
  123. * Mon May 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.10.0-1
  124. - KDE Frameworks 5.10.0
  125. * Tue Apr 07 2015 Daniel Vrátil <dvratil@redhat.com> - 5.9.0-1
  126. - KDE Frameworks 5.9.0
  127. * Mon Mar 16 2015 Daniel Vrátil <dvratil@redhat.com> - 1.8.0-1
  128. - extra-cmake-modules 1.8.0 (KDE Frameworks 5.8.0)
  129. * Fri Feb 13 2015 Daniel Vrátil <dvratil@redhat.com> - 1.7.0-1
  130. - extra-cmake-modules 1.7.0 (KDE Frameworks 5.7.0)
  131. * Mon Jan 12 2015 Daniel Vrátil <dvratil@redhat.com> - 1.6.1-1
  132. - Update to 1.6.1 which includes upstream fix for kde#341717
  133. * Sun Jan 11 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.6.0-3
  134. - Use upstream version of the kde#342717 patch by Alex Merry
  135. * Sun Jan 11 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.6.0-2
  136. - Do not unset old-style variables in KDEInstallDirs.cmake, it breaks projects
  137. using GNUInstallDirs for some parts and KDEInstallDirs for others (kde#342717)
  138. * Thu Jan 08 2015 Daniel Vrátil <dvratil@redhat.com> - 1.6.0-1
  139. - extra-cmake-modules 1.6.0 (KDE Frameworks 5.6.0)
  140. * Thu Dec 11 2014 Daniel Vrátil <dvratil@redhat.com> - 1.5.0-1
  141. - extra-cmake-modules 1.5.0 (KDE Frameworks 5.5.0)
  142. * Mon Nov 03 2014 Daniel Vrátil <dvratil@redhat.com> - 1.4.0-1
  143. - extra-cmake-modules 1.4.0 (KDE Frameworks 5.4.0)
  144. * Tue Oct 07 2014 Daniel Vrátil <dvratil@redhat.com> - 1.3.0-1
  145. - extra-cmake-modules 1.3.0 (KDE Frameworks 5.3.0)
  146. * Tue Sep 16 2014 Daniel Vrátil <dvratil@redhat.com> - 1.2.1-1
  147. - extra-cmake-modules 1.2.1 (KDE Frameworks 5.2.0)
  148. * Mon Sep 15 2014 Daniel Vrátil <dvratil@redhat.com> - 1.2.0-1
  149. - extra-cmake-modules 1.2.0 (KDE Frameworks 5.2.0)
  150. * Wed Aug 06 2014 Daniel Vrátil <dvratil@redhat.com> - 1.1.0-1
  151. - extra-cmake-modules 1.1.0 (KDE Frameworks 5.1.0)
  152. * Thu Jul 10 2014 Daniel Vrátil <dvratil@redhat.com> - 1.0.0-1
  153. - extra-cmake-modules 1.0.0 (KDE Frameworks 5.0.0)
  154. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.14-3
  155. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  156. * Tue Jun 03 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.14-2
  157. - Strip architecture check from a CMake-generated file to fix noarch build
  158. * Tue Jun 03 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.14-1
  159. - extra-cmake-modules 0.0.14 (KDE Frameworks 4.100.0)
  160. * Mon May 05 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.13-1
  161. - extra-cmake-modules 0.0.13 (KDE Frameworks 4.99.0)
  162. * Fri Apr 11 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.12-3
  163. - Remove debug_package, add %%{?dist} to Release
  164. * Fri Apr 11 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.12-2
  165. - Don't depend on kf5-filesystem
  166. * Mon Mar 31 2014 Jan Grulich <jgrulich@redhat.com> 0.0.12-1
  167. - Update to KDE Frameworks 5 Beta 1 (4.98.0)
  168. * Wed Mar 05 2014 Jan Grulich <jgrulich@redhat.com> 0.0.11-1
  169. - Update to KDE Frameworks 5 Alpha 2 (4.97.0)
  170. * Wed Feb 12 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.10-1
  171. - Update to KDE Frameworks 5 Alpha 1 (4.96.0)
  172. * Wed Feb 05 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.10-0.1.20140205git
  173. - Update to pre-relase snapshot of 0.0.10
  174. * Tue Feb 04 2014 Lubomir Rintel <lkundrak@v3.sk> - 0.0.9-1
  175. - Update to Jan 7 release
  176. * Mon Sep 16 2013 Lubomir Rintel <lkundrak@v3.sk> - 0.0.9-0.1.20130013git5367954
  177. - Initial packaging