emacs24-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861
  1. %define emacsversion 24.0.97
  2. #% define bzrdate 20110817
  3. %define emacsrelease 1%{?bzrdate:.%bzrdate}%{?_dist_release}
  4. %define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
  5. %define _noVersionedDependencies 1
  6. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  7. %define infodir %{_infodir}/emacs-%{emacsversion}
  8. %define menutreeelversion 0.97
  9. Summary: GNU Emacs editor
  10. Summary(ja): GNU Emacs エディタ
  11. Name: emacs24
  12. Provides: emacs-snapshot
  13. Version: %{emacsversion}
  14. Release: %{emacsrelease}
  15. #Source0: ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?bzrdate:.bzr%bzrdate}.tar.xz
  16. Source0: ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.gz
  17. Source1: emacs-snapshot.sh
  18. Source10: site-start.el.emacs24
  19. ## local settings for local system
  20. Source20: emacs24-local.el
  21. # desktop file
  22. Source50: emacs24.desktop.in
  23. ## Enable Japanese Menu
  24. ## http://www11.atwiki.jp/s-irie/pages/13.html
  25. Source100: menu-tree-el-%{menutreeelversion}.tar.gz
  26. Source110: menu-tree-init.el.emacs24
  27. ## default settings for Vine Linux
  28. Source150: vine-default-base.el
  29. Source151: vine-default-faces.el
  30. ## Vine Patch(es)
  31. #Patch10: emacs-21.1-ppc-nocombreloc.patch
  32. Patch11: emacs-23.0.60-locallisppath.patch
  33. Patch20: emacs-23.1.90-fixed-resolution.patch
  34. Patch30: emacs-24.0.90-libs-termcap.patch
  35. # Fixed in upstream CVS. (from Fedora)
  36. # security patches (from Debian)
  37. # security patches (from Ubuntu)
  38. # patches from Mandrake
  39. Patch1001: emacs-21.1-bzip2.patch.bz2
  40. License: GPLv3+
  41. Group: Applications/Editors/Emacs
  42. Distribution: Vine Linux
  43. Vendor: Project Vine
  44. Packager: munepi, daisuke
  45. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  46. # Requires: tamago >= 4.0.6
  47. Obsoletes: mule-base, mule-canna, mule-wnn6, mule, emacs-beta
  48. Obsoletes: emacs21 <= 21.2-0vl7
  49. Obsoletes: emacs22 <= 22.0.50
  50. Obsoletes: emacs23 <= 23.0.91-2.20090325vl5
  51. Provides: emacs24 = %{version}
  52. Provides: emacsen = 0.1
  53. #% prereq_ge emacsen-common
  54. Requires(post): emacsen-common
  55. Requires(postun): emacsen-common
  56. BuildRequires: autoconf
  57. BuildRequires: xz
  58. BuildRequires: atk-devel
  59. BuildRequires: dbus-devel GConf2-devel
  60. BuildRequires: alsa-lib-devel
  61. BuildRequires: gnutls-devel
  62. %if %{?_dist_release} >= "vl7"
  63. BuildRequires: gtk3-devel
  64. %else
  65. BuildRequires: gtk2-devel
  66. %endif
  67. BuildRequires: cairo-devel
  68. BuildRequires: freetype2-devel, fontconfig-devel
  69. BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
  70. BuildRequires: librsvg2-devel, libotf-devel
  71. BuildRequires: ImageMagick-devel
  72. BuildRequires: libxml2-devel > 2.6.17
  73. BuildRequires: m17n-lib-devel
  74. BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
  75. BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
  76. BuildRequires: xorg-x11-proto-devel, zlib-devel
  77. BuildRequires: texinfo
  78. BuildRequires: nkf
  79. %description
  80. GNU Emacs is the extensible, customizable, self-documenting real-time
  81. display editor.
  82. %description -l ja
  83. GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
  84. %prep
  85. %setup -q -n emacs-%{version}
  86. %ifarch ppc
  87. #%patch10 -p1
  88. %endif
  89. %patch11 -p1
  90. %patch20 -p1
  91. %patch30 -p1
  92. %patch1001 -p1
  93. #autoconf
  94. autoreconf -i -I m4
  95. %build
  96. export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
  97. #to find installinfo
  98. export PATH="$PATH:/sbin:/usr/sbin"
  99. %configure --with-pop --with-sound \
  100. --libexecdir=%{_libdir} --infodir=%{infodir} \
  101. --disable-rename \
  102. %if %{?_dist_release} >= "vl7"
  103. --with-x-toolkit=gtk3 \
  104. %else
  105. --with-x-toolkit=gtk \
  106. %endif
  107. --with-freetype --with-xft \
  108. --enable-font-backend \
  109. --without-gpm \
  110. --with-libotf \
  111. --with-m17n-flt \
  112. --with-dbus --with-gconf \
  113. ;
  114. %__make bootstrap
  115. %__make %{?_smp_mflags}
  116. #%define recompile src/emacs -batch --no-init-file --no-site-file -f batch-byte-compile
  117. # recompile patched .el files
  118. #%{recompile} lisp/mail/mh-utils.el lisp/progmodes/make-mode.el
  119. # bytecompile python-mode, ssl, php-mode and rpm-spec-mode
  120. #cp %SOURCE12 %SOURCE14 %SOURCE16 %SOURCE17 .
  121. ##%%{recompile} rpm-spec-mode.el php-mode.el ssl.el po-mode.el
  122. %install
  123. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  124. ARCHDIR=${RPM_ARCH}-vine-linux
  125. %makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
  126. infodir=${RPM_BUILD_ROOT}%{infodir}
  127. ## This is a duplicate of the file in FLAVOR/site-lisp
  128. %__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
  129. # (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
  130. # (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
  131. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
  132. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
  133. # cp %{SOURCE100} $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
  134. # nkf -w %{SOURCE100} > $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree-utf8.el
  135. %__tar zxvf %{SOURCE100}
  136. %__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
  137. nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
  138. ## vine default
  139. %__cp -a %{SOURCE150} %{SOURCE151} \
  140. $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
  141. # The elisp reference manual
  142. #bzcat %{SOURCE13} | tar xf -
  143. #pushd elisp-manual-21-2.8
  144. #install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
  145. #popd
  146. # some modifications of installed files
  147. #rm -f $RPM_BUILD_ROOT%{infodir}/dir
  148. #gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
  149. %__install -m 644 %{SOURCE10} \
  150. $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
  151. %__sed -i -e 's/EMACS_VERSION/%{version}/g' \
  152. -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
  153. $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
  154. ## create site-start.d directory
  155. %__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
  156. # install coding-system init.el
  157. %__install -m644 %{SOURCE110} \
  158. $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
  159. %__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
  160. ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
  161. ## install system-wide configure file
  162. %__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
  163. %__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
  164. %__sed -i -e 's/EMACS_VERSION/%{version}/g' \
  165. ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
  166. ## Python mode, php mode and rpm-spec mode
  167. ## make file list
  168. strip $RPM_BUILD_ROOT%{_bindir}/* || :
  169. # install desktop file
  170. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
  171. %__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
  172. $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
  173. [ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
  174. %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
  175. # install icons
  176. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
  177. %__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
  178. ## remove man files
  179. %__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
  180. ## Remove ctags
  181. #rm -f $RPM_BUILD_ROOT/usr/bin/ctags
  182. #rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
  183. #rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
  184. DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
  185. ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
  186. BIN=${RPM_BUILD_ROOT}%{_bindir}
  187. LIB=${RPM_BUILD_ROOT}%{_libdir}
  188. EL="*.el"
  189. ## prepare file list for emacs
  190. echo "/usr/bin/ctags
  191. /usr/bin/ebrowse
  192. /usr/bin/etags
  193. /usr/bin/rcs-checkin
  194. /usr/bin/emacs
  195. /usr/bin/emacsclient
  196. /usr/bin/grep-changelog
  197. /usr/share/icons/hicolor/scalable/apps/emacs.svg
  198. /usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
  199. %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
  200. awk '{system($_)}'
  201. find $DIR $BIN $LIB -type d |
  202. %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
  203. find $DIR $BIN $LIB -type f |
  204. %__sed -e "
  205. s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
  206. s#^${RPM_BUILD_ROOT}##
  207. " >> rpm-files
  208. %clean
  209. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  210. %define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
  211. %pre
  212. if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
  213. %__rm -f %{_datadir}/emacs-%{version}/site-lisp
  214. fi
  215. if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
  216. find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
  217. xargs %__rm -rf
  218. fi
  219. %post
  220. if [ "$1" = 1 ]; then
  221. %_addflavorslist emacs-%{version}
  222. export PRIORITY=50
  223. %_installemacs emacs-%{version}
  224. unset PRIORITY
  225. fi
  226. if [ "$1" = 2 ]; then
  227. # export PRIORITY=50
  228. # %_installemacs emacs-%{version}
  229. # unset PRIORITY
  230. echo emacs-%{version} > /var/lib/emacsen-common/doinstaflavor-emacs
  231. fi
  232. %postun
  233. if [ $1 = 1 ]; then
  234. # run upgrade install time
  235. # old version uninstall
  236. %_removeflavorslist emacs-%{version}
  237. %_removeemacs emacs-%{version}
  238. #new version install
  239. if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
  240. NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
  241. %_addflavorslist $NEWFLAVOR
  242. export PRIORITY=50
  243. %_installemacs $NEWFLAVOR
  244. unset PRIORITY
  245. %__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
  246. fi
  247. fi
  248. %preun
  249. if [ $1 = 0 ]; then
  250. %_removeflavorslist emacs-%{version}
  251. %_removeemacs emacs-%{version}
  252. fi
  253. %triggerpostun -- emacs23 < %{version}-%{release}
  254. %_addflavorslist emacs-%{version}
  255. export PRIORITY=50
  256. %_installemacs emacs-%{version}
  257. unset PRIORITY
  258. %files -f rpm-files
  259. %defattr(-,root,root)
  260. %doc INSTALL README BUGS ChangeLog COPYING
  261. #%doc INSTALL.BZR
  262. %dir %{_sysconfdir}/emacs-%{version}
  263. %dir %{_sysconfdir}/emacs-%{version}/site-start.d
  264. %{_sysconfdir}/emacs-%{version}/site-start.d/*.el
  265. %config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
  266. %{_infodir}/*
  267. # %{_mandir}/*/*
  268. %{_datadir}/applications/emacs24.desktop
  269. %{_datadir}/icons/hicolor/*
  270. # %{_datadir}/emacs-%{version}/site-lisp
  271. %dir %{_localstatedir}/games/emacs
  272. %{_localstatedir}/games/emacs/*
  273. %changelog
  274. * Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
  275. - updated to 24.0.97 (24.1 pretest)
  276. * Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
  277. - updated to 24.0.96 (24.1 pretest)
  278. * Mon Apr 2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
  279. - updated to 24.0.95 (24.1 pretest)
  280. * Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
  281. - rebuild with ImageMagick-6.7.5.10
  282. * Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
  283. - updated to 24.0.94 (24.1 pretest)
  284. * Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
  285. - use gtk as X toolkit (for vl6)
  286. * Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
  287. - updated to 24.0.93 (24.1 pretest)
  288. * Thu Dec 1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
  289. - updated to 24.0.92 (24.1 pretest)
  290. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
  291. - updated to 24.0.91 (24.1 pretest)
  292. * Thu Oct 6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
  293. - set --with-x-toolkit=gtk3 (%%configure)
  294. - added BuildRequires: gtk3-devel
  295. * Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
  296. - updated to 24.0.90 (24.1 pretest)
  297. - applied emacs-24.0.90-libs-termcap.patch
  298. * Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
  299. - emacs24 24.0.50 (20110817) snapshot
  300. - added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
  301. * Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
  302. - emacs24 24.0.50 (20110604) snapshot
  303. * Thu Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
  304. - emacs24 24.0.50 (20110413) snapshot
  305. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
  306. - updated site-start.el
  307. - defined vine-default-major-version, vine-default-minor-version,
  308. vine-default-version
  309. - set "ibus-el" to emacs-ime as default
  310. - added ", modified for Vine Linux" to the end of emacs-build-system
  311. - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
  312. * Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
  313. - fixed site-start.el
  314. - do not use the macro loop (contained in the common lisp)
  315. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
  316. - emacs24 24.0.50 (20110318) snapshot
  317. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
  318. - emacs24 24.0.50 (20110222) snapshot
  319. - updated site-start.el
  320. - defined the function drop-vine-default-from-load-path (regex)
  321. * Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
  322. - emacs24 24.0.50 (20110128) snapshot
  323. * Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
  324. - emacs24 24.0.50 (20110101) snapshot
  325. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
  326. - emacs24 24.0.50 (20101203) snapshot
  327. - applied new vine-default system
  328. - updated site-start.el
  329. - updated vine-default-{base,faces}.el
  330. - dropped showvdefaultemacs
  331. - merged to emacsen-common package as show-vine-default.sh
  332. - renamed local wide configration file to emacs24-local.el
  333. - updated menu-tree.el to version 0.97
  334. - added Provides: emacs-snapshot
  335. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
  336. - updated vine-default-base.el
  337. - changed the variable next-line-add-newlines to nil (default)
  338. * Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
  339. - updated menu-tree.el to version 0.96
  340. * Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
  341. - applied some patches from Fedora
  342. - Fixed handling of dual spacing fonts rhbz#599437
  343. - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
  344. under certain circumstances
  345. - Added a patch fixing m17n and libotf version checking (m17ncheck)
  346. - updated menu-tree.el to version 0.95
  347. - merged emacs23-vl.spec of Vine Linux 5.1
  348. #* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
  349. #- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
  350. #
  351. #* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
  352. #- added Requires(post): emacsen-common, Requires(postun): emacsen-common
  353. #
  354. #* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
  355. #- dropped BuildRequires: m17n-lib-devel
  356. #- added --without-m17n-flt in %%configure
  357. * Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
  358. - new upstream release
  359. - updated menu-tree.el to version 0.94
  360. - updated menu-tree-init.el.emacs23
  361. - used prefer-coding-system
  362. * Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
  363. - updated to 23.1.96 (23.2 pretest)
  364. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
  365. - removed /usr/share/emacs/site-lisp/subdirs.el
  366. * Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
  367. - updated to 23.1.95 (23.2 pretest)
  368. - added BuildRequires:
  369. - atk-devel
  370. - dbus-devel
  371. - GConf2-devel
  372. - alsa-lib-devel
  373. - added some configure options:
  374. --with-libotf --with-m17n-flt --with-dbus --with-gconf
  375. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
  376. - updated to 23.1.94
  377. * Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
  378. - updated to 23.1.93 alpha
  379. * Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
  380. - added Requires(post): emacsen-common, Requires(postun): emacsen-common
  381. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
  382. - update to 23.1.92 alpha
  383. * Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
  384. - added BuildRequires:
  385. - librsvg2-devel
  386. - m17n-lib-devel
  387. - libotf-devel
  388. * Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
  389. - changed License to GPLv3+
  390. - renamed emacs23.desktop to emacs23.desktop.in
  391. - updated vine-default-base.el (See [vine-users:079919])
  392. - fixed in upstream CVS (from Fedora)
  393. - fix #543046 - Using scroll bar in emacs highlights/selects text
  394. - fix #542657 - emacs does not display indic text
  395. - Fixed rhbz#545398 - ETags messes up filenames
  396. * Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
  397. - rebuilt to add signature
  398. * Fri Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
  399. - added BuildRequires: nkf
  400. - updated menu-tree-init.el.emacs23
  401. - fixed menu-tree encoding <BTS:VineLinux:766>
  402. - set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
  403. * Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
  404. - replaced BR: libungif-devel with BR: giflib-devel
  405. * Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
  406. - new upstream release
  407. * Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
  408. - updated vine-default-faces.el to sync with emacs22
  409. * Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
  410. - update to 23.0.96 (20090714) snapshot
  411. - update vine-default-faces.el
  412. - use bash to call gconftool-2
  413. * Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
  414. - update vine-default-faces.el
  415. - added \'font in default-frame-alist
  416. (if \'font is already in default-frame-alist, overwrited it)
  417. * Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
  418. - update vine-default-faces.el:
  419. - use set-frame-font
  420. bacause set-default-font function is obsolete since Emacs 23.1
  421. (See M-x describe-function RET set-default-font)
  422. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
  423. - update vine-default-faces.el:
  424. - set desktop-gnome-interface-monospace-font-name
  425. from /desktop/gnome/interface/monospace_font_name
  426. - automatically set set-default-font
  427. with desktop-gnome-interface-monospace-font-name
  428. * Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
  429. - update to emacs-23.0.94 (20090527) snapshot
  430. - add --without-gpm to configure
  431. * Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
  432. - defined show-vine-default function in site-start.el
  433. - added showvdefaultemacs script
  434. * Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
  435. - set PRIORITY=40
  436. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
  437. - changed menu-tree-init.el from hard copy to symbolic link
  438. on /etc/emacs-23.0.92/site-start.d
  439. - added %%{_mandir}/*/* in %%files section
  440. * Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
  441. - updated menu-tree.el to v0.93
  442. * Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
  443. - returned alternatives priority to 30
  444. (emacs: 30, emacs22: 30)
  445. * Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
  446. - installed system-wide configure file in /etc/emacs
  447. - updated vine-default-base.el
  448. - changed alternatives priority from 30 to 50
  449. (emacs: 50, emacs22: 30)
  450. * Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
  451. - update to emacs 23.0.92 (20090422) snapshot
  452. - add %%triggerpostun to fix alternatives
  453. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
  454. - renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
  455. - updated default settings for Vine Linux
  456. - dropped vine-default-mouse.el, vine-default-misc.el
  457. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
  458. - enable default settings for Vine Linux
  459. - added site-start.el.emacs23
  460. - updated site-start.el
  461. - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
  462. vine-default-misc.el
  463. * Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
  464. - emacs23 23.0.91 snapshot
  465. * Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
  466. - drop patch10
  467. - s/emacsrelese/emacsrelease/
  468. * Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
  469. - emacs23 23.0.60 snapshot
  470. * Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
  471. - new upstream release
  472. * Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
  473. - import security fixes from Debian
  474. CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
  475. CVE-2008-1694: fix insecure temporary file creation in vcdiff script
  476. leading to possible symlink attacks
  477. * Tue Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
  478. - update menu-tree.el
  479. - add 60menu-tree-init.el to sed coding-system and load menu-tree
  480. - build with xorg-x11-7.3
  481. - update BuildRequires
  482. * Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
  483. - new upstream release
  484. * Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
  485. - add Patch10000 to fix local variable processing security bypass
  486. vulnerability.
  487. - http://www.frsirt.com/english/advisories/2007/3715
  488. - http://bugs.debian.org/449008
  489. * Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
  490. - new upstream release
  491. - rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
  492. - drop emcws support
  493. * Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
  494. - rebuilt with new toolchain
  495. * Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
  496. - changed Group:
  497. * Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
  498. - update to CVS-20060403
  499. - update emacs22.desktop
  500. * Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
  501. - fix site-start.el
  502. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
  503. - update to CVS-20050927
  504. * Thu Sep 8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
  505. - initial build for Vine Linux based on emacs package.
  506. - emacs-22.0.50 on CVS-20050907
  507. * Sat Sep 3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
  508. - create site-start.d directory on %install
  509. * Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
  510. - included leim-21.4
  511. - update emcws-21.3-20031213.gz
  512. * Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
  513. - update
  514. * Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
  515. - rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
  516. * Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
  517. - add Patch20 to fix display resolutions. (set to 96dpi)
  518. (do not compute dynamically from display's size)
  519. * Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
  520. - rebuilt with new toolchain environment
  521. * Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
  522. - use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
  523. * Wed May 7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
  524. - add BuildPrereq: libpng >= 1.2.5
  525. * Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
  526. - fixed %%pre script
  527. * Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
  528. - new upstream release
  529. - remove patch14 whick included in upstream
  530. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
  531. - add patch14 to fix frame title text encoding.
  532. - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
  533. * Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
  534. - autoconf-2.13, not autoconf in %%setup section
  535. - BuildPreReq: autoconf213
  536. * Mon Dec 9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
  537. - modifiy rpm scripts.
  538. * Mon Dec 9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
  539. - rename to emacs
  540. - obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
  541. * Sun Dec 1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
  542. - enable menubar fontset patch (Patch103)
  543. * Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
  544. - add requires/buildprereq tags.
  545. * Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
  546. - add emcws-20021014
  547. * Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
  548. - removed *-mode
  549. * Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
  550. - python-mode was made pending
  551. - some additional *.el files was moved from "emacs/site-lisp" to
  552. "emacs-(version)/site-lisp"
  553. * Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
  554. - added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
  555. * Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
  556. - update.
  557. - Package Name emacs-beta -> emacs21
  558. - Add Patch100,101,102, Source100(default = Disable)
  559. - (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
  560. - --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
  561. * Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
  562. - site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
  563. * Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
  564. - move /tmp -> /var/lib/emacsen-common (IP(package)C file)
  565. * Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
  566. - replace patch10 with patch11, posted to gnu.emacs.bug
  567. Message-Id: <jebsiza3db.fsf@sykes.suse.de>
  568. (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
  569. * Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
  570. - fixed build to fail in alpha( only apply patch0 to ppc)
  571. * Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
  572. - added Patch10 (thanks Kitame-san)
  573. * Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
  574. - update to 21.1
  575. * Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
  576. - support shared installing otheremacsen.
  577. * Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
  578. - update 21.0.104
  579. * Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
  580. - support emacsen-common
  581. * Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  582. - 21.0.103-0vl1
  583. - updated to 21.0.103
  584. - revamped and cleaned up spec file :-)
  585. - Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
  586. * Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
  587. - fixed .spec bugs( _libdir)
  588. * Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
  589. - updated to 21.0.95
  590. * Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
  591. - fixed emacs-beta.spec
  592. * Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
  593. - 21.0.93 test packaging.
  594. * Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  595. - added linespace-patch
  596. * Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
  597. - updated to emacs 20.7
  598. * Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  599. - updated to emacs 20.6
  600. * Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
  601. - [emacs-20.5a-2]
  602. - Modified reference of Emacs Info
  603. * Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  604. - [emacs-20.5a-2]
  605. - added ppc patch
  606. * Fri Jan 7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  607. - [emacs-20.5a-1]
  608. - change version from 20.5 to 20.5a
  609. - added Mule-4.1 patch
  610. * Fri Jan 7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
  611. - [emacs-20.5-1]
  612. - add desktop-link files for desktop menu.
  613. * Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  614. - [emacs-20.4-16]
  615. - replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
  616. * Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
  617. - added documents
  618. - strip bins
  619. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  620. - [emacs-20.4-14]
  621. - Change Group to Applications/Editors/Emacs
  622. * Sat Nov 6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  623. - [emacs-20.4-13]
  624. - included Y2K savvy timezone.{el,elc},
  625. modified by Mr. Youichi Teranishi <teranishi@gohome.org>
  626. * Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  627. - [emacs-20.4-12]
  628. - Modified info-dir.
  629. - Removed -c option from %setup.
  630. * Sun Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
  631. - fixed XIM support patch
  632. * Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
  633. - fixed postinst bug and fontset patch
  634. * Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
  635. - first build