empathy-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530
  1. ## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
  2. ## respectively.
  3. %global gtk3_min_version 3.12.0
  4. %global glib2_min_version 2.40.0
  5. %global tp_mc_min_version 5.12.0
  6. %global tp_glib_min_version 0.18.0
  7. %global tp_logger_min_version 0.2.10
  8. %global aspell_version 0.50
  9. %global libcanberra_version 0.25
  10. %global libnotify_version 0.7.4
  11. %global folks_version 0.6.8
  12. %global libsecret_version 0.5
  13. Summary: GNOME Instant Messaging Client
  14. Summary(ja): GNOME インスタントメッセージクラアイント
  15. Name: empathy
  16. Version: 3.12.14
  17. %global shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
  18. Release: 2%{?_dist_release}
  19. Group: Applications/Communications
  20. License: GPLv2+
  21. URL: https://live.gnome.org/Empathy
  22. Source0: https://ftp.gnome.org/pub/GNOME/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  23. Source1: %{name}-README.ConnectionManagers
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. #BuildRequires: enchant-devel >= %{enchant_version}
  26. BuildRequires: aspell-devel >= %{aspell_version}
  27. BuildRequires: iso-codes
  28. BuildRequires: desktop-file-utils
  29. BuildRequires: evolution-data-server-devel
  30. BuildRequires: gettext
  31. BuildRequires: glib2-devel >= %{glib2_min_version}
  32. BuildRequires: gtk3-devel >= %{gtk3_min_version}
  33. BuildRequires: intltool
  34. BuildRequires: libxml2-devel
  35. BuildRequires: perl(XML::Parser)
  36. BuildRequires: telepathy-glib-devel >= %{tp_glib_min_version}
  37. BuildRequires: telepathy-logger-devel >= %{tp_logger_min_version}
  38. BuildRequires: telepathy-mission-control-devel >= %{tp_mc_min_version}
  39. BuildRequires: farstream-devel
  40. BuildRequires: telepathy-farstream-devel
  41. BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
  42. BuildRequires: unique3-devel
  43. BuildRequires: libnotify-devel >= %{libnotify_version}
  44. BuildRequires: folks-devel >= %{folks_version}
  45. BuildRequires: gcr-devel >= %{gnome_keyring_version}
  46. BuildRequires: libsecret-devel >= %{libsecret_version}
  47. BuildRequires: openssl-devel
  48. BuildRequires: NetworkManager-libnm-devel
  49. BuildRequires: webkitgtk4-devel
  50. BuildRequires: geoclue2-devel
  51. BuildRequires: enchant-devel
  52. BuildRequires: libICE-devel
  53. BuildRequires: cheese-devel
  54. BuildRequires: pulseaudio-libs-devel
  55. BuildRequires: gnome-online-accounts-devel
  56. BuildRequires: eudev-libgudev1-devel
  57. BuildRequires: libchamplain-gtk-devel
  58. BuildRequires: gsettings-desktop-schemas-devel
  59. BuildRequires: libaccounts-glib-devel
  60. BuildRequires: clutter-gst-devel
  61. BuildRequires: yelp-tools
  62. BuildRequires: python-rpm-macros
  63. Requires: telepathy-filesystem
  64. Requires: telepathy-gabble
  65. Requires: telepathy-salut
  66. Requires: telepathy-idle
  67. ## Also hardcode Haze dependency since Empathy is the default IM client in F10+
  68. ## and I'd hate for people to simply disregard it for lack of the "out of the
  69. ## box" protocol support that Pidgin has. (RHBZ: 458935)
  70. BuildRequires: telepathy-haze
  71. # Require this for VOIP support
  72. Requires: telepathy-mission-control >= %{tp_mc_min_version}
  73. ## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
  74. Obsoletes: telepathy-haze-mission-control < 0.2.0-3
  75. Provides: telepathy-haze-mission-control = 0.2.0-3
  76. ## upstream 2.29.1 removed shared libraries: #599086
  77. Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
  78. ## upstream 2.29.1 removed python bindings' #599039
  79. Obsoletes: empathy-python < 2.29.1
  80. Obsoletes: nautilus-sendto-empathy < 3.7.0
  81. Vendor: Project Vine
  82. Distribution: Vine Linux
  83. %description
  84. Empathy provides a powerful multiple protocol instant messaging
  85. client using the Telepathy framework.
  86. %prep
  87. %setup -q
  88. %build
  89. ## GCC complains about some unused functions, so we forcibly show those as
  90. ## simple warnings instead of build-halting errors.
  91. %configure --disable-static
  92. ##make %{?_smp_mflags}
  93. ## don't use _smp_mflags at empathy-2.18.1
  94. make
  95. install -m 0644 %{SOURCE1} ./README.ConnectionManagers
  96. %install
  97. rm -rf $RPM_BUILD_ROOT
  98. make install DESTDIR=$RPM_BUILD_ROOT
  99. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  100. %find_lang %{name}
  101. %find_lang %{name}-tpaw
  102. desktop-file-install --vendor "" --delete-original \
  103. --dir %{buildroot}%{_datadir}/applications \
  104. %{buildroot}%{_datadir}/applications/%{name}.desktop
  105. %clean
  106. rm -rf %{buildroot}
  107. %post
  108. touch --no-create %{_datadir}/icons/hicolor ||:
  109. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  110. %postun
  111. touch --no-create %{_datadir}/icons/hicolor || :
  112. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  113. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  114. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  115. fi
  116. %posttrans
  117. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
  118. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  119. %files -f %{name}.lang -f %{name}-tpaw.lang
  120. %defattr(-,root,root,-)
  121. %license COPYING
  122. %doc AUTHORS README README.ConnectionManagers NEWS
  123. %{_bindir}/empathy
  124. %{_bindir}/empathy-accounts
  125. %{_bindir}/empathy-debugger
  126. %{_libexecdir}/empathy-auth-client
  127. %{_libexecdir}/empathy-call
  128. %{_libexecdir}/empathy-chat
  129. %{_libdir}/%{name}/libempathy*.so
  130. %{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
  131. %{_datadir}/GConf/gsettings/*
  132. %{_datadir}/appdata/empathy.appdata.xml
  133. %{_datadir}/applications/*.desktop
  134. %{_datadir}/adium/message-styles
  135. %{_datadir}/dbus-1/services/*
  136. %{_datadir}/%{name}
  137. %{_datadir}/glib-2.0/schemas/*.xml
  138. %{_datadir}/help/*/%{name}
  139. %{_datadir}/icons/hicolor/*/apps/%{name}*
  140. %{_datadir}/telepathy/clients/*.client
  141. %{_mandir}/man1/empathy*.1*
  142. %changelog
  143. * Sun Oct 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.12.14-2
  144. - fixed %%license.
  145. * Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.12.14-1
  146. - new upstream release.
  147. - built with webkitgtk4.
  148. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-2
  149. - rebuild with gnutls-3.4.7
  150. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
  151. - new upstream release
  152. - add BuildRequires: clutter-gst-devel
  153. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
  154. - new upstream release
  155. * Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
  156. - new upstream release
  157. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
  158. - new upstream release
  159. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
  160. - new upstream release
  161. * Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
  162. - new upstream release
  163. * Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
  164. - new upstream release
  165. * Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
  166. - new upstream release
  167. - change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
  168. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  169. - new upstream release
  170. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  171. - new upstream release
  172. - add BuildRequires: libaccounts-glib-devel
  173. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  174. - new upstream release
  175. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
  176. - new upstream release
  177. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
  178. - new upstream release
  179. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  180. - new upstream release
  181. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  182. - new upstream release
  183. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  184. - new upstream release
  185. - remove BuildRequires: gnome-panel, nautilus-sendto-devel
  186. - remove nautilus-sendto-empathy subpackage
  187. * Fri Jan 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-2
  188. - fix spec
  189. * Fri Jan 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  190. - new upstream release
  191. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  192. - new upstream release
  193. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  194. - rebuild with telepathy-logger-0.6.0
  195. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  196. - new upstream release
  197. * Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.3-1
  198. - new upstream release
  199. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  200. - new upstream release
  201. - add BuildRequires: libsecret-devel, yelp-tools
  202. - remove BuildRequires: libgnome-keyring-devel
  203. * Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.3-1
  204. - new upstream release
  205. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
  206. - new upstream release
  207. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  208. - new upstream release
  209. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  210. - new upstream release
  211. - change BuildRequires: gcr-devel instead of gnome-keyring-devel
  212. - change BuildRequires: farstream-devel instead of farsight2-devel
  213. - change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
  214. - add BuildRequires: itstool
  215. - remove Requires: telepathy-stream-engine
  216. - add Requires: telepathy-idle
  217. * Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  218. - new upstream release
  219. * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
  220. - new upstream release
  221. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  222. - new upstream release
  223. - add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
  224. * Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
  225. - new upstream release
  226. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  227. - new upstream release
  228. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  229. - new upstream release
  230. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  231. - new upstream release
  232. * Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
  233. - new upstream release
  234. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
  235. - new upstream release
  236. - add BuildRequires: pulseaudio-libs-devel
  237. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  238. - new upstream release
  239. - change BuildRequires: gtk3-devel instead of gtk2-devel
  240. - change BuildRequires: unique3-devel instead of unique-devel
  241. - change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
  242. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  243. - add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
  244. * Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  245. - new upstream release
  246. - add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
  247. geoclue-devel, enchant-devel
  248. - add Requires: telepathy-mission-control
  249. - add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
  250. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
  251. - new upstream release
  252. - add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
  253. - fix %files
  254. - fix %post, %postun
  255. - drop %pre, %preun
  256. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
  257. - rebuild with evolution-data-server-2.30.2
  258. - add nautilus-sendto-empathy package
  259. - add configure option (--enable-nautilus-sendto=yes)
  260. - add BuildRequires: nautilus-sendto-devel
  261. * Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
  262. - add Obsoletes: empathy-python < 2.29.1
  263. * Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
  264. - new upstream release
  265. - add new files: %%{_bindir}/empathy-{accounts,debugger}
  266. - drop -libs, -devel, -python sub packages: upstream removed
  267. - Obsoletes: empathy-{libs,devel} < 2.29.1
  268. - drop BuildRequires: python-devel
  269. - drop %%{_bindir}/empathy-logs in %%files: upstream don not install
  270. - drop applet files in %%files: upstream removed the panel applets
  271. - update %%post, %pre and %%preun
  272. - update BuildRequires version for glib2 and tp_glib
  273. - defined major_ver, minor_ver and rel
  274. - fix BuildRequires for gnome-keyring
  275. * Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  276. - new upstream release
  277. - add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
  278. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
  279. - rebuilt with python-2.6.4
  280. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
  281. - unuse %%{?_smp_mflags} option to make
  282. * Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
  283. - add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
  284. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  285. - new upstream release
  286. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  287. - new upstream release
  288. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  289. - initial build for Vine Linux
  290. * Tue Sep 9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
  291. - Update to 2.23.92
  292. * Thu Sep 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
  293. - Update to 2.23.91
  294. * Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
  295. - Now that Empathy will be the default IM client in F10+, hardcode a dependency
  296. on telepathy-haze to keep the same protocol functionality across upgrades,
  297. for a much improved "out of the box" experience.
  298. - Reference: bug 458935.
  299. * Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
  300. - Update to new upstream release (2.23.90)
  301. * Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
  302. - Apply patch from Colin Walters to automagically update profile namings for
  303. the switch to using Empathy's provided profiles.
  304. - Drop the upgrade script (no longer needed since it's automatically done).
  305. - upgrade-haze-profiles.sh
  306. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
  307. - Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
  308. the telepathy-haze-mission-control package. (The Haze-provided ones have grown
  309. horribly stale...). This makes for better automagic functionality (if Haze is
  310. installed, Empathy/MC will autodetect it) and tracks upstream more closely.
  311. + upgrade-haze-profiles.sh
  312. * Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
  313. - Update to new upstream release (2.23.6)
  314. - Use the in-tarball libtool scripts instead of the system copy to workaround
  315. 'make install' errors.
  316. * Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
  317. - Update to 0.23.4.
  318. - Update source url.
  319. * Mon Jun 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
  320. - Update to 0.23.3.
  321. - Remove reference to stream-engine in connections managers readme.
  322. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
  323. - Update to 0.23.2.
  324. - Add man pages.
  325. - Use enchant-devel, instead of aspell-devel.
  326. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
  327. - Rebuild for new e-d-s.
  328. * Sun May 4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
  329. - Drop multiple copies of COPYING file.
  330. - Drop BR on gnome-vfs2-devel.
  331. - Require telepathy-stream-engine for VOIP support.
  332. - Add BR on iso-codes-devel, so spell-checking is enabled.
  333. * Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
  334. - Update to new upstream release (0.23.1)
  335. - Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
  336. * Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
  337. - Update to new upstream release (0.22.1)
  338. * Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
  339. - Update to new upstream release (0.22.0)
  340. * Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
  341. - Update to new upstream release (0.21.91)
  342. * Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
  343. - Update to new upstream release (0.21.90)
  344. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
  345. - Autorebuild for GCC 4.3
  346. * Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
  347. - Update to new upstream release (0.21.4)
  348. * Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
  349. - Update to new upstream release (0.21.2)
  350. - Drop backported drag-and-drop patch (fixed upstream):
  351. - svn380-fix-contact-DnD.patch
  352. - Update README.ConnectionManagers: Include Haze package note, remove Galago
  353. note (a feed-only connection manager isn't useful for instant messaging),
  354. and fix some wording.
  355. * Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
  356. - Backport upstream patch to fixes crashes when using drag-and-drop of a
  357. contact from the buddy list to the current conversation window to initiate a
  358. conversation:
  359. + svn380-fix-contact-DnD.patch
  360. - Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
  361. dragged a contact ...)
  362. * Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
  363. - Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
  364. is essentially useless due to the need to install an external connection
  365. manager. Also, add a README.ConnectionManagers to the installed
  366. documentation which lists other possibilities.
  367. - Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
  368. and bug 334221 (Default empathy install is useless).
  369. * Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
  370. - Enable VoIP support for those brave enough to test/break/debug it (F9+
  371. only). Though it is functional, it is still deemed rather unstable by
  372. upstream. Use it at your own risk. :)
  373. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
  374. - Disable VoIP support at this time, since it is deemed unstable by upstream
  375. for now. (Thanks to Brian Pepple for the notice.)
  376. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
  377. - Update to new upstream release (0.14).
  378. * Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
  379. - Update to new upstream release (0.13), which adds a panel applet (Megaphone)
  380. and python bindings.
  381. - Split shared libraries into a libs subpackage for easier handling
  382. in multi-lib environments.
  383. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
  384. - Add ldconfig invocations to %%post and %%postun scriptlets.
  385. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
  386. - Update to new upstream release (0.12).
  387. - Build against new mission-control stack.
  388. - Update License tag (GPLv2+).
  389. - Alphabetize BuildRequires list (aesthetic-only change).
  390. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
  391. - Rebuild for selinux ppc32 issue.
  392. * Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
  393. - Update to new upstream release (0.11)
  394. * Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
  395. - bump to 0.8
  396. - Now with aspell support (deat to teh speeling mistaks)
  397. * Sat Jun 9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
  398. - bump to 0.7
  399. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
  400. - Add telepathy-filesystem to Requires
  401. - Move .desktop from autostart to applications
  402. - Nasty hackery to make empathy launch from the menu
  403. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
  404. - Add gettext to BuildRequires
  405. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
  406. - Bump to 0.6
  407. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
  408. - Let Empathy own the directory and not just the files in it
  409. * Wed May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
  410. - Initial package