expat-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name expat
  3. %define version 2.4.1
  4. %define release 1%{?_dist_release}
  5. Summary: Expat is an XML 1.0 parser written in C
  6. Summary(ja): C で書かれた XML 1.0 パーサ
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Group: accessories
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: MIT/X
  14. URL: https://libexpat.github.io/
  15. %global altver %(echo %{version} | tr '.' '_')
  16. Source: https://github.com/libexpat/libexpat/releases/download/R_%{altver}/%{name}-%{version}.tar.xz
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. Requires: lib%{name} = %{version}-%{release}
  19. BuildRequires: libtool
  20. %description
  21. This is Expat, a C library for parsing XML, written by James Clark.
  22. Expat is a stream-oriented XML parser. This means that you register
  23. handlers with the parser before starting the parse. These handlers
  24. are called when the parser discovers the associated structures in the
  25. document being parsed. A start tag is an example of the kind of
  26. structures for which you may register handlers.
  27. %package -n lib%{name}
  28. Summary: Runtime library of expat
  29. Summary(ja): Expat のための実行ライブラリ
  30. Group: system
  31. %description -n lib%{name}
  32. This package contains the runtime, shared library of expat, the C
  33. library for parsing XML.
  34. %description -n lib%{name} -l ja
  35. Expat を動作させるために必用となるライブラリです.
  36. %package devel
  37. Summary: Development environment for the expat XML parser
  38. Summary(ja): expat XML パーサ用開発環境
  39. Group: programming
  40. Requires: lib%{name} = %{version}-%{release}
  41. Requires: pkgconfig
  42. %description devel
  43. Development environment for the expat XML parser
  44. %description devel -l ja
  45. expat XML パーサ用開発環境です.
  46. ## to build compat32 for x86_64 architecture support
  47. %package -n compat32-lib%{name}
  48. Summary: Runtime library of expat
  49. Summary(ja): Expat のための実行ライブラリ
  50. Group: system,legacy
  51. Requires: lib%{name} = %{version}-%{release}
  52. %description -n compat32-lib%{name}
  53. This package contains the runtime, shared library of expat, the C
  54. library for parsing XML.
  55. %description -n compat32-lib%{name} -l ja
  56. Expat を動作させるために必用となるライブラリです.
  57. %package -n compat32-%{name}-devel
  58. Summary: Development environment for the expat XML parser
  59. Summary(ja): expat XML パーサ用開発環境
  60. Group: programming,legacy
  61. Requires: %{name}-devel = %{version}-%{release}
  62. Requires: compat32-lib%{name} = %{version}-%{release}
  63. %description -n compat32-%{name}-devel
  64. Development environment for the expat XML parser
  65. %description -n compat32-%{name}-devel -l ja
  66. expat XML パーサ用開発環境です.
  67. %debug_package
  68. %prep
  69. %setup -q
  70. %build
  71. export CFLAGS="$RPM_OPT_FLAGS -fPIC"
  72. %configure --enable-shared
  73. make %{?_smp_mflags}
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. rm -f examples/*.dsp
  77. chmod 644 AUTHORS README.md COPYING Changes doc/* examples/*
  78. make DESTDIR=$RPM_BUILD_ROOT install
  79. rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
  80. rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/expat
  81. mkdir -p %{buildroot}%{_mandir}/man1
  82. install -m644 doc/xmlwf.1 %{buildroot}%{_mandir}/man1/
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %files
  86. %defattr(-,root,root)
  87. %license COPYING
  88. %doc AUTHORS Changes README.md
  89. %{_bindir}/xmlwf
  90. %{_mandir}/man1/xmlwf.1*
  91. %files -n lib%{name}
  92. %defattr(-,root,root)
  93. %license COPYING
  94. %doc AUTHORS Changes README.md
  95. %{_libdir}/libexpat.so.*
  96. %files devel
  97. %defattr(-,root,root)
  98. %license COPYING
  99. %doc AUTHORS Changes README.md
  100. %doc doc/* examples
  101. %{_includedir}/*
  102. %{_libdir}/libexpat.a
  103. %{_libdir}/libexpat.so
  104. %{_libdir}/pkgconfig/%{name}.pc
  105. %dir %{_libdir}/cmake
  106. %{_libdir}/cmake/expat-%{version}
  107. ## to build compat32 for x86_64 architecture support
  108. %if %{build_compat32}
  109. %files -n compat32-lib%{name}
  110. %defattr(-,root,root)
  111. %{_libdir}/libexpat.so.*
  112. %files -n compat32-%{name}-devel
  113. %defattr(-,root,root)
  114. %{_libdir}/libexpat.a
  115. %{_libdir}/libexpat.so
  116. %endif
  117. %changelog
  118. * Fri Jul 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
  119. - new upstream release.
  120. - dropped ldconfig scriptlets.
  121. * Wed Feb 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.10-1
  122. - new upstream release.
  123. * Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
  124. - new upstream release.
  125. * Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-1
  126. - new upstream release.
  127. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
  128. - new upstream release.
  129. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
  130. - new upstream release.
  131. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-2
  132. - rebuild with VineSeed environment
  133. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
  134. - update to 2.1.0
  135. - remove old patches
  136. * Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
  137. - update patch100 to regrassion fix (same as debian bug #561658)
  138. - add Vendor and Distribution tags
  139. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
  140. - rebuilt with rpm-4.8.1-3
  141. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
  142. - rebuilt with gcc-4.4.3-3 on ppc
  143. * Mon Feb 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
  144. - rebuilt with new toolchains (for VineSeed)
  145. * Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
  146. - add patch110 for fix CVE-2009-3720 (xml parser)
  147. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
  148. - add Patch100 for fix CVE-2009-3560 (xml parser)
  149. * Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
  150. - added Requires: tag to compat32-* sub-packages.
  151. - removed unnecessary %%configure CC='gcc -m32' option
  152. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
  153. - applied new versioning policy and spec in utf-8
  154. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
  155. - removed %%if !%%{build_compat32} case condition
  156. * Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
  157. - new upstream release
  158. - drop Patch0
  159. - drop .la
  160. - chmod 644 the documentation
  161. - strip DSP files from examples
  162. - update description and drop description-ja
  163. - add -fPIC
  164. * Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
  165. - rebuilt
  166. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
  167. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  168. * Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
  169. - added compat32* packages for x86_64 architecture support
  170. * Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
  171. - add missing header file (expat_external.h) to %%files.
  172. * Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
  173. - updated/revised Patch1 (%%install will fail without this patch)
  174. * Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
  175. - new upstream release
  176. -- dropped patch1
  177. * Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
  178. - updated to 1.95.7
  179. - changed URL and Group
  180. - fixed License to MIT/X (based on rpm package at sourceforge)
  181. * Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
  182. - version up to 1.95.6
  183. - drop expat-xmlwf-dynamiclink.patch (Patch0)
  184. - add expat-1.95.6-mandir.patch for installing manpage (Patch0)
  185. - add manpage (xmlwf.1)
  186. * Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
  187. - fixed license ( s/MPL or GPL/distributable/ )
  188. - use License tag
  189. * Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
  190. - new sub-package libexpat.
  191. - added BuildPreReq: libtool
  192. * Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
  193. - updated to 1.95.2 release
  194. * Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  195. - 1.95.1-3vl1
  196. - based on 1.95.1-3mdk from Mandrake 8.0
  197. - added Japanese summary and description
  198. - modified spec macros for Vine
  199. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
  200. - real version is 1.95.1
  201. - reenable optimisations
  202. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
  203. - release .
  204. * Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
  205. - Don't try to use optimizations
  206. - Bzip2 sources
  207. * Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
  208. - first version