fcitx-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257
  1. Summary: an input method framework with extension support
  2. Name: fcitx
  3. Version: 4.2.9.8
  4. Release: 1%{?_dist_release}
  5. Group: localization
  6. Distribution: Vine Linux
  7. Vendor: Project Vine
  8. Packager: iwaim
  9. License: GPLv2+
  10. URL: https://fcitx-im.org/
  11. Source0: https://download.fcitx-im.org/fcitx/%{name}-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  13. BuildRequires: cmake
  14. BuildRequires: wget
  15. BuildRequires: libX11-devel
  16. BuildRequires: dbus-glib-devel
  17. BuildRequires: xorg-x11-proto-devel
  18. BuildRequires: xorg-x11-xtrans-devel
  19. BuildRequires: libxkbcommon-devel
  20. BuildRequires: pango-devel
  21. BuildRequires: cairo-devel
  22. BuildRequires: dbus-devel
  23. BuildRequires: libicu-devel
  24. BuildRequires: iso-codes
  25. BuildRequires: libxml2-devel
  26. BuildRequires: gtk2-devel
  27. BuildRequires: gtk3-devel
  28. BuildRequires: qt4-devel
  29. BuildRequires: enchant2-devel
  30. BuildRequires: lua-devel
  31. BuildRequires: gobject-introspection-devel
  32. BuildRequires: json-c-devel
  33. BuildRequires: extra-cmake-modules
  34. BuildRequires: libxkbfile-devel
  35. BuildRequires: xkeyboard-config
  36. Requires: %{name}-libs = %{version}-%{release}
  37. Requires: %{name}-data = %{version}-%{release}
  38. %description
  39. Fcitx [ˈfaɪtɪks] is an input method framework with extension support.
  40. Currently it supports Linux and Unix systems like freebsd.
  41. It has three built-in Input Method Engine, Pinyin, QuWei and Table-based
  42. input methods.
  43. %package data
  44. Summary: Data files for Fcitx
  45. Group: localization
  46. Requires: hicolor-icon-theme
  47. Requires: dbus
  48. %description data
  49. This package provides shared datas for Fxitx.
  50. %package libs
  51. Summary: Shared libraries for Fcitx
  52. Group: localization
  53. %description libs
  54. This package provides shared libraries for Fcitx.
  55. %package devel
  56. Summary: Development files for Fcitx
  57. Group: programming
  58. Requires: %{name} = %{version}-%{release}
  59. %description devel
  60. This package contains libraries and header files necessary for
  61. developing programs using Fcitx libraries.
  62. %package gtk2
  63. Summary: Fcitx IM module for GTK2
  64. Group: system
  65. Requires: %{name} = %{version}-%{release}
  66. %description gtk2
  67. This package contains Fcitx IM module for GTK2.
  68. %package gtk3
  69. Summary: Fcitx IM module for GTK3
  70. Group: localization
  71. Requires: %{name} = %{version}-%{release}
  72. %description gtk3
  73. This package contains Fcitx IM module for GTK3.
  74. %package qt4
  75. Summary: Fcitx IM module for Qt4
  76. Group: localization
  77. Requires: %{name} = %{version}-%{release}
  78. %description qt4
  79. This package contains Fcitx IM module for Qt4.
  80. %prep
  81. %setup -q
  82. %build
  83. %__mkdir build
  84. pushd build
  85. cmake .. \
  86. -DCMAKE_VERBOSE_MAKEFILE=ON \
  87. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  88. -DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \
  89. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
  90. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  91. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  92. -DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
  93. -DENABLE_GTK3_IM_MODULE=On \
  94. -DENABLE_QT_IM_MODULE=On \
  95. -DENABLE_OPENCC=Off \
  96. -DENABLE_LUA=On \
  97. -DENABLE_GIR=On \
  98. -DENABLE_XDGAUTOSTART=Off \
  99. -DENABLE_PRESAGE=Off
  100. make %{?_smp_mflags}
  101. popd
  102. %install
  103. %__rm -rf $RPM_BUILD_ROOT
  104. pushd build
  105. make install INSTALL="install -p" DESTDIR=$RPM_BUILD_ROOT
  106. rm -f %{buildroot}%{_libdir}/*.la
  107. popd
  108. %{find_lang} %{name}
  109. %clean
  110. %__rm -rf $RPM_BUILD_ROOT
  111. %post
  112. update-desktop-database %{_datadir}/applications &>/dev/null || :
  113. %postun
  114. update-desktop-database %{_datadir}/applications &>/dev/null || :
  115. %post libs -p /sbin/ldconfig
  116. %postun libs -p /sbin/ldconfig
  117. %post data
  118. /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  119. %postun data
  120. if [ $1 -eq 0 ] ; then
  121. /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  122. /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  123. fi
  124. %posttrans data
  125. /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  126. %post gtk2
  127. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules || :
  128. %postun gtk2
  129. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules || :
  130. %post gtk3
  131. %{_bindir}/gtk-query-immodules-3.0 --update-cache || :
  132. %postun gtk3
  133. %{_bindir}/gtk-query-immodules-3.0 --update-cache || :
  134. %files -f %{name}.lang
  135. %defattr(-,root,root,-)
  136. %license COPYING*
  137. %doc README
  138. %{_bindir}/fcitx*
  139. %exclude %{_bindir}/fcitx4-config
  140. %{_bindir}/createPYMB
  141. %{_bindir}/mb2org
  142. %{_bindir}/mb2txt
  143. %{_bindir}/readPYBase
  144. %{_bindir}/readPYMB
  145. %{_bindir}/scel2org
  146. %{_bindir}/txt2mb
  147. %{_datadir}/applications/fcitx-configtool.desktop
  148. %{_datadir}/applications/fcitx-skin-installer.desktop
  149. %{_datadir}/applications/fcitx.desktop
  150. %{_datadir}/doc/fcitx
  151. %{_mandir}/man1/*.1*
  152. %{_datadir}/mime/packages/x-fskin.xml
  153. %files devel
  154. %defattr(-,root,root,-)
  155. %{_bindir}/fcitx4-config
  156. %{_libdir}/libfcitx*.so
  157. %{_libdir}/pkgconfig/fcitx-config.pc
  158. %{_libdir}/pkgconfig/fcitx-gclient.pc
  159. %{_libdir}/pkgconfig/fcitx-qt.pc
  160. %{_libdir}/pkgconfig/fcitx-utils.pc
  161. %{_libdir}/pkgconfig/fcitx.pc
  162. %{_includedir}/fcitx*
  163. %{_datadir}/cmake/fcitx
  164. %{_datadir}/gir-1.0/Fcitx-1.0.gir
  165. %files libs
  166. %defattr(-,root,root,-)
  167. %{_libdir}/fcitx
  168. %{_libdir}/libfcitx*.so.*
  169. %{_libdir}/girepository-1.0/Fcitx-1.0.typelib
  170. %files data
  171. %defattr(-,root,root,-)
  172. %{_datadir}/icons/hicolor/*/*/*.png
  173. %{_datadir}/icons/hicolor/scalable/apps/fcitx.svg
  174. %{_datadir}/icons/hicolor/scalable/apps/fcitx-*.svg
  175. %{_datadir}/fcitx
  176. %{_datadir}/dbus-1/services/org.fcitx.Fcitx.service
  177. %files gtk2
  178. %defattr(-,root,root,-)
  179. %{_libdir}/gtk-2.0/*/immodules/im-fcitx.so
  180. %files gtk3
  181. %defattr(-,root,root,-)
  182. %{_libdir}/gtk-3.0/*/immodules/im-fcitx.so
  183. %files qt4
  184. %defattr(-,root,root,-)
  185. %{_libdir}/qt4/plugins/inputmethods/qtim-fcitx.so
  186. %changelog
  187. * Fri Aug 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.9.8-1
  188. - new upstream release.
  189. * Wed Dec 20 2017 Toshiaki Ara <ara_t@384.jp> 4.2.9.4-1
  190. - update to 4.2.9.4
  191. - add BR: extra-cmake-modules
  192. - add BR: libxkbfile-devel
  193. - add BR: xkeyboard-config
  194. * Sun Jul 3 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.9.1-1
  195. - new upstream release.
  196. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.8.6-3
  197. - rebuilt with new toolchain.
  198. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.8.6-2
  199. - rebuild with icu-56.1
  200. * Tue Apr 28 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 4.2.8.6-1
  201. - update to 4.2.8.6
  202. * Mon Nov 24 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 4.2.8.5-1
  203. - update to 4.2.8.5
  204. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.8.4-2
  205. - rebuild with icu-54.1
  206. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.8.3-2
  207. - rebuild with icu-52.1
  208. - move pkgconfig files to %%{name}-devel
  209. * Tue Nov 5 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 4.2.8.3-1
  210. - initial release