gdk-pixbuf2-vl.spec 9.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. # biarch support
  4. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  5. %define _query_suffix %{nil}
  6. %if %{build_compat32}
  7. %define _query_suffix -32
  8. %endif
  9. Name: gdk-pixbuf2
  10. Summary: An image loading library
  11. Version: 2.42.6
  12. Release: 1%{?_dist_release}
  13. Group: system
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: LGPLv2+
  17. URL: http://www.gtk.org
  18. %global shortver %(echo %{version} | cut -d . -f 1,2)
  19. Source: https://download.gnome.org/sources/gdk-pixbuf/%{shortver}/gdk-pixbuf-%{version}.tar.xz
  20. BuildRequires: meson
  21. BuildRequires: glib2-devel >= 2.36.0
  22. BuildRequires: libpng-devel
  23. BuildRequires: libjpeg-turbo-devel
  24. BuildRequires: libtiff-devel
  25. BuildRequires: gobject-introspection-devel
  26. BuildConflicts: jasper-devel
  27. # gdk-pixbuf does a configure time check which uses the GIO mime
  28. # layer; we need to actually have the mime type database.
  29. BuildRequires: shared-mime-info
  30. BuildRequires: gtk-doc
  31. ## BuildRequires: libtool >= 2.2.10
  32. BuildRequires: libtool
  33. BuildRequires: gettext
  34. # We also need MIME information at runtime
  35. Requires: shared-mime-info
  36. # gdk-pixbuf was included in gtk2 until 2.21.2
  37. Conflicts: gtk2 <= 2.21.2
  38. # https://bugzilla.gnome.org/show_bug.cgi?id=624712
  39. Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
  40. %description
  41. gdk-pixbuf is an image loading library that can be extended by loadable
  42. modules for new image formats. It is used by toolkits such as GTK+ or
  43. clutter.
  44. %package devel
  45. Summary: Development files for gdk-pixbuf
  46. Group: programming
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: glib2-devel
  49. Requires: gobject-introspection-devel
  50. Requires: libpng-devel
  51. # gdk-pixbuf was included in gtk2 until 2.21.2
  52. Conflicts: gtk2-devel <= 2.21.2
  53. %description devel
  54. This package contains the libraries and header files that are needed
  55. for writing applications that are using gdk-pixbuf.
  56. %if %{build_compat32}
  57. #######################################################################
  58. # compat32
  59. %package -n compat32-%{name}
  60. Summary: An image loading library
  61. Group: system,legacy
  62. Requires(post): compat32-glib2
  63. # gdk-pixbuf was included in gtk2 until 2.21.2
  64. Conflicts: compat32-gtk2 <= 2.21.2
  65. %description -n compat32-%{name}
  66. gdk-pixbuf is an image loading library that can be extended by loadable
  67. modules for new image formats. It is used by toolkits such as GTK+ or
  68. clutter.
  69. %package -n compat32-%{name}-devel
  70. Summary: Development files for gdk-pixbuf
  71. Group: programming,legacy
  72. Requires: compat32-%{name} = %{version}-%{release}
  73. Requires: %{name} = %{version}-%{release}
  74. Requires: compat32-libpng-devel
  75. # gdk-pixbuf was included in gtk2 until 2.21.2
  76. Conflicts: compat32-gtk2-devel <= 2.21.2
  77. %description -n compat32-%{name}-devel
  78. This package contains the libraries and header files that are needed
  79. for writing applications that are using gdk-pixbuf.
  80. %endif
  81. %debug_package
  82. %prep
  83. %setup -q -n gdk-pixbuf-%{version}
  84. ## %patch0 -p1 -b .libpng-linking
  85. %build
  86. %meson \
  87. -Dbuiltin_loaders=png \
  88. -Dinstalled_tests=false \
  89. -Dgtk_doc=false
  90. %meson_build
  91. %install
  92. %meson_install
  93. touch %{buildroot}%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  94. %if %{build_compat32}
  95. cp %{buildroot}%{_bindir}/gdk-pixbuf-query-loaders \
  96. %{buildroot}%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
  97. %endif
  98. %find_lang gdk-pixbuf
  99. %transfiletriggerin -- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  100. gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
  101. %transfiletriggerpostun -- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  102. gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
  103. %if %{build_compat32}
  104. %transfiletriggerin -n compat32-%{name} -- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  105. gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
  106. %transfiletriggerpostun -n compat32-%{name} -- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  107. gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
  108. %endif
  109. %files -f gdk-pixbuf.lang
  110. %defattr(-,root,root,-)
  111. %license COPYING
  112. %doc NEWS README.md
  113. %{_bindir}/gdk-pixbuf-pixdata
  114. %{_bindir}/gdk-pixbuf-thumbnailer
  115. %{_libdir}/libgdk_pixbuf-2.0.so.*
  116. %{_libdir}/girepository-1.0
  117. %dir %{_libdir}/gdk-pixbuf-2.0
  118. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
  119. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  120. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
  121. %ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  122. %{_bindir}/gdk-pixbuf-query-loaders
  123. %{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
  124. %{_datadir}/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer
  125. %files devel
  126. %defattr(-,root,root,-)
  127. %{_includedir}/gdk-pixbuf-2.0
  128. %{_libdir}/libgdk_pixbuf-2.0.so
  129. %{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
  130. %{_bindir}/gdk-pixbuf-csource
  131. #{_datadir}/gtk-doc/html/*
  132. %{_datadir}/gir-1.0
  133. %{_mandir}/man1/gdk-pixbuf-csource.1.gz
  134. %if %{build_compat32}
  135. %files -n compat32-%{name}
  136. %defattr(-,root,root,-)
  137. %{_libdir}/libgdk_pixbuf-2.0.so.*
  138. %dir %{_libdir}/gdk-pixbuf-2.0
  139. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
  140. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  141. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
  142. %ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  143. %{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
  144. %files -n compat32-%{name}-devel
  145. %defattr(-,root,root,-)
  146. %{_libdir}/libgdk_pixbuf-2.0.so
  147. %endif
  148. %changelog
  149. * Sun Apr 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.42.6-1
  150. - new upstream release.
  151. * Sat Apr 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.42.4-1
  152. - new upstream release.
  153. - dropped ldconfig scriptlets.
  154. * Mon Mar 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.42.2-1
  155. - new upstream release.
  156. - updated %%post{,un} and trigger scripts.
  157. * Sat May 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.0-1
  158. - new upstream release.
  159. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.36.11-1
  160. - new upstream release.
  161. - disabled JPEG2000: jasper is too buggy and not fully implemented.
  162. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
  163. - new upstream release
  164. * Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
  165. - new upstream release
  166. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  167. - new upstream release
  168. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  169. - new upstream release
  170. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.6-1
  171. - new upstream release
  172. * Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.4-1
  173. - new upstream release
  174. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.3-1
  175. - new upstream release
  176. * Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.2-1
  177. - new upstream release
  178. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.1-1
  179. - new upstream release
  180. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.8-2
  181. - rebuild with libpng-1.6.12
  182. * Fri Jun 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.8-1
  183. - new upstream release
  184. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.7-1
  185. - new upstream release
  186. * Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
  187. - new upstream release
  188. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
  189. - new upstream release
  190. * Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  191. - new upstream release
  192. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  193. - new upstream release
  194. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  195. - new upstream release
  196. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  197. - new upstream release
  198. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
  199. - new upstream release
  200. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.5-1
  201. - new upstream release
  202. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.4-1
  203. - new upstream release
  204. * Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.2-1
  205. - new upstream release
  206. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
  207. - new upstream release
  208. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
  209. - new upstream release
  210. - add configure option (--with-x11)
  211. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
  212. - new upstream release
  213. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.23.5-1
  214. - new upstream release
  215. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
  216. - new upstream release
  217. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
  218. - new upstream release
  219. - add configure option (--enable-introspection=yes)
  220. - drop Patch0
  221. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
  222. - initial build for Vine Linux
  223. * Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
  224. - Require libpng for linking
  225. * Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
  226. - Rebuild with new gobject-introspection
  227. * Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
  228. - Update to 2.21.6
  229. * Fri Jul 2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
  230. - Also Require shared-mime-info for same reason
  231. * Fri Jul 2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
  232. - BR shared-mime-info; see comment above it
  233. * Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
  234. - Changes to support snapshot builds
  235. * Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
  236. - Update to 2.21.5
  237. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
  238. - Rename to gdk-pixbuf2 to avoid conflict with the
  239. existing gdk-pixbuf package
  240. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
  241. - Update to 2.21.4
  242. - Incorporate package review feedback
  243. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
  244. - Initial packaging