gitflow-vl.spec 2.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091
  1. %global githash 53e9c76
  2. %global gitdate 20120723
  3. %global checkout %{gitdate}git%{githash}
  4. %define ver 4.2.0
  5. %define rel 1.pre%{checkout}
  6. Name: gitflow
  7. Version: %{ver}
  8. Release: %{rel}%{?_dist_release}
  9. Summary: Extensions providing operations for V. Driessen's branching model
  10. Group: Development/Tools
  11. License: BSD
  12. URL: https://github.com/nvie/gitflow
  13. # You can get this tarball by cloning the repository from github and checking
  14. # out revision %%{githash}
  15. Source0: gitflow-0.4.2.%{checkout}.tar.gz
  16. # There is no upstream ticket for this patch, but instead just hardcodes the
  17. # directory we're installing to for Fedora.
  18. Patch0: gitflow-Appropriate-GITFLOW_DIR.patch
  19. BuildArch: noarch
  20. Requires: shflags
  21. Requires: git
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: iwaim
  25. %description
  26. A collection of Git extensions to provide high-level repository operations
  27. for Vincent Driessen's [branching model](http://nvie.com/git-model "original
  28. blog post").
  29. For the best introduction to get started with `git flow`, please read Jeff
  30. Kreeftmeijer's blog post:
  31. http://jeffkreeftmeijer.com/2010/why-arent-you-using-git-flow/
  32. Or have a look at one of these screen casts:
  33. * [A short introduction to git-flow]
  34. (http://vimeo.com/16018419) (by Mark Derricutt)
  35. * [On the path with git-flow]
  36. (http://codesherpas.com/screencasts/on_the_path_gitflow.mov) (by Dave Bock)
  37. %prep
  38. %setup -q -n %{name}
  39. %patch0 -p1 -b .gitflowdir
  40. %build
  41. # This section is empty because this package ccontains shell scripts
  42. # to be sourced: there's nothing to build
  43. %install
  44. mkdir -p %{buildroot}/%{_bindir}
  45. install -v -m 0755 git-flow %{buildroot}/%{_bindir}
  46. mkdir -p %{buildroot}/%{_datadir}/%{name}
  47. install -v -m 0644 git-flow-init %{buildroot}/%{_datadir}/%{name}
  48. install -v -m 0644 git-flow-feature %{buildroot}/%{_datadir}/%{name}
  49. install -v -m 0644 git-flow-hotfix %{buildroot}/%{_datadir}/%{name}
  50. install -v -m 0644 git-flow-release %{buildroot}/%{_datadir}/%{name}
  51. install -v -m 0644 git-flow-support %{buildroot}/%{_datadir}/%{name}
  52. install -v -m 0644 git-flow-version %{buildroot}/%{_datadir}/%{name}
  53. install -v -m 0644 gitflow-common %{buildroot}/%{_datadir}/%{name}
  54. ln -s %{_datadir}/shflags/shflags %{buildroot}/%{_datadir}/%{name}/gitflow-shFlags
  55. %files
  56. %doc README.mdown LICENSE AUTHORS Changes.mdown
  57. %{_bindir}/git-flow*
  58. %{_datadir}/%{name}
  59. %changelog
  60. * Fri Jan 18 2013 IWAI, Masaharu <iwai@alib.jp> 4.2.0-1.pre20120723git53e9c76
  61. - initial build for Vine Linux
  62. * Mon Jul 23 2012 Ralph Bean <rbean@redhat.com> - 0.4.2.20120723git53e9c76-1
  63. - New checkout from upstream git for review process.
  64. * Mon Jul 23 2012 Ralph Bean <rbean@redhat.com> - 0.4.2.20120626gitab7fda2-2
  65. - Changed License field to BSD
  66. - Dropped requirement on util-linux.
  67. - Added comments for Source0 and Patch0
  68. - Using macro for %%{gitdate} as well as %%{githash}
  69. * Tue Jun 26 2012 Ralph Bean <rbean@redhat.com> - 0.4.2.20120626gitab7fda2-1
  70. - Initial packaging for Fedora.