gmime-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302
  1. %define apiver 3.0
  2. %define docver 3.2
  3. %define _unpackaged_files_terminate_build 1
  4. Summary: Library for creating and parsing MIME messages
  5. Summary(ja): MIMEメッセージを生成またパースするためのライブラリ
  6. Name: gmime
  7. Version: 3.2.7
  8. Release: 1%{?_dist_release}
  9. Group: System Environment/Libraries
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: GPL
  13. URL: https://github.com/jstedfast/gmime
  14. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  15. Source0: https://download.gnome.org/sources/gmime/%{shortver}/%{name}-%{version}.tar.xz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: glib2-devel >= 2.26.0
  18. BuildRequires: gpgme-devel
  19. BuildRequires: zlib-devel >= 1.2.1.1
  20. BuildRequires: automake, libtool, gettext, gtk-doc
  21. # Mono only availible on these:
  22. %define mono_archs none
  23. # no mono on s390 for now: s390 s390x
  24. %ifarch %mono_archs
  25. BuildRequires: mono-devel gtk-sharp2-gapi
  26. BuildRequires: gtk-sharp2 >= 2.8.0
  27. %define monodir %{_prefix}/lib/mono
  28. %endif
  29. %description
  30. The GMime suite provides a core library and set of utilities which may be
  31. used for the creation and parsing of messages using the Multipurpose
  32. Internet Mail Extension (MIME).
  33. %package devel
  34. Summary: Header files to develop libgmime applications
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. Requires: glib2-devel
  38. %description devel
  39. The GMime suite provides a core library and set of utilities which may be
  40. used for the creation and parsing of messages using the Multipurpose
  41. Internet Mail Extension (MIME). The devel-package contains header files
  42. to develop applications that use libgmime.
  43. %ifarch %mono_archs
  44. %package sharp
  45. Summary: mono bindings for gmime
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: gtk-sharp2
  49. %description sharp
  50. The GMime suite provides a core library and set of utilities which may be
  51. used for the creation and parsing of messages using the Multipurpose
  52. Internet Mail Extension (MIME). The devel-package contains support
  53. for developing mono applications that use libgmime.
  54. %endif
  55. %prep
  56. %setup -q
  57. %build
  58. cp %{_datadir}/gettext/config.rpath .
  59. ## autoreconf --force --install
  60. %ifarch %mono_archs
  61. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  62. MONO_ARGS="--enable-mono"
  63. %endif
  64. %configure $MONO_ARGS
  65. make %{?_smp_mflags}
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  69. make install DESTDIR=$RPM_BUILD_ROOT
  70. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  71. # Don't conflict with sharutils:
  72. #mv $RPM_BUILD_ROOT%{_bindir}/uuencode $RPM_BUILD_ROOT%{_bindir}/gmime-uuencode
  73. #mv $RPM_BUILD_ROOT%{_bindir}/uudecode $RPM_BUILD_ROOT%{_bindir}/gmime-uudecode
  74. %clean
  75. rm -rf $RPM_BUILD_ROOT
  76. %post -p /sbin/ldconfig
  77. %postun -p /sbin/ldconfig
  78. %files
  79. %defattr(-,root,root,-)
  80. %license COPYING
  81. %doc AUTHORS README.md TODO
  82. #%{_bindir}/gmime-uu??code
  83. %{_libdir}/lib*.so.*
  84. %files devel
  85. %defattr(-,root,root,-)
  86. %{_libdir}/lib*.a
  87. %{_libdir}/lib*.so
  88. %{_libdir}/pkgconfig/gmime-%{apiver}.pc
  89. %{_includedir}/gmime-%{apiver}
  90. %{_datadir}/gtk-doc/html/gmime-%{docver}
  91. %ifarch %mono_archs
  92. %files sharp
  93. %defattr(-,root,root,-)
  94. %{_libdir}/pkgconfig/gmime-sharp-%{apiver}.pc
  95. %{monodir}/gac/gmime-sharp
  96. %{monodir}/gmime-sharp-%{apiver}
  97. %{_datadir}/gapi-2.0/gmime-api.xml
  98. %endif
  99. %changelog
  100. * Fri May 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.7-1
  101. - new upstream release.
  102. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.3-1
  103. - new upstream release.
  104. - disabled to build mono stuff.
  105. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.20-1
  106. - new upstream release
  107. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.19-2
  108. - rebuild with VineSeed environment
  109. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.19-1
  110. - new upstream release
  111. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.17-1
  112. - new upstream release
  113. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.16-1
  114. - new upstream release
  115. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.15-1
  116. - new upstream release
  117. * Thu Jan 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.13-1
  118. - new upstream release
  119. * Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.12-1
  120. - new upstream release
  121. * Fri Oct 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.11-1
  122. - new upstream release
  123. * Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.10-1
  124. - new upstream release
  125. * Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-1
  126. - new upstream release
  127. * Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.7-1
  128. - new upstream release
  129. - remove Patch4
  130. * Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  131. - new upstream release
  132. * Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
  133. - new upstream release
  134. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
  135. - new upstream release
  136. - add BuildRequires: gpgme-devel
  137. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.25-1
  138. - new upstream release
  139. * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.24-1
  140. - new upstream release
  141. * Wed Jan 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.22-1
  142. - new upstream release
  143. * Tue Dec 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.21-1
  144. - new upstream release
  145. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.20-1
  146. - new upstream release
  147. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.19-1
  148. - new upstream release
  149. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.17-2
  150. - rebuild with rpm-4.8.1 for pkg-config file
  151. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.17-1
  152. - new upstream release
  153. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.15-1
  154. - new upstream release
  155. - fix files for gmime-2.4
  156. - drop Patch1, Patch2, Patch3
  157. * Thu Sep 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.23-1vl5
  158. - new upstream release
  159. - rebuilt with mono-2.0
  160. - added gmime-2.2.23-gacutil.patch
  161. * Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.9-1vl5
  162. - applied new versioning policy, spec in utf-8
  163. - updated gmime to 2.2.9
  164. - dropt gmime-2.2.3-libdir.patch
  165. - dropt gmime-2.2.3-automake.patch
  166. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  167. - initial build for Vine Linux
  168. * Tue Feb 6 2007 Alexander Larsson <alexl@redhat.com> - 2.2.3-5
  169. - Fix build with new automake (#224157)
  170. * Thu Oct 12 2006 Alexander Larsson <alexl@redhat.com> - 2.2.3-4
  171. - Bump glib requirement to 2.6 (#209565)
  172. * Tue Sep 5 2006 Alexander Larsson <alexl@redhat.com> - 2.2.3-3
  173. - fix gmime-config multilib conflict (#205208)
  174. * Sat Aug 19 2006 Matthias Clasen <mclasen@redhat.com> - 2.2.3-2
  175. - Rebuild
  176. * Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 2.2.3-1
  177. - Upgrade to 2.2.3
  178. - Use the new mono libdir
  179. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
  180. - rebuild
  181. * Fri Jun 9 2006 Alexander Larsson <alexl@redhat.com> - 2.2.1-2
  182. - Disable mono parts on s390* as mono doesn't build on s390 atm
  183. * Tue May 23 2006 Alexander Larsson <alexl@redhat.com> - 2.2.1-1
  184. - Update to 2.2.1
  185. - Fix multilib -devel conflict by using pkg-config in gmime-config (#192675)
  186. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.1.19-4
  187. - BuildRequires: gtk-sharp2 on mono archs only
  188. * Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 2.1.19-3
  189. - Rebuild
  190. * Tue Feb 7 2006 Jesse Keating <jkeating@redhat.com> - 2.1.19-2.1
  191. - rebuilt for new gcc4.1 snapshot and glibc changes
  192. * Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 2.1.19-2
  193. - Rebuild
  194. * Sun Jan 22 2006 Alexander Larsson <alexl@redhat.com> - 2.1.19-1
  195. - Update to 2.1.19 (needed by beagle 0.2.0)
  196. * Thu Jan 19 2006 Alexander Larsson <alexl@redhat.com> 2.1.17-3
  197. - Build on s390x
  198. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> 2.1.17-2
  199. - build gmime-sharp conditionally on mono arches
  200. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 2.1.17-1
  201. - Move from Extras to Core, Update to 2.1.17, add gmime-sharp subpackage
  202. * Wed Aug 10 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.1.15-1
  203. - Update to 2.1.15
  204. - Use dist
  205. * Wed May 18 2005 Colin Charles <colin@fedoraproject.org> - 2.1.9-5
  206. - bump release, request build on ppc
  207. * Thu Mar 31 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.1.9-4
  208. - add dep glib2-devel for pkgconfig in -devel package
  209. * Mon Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.9-0.fdr.3
  210. - Remove ldconfig from Requires pre and post
  211. * Mon Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.9-0.fdr.2
  212. - BR zlib-devel
  213. - Don't ship empty news file
  214. - Fixes to the files section
  215. - Change ldconfig in post* calls to -p /sbin/ldconfig
  216. * Sun Oct 17 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.9-0.fdr.1
  217. - Initial RPM release.