gnash-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. # ghelp/omf/scrollkeeper support
  3. # not working as of version 0.8.7
  4. %define scrollkeeper 0
  5. # kde and klash support
  6. %define kde_support 0
  7. Name: gnash
  8. Version: 0.8.10
  9. Release: 4%{?_dist_release}
  10. Summary: GNU flash movie player
  11. Group: Applications/Multimedia
  12. License: GPLv3+
  13. URL: http://www.gnu.org/software/gnash/
  14. Source0: http://ftp.gnu.org/gnu/gnash/%{version}/%{name}-%{version}.tar.bz2
  15. Patch0: %{name}-%{version}-add-unistd-header.patch
  16. Patch1: %{name}-%{version}-integer-overflow.patch
  17. Patch2: %{name}-%{version}-libboost-1.50.0.patch
  18. # register KComponentData properly in KDE 4 KPart
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: libxml2-devel libpng-devel libjpeg-devel libogg-devel
  21. BuildRequires: libboost-devel curl-devel freetype-devel fontconfig-devel
  22. BuildRequires: libboost-date-time libboost-serialization libboost-thread
  23. BuildRequires: SDL-devel
  24. BuildRequires: agg-devel
  25. BuildRequires: python-devel
  26. BuildRequires: libXv-devel
  27. %if %{kde_support}
  28. #BuildRequires: kde-filesystem
  29. BuildRequires: kdelibs-devel
  30. %endif
  31. BuildRequires: gtkglext-devel
  32. BuildRequires: docbook2X
  33. #BuildRequires: %{_bindir}/docbook2pdf
  34. BuildRequires: gstreamer-devel >= 0.10%
  35. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  36. %if %{scrollkeeper}
  37. BuildRequires: scrollkeeper
  38. %endif
  39. BuildRequires: giflib-devel
  40. BuildRequires: gettext
  41. BuildRequires: desktop-file-utils
  42. BuildRequires: speex-devel
  43. BuildRequires: gstreamer-plugins-base-devel
  44. BuildRequires: pygtk2-devel
  45. BuildRequires: libtool-ltdl-devel
  46. BuildRequires: dejagnu
  47. BuildRequires: GConf2-devel
  48. BuildRequires: xulrunner-devel
  49. BuildRequires: autoconf automake libtool
  50. BuildRequires: libboost-devel
  51. BuildRequires: libboost-program-options
  52. BuildRequires: libboost-iostreams
  53. BuildRequires: mesa-libGLU-devel
  54. BuildRequires: libXmu-devel
  55. %if %{scrollkeeper}
  56. Requires(post): scrollkeeper
  57. Requires(postun): scrollkeeper
  58. %endif
  59. Requires(post): /sbin/ldconfig
  60. Requires(postun): /sbin/ldconfig
  61. Requires(post): /sbin/install-info
  62. Requires(preun): /sbin/install-info
  63. %description
  64. Gnash is capable of reading up to SWF v9 files and opcodes, but primarily
  65. supports SWF v7, with better SWF v8 and v9 support under heavy development.
  66. Gnash includes initial parser support for SWF v8 and v9. Not all
  67. ActionScript 2 classes are implemented yet, but all of the most heavily
  68. used ones are. Many ActionScript 2 classes are partially implemented;
  69. there is support for all of the commonly used methods of each
  70. class.
  71. %package plugin
  72. Summary: Web-client flash movie player plugin
  73. Requires: %{name} = %{version}-%{release}
  74. # this doesn't prevent wrong dependencies, in case a package
  75. # provides %%{_libdir}/mozilla/plugins (like kdebase for konqueror)
  76. # and another unrelated webbrowser is installed, like w3m-el.
  77. # Moreover konqueror could provide webclient some day
  78. #Requires: %{_libdir}/mozilla/plugins webclient
  79. Requires: webclient
  80. Group: Applications/Internet
  81. %description plugin
  82. The gnash flash movie player plugin for firefox or mozilla.
  83. %if %{kde_support}
  84. %package klash
  85. Summary: Konqueror flash movie player plugin
  86. Requires: %{name} = %{version}-%{release}
  87. Group: Applications/Multimedia
  88. %description klash
  89. The gnash flash movie player plugin for Konqueror.
  90. %endif
  91. %package cygnal
  92. Summary: Streaming media server
  93. Requires: %{name} = %{version}-%{release}
  94. Group: Applications/Multimedia
  95. %description cygnal
  96. Cygnal is a streaming media server that's Flash aware.
  97. #'
  98. %package devel
  99. Summary: Gnash header files
  100. Requires: %{name} = %{version}-%{release}
  101. Group: Development/Libraries
  102. %description devel
  103. Gnash header files can be used to write external Gnash extensions or to embed
  104. the Gnash GTK+ widget into a C/C++ application.
  105. %package -n python-gnash
  106. Summary: Gnash Python bindings
  107. Requires: %{name} = %{version}-%{release}
  108. Group: Applications/Multimedia
  109. %description -n python-gnash
  110. Python bindings for the Gnash widget. Can be used to embed Gnash into any PyGTK
  111. application.
  112. %prep
  113. %setup -q
  114. %patch0 -p1 -b .unistd-header
  115. %patch1 -p1 -b .integer-overflow
  116. %patch2 -p1 -b .boost
  117. autoreconf -if
  118. %build
  119. %configure --disable-static \
  120. --with-npapi-plugindir=%{_libdir}/mozilla/plugins \
  121. --enable-docbook --enable-ghelp --enable-media=GST \
  122. --disable-dependency-tracking --disable-rpath \
  123. --disable-testsuite \
  124. --without-swfdec-testsuite \
  125. --without-ming \
  126. --enable-cygnal \
  127. --enable-sdkinstall \
  128. --enable-python \
  129. %if %{kde_support}
  130. --enable-gui=gtk,kde4,sdl,fb \
  131. --with-kde4-prefix=%{_kde4_prefix} \
  132. --with-kde4-lib=%{_kde4_libdir}/kde4/devel \
  133. --with-kde4-incl=%{_kde4_includedir} \
  134. %else
  135. --enable-gui=gtk,sdl,fb \
  136. %endif
  137. --enable-renderer=all \
  138. --with-plugins-install=system \
  139. --disable-jemalloc \
  140. --enable-doublebuf \
  141. --htmldir=%{_datadir}/gnash/html
  142. %if %{kde_support}
  143. # make sure the Qt 4 moc etc. tools are found
  144. export PATH=%{_qt4_prefix}/bin:$PATH
  145. #doesn't work currently: %%{?_smp_mflags}
  146. # override KDE4_LIBS because configure doesn't detect it properly
  147. make KDE4_LIBS='-L%{_kde4_libdir}/kde4/devel -lkparts -lkdeui -lkdecore'
  148. %else
  149. #doesn't work currently: %%{?_smp_mflags}
  150. make
  151. %endif
  152. %install
  153. rm -rf $RPM_BUILD_ROOT
  154. make install install-plugins \
  155. DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' \
  156. %if %{kde_support}
  157. KDE4_PLUGINDIR=%{_kde4_libdir}/kde4 \
  158. KDE4_SERVICESDIR=%{_kde4_datadir}/kde4/services \
  159. KDE4_CONFIGDIR=%{_kde4_configdir} \
  160. KDE4_APPSDATADIR=%{_kde4_appsdir}/klash
  161. %endif
  162. rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.la
  163. %if %{kde_support}
  164. # KDE 4 doesn't need the .la file anymore, thankfully
  165. rm $RPM_BUILD_ROOT%{_kde4_libdir}/kde4/libklashpart.la
  166. %endif
  167. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  168. %find_lang %{name}
  169. %clean
  170. rm -rf $RPM_BUILD_ROOT
  171. %post
  172. /sbin/ldconfig
  173. %if %{scrollkeeper}
  174. scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
  175. %endif
  176. /sbin/install-info %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  177. /sbin/install-info %{_infodir}/gnash_user.info %{_infodir}/dir || :
  178. update-desktop-database &> /dev/null || :
  179. touch --no-create %{_datadir}/icons/hicolor
  180. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  181. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  182. fi
  183. %preun
  184. if [ $1 = 0 ]; then
  185. /sbin/install-info --delete %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  186. /sbin/install-info --delete %{_infodir}/gnash_user.info %{_infodir}/dir || :
  187. fi
  188. %postun
  189. /sbin/ldconfig
  190. %if %{scrollkeeper}
  191. scrollkeeper-update -q || :
  192. %endif
  193. update-desktop-database &> /dev/null || :
  194. touch --no-create %{_datadir}/icons/hicolor
  195. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  196. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  197. fi
  198. %files -f %{name}.lang
  199. %defattr(-,root,root,-)
  200. %doc README AUTHORS COPYING NEWS
  201. %config(noreplace) %{_sysconfdir}/gnashpluginrc
  202. %config(noreplace) %{_sysconfdir}/gnashrc
  203. %{_bindir}/fb-gnash
  204. %{_bindir}/gtk-gnash
  205. %{_bindir}/gnash-gtk-launcher
  206. %{_bindir}/rtmpget
  207. %{_bindir}/sdl-gnash
  208. %{_bindir}/gnash
  209. %{_bindir}/gprocessor
  210. %{_bindir}/findmicrophones
  211. %{_bindir}/findwebcams
  212. %dir %{_libdir}/gnash
  213. %{_libdir}/gnash/*.so*
  214. %{_mandir}/man1/gnash.1*
  215. %{_mandir}/man1/gprocessor.1*
  216. %{_mandir}/man1/findmicrophones.1*
  217. %{_mandir}/man1/findwebcams.1*
  218. %{_mandir}/man1/gtk-gnash.1*
  219. %{_mandir}/man1/gnash-gtk-launcher.1*
  220. %{_mandir}/man1/fb-gnash.1*
  221. %{_mandir}/man1/sdl-gnash.1*
  222. %{_mandir}/man1/rtmpget.1*
  223. %{_infodir}/gnash*
  224. %{_datadir}/gnash/
  225. %{_datadir}/icons/hicolor/32x32/apps/*.xpm
  226. %{_datadir}/applications/*.desktop
  227. %files plugin
  228. %defattr(-,root,root,-)
  229. %{_libdir}/mozilla/plugins/libgnashplugin.so
  230. %if %{kde_support}
  231. %files klash
  232. %defattr(-,root,root,-)
  233. %{_kde4_bindir}/kde4-gnash
  234. %{_kde4_libdir}/kde4/libklashpart.so
  235. %{_kde4_appsdir}/klash/
  236. %{_kde4_datadir}/kde4/services/klash_part.desktop
  237. %{_mandir}/man1/kde4-gnash.1*
  238. %endif
  239. %files cygnal
  240. %defattr(-,root,root,-)
  241. %config(noreplace) %{_sysconfdir}/cygnalrc
  242. %{_bindir}/cygnal
  243. %{_bindir}/flvdumper
  244. %{_bindir}/soldumper
  245. %{_mandir}/man1/cygnal.1*
  246. %{_mandir}/man1/flvdumper.1*
  247. %{_mandir}/man1/soldumper.1*
  248. %dir %{_libdir}/cygnal
  249. %{_libdir}/cygnal/plugins/*.so*
  250. %files devel
  251. %defattr(-,root,root,-)
  252. %{_includedir}/gnash/
  253. %{_libdir}/pkgconfig/gnash.pc
  254. %files -n python-gnash
  255. %defattr(-,root,root,-)
  256. %{python_sitearch}/gtk-2.0/*
  257. %changelog
  258. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 0.8.10-4
  259. - rebuild with libboost-1.66.0
  260. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.10-3
  261. - rebuild with libpng-1.6.12
  262. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.10-2
  263. - rebuild with libboost-1.54.0
  264. - add Patch2 (%%{name}-%%{version}-libboost-1.50.0.patch)
  265. * Mon Apr 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.10-1
  266. - update to 0.8.10
  267. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-5
  268. - rebuild with python-2.7.2
  269. * Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-4
  270. - add BuildRequires: python-devel, libXv-devel
  271. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 0.8.7-3
  272. - rebuilt with libboost-1.45.0
  273. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.7-2
  274. - rebuilt with rpm-4.8.1 for pkg-config
  275. * Wed Mar 17 2010 IWAI, Masaharu <iwai@alib.jp> 0.8.7-1
  276. - initial build for Vine Linux: based Fedora 0.8.7-1.fc14
  277. * Sat Feb 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.7-1
  278. - update to 0.8.7
  279. - make scrollkeeper a conditional (still disabled as it's not working)
  280. - drop gnash-0.8.3-manual.patch, should no longer be needed
  281. - drop gnash-0.8.6-python-install-dir.patch, fixed upstream
  282. * Fri Feb 12 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-13
  283. - delete bundled libltdl stuff to make sure it's not used
  284. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-12
  285. - don't build libltdlc.a
  286. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-11
  287. - --without-included-ltdl (CVE-2009-3736)
  288. * Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-10
  289. - Rebuild for new Boost (1.41.0)
  290. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-9
  291. - Add missing Epoch to Requires
  292. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-8
  293. - Install icon to the correct place (#551621)
  294. * Wed Dec 30 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-7
  295. - One more try at using the correct dir
  296. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-6
  297. - Patch was reversed
  298. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-5
  299. - Patch Makefile.in, not Makefile.am
  300. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-4
  301. - Pick up python modules from the right dir
  302. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-3
  303. - Install python modules in the right dir
  304. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-2
  305. - Add cygnal plugins
  306. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-1
  307. - Update to 0.8.6, increase epoch.
  308. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.8.20090910bzr11506
  309. - update to HEAD
  310. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.7.20090910bzr11505
  311. - update to HEAD
  312. * Mon Aug 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.6.20090809bzr11401
  313. - don't package headers in -widget, only in -devel (no duplicate files)
  314. - own %%{_includedir}/gnash/ in -devel
  315. - add missing %%defattr for -devel and -widget
  316. - make -devel and -widget require the main package (with exact VR)
  317. - fix -devel group and description
  318. - rename gnash-widget to python-gnash as per the naming guidelines
  319. * Sun Aug 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.5.20090809bzr11401
  320. - use %%{_includedir}, not %%{_prefix}/include
  321. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.4.20090809bzr11401
  322. - Install the python module in the sitearch dir
  323. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11401
  324. - One more 64bit fix
  325. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11400
  326. - Fix the packaging in 64bits
  327. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.2.20090809bzr11400
  328. - upload the .swf file
  329. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.1.20090809bzr11400
  330. - merge upstream changes into the spec
  331. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-5
  332. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  333. * Fri May 22 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-4
  334. - rebuild for new Boost
  335. * Fri Mar 06 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-3
  336. - explicitly link the KlashPart against the libraries it uses
  337. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-2
  338. - add missing speex-devel and gstreamer-plugins-base-devel BR
  339. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-1
  340. - update to 0.8.5
  341. - remove use_kde3_executable_hack
  342. - remove autoreconf
  343. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.8.4-7
  344. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  345. * Thu Dec 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-6
  346. - rebuild for new boost
  347. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-5
  348. - add missing portions of KDE 4 port from upstream kde4 branch
  349. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-4
  350. - add 3 more patches from bero to fix the KDE 4 viewer executable
  351. - disable use_kde3_executable hack
  352. * Sun Oct 19 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-3
  353. - add a desktop file
  354. * Sat Oct 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-2
  355. - update KDE 4 patch (undo the backporting and use original patch)
  356. - patch to make autoreconf work
  357. - add missing BR giflib-devel, gettext
  358. - omit unrecognized --with-qtdir
  359. * Sat Oct 18 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-1
  360. - update to 0.8.4
  361. * Sat Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-6
  362. - use the KDE 3 executable with the KDE 4 KPart for now (making this conditional
  363. so it can easily be disabled or removed once the KDE 4 executable is fixed)
  364. * Sat Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-5
  365. - register KComponentData properly in KDE 4 KPart
  366. * Fri Oct 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-4
  367. - KDE 4 port of klash by Benjamin Wolsey and Bernhard Rosenkränzer
  368. * Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> 0.8.3-3
  369. - include %%_libdir/gnash directory
  370. * Wed Jun 25 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-2
  371. - add glib in the link, thanks Daniel Drake (#452767)
  372. * Sun Jun 22 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-1
  373. - update to 0.8.3
  374. * Wed Apr 9 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-3
  375. - ship libklashpart (#441601)
  376. * Mon Mar 10 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-2
  377. - don't ship libltdl.so.3 (#436725)
  378. * Fri Mar 7 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-1
  379. - update to 0.8.2
  380. * Sat Oct 27 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-6
  381. - add patch from Martin Stransky to fix wrapped plugin #281061
  382. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-5
  383. - info files are empty, don't install them
  384. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-4
  385. - omf/scrollkeeper doc is broken, remove it
  386. * Fri Sep 7 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-3
  387. - better documentation generation
  388. * Wed Sep 5 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-2
  389. - update to 0.8.1
  390. - agg is now the default renderer
  391. * Fri Aug 3 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-2
  392. - rebuild for boost soname change
  393. * Sun Jun 17 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-1
  394. - update to 0.8.0
  395. * Wed May 9 2007 Patrice Dumas <pertusus@free.fr> 0.7.2-2
  396. - fix CVE-2007-2500 (fix 239213)
  397. * Mon Nov 6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
  398. - update for 0.7.2 release.
  399. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
  400. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  401. * Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
  402. - plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
  403. temporarily, but there is no better solution yet) #207613
  404. * Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
  405. - add defattr for klash
  406. - add warnings in the description about stability
  407. * Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
  408. - remove superfluous buildrequires autoconf
  409. - rename last patch to gnash-plugin-tempfile-dir.patch
  410. - add README.fedora to plugin to explain tmpdirs
  411. * Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
  412. - source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
  413. - add plugin-tempfile-dir.patch for plugin to use a safe tempdir
  414. * Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
  415. - buildrequire autotools (Michael Knox)
  416. * Fri Jun 2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
  417. - add gnash-continue_on_info_install_error.patch to avoid
  418. - buildrequire libXmu-devel
  419. * Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
  420. - configure with --disable-rpath
  421. - buildrequire docbook2X
  422. - remove devel files
  423. * Sun May 7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
  424. - update to 0.7.1 alpha release
  425. * Sat Apr 22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
  426. - install the info file. Various tweaks for my system based on
  427. Patrice's latest patch,
  428. * Fri Feb 3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-1
  429. - initial packaging