gtkhtml-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190
  1. Summary: gtkhtml library
  2. Name: gtkhtml
  3. Version: 1.1.9
  4. Release: 5vl2
  5. License: LGPL
  6. Group: System Environment/Libraries
  7. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  8. Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.1/%{name}-%{version}.tar.bz2
  9. Source1: pohack.awk
  10. Patch0: gtkhtml-1.1.7-bequiet.patch
  11. Patch1: gtkhtml-1.1.7-fixfont.patch
  12. Patch2: gtkhtml-1.1.9-textslave.patch
  13. Patch3: gtkhtml-1.1-nocapplet.patch
  14. Patch4: gtkhtml-1.1.9-gcc34_fixes.patch
  15. Requires: libgnomeprint15 >= 0.24
  16. Requires: gdk-pixbuf >= 0.8.0
  17. Requires: bonobo >= 0.32
  18. BuildRequires: gdk-pixbuf-devel >= 0.8.0
  19. BuildRequires: libgnomeprint-devel >= 0.24
  20. BuildRequires: gal-devel >= 0.24
  21. BuildRequires: gnome-libs-devel libcapplet0-devel libxml-devel libglade-devel
  22. BuildRequires: bonobo-devel >= 0.32
  23. %description
  24. This is GtkHTML, a lightweight HTML rendering/printing/editing engine.
  25. It was originally based on KHTMLW, but is now being developed
  26. independently of it.
  27. %package devel
  28. Summary: Libraries, includes, etc to develop gtkhtml applications
  29. Group: Development/Libraries
  30. Requires: gtkhtml = %{version}-%{release} gnome-libs-devel
  31. Requires: libgnomeprint-devel >= 0.25
  32. Requires: gdk-pixbuf-devel >= 0.8.0
  33. Requires: libglade-devel libxml-devel
  34. Requires: bonobo-devel
  35. Requires: gal-devel >= 0.24
  36. %description devel
  37. Libraries, include files, etc you can use to develop gtkhtml applications.
  38. %prep
  39. %setup -q
  40. %patch0 -p1
  41. %patch1 -p1
  42. %patch2 -p1 -b .textslave
  43. %patch3 -p1
  44. %patch4 -p1
  45. %build
  46. %configure
  47. # Patch1: hack to modify po. (ugly!)
  48. function pohack() {
  49. POHACKTMP=`mktemp /tmp/pohack.XXXXXX` || exit 1
  50. POHACKNEW=`mktemp /tmp/pohack.XXXXXX` || exit 1
  51. awk -v tempfile=${POHACKTMP} -v tempnewfile=${POHACKNEW} -v key="\"$1\"" -v val="$2" -f %{SOURCE1} $3 > $3.new
  52. mv $3.new $3
  53. rm -f $POHACKTMP $POHACKNEW
  54. }
  55. (cd po
  56. make update-po
  57. pohack '-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' '-*-kochi gothic-*-*-*-*-14-*-*-*-*-*-*-*' ja.po
  58. pohack '-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' '-*-kochi gothic-*-*-*-*-14-*-*-*-*-*-*-*' ja.po
  59. pohack 'font_variable_print=-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' 'font_variable_print=-*-kochi gothic-*-*-*-*-14-*-*-*-*-*-*-*' ja.po
  60. pohack 'font_fixed_print=-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' 'font_fixed_print=-*-kochi gothic-*-*-*-*-14-*-*-*-*-*-*-*' ja.po
  61. pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-helvetica-*-*-*-*-14-*-*-*-*-*-%s-%s,-alias-*-*-r-*' ja.po
  62. pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-courier-*-*-*-*-14-*-*-*-*-*-%s-%s,-alias-*-*-r-*' ja.po
  63. pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*' '-*-helvetica-*-*-*-*-14-*-*-*-*-*-*-*,-alias-*-*-r-*' ja.po
  64. pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*' '-*-courier-*-*-*-*-14-*-*-*-*-*-*-*,-alias-*-*-r-*' ja.po
  65. pohack '-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' '-*-baekmuk gulim-*-*-*-*-12-*-*-*-*-*-*-*' ko.po
  66. pohack '-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' '-*-baekmuk gulim-*-*-*-*-12-*-*-*-*-*-*-*' ko.po
  67. pohack 'font_variable_print=-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' 'font_variable_print=-*-baekmuk gulim-*-*-*-*-12-*-*-*-*-*-*-*' ko.po
  68. pohack 'font_fixed_print=-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' 'font_fixed_print=-*-baekmuk gulim-*-*-*-*-12-*-*-*-*-*-*-*' ko.po
  69. pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s,-*-baekmuk gulim-*-r-*' ko.po
  70. pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s,-*-baekmuk gulim-*-r-*' ko.po
  71. pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*,-*-baekmuk gulim-*-r-*' ko.po
  72. pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*' '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*,-*-baekmuk gulim-*-r-*' ko.po
  73. pohack '-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' '-*-ar pl sungtil gb-*-*-*-*-10-*-*-*-*-*-*-*' zh_CN.po
  74. pohack '-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' '-*-ar pl sungtil gb-*-*-*-*-10-*-*-*-*-*-*-*' zh_CN.po
  75. pohack 'font_variable_print=-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' 'font_variable_print=-*-ar pl sungtil gb-*-*-*-*-10-*-*-*-*-*-*-*' zh_CN.po
  76. pohack 'font_fixed_print=-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' 'font_fixed_print=-*-ar pl sungtil gb-*-*-*-*-10-*-*-*-*-*-*-*' zh_CN.po
  77. pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s,*-r-*' zh_CN.po
  78. pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s,*-r-*' zh_CN.po
  79. pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*,*-r-*' zh_CN.po
  80. pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*' '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*,*-r-*' zh_CN.po
  81. pohack '-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' '-*-ar pl mingti2l big5-*-*-*-*-10-*-*-*-*-*-*-*' zh_TW.po
  82. pohack '-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' '-*-ar pl mingti2l big5-*-*-*-*-10-*-*-*-*-*-*-*' zh_TW.po
  83. pohack 'font_variable_print=-*-helvetica-*-*-*-*-10-*-*-*-*-*-*-*' 'font_variable_print=-*-ar pl mingti2l big5-*-*-*-*-10-*-*-*-*-*-*-*' zh_TW.po
  84. pohack 'font_fixed_print=-*-courier-*-*-*-*-10-*-*-*-*-*-*-*' 'font_fixed_print=-*-ar pl mingti2l big5-*-*-*-*-10-*-*-*-*-*-*-*' zh_TW.po
  85. pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-%s-%s,*-r-*' zh_TW.po
  86. pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s' '-*-courier-*-*-*-*-12-*-*-*-*-*-%s-%s,*-r-*' zh_TW.po
  87. pohack '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*' '-*-helvetica-*-*-*-*-12-*-*-*-*-*-*-*,*-r-*' zh_TW.po
  88. pohack '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*' '-*-courier-*-*-*-*-12-*-*-*-*-*-*-*,*-r-*' zh_TW.po
  89. )
  90. make
  91. %install
  92. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  93. make DESTDIR=$RPM_BUILD_ROOT install
  94. # remove things for new gnomecc that we don't have
  95. rm -rf $RPM_BUILD_ROOT/%{_libdir}/control-center/capplets
  96. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  97. rm -rf $RPM_BUILD_ROOT/%{_libdir}/bonobo
  98. rm -rf $RPM_BUILD_ROOT/%{_datadir}/control-center
  99. rm -rf $RPM_BUILD_ROOT/%{_datadir}/gnome/apps
  100. %find_lang %{name}
  101. %clean
  102. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  103. %post -p /sbin/ldconfig
  104. %postun -p /sbin/ldconfig
  105. %files -f %{name}.lang
  106. %defattr(-, root, root)
  107. %doc AUTHORS ChangeLog NEWS README COPYING TODO
  108. %{_bindir}/*
  109. %{_libdir}/*.so.*
  110. %{_datadir}/gnome/*
  111. %{_datadir}/gtkhtml-1.1/*
  112. %{_datadir}/oaf/*
  113. %files devel
  114. %defattr(-, root, root)
  115. %{_includedir}/gtkhtml-1.1
  116. %{_libdir}/*.a
  117. %{_libdir}/*.so
  118. #%{_libdir}/*.sh
  119. %{_libdir}/pkgconfig/*.pc
  120. %changelog
  121. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.9-5vl2
  122. - rebuilt with db4-4.2.52, gdk-pixbuf-0.22.0-0vl5, gal-0.24-1vl2
  123. - s/Copyright/License/
  124. - added Patched from Fedora
  125. * Mon Jun 21 2004 David Malcolm <dmalcolm@redhat.com> - 1.1.9-10
  126. - Added fix for gcc 3.4
  127. * Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 1.1.9-7
  128. - don't build the capplet
  129. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.9-5vl1
  130. - based on Fedora 1.1.9-5
  131. * Fri Sep 5 2003 Bill Nottingham <notting@redhat.com> 1.1.9-5
  132. - don't buildprereq libunicode-devel
  133. * Wed Aug 20 2003 Havoc Pennington <hp@redhat.com> 1.1.9-4.1
  134. - fix crash in htmltextslave.c
  135. - rebuilt with new toolchains
  136. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.9-3vl1
  137. - based on Rawhide 1.1.9-3
  138. - rebuilt with new toolchains
  139. - removed BuildPreReq gnome-core-devel, control-center-devel
  140. - added BuildPrereq /usr/lib/libcapples.so
  141. (for compatible control-center-devel and libcapplet0-devel :p)
  142. - added Requires pkgconfig
  143. * Sun Sep 15 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.4-0vl1
  144. - updated to new upstream release
  145. * Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
  146. - New upstream release.
  147. * Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
  148. - New upstream release.
  149. * Tue May 8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.9.2-0vl1
  150. - New upstream release.
  151. * Tue Apr 3 2001 Shoji Matsumoto <shom@vinelinux.org> 0.8.3-0vl1
  152. - updated to 0.8.3
  153. - add may BuildPrereq: and Requires:
  154. - add fontencfix / fontset patch
  155. * Wed Mar 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.8.2-0vl1
  156. - New upstream Release.