guile18-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define mver 1.8
  3. Name: guile18
  4. Summary: A GNU implementation of Scheme for application extensibility.
  5. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  6. Version: 1.8.8
  7. Release: 4%{?_dist_release}
  8. Group: Development/Languages
  9. License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
  10. URL: http://www.gnu.org/software/guile/
  11. Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
  12. # following patchs are imported from fedora-dev
  13. Patch1: guile-1.8.7-multilib.patch
  14. Patch2: guile-1.8.7-testsuite.patch
  15. Patch4: guile-1.8.6-deplibs.patch
  16. Buildroot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
  18. BuildRequires: gmp-devel readline-devel emacs
  19. Requires(post): /sbin/install-info
  20. Requires(preun): /sbin/install-info
  21. Requires: coreutils
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: yasumichi, Takemikaduchi
  25. %description
  26. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  27. implementation of the Scheme programming language, written in C. GUILE
  28. provides a machine-independent execution platform that can be linked in
  29. as a library during the building of extensible programs.
  30. Install the guile package if you'd like to add extensibility to programs
  31. that you are developing.
  32. %package devel
  33. Summary: Libraries and header files for the GUILE extensibility library.
  34. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. Requires: gmp-devel
  38. %description devel
  39. The guile-devel package includes the libraries, header files, etc.,
  40. that you'll need to develop applications that are linked with the
  41. GUILE extensibility library.
  42. You need to install the guile-devel package if you want to develop
  43. applications that will be linked to GUILE. You'll also need to
  44. install the guile package.
  45. %package -n compat32-%{name}
  46. Summary: A GNU implementation of Scheme for application extensibility.
  47. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  48. Group: Development/Languages
  49. Requires: %{name} = %{version}-%{release}
  50. %description -n compat32-%{name}
  51. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  52. implementation of the Scheme programming language, written in C. GUILE
  53. provides a machine-independent execution platform that can be linked in
  54. as a library during the building of extensible programs.
  55. Install the guile package if you'd like to add extensibility to programs
  56. that you are developing.
  57. %package -n compat32-%{name}-devel
  58. Summary: Libraries and header files for the GUILE extensibility library.
  59. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  60. Group: Development/Libraries
  61. Requires: %{name}-devel = %{version}-%{release}
  62. Requires: compat32-%{name} = %{version}-%{release}
  63. Requires: compat32-gmp-devel
  64. %description -n compat32-%{name}-devel
  65. The guile-devel package includes the libraries, header files, etc.,
  66. that you'll need to develop applications that are linked with the
  67. GUILE extensibility library.
  68. You need to install the guile-devel package if you want to develop
  69. applications that will be linked to GUILE. You'll also need to
  70. install the guile package.
  71. %prep
  72. %setup -q -n guile-%{version}
  73. %patch1 -p1 -b .multilib
  74. %patch2 -p1 -b .testsuite
  75. %patch4 -p1 -b .deplibs
  76. %build
  77. %configure --disable-static --disable-error-on-warning
  78. # Remove RPATH
  79. sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
  80. {,guile-readline/}libtool
  81. make %{?_smp_mflags}
  82. %install
  83. rm -rf $RPM_BUILD_ROOT
  84. make DESTDIR=$RPM_BUILD_ROOT install
  85. mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site
  86. rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
  87. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  88. # Compress large documentation
  89. bzip2 NEWS
  90. for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
  91. iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
  92. done
  93. touch $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slibcat
  94. ln -s ../../slib $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slib
  95. # rename file
  96. mv $RPM_BUILD_ROOT%{_bindir}/guile $RPM_BUILD_ROOT%{_bindir}/guile-%{mver}
  97. mv $RPM_BUILD_ROOT%{_bindir}/guile-tools $RPM_BUILD_ROOT%{_bindir}/guile-tools-%{mver}
  98. mv $RPM_BUILD_ROOT%{_bindir}/guile-config $RPM_BUILD_ROOT%{_bindir}/guile-config-%{mver}
  99. mv $RPM_BUILD_ROOT%{_bindir}/guile-snarf $RPM_BUILD_ROOT%{_bindir}/guile-snarf-%{mver}
  100. %clean
  101. rm -rf $RPM_BUILD_ROOT
  102. %post -p /sbin/ldconfig
  103. %postun -p /sbin/ldconfig
  104. %post -n compat32-%{name} -p /sbin/ldconfig
  105. %postun -n compat32-%{name} -p /sbin/ldconfig
  106. %files
  107. %defattr(-,root,root,-)
  108. %doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
  109. %{_bindir}/guile-%{mver}
  110. %{_bindir}/guile-tools-%{mver}
  111. %{_libdir}/libguile*.so.*
  112. %{_libdir}/libguilereadline-*.so
  113. %{_libdir}/libguile-srfi-srfi-*.so
  114. %dir %{_datadir}/guile/%{mver}
  115. %{_datadir}/guile/%{mver}/ice-9
  116. %{_datadir}/guile/%{mver}/lang
  117. %{_datadir}/guile/%{mver}/oop
  118. %{_datadir}/guile/%{mver}/scripts
  119. %{_datadir}/guile/%{mver}/srfi
  120. %{_datadir}/guile/%{mver}/guile-procedures.txt
  121. %ghost %{_datadir}/guile/%{mver}/slibcat
  122. %ghost %{_datadir}/guile/%{mver}/slib
  123. %exclude %{_infodir}/*
  124. %exclude %{_mandir}/man1/guile.1*
  125. %files devel
  126. %defattr(-,root,root,-)
  127. %{_bindir}/guile-config-%{mver}
  128. %{_bindir}/guile-snarf-%{mver}
  129. %{_libdir}/libguile.so
  130. %{_libdir}/pkgconfig/*.pc
  131. %{_includedir}/guile
  132. %{_includedir}/libguile
  133. %{_includedir}/libguile.h
  134. %exclude %{_datadir}/aclocal/*
  135. # compat32
  136. %if %{build_compat32}
  137. %files -n compat32-%{name}
  138. %defattr(-,root,root,-)
  139. %{_libdir}/libguile*.so.*
  140. %{_libdir}/libguilereadline-*.so
  141. %{_libdir}/libguile-srfi-srfi-*.so
  142. %files -n compat32-%{name}-devel
  143. %defattr(-,root,root,-)
  144. %{_libdir}/libguile.so
  145. %endif
  146. %changelog
  147. * Wed Sep 04 2019 Toshiaki Ara <ara_t@384.jp> 1.8.8-4
  148. - rebuild with readline-8.0
  149. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-3
  150. - rebuild with readline-6.3
  151. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-2
  152. - rename package (guile18)
  153. * Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-1
  154. - update to 1.8.8
  155. - remove Patch3,5,6 (guile-1.8.7-ia64jmp.patch)
  156. * Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
  157. - rebuilt with rpm-4.8.1
  158. - added Patch1, 2, 3, 5 and 6 from Fedora
  159. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
  160. - new upstream release.
  161. - comment out Patch11,12.
  162. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
  163. - added Requires: gmp-devel to guile-devel
  164. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
  165. - added compat32 package for x86_64 arch support
  166. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
  167. - rebuild with libtool-2.2.6a
  168. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
  169. - new upstream release
  170. - import some patches from fedora development
  171. - drop some old patches
  172. - update spec based on fedora package
  173. - spec in utf-8
  174. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
  175. - use macro for Release
  176. * Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
  177. - apply new virsioning policy.
  178. - remove *.la
  179. * Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
  180. - rebuilt with readline 5.1
  181. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
  182. - added Patches from Fedora
  183. * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
  184. - Fix dynamic linking on 64bit archs (#159971)
  185. * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
  186. - Moved info files to base package as they are not devel related (#139948)
  187. - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
  188. - Fixed guile-tools not finding guile lib dir (#142642)
  189. - Added some nice tools (#142642)
  190. - Removed smp build, seems to be broken atm
  191. * Fri Jan 7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
  192. - new upstream release
  193. - dropped patch2, 4, 6
  194. - added BuildPrereq: perl
  195. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
  196. - rebuild with new toolchains
  197. - s/Copyright/License/
  198. - added srfi libs
  199. - patch for ppc64 from Fedora package
  200. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
  201. - update to 1.6.4
  202. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
  203. - rebuild with readline-4.3
  204. * Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
  205. - based on Rawhide 1.6.0-4
  206. - Included s390 as working arch as well, switch to general unknown arch patch
  207. - rebuild to fix broken deps
  208. - fix continuations.h on ia64
  209. - new upstream 1.6.3
  210. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
  211. - porting for Vine Linux
  212. - remove 1.3 patches( not required so that upstream upgrade )
  213. * Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  214. - Add version number to prereq for umb-scheme to get the post-install to
  215. work properly.
  216. * Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  217. - Add an Epoch = 1 in case anyone happened to have 1.4 installed.
  218. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  219. - automatic rebuild
  220. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  221. - Back down to 1.3.4.
  222. - Fix to actually link against the version of libguile in the package.
  223. * Sun Jun 4 2000 Nalin Dahyabhai <nalin@redhat.com>
  224. - FHS fixups using the %%{makeinstall} macro.
  225. * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  226. - fix preun-devel
  227. - call ldconfig directly in postun
  228. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  229. - rebuild with new readline
  230. - update to 1.3.4
  231. * Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  232. - using the same catalog as umb-scheme makes umb-scheme a prereq
  233. * Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  234. - readline is needed for %post
  235. * Tue Feb 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  236. - use the same catalog as umb-scheme
  237. * Thu Sep 2 1999 Jeff Johnson <jbj@redhat.com>
  238. - fix broken %postun
  239. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  240. - auto rebuild in the new build environment (release 6)
  241. * Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
  242. - added .ansi patch to fix #endif
  243. * Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
  244. - add patch for the scm stuff
  245. * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
  246. - integrate changes from rhcn version (#640)
  247. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  248. - call libtoolize first to get it to compile on the arm
  249. * Sat Jan 9 1999 Todd Larason <jtl@molehill.org>
  250. - Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
  251. * Fri Jan 1 1999 Todd Larason <jtl@molehill.org>
  252. - guile-devel does depend on guile
  253. - remove devel dependancy on m4
  254. - move guile-snarf from guile to guile-devel
  255. - Converted to rhcn
  256. * Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
  257. - update to 1.3.
  258. - don't strip libguile.so.*.0.0. (but set the execute bits).
  259. * Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
  260. - spec file fixups
  261. * Wed Sep 2 1998 Michael Fulbright <msf@redhat.com>
  262. - Updated for RH 5.2
  263. * Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
  264. - Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
  265. - added slib link
  266. * Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl> (1.2-3)
  267. - added %attr(-, root, root) for %doc,
  268. - in %post, %postun ldconfig runed as parameter "-p",
  269. - removed /bin/sh from requires,
  270. - added %description,
  271. - changes in %files.
  272. * Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl> (1.2-2)
  273. - all rewrited for using Buildroot,
  274. - added %postun,
  275. - removed making buid logs,
  276. - removed "--inclededir", added "--enable-dynamic-linking" to configure
  277. parameters,
  278. - added striping shared libs and /usr/bin/guile,
  279. - added "Requires: /bin/sh" (for guile-snarf) in guile package and
  280. "Requires: m4" for guile-devel,
  281. - added macro %{PACKAGE_VERSION} in "Source:" and %files,
  282. - added %attr macros in %files.