haveged-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177
  1. Summary: A Linux entropy source using the HAVEGE algorithm
  2. Summary(ja): HAVEFE アルゴリズムを使った Linux のエントロピーソース
  3. Name: haveged
  4. Version: 1.9.8
  5. Release: 2%{?_dist_release}
  6. Group: System Environment/Daemons
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. License: GPLv3+
  11. URL: https://github.com/jirka-h/haveged
  12. Source0: https://github.com/jirka-h/haveged/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  13. Requires(post): chkconfig
  14. Requires(preun): chkconfig, initscripts
  15. Requires(postun): initscripts
  16. BuildRequires: automake gdb coreutils glibc-common
  17. %{!?_unitdir:%global _unitdir /lib/systemd/system}
  18. %{!?_userunitdir:%global _userunitdir /usr/lib/systemd/user}
  19. %description
  20. A Linux entropy source using the HAVEGE algorithm
  21. Haveged is a user space entropy daemon which is not dependent upon the
  22. standard mechanisms for harvesting randomness for the system entropy
  23. pool. This is important in systems with high entropy needs or limited
  24. user interaction (e.g. headless servers).
  25. Haveged uses HAVEGE (HArdware Volatile Entropy Gathering and Expansion)
  26. to maintain a 1M pool of random bytes used to fill /dev/random
  27. whenever the supply of random bits in /dev/random falls below the low
  28. water mark of the device. The principle inputs to haveged are the
  29. sizes of the processor instruction and data caches used to setup the
  30. HAVEGE collector. The haveged default is a 4kb data cache and a 16kb
  31. instruction cache. On machines with a cpuid instruction, haveged will
  32. attempt to select appropriate values from internal tables.
  33. %package devel
  34. Summary: Headers and shared development libraries for HAVEGE algorithm
  35. Summary(ja): Headers and shared development libraries for HAVEGE algorithm
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. %description devel
  39. Headers and shared object symbolic links for the HAVEGE algorithm
  40. %prep
  41. %setup -q
  42. %build
  43. #autoreconf -fiv
  44. %configure --enable-init=sysv.redhat
  45. #SMP build is not working
  46. #make %{?_smp_mflags}
  47. make
  48. %check
  49. make check
  50. %install
  51. rm -rf %{buildroot}
  52. make install DESTDIR=%{buildroot} INSTALL="install -p"
  53. chmod 0644 COPYING README ChangeLog AUTHORS
  54. # We don't ship .la files.
  55. rm -rf %{buildroot}%{_libdir}/libhavege.*a
  56. install -Dpm 0644 init.d/service.fedora %{buildroot}%{_unitdir}/%{name}.service
  57. %clean
  58. rm -rf %{buildroot}
  59. %post
  60. /sbin/chkconfig --add haveged
  61. %preun
  62. if [ "$1" -eq "0" ]; then
  63. /sbin/service haveged stop >/dev/null 2>&1
  64. /sbin/chkconfig --del haveged
  65. fi
  66. %postun
  67. if [ "$1" -ge "1" ]; then
  68. /sbin/service haveged condrestart >/dev/null 2>&1
  69. fi
  70. %files
  71. %defattr(-, root, root, -)
  72. %license COPYING
  73. %doc README ChangeLog AUTHORS contrib/build/havege_sample.c
  74. %{_mandir}/man8/haveged.8*
  75. %{_sbindir}/haveged
  76. %{_libdir}/*so.*
  77. %{_sysconfdir}/init.d/haveged
  78. %dir /lib/systemd
  79. %dir %{_unitdir}
  80. %{_unitdir}/haveged.service
  81. %files devel
  82. %defattr(-, root, root, -)
  83. %{_mandir}/man3/libhavege.3*
  84. %dir %{_includedir}/%{name}
  85. %{_includedir}/%{name}/havege.h
  86. %{_libdir}/*.so
  87. %changelog
  88. * Mon Mar 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.8-2
  89. - added a .service file for systemd.
  90. * Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.8-1
  91. - new upstream release.
  92. * Sat Jul 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.1-1
  93. - new upstream release.
  94. * Sun Mar 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7a-1
  95. - update to 1.7a
  96. * Sat Mar 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-1
  97. - initial build for Vine Linux
  98. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-1
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  100. * Sat Jan 19 2013 Jirka Hladky <hladky.jiri@gmail.com> - 1.7-0
  101. - Updated to the version 1.7
  102. - Version 1.7 brings developement libraries
  103. - Added devel package
  104. * Sat Oct 13 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.5-2
  105. - BZ 850144
  106. - Introduce new systemd-rpm macros in haveged spec file
  107. - Fedora 19 changes the way how to work with services in spec files.
  108. - It introduces new macros - systemd_post, systemd_preun and systemd_postun;
  109. - which replace scriptlets from Fedora 18 and older
  110. - see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
  111. * Tue Aug 14 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.5-1
  112. - Update to the version 1.5
  113. - Main new feature is a run time verification of the produced random numbers
  114. - PIDFILE set to /run/haveged.pid
  115. - converted README and man page to UTF-8. Informed the upstream to fix it.
  116. * Wed Feb 15 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-3
  117. - PIDFile should be stored at /run instead of the default location /var/run
  118. - There is long term plan that directory /var/run will not further exist in the future Fedora versions
  119. - Asked upstream to add -p <PID_FILE_location> switch to influence the location of the PID File
  120. - Set PIDFile=/var/run/haveged.pid This is needed as long -p option is not implemented
  121. - https://bugzilla.redhat.com/show_bug.cgi?id=770306#c10
  122. * Wed Feb 15 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-2
  123. - Updated systemd service file, https://bugzilla.redhat.com/show_bug.cgi?id=770306
  124. * Tue Feb 14 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-1
  125. - Update to the version 1.4
  126. - Conversion to systemd, drop init script
  127. * Sun Nov 06 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-2
  128. - Fixed a bug on non x86 systems
  129. * Sat Nov 05 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-1
  130. - update from the upstream (1.3 stable)
  131. * Mon Oct 03 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-0
  132. -version 1.3 beta
  133. * Fri Sep 30 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-4
  134. - ppc64 build
  135. * Mon Sep 26 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-3
  136. - Cleaned spec file according to https://bugzilla.redhat.com/show_bug.cgi?id=739347#c11
  137. * Sat Sep 24 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-2
  138. - Added comment to explain why we need use Fedora specific start script
  139. * Wed Sep 21 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-1
  140. - Cleaned spec file according to https://bugzilla.redhat.com/show_bug.cgi?id=739347#c1
  141. * Wed Sep 07 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-0
  142. - Initial build