havp-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154
  1. %bcond_with libclamav
  2. %define clamav_version 0.96
  3. Summary: HAVP - HTTP Anti Virus Proxy
  4. Name: havp
  5. Version: 0.92a
  6. Release: 5%{_dist_release}
  7. License: GPL
  8. Group: Applications/System
  9. URL: http://www.server-side.de/
  10. Source0: http://www.server-side.de/download/havp-%{version}.tar.gz
  11. Patch0: havp.patch
  12. BuildRequires: libstdc++-devel, zlib-devel, bzip2-devel
  13. BuildRequires: gmp-devel, openssl-devel
  14. BuildRequires: clamav-devel => %{clamav_version}
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root/
  16. #Requires: libstdc++, zlib, bzip2, gmp
  17. Requires: clamav => %{clamav_version}
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: tomop
  21. %description
  22. HAVP (HTTP AntiVirus proxy) is a proxy with an anti-virus filter.
  23. It does not cache or filter content. At the moment the complete
  24. traffic is scanned. The reason for this is the chance of malicious
  25. code in nearly every filetype e.g. HTML (JavaScript) or Jpeg. I aim
  26. to stop especially dialer or browser exploits. But writing a http
  27. Anti Virus Proxy is a real dilemma! Huge downloads are a problem
  28. for virus scanning proxies. A Client should not receive data which
  29. is unchecked by the virus scanner, but big downloads should not timeout.
  30. %prep
  31. %setup -q
  32. %patch0 -p0
  33. #%patch1 -p1
  34. %build
  35. export CFLAGS="%{optflags} -std=c++0x"
  36. export CXXFLAGS="%{optflags} -std=c++0x"
  37. %configure \
  38. %if %{with libclamav}
  39. --with-scanner=libclamav \
  40. %else
  41. --disable-clamav \
  42. %endif
  43. --enable-ssl-tunnel
  44. make %{?_smp_mflags}
  45. %install
  46. rm -rf %{buildroot}
  47. mkdir -p %{buildroot}%{_sbindir}
  48. mkdir -p %{buildroot}%{_sysconfdir}/havp/templates
  49. mkdir -p %{buildroot}%{_localstatedir}/log/havp
  50. mkdir -p %{buildroot}%{_localstatedir}/tmp/havp
  51. mkdir -p %{buildroot}%{_localstatedir}/run/havp
  52. mkdir -p %{buildroot}%{_initdir}
  53. install -m755 havp/havp %{buildroot}%{_sbindir}
  54. install -m755 etc/init.d/havp %{buildroot}%{_initdir}
  55. install -m644 etc/havp/havp.config %{buildroot}%{_sysconfdir}/havp/havp.config
  56. install -m644 etc/havp/whitelist %{buildroot}%{_sysconfdir}/havp/whitelist
  57. install -m644 etc/havp/blacklist %{buildroot}%{_sysconfdir}/havp/blacklist
  58. cp -r etc/havp/templates/* %{buildroot}%{_sysconfdir}/havp/templates
  59. chmod -R a+rX %{buildroot}/etc/havp/templates
  60. %clean
  61. rm -rf %{buildroot}
  62. %pre
  63. if ! grep -q '^havp:' /etc/group; then
  64. /usr/sbin/groupadd -r havp
  65. fi
  66. if ! grep -q '^havp:' /etc/passwd; then
  67. /usr/sbin/useradd -M -r -s /sbin/nologin -g havp havp || :
  68. fi
  69. %postun
  70. /sbin/ldconfig
  71. if [ $1 = 0 ]; then
  72. if [ `grep havp /etc/passwd | wc -l` = 1 ]; then
  73. /usr/sbin/userdel havp
  74. fi
  75. if [ `grep havp /etc/group | wc -l` = 1 ]; then
  76. /usr/sbin/groupdel havp
  77. fi
  78. fi
  79. %post -p /sbin/ldconfig
  80. %files
  81. %defattr(-,root,root,-)
  82. %doc INSTALL COPYING ChangeLog
  83. %{_initdir}/havp
  84. %{_sbindir}/havp
  85. %config(noreplace) %{_sysconfdir}/havp/havp.config
  86. %config(noreplace) %{_sysconfdir}/havp/whitelist
  87. %config(noreplace) %{_sysconfdir}/havp/blacklist
  88. %{_sysconfdir}/havp/templates/*
  89. %attr(750,havp,havp) %dir /var/log/havp
  90. %attr(750,havp,havp) %dir /var/tmp/havp
  91. %attr(750,havp,havp) %dir /var/run/havp
  92. %changelog
  93. * Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-5
  94. - disabled libclamav support.
  95. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-4
  96. - rebuilt with new toolchain.
  97. * Thu Dec 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-3
  98. - built with clamav-0.99.
  99. * Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-2
  100. - rebuilt with current environment.
  101. * Sun Dec 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-1
  102. - new upstream release.
  103. * Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92-1
  104. - new upstream release.
  105. * Thu Jun 11 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.90-1
  106. - new upstream release.
  107. * Tue Mar 24 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.89-1
  108. - new upstream release.
  109. - built with clamav-0.95.
  110. * Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-2
  111. - rebuild with clamav-0.93.
  112. * Mon Apr 14 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-1
  113. - rebuilt with VineSeed.
  114. * Sat Mar 1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-0vl1
  115. - new upstream release.
  116. * Sun Mar 11 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.85-0vl2
  117. - built with clamav-0.90.1.
  118. * Mon Feb 26 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.85-0vl1
  119. - new upstream release.
  120. * Thu Oct 19 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.82-0vl1
  121. - new upstream release.
  122. * Thu Jul 20 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.81-0vl1
  123. - initial build.