herqq-vl.spec 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100
  1. %define _qt4_ver 4.8.0
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  4. %define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/lib)
  5. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  6. Name: herqq
  7. Summary: A software library for building UPnP devices and control points
  8. Version: 1.0.0
  9. Release: 5%{?_dist_release}
  10. # test application is GPLv3 but we do not ship it
  11. License: LGPLv3+
  12. Group: System Environment/Libraries
  13. URL: http://herqq.org/
  14. Source0: http://downloads.sourceforge.net/project/hupnp/hupnp/%{name}-%{version}.zip
  15. Patch2: herqq-1.0.0-qtsoap-library.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: desktop-file-utils
  18. BuildRequires: qt4-devel
  19. BuildRequires: qtsoap-devel
  20. Requires: qt4 >= %{_qt4_version}
  21. %description
  22. Herqq UPnP (HUPnP) is a software library for building UPnP
  23. devices and control points conforming to the UPnP Device
  24. Architecture version 1.1.
  25. %package devel
  26. Summary: Development files for %{name}
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: qt4-devel >= %{_qt4_version}
  30. %description devel
  31. Header files for developing applications using %{name}.
  32. %prep
  33. %setup -q
  34. # lQtSolutions to lqtsoap
  35. %patch2 -p1 -b .qtsoap-library
  36. %build
  37. # we have to disable bundled QtSOAP library
  38. qmake PREFIX=%{_prefix} -config DISABLE_QTSOAP \
  39. -config DISABLE_TESTAPP -config USE_QT_INSTALL_LOC
  40. make %{?_smp_mflags}
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. make INSTALL_ROOT=%{buildroot} install
  44. %clean
  45. rm -rf $RPM_BUILD_ROOT
  46. %post -p /sbin/ldconfig
  47. %postun -p /sbin/ldconfig
  48. %files
  49. %doc hupnp/ChangeLog hupnp/LICENSE_LGPLv3.txt
  50. %{_qt4_libdir}/libHUpnp.so.1*
  51. %files devel
  52. %{_qt4_libdir}/libHUpnp.so
  53. %{_qt4_headerdir}/HUpnpCore/
  54. %changelog
  55. * Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-5
  56. - rebuild with gcc-5.4.0
  57. * Mon Oct 27 2014 Ryoiochi INAGAKI <ryo1@toki.waseda.jp> - 1.0.0-4
  58. - added Group tag
  59. - added %%clean section
  60. * Sun Jan 8 2012 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
  61. - rebuilt with qt-4.8.0
  62. * Sun Jul 31 2011 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
  63. - Initial build for Vine Linux
  64. * Wed Jul 20 2011 Jaroslav Reznik <jreznik@redhat.com> - 1.0.0-1
  65. - post-review update to 1.0.0
  66. * Wed Jul 20 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-3
  67. - fix license to LGPLv3+
  68. - qt4 header dir for consistency
  69. - shlib soname tracked in %files
  70. - -devel should not duplicate COPYING
  71. * Tue Jul 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-2
  72. - qtsoap library
  73. - cleanup SPEC file
  74. * Tue Feb 22 2011 Jaroslav Reznik <jreznik@redhat.com> - 0.9.1-1
  75. - Initial spec file