hostapd-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175
  1. %define base_name hostapd
  2. %define pkg_version 2.7
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
  5. Summary(ja): IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS 認証局
  6. Name: %{base_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. Source0: %{base_name}-%{version}.tar.gz
  10. Source1: %{base_name}-init.sh
  11. Source2: %{base_name}-%{version}.config
  12. License: GPL2
  13. Group: System Environment/Daemons
  14. URL: http://hostap.epitest.fi/hostapd/
  15. Requires: openssl, libnl >= 1.1
  16. Requires(post): %{_syssbindir}/chkconfig
  17. Requires(preun): %{_syssbindir}/chkconfig
  18. BuildRequires: openssl-devel, libnl-devel
  19. BuildRoot: %{_tmppath}/%{base_name}-%{version}-root
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: miyabi
  23. %description
  24. hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
  25. IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
  26. The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
  27. %description -l ja
  28. hostapd はアクセスポイントと認証サーバのためのユーザスペースデーモンです。
  29. IEEE 802.11 アクセスポイント管理、IEEE 802.1X/WPA/WPA2/EAP 認証局、RADIUS クライアント、EAP サーバ、および RADIUS 認証サーバを実装します。
  30. 最新版は、Linux(Host AP、madwifi、mac80211ベースのドライバー)とFreeBSD(net80211)をサポートします。
  31. %prep
  32. %setup -q
  33. cp %{SOURCE1} .
  34. cp %{SOURCE2} ./%{base_name}/.config
  35. %build
  36. cd %{base_name}
  37. %{__make} %{?_smp_mflags}
  38. %install
  39. [ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
  40. pushd %{base_name}
  41. %{__make} install DESTDIR="${RPM_BUILD_ROOT}" BINDIR="%{_sbindir}"
  42. popd
  43. %{__install} -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{base_name}
  44. %{__install} -D %{base_name}/hostapd.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
  45. %{__install} -D %{base_name}/hostapd.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/hostapd.8
  46. %{__install} -D %{base_name}/hostapd_cli.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/hostapd_cli.1
  47. %post
  48. if ! /sbin/chkconfig %{base_name}; then
  49. /sbin/chkconfig --add %{base_name}
  50. fi
  51. if [ "$1" -eq "2" ]; then
  52. %{_initdir}/%{base_name} condrestart
  53. fi
  54. %preun
  55. if [ "$1" -eq "0" ]; then
  56. %{_initdir}/%{base_name} stop
  57. /sbin/chkconfig --del %{base_name}
  58. fi
  59. %clean
  60. [ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
  61. %files
  62. %defattr(-, root, root)
  63. # Directory
  64. %dir %{_sysconfdir}/%{base_name}/
  65. # Program Files
  66. %attr(0755, root, root) %{_sbindir}/hostapd
  67. %attr(0755, root, root) %{_sbindir}/hostapd_cli
  68. %attr(0755, root, root) %{_initdir}/%{base_name}
  69. # Config Files
  70. %attr(0644, root, root) %config(noreplace) %{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
  71. # Document Files
  72. %doc %{base_name}/ChangeLog COPYING README
  73. %{_mandir}/man8/%{base_name}.8.gz
  74. %{_mandir}/man1/hostapd_cli.1.gz
  75. %changelog
  76. * Wed Jan 02 2019 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.7-1
  77. - new upstream release
  78. * Fri Oct 20 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6-2
  79. - add patch11-18 for fix "KRACK" issue
  80. * Sat Feb 04 2017 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.6-1
  81. - new upstream release
  82. * Sat Jan 02 2016 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.5-1
  83. - new upstream release
  84. * Sat Mar 21 2015 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.4-1
  85. - new upstream release
  86. - change hostapd_cli install path /usr/bin -> /usr/sbin
  87. * Sat Dec 06 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.3-1
  88. - new upstream release
  89. * Wed Jul 09 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.2-1
  90. - new upstream release
  91. * Wed Apr 23 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-2
  92. - add patch - hostapd-2.1.334ec001bbd31c5bc83d6593e58dfbbf6b8785a2.patch
  93. - fix segfault
  94. * Sat Mar 15 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-1
  95. - new upstream release
  96. - change .config
  97. - add ACS support(Supported ACS drivers: ath5k, ath9k, ath10k)
  98. * Sun Mar 17 2013 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.0-1
  99. - new upstream release
  100. - change filename hostapd.conf -> hostapd.conf.sample
  101. - change .config
  102. - add WPS support
  103. * Sun Dec 2 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.1-1
  104. - new upstream release
  105. * Fri Oct 19 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0.0-1
  106. - new upstream release
  107. - add Summary(ja)
  108. - add section - %description -l ja
  109. - add parameter noreplace to %config
  110. - change spec file
  111. * Tue Oct 9 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
  112. - add patch100 for fix CVE-2012-4445 (EPA-TLS message)
  113. * Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
  114. - fix daemon script
  115. - change spec file
  116. - separation from patch file
  117. - daemon script
  118. - .config
  119. - add Source1 - hostapd-init.sh
  120. - add Source2 - hostapd-0.7.3.config
  121. - add Requires(post) - chkconfig
  122. - add Requires(preun) - chkconfig
  123. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
  124. - rebuild with openssl-1.0.0c
  125. * Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
  126. - new upstream release
  127. * Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
  128. - new upstream release
  129. * Sun Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
  130. - new upstream release
  131. * Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
  132. - new upstream release
  133. * Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
  134. - initial build for Vine Linux