hscolour-vl.spec 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. %define pkg_name hscolour
  2. %define pkg_version 1.24
  3. %define pkg_release 4%{?_dist_release}
  4. Summary: A small Haskell script to colourise Haskell code
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: GPLv2
  9. Group: Applications/Text
  10. URL: http://hackage.haskell.org
  11. Source0: http://hackage.haskell.org/package/%{pkg_name}-%{pkg_version}/%{pkg_name}-%{pkg_version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
  13. BuildRequires: ghc-bootstrap
  14. BuildRequires: gmp-devel
  15. BuildRequires: libffi-devel
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: ara_t
  19. %description
  20. hscolour is a small Haskell script to colourise Haskell code.
  21. It currently has six output formats: ANSI terminal codes
  22. (optionally XTerm-256colour codes), HTML 3.2 with font tags,
  23. HTML 4.01 with CSS, HTML 4.01 with CSS and mouseover annotations,
  24. XHTML 1.0 with inline CSS styling, LaTeX, and mIRC chat codes.
  25. %prep
  26. %{__rm} -rf ${RPM_BUILD_ROOT}
  27. %setup -q
  28. %build
  29. ghc -threaded --make Setup
  30. ./Setup configure \
  31. --disable-shared \
  32. --prefix=%{_prefix} \
  33. --libsubdir=%{_libdir}/ghc-lib/%{name}-%{version} \
  34. --datasubdir=%{_docdir}/%{name}-%{version} \
  35. --docdir=%{_docdir}/%{name}-%{version}
  36. ./Setup build
  37. %install
  38. ./Setup copy --destdir=${RPM_BUILD_ROOT}
  39. cd ${RPM_BUILD_ROOT}%{_bindir}
  40. %{__ln_s} HsColour hscolour
  41. %clean
  42. %{__rm} -rf ${RPM_BUILD_ROOT}
  43. %files
  44. %defattr(-, root, root)
  45. %{_bindir}/
  46. %{_libdir}/ghc-lib/
  47. %{_datadir}/
  48. %changelog
  49. * Mon May 02 2016 Toshiaki Ara <ara_t@384.jp> 1.24-4
  50. - rebuilt under ghc-bootstrap only (without haskell-platform)
  51. - delete Requires: ghc
  52. * Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.24-3
  53. - correct SPEC file
  54. * Sat Feb 20 2016 Toshiaki Ara <ara_t@384.jp> 1.24-2
  55. - rebuild under ghc-7.10.3 and haskell-platform-2015.7.10.3
  56. * Tue Feb 09 2016 Toshiaki Ara <ara_t@384.jp> 1.24-1
  57. - new package