html-helper-mode-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origname html-helper-mode
  4. %define origver 2.19.1.1
  5. %define release 8
  6. # Main
  7. Summary: Major mode for editing HTML (for Emacsen)
  8. Name: %{origname}
  9. Version: %{origver}
  10. Release: %{release}%{?_dist_release}
  11. License: GPLv2+
  12. Group: Applications/Editors/Emacs
  13. URL: http://www.santafe.edu/~nelson/tools/
  14. Source0: http://www.santafe.edu/~nelson/hhm-beta/html-helper-mode.el
  15. Source1: http://www.santafe.edu/~nelson/hhm-beta/tempo.el
  16. Source2: http://www.santafe.edu/~nelson/hhm-beta/index.html
  17. Source3: http://www.santafe.edu/~nelson/tools/configuring.html
  18. Source4: http://www.santafe.edu/~nelson/tools/differences.html
  19. Source5: http://www.santafe.edu/~nelson/tools/documentation.html
  20. Source6: http://www.santafe.edu/~nelson/tools/keybindings.html
  21. Source7: hhm.dot.emacs
  22. Source8: HHM-MK
  23. Source9: html-helper-mode-install.sh
  24. Source10: html-helper-mode-remove.sh
  25. Source11: vine-default-%{origname}.el
  26. Source12: %{origname}-init.el
  27. Buildroot: %{_tmppath}/%{name}-root
  28. PreReq: emacsen
  29. Requires: emacsen
  30. %prereq_ge emacsen-common
  31. BuildArchitectures: noarch
  32. #Obsoletes: %{name}-2.19.1.1-3
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. html-helper-mode makes it easier to write HTML documents.
  37. This mode handles inserting HTML codes in a variety of ways
  38. (keybindings, completion in the buffer).
  39. It also supports indentation, timestamps, skeletons for new documents,
  40. hilit19 patterns, and a variety of other things.
  41. Initialization
  42. ===============
  43. Please refer the following file:
  44. "%{_docdir}/%{name}-%{version}/hhm.dot.emacs"
  45. "%{_docdir}/%{name}-%{version}/*.html"
  46. %description -l ja
  47. html-helper-mode は、HTML ドキュメントの作成を簡単にします。
  48. このモードでは、HTML コードの挿入に多様な方法が使えます。
  49. また、INDENTATION、タイムスタンプ等をサポートします。
  50. 初期設定
  51. =========
  52. 下記を参考にしてください:
  53. "%{_docdir}/%{name}-%{version}/hhm.dot.emacs"
  54. "%{_docdir}/%{name}-%{version}/*.html"
  55. # '
  56. %prep
  57. %setup -q -T -c %{name}-%{version}
  58. cp %SOURCE0 ./
  59. cp %SOURCE1 ./
  60. cp %SOURCE2 ./
  61. cp %SOURCE3 ./
  62. cp %SOURCE4 ./
  63. cp %SOURCE5 ./
  64. cp %SOURCE6 ./
  65. cp %SOURCE7 ./
  66. cp %SOURCE8 ./
  67. %build
  68. # byte-compile
  69. #emacs-%{emacsver} -batch -l HHM-MK
  70. %install
  71. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  72. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  73. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  74. mkdir -p %{buildroot}%{emacsen_pkgdir}/install
  75. mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
  76. #
  77. # install el files
  78. #
  79. cp -a html-helper-mode.el tempo.el HHM-MK %{SOURCE11} %{SOURCE12} \
  80. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  81. #
  82. # install script( bytecompile el and install elc , remove )
  83. #
  84. %_installemacsenscript %{origname} %{SOURCE9}
  85. %_removeemacsenscript %{origname} %{SOURCE10}
  86. %post
  87. #
  88. # bytecompile and install
  89. #
  90. if [ "$1" = 2 ]; then
  91. %_emacsenPackageRemove %{origname}
  92. fi
  93. %_addemacsenlist %{origname}
  94. %_emacsenPackageInstall %{origname}
  95. %preun
  96. if [ "$1" = 0 ]; then
  97. %_emacsenPackageRemove %{origname}
  98. %_removeemacsenlist %{origname}
  99. fi
  100. %clean
  101. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  102. rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
  103. %files
  104. %defattr(-,root,root)
  105. %doc *.html hhm.dot.emacs
  106. %{_datadir}/emacs/site-lisp/%{origname}
  107. %{emacsen_pkgdir}/install/%{origname}
  108. %{emacsen_pkgdir}/remove/%{origname}
  109. %changelog
  110. * Sun Feb 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.19.1.1-8
  111. - updated html-helper-mode-init.el
  112. * Mon Apr 19 2010 IWAI, Masaharu <iwai@alib.jp> 2.19.1.1-7
  113. - fix html-helper-mode-install.sh: installing vine-default file
  114. * Wed Apr 7 2010 IWAI, Masaharu <iwai@alib.jp> 2.19.1.1-6
  115. - apply vine-default
  116. - add vine-default (Source11)
  117. - add init.el (Source12)
  118. - update html-helper-mode-{install,removce}.sh for init.el file
  119. - using %%{emacsen_pkgdir} macro
  120. - update %%description
  121. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.19.1.1-5
  122. - spec in utf8
  123. - applied new versioning policy
  124. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.19.1.1-4vl3
  125. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  126. - s/Copyright/License/
  127. * Wed Jan 2 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.19.1.1-4vl2
  128. - emacsenize
  129. - rewrite Summary and %%description for emacesnize
  130. * Sun Oct 15 2000 Jun Nishii <jun@vinelinux.org>
  131. - 2.19.1.1-4vl1
  132. - rebuid for Vine Linux 2.1/emacs-20.7
  133. * Mon Apr 17 2000 Jun Nishii <jun@vinelinux.org>
  134. - rebuid for Vine Linux 2.0
  135. * Fri Dec 17 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  136. - Released as version "html-helper-mode-emacs20-2.19.1.1-3".
  137. Changed from "html-helper-mode-emacs20-2.19.1.1-2".
  138. - Changed emacs version, "20.4" => "20.5".
  139. - Revised some, the definition part of data.
  140. * Thu Dec 2 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  141. - Released as version "html-helper-mode-emacs20-2.19.1.1-2".
  142. Changed from "html-helper-mode-emacs20-2.19.1.1-1".
  143. - Added source file, "HHM-MK".
  144. - Revised some, the definition part of data.
  145. - Revised some, part of "%description, %build".
  146. * Thu Nov 25 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  147. - Released as version "html-helper-mode-emacs20-2.19.1.1-1".
  148. # $Id: html-helper-mode-emacs20-2.19.1.1.spec,v 1.7 1999-12-17 17:50:58+09 ushio Exp $