ibus-el-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origname ibus-el
  4. %define origver 0.3.2
  5. Summary: a IBus client for GNU Emacs
  6. Summary(ja): GNU Emacs 用 IBus クライアント
  7. Name: %{origname}
  8. Version: %{origver}
  9. Release: 1%{?_dist_release}
  10. # http://launchpad.net/ibus.el
  11. Source0: http://launchpad.net/ibus.el/0.3/0.3.1/+download/ibus-el-%{version}.tar.gz
  12. Source1: %{origname}-install.sh
  13. Source2: %{origname}-remove.sh
  14. Source3: vine-default-%{origname}.el
  15. Source4: %{origname}-init.el
  16. # Patch0: ibus-el-0.2.1-emacs-24.0.90.patch
  17. # Patch1: ibus-el-0.3.0-disable-surrounding-text.patch
  18. License: GPLv3
  19. Group: Applications/Editors/Emacs
  20. URL: http://www11.atwiki.jp/s-irie/pages/21.html
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildArch: noarch
  23. Requires: emacsen
  24. Requires(post): emacsen
  25. %prereq_ge emacsen-common
  26. Requires: python >= 2.5
  27. Requires: ibus >= 1.2
  28. Requires: python-xlib
  29. Distribution: Vine Linux
  30. Vendor: Project Vine
  31. Packager: iwaim, munepi
  32. %description
  33. ibus.el is a IBus client for GNU Emacs. This program allows users
  34. on-the-spot style input with IBus. The input statuses are individually
  35. kept for each buffer, and prefix-keys such as C-x and C-c can be used
  36. even if IBus is active. So you can input various languages fast and
  37. comfortably by using it.
  38. %prep
  39. %setup -q -n %{origname}-%{origver}
  40. #%patch0 -p1 -b .emacs24
  41. #%if %{?_dist_release} == "vl6"
  42. #%patch1 -p1 -b .surrounding
  43. #%endif
  44. %build
  45. %install
  46. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  47. [ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
  48. mkdir -p %{buildroot}%{_datadir}/%{name}
  49. install -m 0755 ibus-el-agent %{buildroot}%{_datadir}/%{name}
  50. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  51. mkdir -p %{buildroot}%{emacsen_pkgdir}/install
  52. mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
  53. #
  54. # install el files
  55. #
  56. cp -p *.el %{SOURCE3} %{SOURCE4} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  57. #
  58. # install script (bytecompile el and install elc , remove)
  59. #
  60. %_installemacsenscript %{origname} %{SOURCE1}
  61. %_removeemacsenscript %{origname} %{SOURCE2}
  62. %clean
  63. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  64. %post
  65. #
  66. # bytecompile and install
  67. #
  68. if [ "$1" = 2 ]; then
  69. %_emacsenPackageRemove %{origname}
  70. fi
  71. %_addemacsenlist %{origname}
  72. %_emacsenPackageInstall %{origname}
  73. %preun
  74. if [ "$1" = 0 ]; then
  75. %_emacsenPackageRemove %{origname}
  76. %_removeemacsenlist %{origname}
  77. fi
  78. %files
  79. %defattr(-,root,root)
  80. %doc README doc/COPYING doc/ChangeLog
  81. %{_datadir}/emacs/site-lisp/%{origname}
  82. %{emacsen_pkgdir}/install/%{origname}
  83. %{emacsen_pkgdir}/remove/%{origname}
  84. %dir %{_datadir}/%{name}
  85. %{_datadir}/%{name}/ibus-el-agent
  86. %changelog
  87. * Thu Mar 8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-1
  88. - new upstream release
  89. * Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.1-1
  90. - new upstream release
  91. * Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.0-3
  92. - apply ibus-el-0.3.0-disable-surrounding-text.patch (for vl6)
  93. * Mon Feb 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.0-2
  94. - fix a typo in ibus-el-init.el
  95. * Tue Jan 31 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.0-1
  96. - new upstream release
  97. - added "munepi" in Packager tag
  98. * Mon Oct 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.2.1-3
  99. - supported emacs-24.0.90
  100. - updated ibus-el-init.el
  101. - output "Loading vine-default-ibus-el ..." to the buffer *Messages*
  102. * Tue Apr 5 2011 IWAI, Masaharu <iwai@alib.jp> 0.2.1-2vl6
  103. - fix <BTS:VineLinux:1117>
  104. - update vine-default-ibus-el.el (Source3): sync [VineSeed:22997]
  105. * Wed Nov 24 2010 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
  106. - new upstream release
  107. * Tue Aug 31 2010 IWAI, Masaharu <iwai@alib.jp> 0.2.0-1
  108. - new upstream release
  109. * Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
  110. - new upstream release
  111. * Mon Jun 7 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
  112. - first release for Vine Linux