icedtea-web-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246
  1. # We require at the least the first release java-1.6.0-openjdk
  2. # with IcedTea6 1.10
  3. %define min_openjdk_version 1.6.0.0-60
  4. %define multilib_arches ppc64 sparc64 x86_64
  5. # Version of java
  6. %define javaver 1.7.0
  7. # Alternatives priority
  8. %define priority 17000
  9. %ifarch %{ix86}
  10. %define archinstall i386
  11. %endif
  12. %ifarch x86_64
  13. %define archinstall amd64
  14. %endif
  15. # 32 bit sparc, optimized for v9
  16. %ifarch sparcv9
  17. %define archinstall sparc
  18. %endif
  19. # 64 bit sparc
  20. %ifarch sparc64
  21. %define archinstall sparcv9
  22. %endif
  23. %ifarch %{multilib_arches}
  24. %define javadir %{_jvmdir}/java-%{javaver}-openjdk.%{_arch}
  25. %define jredir %{_jvmdir}/jre-%{javaver}-openjdk.%{_arch}
  26. %define jre6dir %{_jvmdir}/jre-1.6.0-openjdk.%{_arch}
  27. %define javaplugin libjavaplugin.so.%{_arch}
  28. %else
  29. %define javadir %{_jvmdir}/java-%{javaver}-openjdk
  30. %define jredir %{_jvmdir}/jre-%{javaver}-openjdk
  31. %define jre6dir %{_jvmdir}/jre-1.6.0-openjdk
  32. %define javaplugin libjavaplugin.so
  33. %endif
  34. %define binsuffix .itweb
  35. Name: icedtea-web
  36. Version: 1.4.1
  37. Release: 1%{?_dist_release}
  38. Summary: Java browser plug-in and Web Start implementation
  39. Summary(ja): Java ブラウザプラグイン
  40. Group: Applications/Internet
  41. License: LGPLv2+ and GPLv2 with exceptions
  42. URL: http://icedtea.classpath.org/wiki/IcedTea-Web
  43. Source0: http://icedtea.classpath.org/download/source/%{name}-%{version}.tar.gz
  44. BuildRequires: java-%{javaver}-openjdk-devel
  45. BuildRequires: desktop-file-utils
  46. BuildRequires: gecko-devel
  47. BuildRequires: glib2-devel
  48. BuildRequires: xulrunner-devel
  49. # For functionality and the OpenJDK dirs
  50. Requires: java-%{javaver}-openjdk
  51. # Post requires alternatives to install plugin alternative.
  52. Requires(post): alternatives
  53. # Postun requires alternatives to uninstall plugin alternative.
  54. Requires(postun): alternatives
  55. # Standard JPackage plugin provides.
  56. Provides: java-plugin = %{javaver}
  57. Provides: javaws = %{javaver}
  58. Provides: java-1.7.0-openjdk-plugin
  59. Obsoletes: java-1.6.0-openjdk-plugin <= %{min_openjdk_version}
  60. # IcedTea is only built on these archs for now
  61. ExclusiveArch: x86_64 i686 %{arm}
  62. %description
  63. The IcedTea-Web project provides a Java web browser plugin, an implementation
  64. of Java Web Start (originally based on the Netx project) and a settings tool to
  65. manage deployment settings for the aforementioned plugin and Web Start
  66. implementations.
  67. %package javadoc
  68. Summary: API documentation for IcedTea-Web
  69. Summary(ja): API documentation for IcedTea-Web
  70. Group: Documentation
  71. Requires: jpackage-utils
  72. BuildArch: noarch
  73. %description javadoc
  74. This package contains Javadocs for the IcedTea-Web project.
  75. %prep
  76. %setup -q
  77. %build
  78. autoconf
  79. ./configure \
  80. --with-pkgversion=vine-%{release}-%{_arch} \
  81. --docdir=%{_datadir}/javadoc/%{name} \
  82. --with-jdk-home=%{javadir} \
  83. --with-jre-home=%{jredir} \
  84. --libdir=%{_libdir} \
  85. --program-suffix=%{binsuffix} \
  86. --prefix=%{_prefix}
  87. make CXXFLAGS="$RPM_OPT_FLAGS"
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. make install DESTDIR=$RPM_BUILD_ROOT
  91. # Move javaws man page to a more specific name
  92. mv $RPM_BUILD_ROOT/%{_mandir}/man1/javaws.1 $RPM_BUILD_ROOT/%{_mandir}/man1/javaws-itweb.1
  93. # Install desktop files.
  94. install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/{applications,pixmaps}
  95. cp javaws.png $RPM_BUILD_ROOT%{_datadir}/pixmaps
  96. desktop-file-install --vendor ''\
  97. --dir $RPM_BUILD_ROOT%{_datadir}/applications javaws.desktop
  98. desktop-file-install --vendor ''\
  99. --dir $RPM_BUILD_ROOT%{_datadir}/applications itweb-settings.desktop
  100. mkdir -p $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/
  101. %post
  102. if [ $1 -gt 1 ]
  103. then
  104. alternatives --remove %{javaplugin} \
  105. %{jre6dir}/lib/%{archinstall}/IcedTeaPlugin.so 2>/dev/null || :
  106. fi
  107. %posttrans
  108. update-desktop-database &> /dev/null || :
  109. alternatives \
  110. --install %{_libdir}/mozilla/plugins/libjavaplugin.so %{javaplugin} \
  111. %{_libdir}/IcedTeaPlugin.so %{priority} \
  112. --slave %{_bindir}/javaws javaws %{_prefix}/bin/javaws%{binsuffix} \
  113. --slave %{_mandir}/man1/javaws.1.gz javaws.1.gz \
  114. %{_mandir}/man1/javaws-itweb.1.gz
  115. exit 0
  116. %postun
  117. update-desktop-database &> /dev/null || :
  118. if [ $1 -eq 0 ]
  119. then
  120. alternatives --remove %{javaplugin} \
  121. %{_libdir}/IcedTeaPlugin.so
  122. fi
  123. exit 0
  124. %files
  125. %defattr(-,root,root,-)
  126. %doc NEWS README COPYING
  127. %{_prefix}/bin/*
  128. %{_libdir}/IcedTeaPlugin.so
  129. %{_datadir}/applications/*
  130. %{_datadir}/icedtea-web
  131. %{_datadir}/man/man1/*
  132. %{_datadir}/pixmaps/*
  133. %dir %{_libdir}/mozilla/plugins/
  134. %files javadoc
  135. %defattr(-,root,root,-)
  136. %{_datadir}/javadoc/%{name}
  137. %doc COPYING
  138. %changelog
  139. * Fri Dec 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  140. - update to 1.4.1
  141. * Mon Mar 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-1
  142. - update to 1.3.1
  143. * Mon Sep 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  144. - initial build for Vine Linux
  145. * Tue Jul 31 2012 Deepak Bhole <dbhole@redhat.com> 1.2.1-1
  146. - Updated to 1.2.1
  147. - Resolves: RH840592/CVE-2012-3422
  148. - Resolves: RH841345/CVE-2012-3423
  149. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
  150. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  151. * Thu May 03 2012 Deepak Bhole <dbhole@redhat.com> 1.2-4
  152. - Resolves rhbz#814585
  153. - Fixed java-plugin provides and added one for javaws
  154. * Tue Apr 17 2012 Deepak Bhole <dbhole@redhat.com> 1.2-3
  155. - Updated summary
  156. - Fixed virtual provide
  157. * Tue Mar 13 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.2-2
  158. - Enable building on ARM platforms
  159. * Mon Mar 05 2012 Deepak Bhole <dbhole@redhat.com> 1.2-1
  160. - Updated to 1.2
  161. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-4
  162. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  163. * Fri Nov 25 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-3
  164. - Resolves rhbz#757191
  165. - Bumped min_openjdk_version to -60 (latest)
  166. * Thu Nov 24 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-2
  167. - Resolves: rhbz#742887. Do not own directories not created by the package.
  168. * Tue Nov 08 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-1
  169. - Updated to 1.1.4
  170. - Added npapi-fix patch so that the plug-in compiles with xulrunner 8
  171. * Thu Sep 01 2011 Deepak Bhole <dbhole@redhat.com> 1.1.2-1
  172. - Updated to 1.1.2
  173. - Removed all patches (now upstream)
  174. - Resolves: rhbz# 734890
  175. * Tue Aug 23 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-3
  176. - Added patch to allow install to jre dir
  177. - Fixed requirement for java-1.7.0-openjdk
  178. * Tue Aug 09 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-2
  179. - Fixed file ownership so that debuginfo is not in main package
  180. * Wed Aug 03 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-1
  181. - Bump to 1.1.1
  182. - Added patch for PR768 and PR769
  183. * Wed Jul 20 2011 Deepak Bhole <dbhole@redhat.com> 1.0.4-1
  184. - Bump to 1.0.4
  185. - Fixed rhbz#718164: Home directory path disclosure to untrusted applications
  186. - Fixed rhbz#718170: Java Web Start security warning dialog manipulation
  187. * Mon Jun 13 2011 Deepak Bhole <dbhole@redhat.com> 1.0.3-1
  188. - Update to 1.0.3
  189. - Resolves: rhbz#691259
  190. * Mon Apr 04 2011 Deepak Bhole <dbhole@redhat.com> 1.0.2-2
  191. - Fixed incorrect macro value for min_openjdk_version
  192. - Use posttrans instead of post, so that upgrade from old plugin works
  193. * Mon Apr 04 2011 Deepak Bhole <dbhole@redhat.com> 1.0.2-1
  194. - Initial build