iscan-vl.spec 2.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. # Macro definitions
  2. %define ver 1.10.0
  3. %define rel 3
  4. %define epsane_ver 1.0.6
  5. %define epsane_maj 1
  6. Summary: Image Scan! for Linux is the frontend for epson scanners
  7. Summary(ja): Image Scan! for Linux - EPSON 製スキャナ用のフロントエンド
  8. Name: iscan
  9. Version: %{ver}
  10. Release: %{rel}vl1
  11. License: GPL (with exception clause)/EKPL
  12. URL: http://www.epkowa.co.jp/
  13. Source: iscan-%{ver}-%{rel}.tar.gz
  14. Group: Applications/Multimedia
  15. Requires: sane >= 1.0.3
  16. BuildRoot: /var/tmp/%{name}-%{version}-root
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  20. %description
  21. Image Scan! for Linux is the frontend for epson scanners
  22. %description -l ja
  23. iscan (Image Scan! for Linux) は EPSON 製スキャナ用のフロントエンド
  24. です。
  25. %prep
  26. %setup -q
  27. %build
  28. %configure
  29. make %{?_smp_mflags}
  30. %install
  31. rm -rf ${RPM_BUILD_ROOT}
  32. %makeinstall
  33. %clean
  34. rm -rf ${RPM_BUILD_ROOT}
  35. %post
  36. config=%{_sysconfdir}/sane.d/dll.conf
  37. if test -z "$(grep epkowa $config)"; then
  38. echo Adding the SANE epkowa backend for EPSON scanners to $config
  39. echo Your old configuration is saved in $config.orig
  40. cp $config $config.orig
  41. echo epkowa >> $config
  42. fi
  43. if test -n "$(grep '#[[:space:]]*epkowa' $config)"; then
  44. echo Enabling SANE epkowa backend for EPSON scanners in $config
  45. echo Your old configuration is saved in $config.orig
  46. mv $config $config.orig
  47. sed 's,#[[:space:]]*\(epkowa\),\1,' $config.orig > $config
  48. fi
  49. if test -z "$(grep 6566/tcp %{_sysconfdir}/services)"; then
  50. echo Adding the sane service to %{_sysconfdir}/services
  51. echo The original file is saved in %{_sysconfdir}/services.orig
  52. cp %{_sysconfdir}/services %{_sysconfdir}/services.orig
  53. echo "sane 6566/tcp saned # SANE network scanner daemon" >> %{_sysconfdir}/services
  54. fi
  55. %preun
  56. if [ $1 = 0 ]
  57. then
  58. rm -f %{_libdir}/sane/libsane-epson.so
  59. rm -f %{_libdir}/sane/libsane-epson.so.%{epsane_maj}
  60. fi
  61. %files
  62. %defattr(-,root,root)
  63. %doc README README.ja
  64. %doc COPYING COPYING.LIB COPYING.KOWA COPYING.KOWA.ja
  65. %doc doc/xinetd.sane
  66. %{_sysconfdir}/sane.d/epkowa.conf
  67. %{_bindir}/iscan
  68. %{_libdir}/libesmod.so*
  69. %{_libdir}/libesint*.so*
  70. %{_libdir}/sane/libsane-epkowa.so*
  71. %{_datadir}/iscan/esf*.bin
  72. %{_datadir}/locale/*/LC_MESSAGES/iscan.mo
  73. %{_mandir}/man1/*
  74. %changelog
  75. * Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-3vl1
  76. - new upstream release
  77. * Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-0vl1
  78. - initial build for Vine Linux based on epkowa package.
  79. - use rpmmacros