iverilog-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199
  1. # TODO for 1.0 release - redefine
  2. #Version: 0.9.%{snapshot}
  3. #Release: 6%{?dist}
  4. # to
  5. #Version: 1.0
  6. #Release: 1.snap%{snapshot}%{?dist}
  7. #
  8. # Test suite for iverilog is detailed on
  9. # https://fedorahosted.org/fedora-electronic-lab/wiki/Testing/iverilog
  10. # Please execute the testsuite as explained before pushed a new release to stable repos
  11. #
  12. %define snapshot 20091230
  13. Name: iverilog
  14. Version: 0.9.7
  15. Release: 3%{?_dist_release}
  16. Summary: A Verilog simulation and synthesis tool
  17. Group: Applications/Engineering
  18. License: GPLv2
  19. URL: http://iverilog.icarus.com/
  20. # Development Snapshot Download :
  21. # git clone git://icarus.com/~steve-icarus/verilog
  22. # cd verilog
  23. # git checkout --track -b v0_9-branch origin/v0_9-branch
  24. # This is the latest stable snapshot
  25. Source0: ftp://ftp.icarus.com/pub/eda/verilog/v0.9/verilog-%{version}.tar.gz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: autoconf
  28. BuildRequires: bison
  29. BuildRequires: bzip2-devel
  30. BuildRequires: flex
  31. BuildRequires: gperf
  32. BuildRequires: ncurses-devel
  33. BuildRequires: readline-devel
  34. BuildRequires: zlib-devel
  35. %description
  36. Icarus Verilog is a Verilog compiler that generates a variety of
  37. engineering formats, including simulation. It strives to be true
  38. to the IEEE-1364 standard.
  39. %package devel
  40. Summary: Icarus Verilog devel files
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. %description devel
  44. Icarus Verilog devel files.
  45. %prep
  46. %setup -q -n verilog-%{version}
  47. #sh autoconf.sh
  48. # clean junks from tarball
  49. find . -type f -name ".git" -exec rm '{}' \;
  50. rm -rf `find . -type d -name "autom4te.cache" -exec echo '{}' \;`
  51. %build
  52. CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" \
  53. %configure
  54. make %{?_smp_mflags}
  55. %install
  56. rm -rf %{buildroot}
  57. make prefix=%{buildroot}%{_prefix} \
  58. bindir=%{buildroot}%{_bindir} \
  59. libdir=%{buildroot}%{_libdir} \
  60. libdir64=%{buildroot}%{_libdir} \
  61. includedir=%{buildroot}%{_includedir} \
  62. mandir=%{buildroot}%{_mandir} \
  63. vpidir=%{buildroot}%{_libdir}/ivl/ \
  64. INSTALL="install -p" \
  65. install
  66. %check
  67. make check
  68. %clean
  69. rm -rf %{buildroot}
  70. %files
  71. %defattr(-,root,root,-)
  72. # contents of QUICK_START.txt can be found also on README.txt, hence omitted
  73. %doc attributes.txt BUGS.txt COPYING extensions.txt glossary.txt ieee1364-notes.txt
  74. %doc README.txt swift.txt netlist.txt t-dll.txt vpi.txt tgt-fpga/fpga.txt
  75. %doc va_math.txt cadpli/cadpli.txt xilinx-hint.txt examples/
  76. %{_bindir}/*
  77. %{_libdir}/ivl
  78. %{_mandir}/man1/*
  79. %files devel
  80. %defattr(-,root,root,-)
  81. # headers for PLI: This is intended to be used by the user.
  82. %{_includedir}/*.h
  83. # RHBZ 480531
  84. %{_libdir}/*.a
  85. %changelog
  86. * Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> - 0.9.7-3
  87. - rebuild with gcc-5.4.0
  88. * Sun Apr 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.9.7-2
  89. - rebuilt with readline 6.3
  90. * Sun Feb 1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.9.7-1
  91. - updated to 0.9.7
  92. - built on current VineSeed
  93. - added BR: ncurses-devel, readline-devel
  94. * Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.2-1
  95. - Initial build for Vine Linux
  96. * Wed Dec 30 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091230-1
  97. - New stable snapshot - 0.9.2
  98. * Sat Dec 12 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091212-1
  99. - New development snapshot - 0.9.2 final prerelease snapshot
  100. * Sat Dec 05 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091205-1
  101. - New development snapshot - 0.9.2 prerelease snapshot
  102. * Fri Dec 04 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091204-1
  103. - New development snapshot - 0.9.2 prerelease snapshot
  104. * Sat Nov 28 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091130-1
  105. - New development snapshot
  106. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.20090423-6
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  108. * Mon Jun 13 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20090423-5
  109. - Improved VPI support
  110. * Mon Mar 23 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20081118-4
  111. - new development release
  112. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.20081118-2
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  114. * Sun Dec 07 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20081118-1
  115. - new snapshot release upstream.
  116. * Fri Sep 12 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080905-1
  117. - new snapshot release upstream.
  118. * Mon May 26 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080429-1
  119. - new snapshot release upstream.
  120. * Fri Mar 28 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080314-1
  121. - new snapshot release upstream.
  122. - add check section for some tests
  123. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.20070608-2
  124. - Autorebuild for GCC 4.3
  125. * Sun Jun 10 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070608-1
  126. - new snapshot release upstream.
  127. * Mon Apr 23 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070421-1
  128. - new snapshot release upstream.
  129. * Thu Feb 27 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070227-1
  130. - new snapshot release.
  131. * Thu Feb 27 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070123-5
  132. - clean junks from tarball
  133. - exlude static library
  134. - smp build seems fine
  135. - use snapshot instead of cvsver macro
  136. - follow package n-v-r from fedora standard
  137. * Thu Feb 23 2007 Balint Cristian <cbalint@redhat.com> 20070123-4
  138. - use cvsver macro
  139. - move examples in main.
  140. - more spec cleanup
  141. * Thu Feb 23 2007 Balint Cristian <cbalint@redhat.com> 20070123-3
  142. - buildroot coherency in spec
  143. * Thu Feb 22 2007 Balint Cristian <cbalint@redhat.com> 20070123-2
  144. - first build for fedora-extras
  145. - request gnu/stubs-32.h to force working gcc in 32 bit enviroment
  146. - fix PAGE_SIZE wich is missing on some arch
  147. - dont use libdir macro, all library always will be 32 bit
  148. * Thu Feb 22 2007 Balint Cristian <cbalint@redhat.com> 20070123-1
  149. - initial release