kBuild-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. %define origver 0.1.9998
  2. %define svnrev 2662
  3. Summary: A cross-platform build environment
  4. Summary(ja): クロスプラットフォームビルド環境
  5. Name: kBuild
  6. Version: 0.1.9998
  7. Release: 2.svn%{svnrev}%{?_dist_release}
  8. Group: Development/Tools
  9. License: BSD and GPLv2+
  10. # most tools are from NetBSD, some are from FreeBSD,
  11. # and make and sed are from GNU
  12. URL: http://svn.netlabs.org/kbuild
  13. #Source0: ftp://ftp.netlabs.org/pub/kbuild/%{name}-%{origver}-src.tar.gz
  14. Source0: kBuild-0.1.9998.svn%{svnrev}.tar.bz2
  15. Patch0: kBuild-0.1.3-escape.patch
  16. Patch1: kBuild-0.1.5-dprintf.patch
  17. Patch2: kBuild-0.1.5-pthread.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: byacc libacl-devel flex
  20. BuildRequires: autoconf automake gettext-devel cvs subversion
  21. %description
  22. This is a GNU make fork with a set of scripts to simplify
  23. complex tasks and portable versions of various UNIX tools to
  24. ensure cross-platform portability.
  25. It is used mainly to build VirtualBox OSE packages for RPM Fusion
  26. repository.
  27. %prep
  28. %setup -q -n %{name}-%{origver}.svn%{svnrev}
  29. %patch0 -p1 -b .escape
  30. %patch1 -p1 -b .dprintf
  31. %patch2 -p1 -b .pthreads
  32. # Remove prebuilt stuff
  33. rm -rf kBuild/bin/*
  34. %build
  35. %define bootstrap_mflags %{_smp_mflags} \\\
  36. CFLAGS="%{optflags}" \\\
  37. KBUILD_VERBOSE=2
  38. %define mflags %{bootstrap_mflags} \\\
  39. NIX_INSTALL_DIR=%{_prefix} \\\
  40. BUILD_TYPE=release \\\
  41. MY_INST_MODE=0644 \\\
  42. MY_INST_BIN_MODE=0755
  43. # The bootstrap would probably not be needed if we depended on ourselves,
  44. # yet it is not guarranteed that new versions are compilable with older
  45. # kmk versions, so with this we are on a safer side
  46. kBuild/env.sh --full make -f bootstrap.gmk %{bootstrap_mflags}
  47. kBuild/env.sh kmk %{mflags} rebuild
  48. %install
  49. rm -rf $RPM_BUILD_ROOT
  50. export KBUILD_VERBOSE=2
  51. kBuild/env.sh kmk %{mflags} PATH_INS=$RPM_BUILD_ROOT install
  52. # These are included later in files section
  53. rm -r $RPM_BUILD_ROOT%{_docdir}
  54. %clean
  55. rm -rf $RPM_BUILD_ROOT
  56. %files
  57. %defattr(-,root,root,-)
  58. %{_bindir}/*
  59. %{_datadir}/*
  60. %doc COPYING ChangeLog
  61. %doc kBuild/doc/COPYING-FDL-1.3 kBuild/doc/QuickReference*
  62. %changelog
  63. * Fri Sep 14 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.9998-2.svn2662
  64. - updated to 0.1.9998 (svn rev 2662)
  65. * Wed Aug 24 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.9998-1.svn2543
  66. - updated to 0.1.9998 (svn rev 2543)
  67. * Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5p2-1
  68. - update to 0.1.5-p2
  69. - add patch2 to fix build
  70. * Fri May 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5-1
  71. - initial build for Vine Linux
  72. * Mon Apr 13 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-4
  73. - Fix typoes (Robert P. J. Day, #495393)
  74. - Comment out the colliding dprintf
  75. * Sun Mar 1 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-3
  76. - Fix up BRs
  77. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.5-2
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  79. * Sat Jan 24 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-1
  80. - Update to new upstream release
  81. * Tue Dec 30 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-0.1.20081106svn
  82. - Update to build VirtualBox OSE 2.1.0
  83. * Fri Sep 19 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.4-1
  84. - New upstream release
  85. * Thu Aug 28 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-2
  86. - Add gettext-devel to BRs for autopoint
  87. * Sun Aug 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-1
  88. - New upstream version
  89. - Install into FHS hierarchy
  90. - Honour optflags
  91. - No need to be arch specific
  92. * Tue Oct 30 2007 Till Maas <opensource till name> - 0.1.0-0.3.20070627svn
  93. - add support for x86_64
  94. - add BR: autoconf, automake
  95. * Wed Jun 27 2007 Till Maas <opensource till name> - 0.1.0-0.2.20070627svn
  96. - Update to a new version
  97. - just copy the bin files to %%{_libexecdir}, kmk install does not work
  98. * Sun Feb 18 2007 Till Maas <opensource till name> - 0.1.0-0.1.20070218svn
  99. - Initial spec for fedora extras