kbd-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479
  1. %global convert_xkb 0
  2. # {_exec_prefix}/lib/kbd is correct even on x86_64.
  3. # It is traditionally used for kdb data (console fonts, keymaps, ...).
  4. # It is not used for any shared objects/executables.
  5. %global kbd_datadir /lib/kbd
  6. Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
  7. Summary(ja): コンソール(キーボードや仮想ターミナル等)を設定するツール群
  8. Name: kbd
  9. Version: 2.2.0
  10. Release: 1%{?_dist_release}
  11. Group: System Environment/Base
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: GPL
  15. Source0: https://www.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.xz
  16. Source1: kbd-latsun-fonts.tar.bz2
  17. Source2: kbd-latarcyrheb-32.tar.bz2
  18. Source3: xml2lst.pl
  19. Source4: vlock.pamd
  20. Source5: kbdinfo.1
  21. Source6: cz-map.patch
  22. Requires: pam >= 0.66-4, /etc/pam.d/system-auth, usermode
  23. BuildRequires: bison, flex, gettext, pam-devel
  24. %if 0%{convert_xkb}
  25. BuildRequires: console-setup
  26. %endif
  27. BuildRoot: %{_tmppath}/%{name}-root
  28. # Patch0: puts additional information into man pages
  29. Patch0: kbd-1.15-keycodes-man.patch
  30. # Patch1: sparc modifications
  31. Patch1: kbd-1.15-sparc.patch
  32. # Patch2: adds default unicode font to unicode_start script
  33. Patch2: kbd-1.15-unicode_start.patch
  34. # Patch3: add missing dumpkeys option to man page
  35. Patch3: kbd-1.15.3-dumpkeys-man.patch
  36. # Patch4: fixes decimal separator in Swiss German keyboard layout, bz 882529
  37. Patch4: kbd-1.15.5-sg-decimal-separator.patch
  38. # Patch5: adds xkb and legacy keymaps subdirs to loadkyes search path, bz 1028207
  39. Patch5: kbd-1.15.5-loadkeys-search-path.patch
  40. # Patch6: don't hardcode font used in unicode_start, take it from vconsole.conf,
  41. # bz 1101007
  42. Patch6: kbd-2.0.2-unicode-start-font.patch
  43. # Patch7: fixes issues found by static analysis
  44. Patch7: kbd-2.0.4-covscan-fixes.patch
  45. # Patch8: fix flags
  46. Patch8: kbd-2.2.0-fix-flags.patch
  47. # Patch9: workaround -Werror=format-security build error
  48. Patch9: kbd-2.2.0-format-security.patch
  49. Obsoletes: console-tools open
  50. Provides: console-tools open
  51. Conflicts: util-linux < 2.11r-9
  52. Requires(pre): initscripts >= 5.86-1
  53. ExcludeArch: s390 s390x
  54. %description
  55. The %{name} package contains tools for managing a Linux
  56. system's console's behavior, including the keyboard, the screen
  57. fonts, the virtual terminals and font files.
  58. %prep
  59. %setup -q -a 1 -a 2
  60. cp -fp %{SOURCE3} .
  61. cp -fp %{SOURCE6} .
  62. %patch0 -p1 -b .keycodes-man
  63. %patch1 -p1 -b .sparc
  64. %patch2 -p1 -b .unicode_start
  65. %patch3 -p1 -b .dumpkeys-man
  66. %patch4 -p1 -b .sg-decimal-separator
  67. %if 0%{convert_xkb}
  68. %patch5 -p1 -b .loadkeys-search-path
  69. %endif
  70. %patch6 -p1 -b .unicode-start-font
  71. %patch7 -p1 -b .covscan-fixes
  72. %patch8 -p1 -b .fix-flags
  73. %patch9 -p1 -b .format-security
  74. # 7-bit maps are obsolete; so are non-euro maps
  75. pushd data/keymaps/i386
  76. cp qwerty/pt-latin9.map qwerty/pt.map
  77. cp qwerty/sv-latin1.map qwerty/se-latin1.map
  78. mv azerty/fr.map azerty/fr-old.map
  79. cp azerty/fr-latin9.map azerty/fr.map
  80. cp azerty/fr-latin9.map azerty/fr-latin0.map # legacy alias
  81. # Rename conflicting keymaps
  82. mv fgGIod/trf.map fgGIod/trf-fgGIod.map
  83. mv olpc/es.map olpc/es-olpc.map
  84. mv olpc/pt.map olpc/pt-olpc.map
  85. mv qwerty/cz.map qwerty/cz-qwerty.map
  86. popd
  87. # remove obsolete "gr" translation
  88. pushd po
  89. rm -f gr.po gr.gmo
  90. popd
  91. # Convert to utf-8
  92. iconv -f iso-8859-1 -t utf-8 < "ChangeLog" > "ChangeLog_"
  93. mv "ChangeLog_" "ChangeLog"
  94. %build
  95. export OLD_PO_FILE_INPUT=yes
  96. # We don't use % {configure} because the ./configure included here does not
  97. # understand most of the options.
  98. CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
  99. #./configure --prefix=%{_prefix} --datadir=/lib/kbd --mandir=%{_mandir}
  100. %configure --prefix=%{_prefix} --datadir=%{kbd_datadir} --mandir=%{_mandir} --localedir=%{_datadir}/locale --enable-nls
  101. make %{?_smp_mflags}
  102. %install
  103. rm -rf $RPM_BUILD_ROOT
  104. # Basic install.
  105. make install DESTDIR=$RPM_BUILD_ROOT
  106. # ro_win.map.gz is useless
  107. rm -f $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/i386/qwerty/ro_win.map.gz
  108. # Create additional name for Serbian latin keyboard
  109. ln -s sr-cy.map.gz $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/i386/qwerty/sr-latin.map.gz
  110. # The rhpl keyboard layout table is indexed by kbd layout names, so we need a
  111. # Korean keyboard
  112. ln -s us.map.gz $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/i386/qwerty/ko.map.gz
  113. # Move binaries which we use before /usr is mounted from %{_bindir} to /bin.
  114. mkdir -p $RPM_BUILD_ROOT/bin
  115. for binary in setfont dumpkeys kbd_mode unicode_start unicode_stop loadkeys ; do
  116. mv $RPM_BUILD_ROOT%{_bindir}/$binary $RPM_BUILD_ROOT/bin/
  117. done
  118. # Some microoptimization
  119. sed -i -e 's,\<kbd_mode\>,/bin/kbd_mode,g;s,\<setfont\>,/bin/setfont,g' \
  120. $RPM_BUILD_ROOT/bin/unicode_start
  121. # Link open to openvt
  122. ln -s openvt $RPM_BUILD_ROOT%{_bindir}/open
  123. ln -s openvt.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/open.1.gz
  124. # install kbdinfo manpage
  125. gzip -c %SOURCE5 > $RPM_BUILD_ROOT/%{_mandir}/man1/kbdinfo.1.gz
  126. # Move locale files to correct place
  127. cp -r $RPM_BUILD_ROOT%{kbd_datadir}/locale/ $RPM_BUILD_ROOT%{_datadir}/locale
  128. rm -rf $RPM_BUILD_ROOT%{kbd_datadir}/locale
  129. # Install PAM configuration for vlock
  130. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
  131. install -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/vlock
  132. %if 0%{convert_xkb}
  133. # Move original keymaps to legacy directory
  134. mkdir -p $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/legacy
  135. mv $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/{amiga,atari,i386,include,mac,ppc,sun} $RPM_B
  136. UILD_ROOT%{kbd_datadir}/keymaps/legacy
  137. # Convert X keyboard layouts to console keymaps
  138. mkdir -p $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb
  139. perl xml2lst.pl < /usr/share/X11/xkb/rules/base.xml > layouts-variants.lst
  140. while read line; do
  141. XKBLAYOUT=`echo "$line" | cut -d " " -f 1`
  142. echo "$XKBLAYOUT" >> layouts-list.lst
  143. XKBVARIANT=`echo "$line" | cut -d " " -f 2`
  144. ckbcomp "$XKBLAYOUT" "$XKBVARIANT" | gzip > $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xk
  145. b/"$XKBLAYOUT"-"$XKBVARIANT".map.gz
  146. done < layouts-variants.lst
  147. # Convert X keyboard layouts (plain, no variant)
  148. cat layouts-list.lst | sort -u >> layouts-list-uniq.lst
  149. while read line; do
  150. ckbcomp "$line" | gzip > $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/"$line".map.gz
  151. done < layouts-list-uniq.lst
  152. # wipe converted layouts which cannot input ASCII (#1031848)
  153. zgrep -L "U+0041" $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/* | xargs rm -f
  154. # Rename the converted default fi (kotoistus) layout (#1117891)
  155. gunzip $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/fi.map.gz
  156. mv $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/fi.map $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xk
  157. b/fi-kotoistus.map
  158. gzip $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/fi-kotoistus.map
  159. # Fix converted cz layout - add compose rules
  160. gunzip $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/cz.map.gz
  161. patch $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/cz.map < %{SOURCE6}
  162. gzip $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/cz.map
  163. %endif
  164. %find_lang %{name}
  165. %clean
  166. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  167. %triggerun -- kbd < 1.08-10.2
  168. /sbin/chkconfig --del keytable || :
  169. %files -f %{name}.lang
  170. %defattr(-,root,root)
  171. %license COPYING
  172. %doc ChangeLog AUTHORS README docs/doc/kbd.FAQ*.html docs/doc/font-formats/*.html docs/doc/utf/utf* docs/doc/dvorak/*
  173. /bin/*
  174. %{_bindir}/*
  175. %{_mandir}/*/*
  176. %{kbd_datadir}
  177. %config(noreplace) %{_sysconfdir}/pam.d/vlock
  178. %changelog
  179. * Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
  180. - new upstream release.
  181. - imported Patch7-9 from rawhide.
  182. * Sun Sep 24 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
  183. - new upstream release.
  184. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12-22
  185. - rebuild with VineSeed environment
  186. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.12-21vl5
  187. - applied new versioning policy, spec in utf-8
  188. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-21vl1
  189. - initial build for Vine Linux based on Fedora package.
  190. * Tue Jan 9 2007 Miloslav Trmac <mitr@redhat.com> - 1.12-21
  191. - Add a "ko" (Korean) keyboard layout, equivalent to the "us" layout
  192. Resolves: #220151
  193. * Thu Dec 7 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-20
  194. - Document that setkeycodes doesn't affect USB keyboards and that the kernel
  195. doesn't provide the raw scan codes by default
  196. Resolves: #211803
  197. * Tue Oct 31 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-19
  198. - Ship "el" translation instead of the obsolete "gr" translation
  199. Resolves: #210749
  200. - Fix %% quoting in %%changelog
  201. * Fri Sep 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-18
  202. - Add a missing tilde to U+00E3 in latarcyrheb-sun16.psfu (#204470)
  203. * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.12-17
  204. - Obsoletes/Provides open
  205. - Create a symlink from open to openvt
  206. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.12-16.1
  207. - rebuild
  208. * Sun Jul 9 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-16
  209. - Don't include <asm/kbdio.h> on SPARC (#198040, patch by Dennis Gilmore
  210. <dennis@ausil.us>)
  211. * Mon May 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-15
  212. - Fix missing BuildRequires (#193406)
  213. * Mon Mar 27 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-14
  214. - Don't install resizecons.8 on non-x86 (#186877, patch by Keiichi Mori
  215. <kmori@redhat.com>)
  216. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.2
  217. - bump again for double-long bug on ppc(64)
  218. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.1
  219. - rebuilt for new gcc4.1 snapshot and glibc changes
  220. * Fri Jan 20 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-13
  221. - Fix build with new coreutils
  222. - Hardcode paths in unicode_start to avoid a few file lookups (#178329)
  223. - Drop unnecessary Prereq: sed mktemp
  224. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  225. - rebuilt
  226. * Thu Dec 1 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-12
  227. - Don't reload the keymap in unicode_start (#172425)
  228. * Fri Nov 11 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-11
  229. - Don't ship character set lists (they are already in glibc-common) and an
  230. obsolete copy of kbd.FAQ
  231. * Fri May 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-10
  232. - Don't attempt to open directories as source files (#141634, original patch by
  233. Paul Nasrat)
  234. * Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-9
  235. - Fix another violation of C aliasing rules (#157720, patch by Jan Kratochvil)
  236. * Sat Mar 12 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-8
  237. - Fix violation of C aliasing rules (#150440)
  238. * Sun Mar 6 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-7
  239. - Don't run ldconfig
  240. - Don't strip executables
  241. * Fri Mar 4 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-6
  242. - Rebuild with gcc4
  243. * Sun Feb 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-5
  244. - Put "Meta_acute" back in German keymaps, just ignore it in (loadkeys -u)
  245. (patch by Jochen Schmitt)
  246. - Don't ship patch backup files, simpler way
  247. * Sat Feb 19 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-4
  248. - Don't ship a patch backup file
  249. - Mention in setfont.8 that 512-glyph fonts reduce the number of available
  250. colors (#140935, patch by Dmitry Butskoj)
  251. - Remove "Meta_acute" from German keymaps (#143124)
  252. - Make the %%triggerun script condition more precise, ignore failure of the
  253. script
  254. * Mon Feb 14 2005 Adrian Havill <havill@redhat.com>
  255. - rebuilt
  256. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  257. - rebuilt
  258. * Thu Feb 26 2004 Adrian Havill <havill@redhat.com>
  259. - update to 1.12
  260. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  261. - rebuilt
  262. * Wed Jan 14 2004 Bill Nottingham <notting@redhat.com> 1.08-12
  263. - remove speakup patch at request of author
  264. * Fri Oct 10 2003 Bill Nottingham <notting@redhat.com> 1.08-11
  265. - remove keytable init script (#106783)
  266. * Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10.1
  267. - bump for RHEL
  268. * Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10
  269. - apply the rukbd patch (#78218)
  270. * Thu Jul 31 2003 Adrian Havill <havill@redhat.com> 1.08-9
  271. - don't print "plus before..." warnings about non-supported capslock
  272. in unimode <Andries.Brouwer@cwi.nl> (#81855)
  273. * Wed Jul 30 2003 Adrian Havill <havill@redhat.com> 1.08-8
  274. - replaced Russian keyboard map with working UTF-8 equivalent (#79338)
  275. * Thu Jul 24 2003 Adrian Havill <havill@redhat.com> 1.08-7
  276. - make euro/latin-9 the default instead of latin-1 and 7-bit (#97013)
  277. - fix swedish keymap; se, not sv (#88791)
  278. - add fr-latin0 legacy alias of fr-latin-9 (#88324)
  279. - add ".map" ext to filename param of init script (#90562)
  280. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  281. - rebuilt
  282. * Thu Mar 06 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  283. - build new rpm
  284. * Fri Feb 21 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  285. - ExcludeArch mainframe
  286. * Thu Jan 30 2003 Bill Nottingham <notting@redhat.com> 1.08-4
  287. - remove condrestart from initscript
  288. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  289. - rebuilt
  290. * Fri Dec 6 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-2
  291. - only output terminal unicode init sequence if both stdout and stderr are
  292. connected to terminals, so that it doesn't show up when script outputs
  293. get piped to files
  294. * Fri Nov 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-1
  295. - update to 1.08
  296. - drop updates which went mainline
  297. * Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-27
  298. - add detached signature
  299. - remove directory names from PAM configuration so that the same config file
  300. can be used for any arch on multilib systems
  301. * Wed Sep 4 2002 Bill Nottingham <notting@redhat.com> 1.06-26
  302. - don't munge /etc/sysconfig/i18n
  303. * Tue Sep 3 2002 Bill Nottingham <notting@redhat.com> 1.06-25
  304. - don't run setsysfont in upgrade trigger on console-tools
  305. * Thu Aug 29 2002 Jakub Jelinek <jakub@redhat.com> 1.06-24
  306. - use cyr-sun16 cyrillic chars in latarcyrheb-sun16 font
  307. instead of old LatArCyrHeb-16 chars
  308. - add Euro character to latarcyrheb-sun16
  309. - use latarcyrheb-sun16 by default in unicode_start script
  310. * Tue Aug 27 2002 Jakub Jelinek <jakub@redhat.com> 1.06-23
  311. - add back lat[02]-sun16 fonts plus latarcyrheb-sun16 font
  312. * Thu Aug 22 2002 Karsten Hopp <karsten@redhat.de>
  313. - needs to conflict with older util-linux packages
  314. (kbdrate moved between packages)
  315. * Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 1.06-21
  316. - remove Evil Hack in favor of slightly-less-evil-hack in initscripts
  317. * Tue Jul 9 2002 Bill Nottingham <notting@redhat.com> 1.06-20
  318. - fix speakup keymap names
  319. * Tue Jul 09 2002 Phil Knirsch <pknirsch@redhat.com> 1.06-19
  320. - Evil hack to make setfont work correctly on all consoles (#68018)
  321. * Thu Jun 27 2002 Bill Nottingham <notting@redhat.com> 1.06-18
  322. - move unicode_stop to /bin too
  323. - fix path to loadkeys in keytable.init
  324. - add in speakup keymaps
  325. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  326. - automated rebuild
  327. * Tue Jun 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-16
  328. - fix incorrect path in console.apps configuration file
  329. * Thu May 30 2002 Bill Nottingham <notting@redhat.com> 1.06-14
  330. - move some more stuff to /bin (unicode_start and dependencies)
  331. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  332. - automated rebuild
  333. * Mon Feb 25 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-12
  334. - Rebuild in new environment
  335. * Wed Jan 30 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-11
  336. - Oops, actually list the pam files in %%files
  337. * Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-10
  338. - Add and consolehelper'ify kbdrate
  339. * Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-9
  340. - Re-remove kbdrate
  341. * Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-7
  342. - Fix build in current environment
  343. - Get rid of kbdrate, it's in util-linux these days
  344. * Wed Jul 18 2001 Matt Wilson <msw@redhat.com>
  345. - added a patch (Patch4) that allows --tty= in setfont
  346. - modified patch not to break translations
  347. * Tue Jul 3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-4
  348. - Add cyrillic patches from leon@geon.donetsk.ua (#47144)
  349. * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-3
  350. - Fix "Alt+AltGr=Compose" in qwertz-keyboards
  351. * Mon Jun 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-2
  352. - Fix "make install" and init script (#45327)
  353. * Sat Jun 16 2001 Than Ngo <than@redhat.com>
  354. - update to 1.0.6
  355. - use %%{_tmppath}
  356. - use find_lang
  357. - support new gettext
  358. - remove some patch files, which are included in 1.0.6
  359. - fix to use RPM_OPT_FLAGS
  360. * Thu May 3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-3
  361. - Fix up resizecons
  362. * Wed May 2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-2
  363. - Build everything, obsoletes console-tools
  364. - s/Copyright:/License:/
  365. - License is GPL, not just distributable
  366. - Add our compose mappings from old console-tools
  367. - Add triggerpostun -- console-tools magic to get sane fonts and mappings
  368. * Tue Apr 17 2001 Erik Troan <ewt@redhat.com>
  369. - initial packaging for kbdrate