kdbg-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155
  1. Summary: KDbg - a graphical user interface to gdb
  2. Summary(ja): GDB のグラフィカルユーザインターフェイス
  3. Name: kdbg
  4. Version: 2.5.4
  5. Release: 1%{?_dist_release}
  6. License: GPL+
  7. Group: Applications/Development
  8. URL: http://www.kdbg.org/
  9. Source: http://download.sourceforge.net/kdbg/%{name}-%{version}.tar.gz
  10. Patch0: kdbg-2.5.1-icons.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: cmake
  13. BuildRequires: desktop-file-utils
  14. BuildRequires: gettext
  15. BuildRequires: kdelibs4-devel
  16. Requires(post): desktop-file-utils
  17. Requires(postun): desktop-file-utils
  18. Requires: gdb
  19. Requires: xterm
  20. %description
  21. KDbg is a K Desktop Environment (KDE) GUI for gdb, the GNU debugger.
  22. KDbg provides the programmer with an intuitive interface for setting
  23. breakpoints, inspecting variables, and stepping through code. KDbg
  24. requires X and KDE to be installed in order to run.
  25. %prep
  26. %setup -q
  27. %patch0 -p1 -b .icons
  28. %build
  29. # don't install icons, which are included in oxygen-icon-theme
  30. rm -f kdbg/pics/*action-debug-run*
  31. mkdir -p %{_target_platform}
  32. pushd %{_target_platform}
  33. %{cmake} \
  34. -DCMAKE_BUILD_TYPE=release \
  35. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  36. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  37. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  38. -DKDE_DISTRIBUTION_TEXT="%{version}-%{release} Vine Linux" \
  39. ..
  40. popd
  41. make %{?_smp_mflags} -C %{_target_platform}
  42. %install
  43. rm -rf $RPM_BUILD_ROOT
  44. make DESTDIR=$RPM_BUILD_ROOT install/fast -C %{_target_platform}
  45. %clean
  46. rm -rf $RPM_BUILD_ROOT
  47. %post
  48. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  49. touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
  50. %postun
  51. if [ $1 -eq 0 ] ; then
  52. update-desktop-database -q &> /dev/null
  53. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  54. touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
  55. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  56. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
  57. fi
  58. %posttrans
  59. update-desktop-database -q &> /dev/null
  60. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  61. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
  62. %files
  63. %defattr(-,root,root)
  64. %doc BUGS ChangeLog* COPYING README TODO ReleaseNotes-*
  65. %{_bindir}/kdbg
  66. %{_datadir}/applications/kde4/*
  67. %{_datadir}/kde4/apps/%{name}
  68. %{_datadir}/icons/*/*/*/*
  69. %{_datadir}/locale/*
  70. %config (noreplace) %{_datadir}/config/kdbgrc
  71. %doc %{_docdir}/HTML/*
  72. %changelog
  73. * Sat Jan 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.5.4-1
  74. - updated to 2.5.4
  75. - built on current VineSeed
  76. * Fri Apr 16 2010 Shu KONNO <owa@bg.wakwak.com> 2.1.1-3
  77. - rebuilt without smp option
  78. - added BR: arts-devel
  79. * Wed Mar 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.1-2
  80. - rebuilt with new toolchain
  81. - added %%post, %%postun and %%posttrans section
  82. - added Patch0 from Fedora
  83. * Fri Feb 27 2009 Than Ngo <than@redhat.com> - 2.1.1-1
  84. - fix build issue against gcc-4.4
  85. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.1-1
  86. - applied new versioning policy, spec in UTF-8
  87. - new upstream release
  88. * Sun Dec 30 2007 Shu KONNO <owa@bg.wakwak.com> 2.0.4-0vl3
  89. - changed configure to %%configure
  90. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.4-0vl2
  91. - rebuild for VineSeed
  92. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.4-0vl1
  93. - new upstream release
  94. - update URL
  95. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.0-0vl1
  96. - new upstream release
  97. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl3
  98. - rebuild with kde-3.4.0 (VineSeed)
  99. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl2
  100. - rebuild with kde-3.4.0 (Vine3.1)
  101. * Fri Oct 22 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl1
  102. - source upgrade
  103. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.9-0vl2
  104. - use License tag
  105. - rebuild with qt-3.3.2 and kde-3.2.2
  106. * Sun Sep 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.9-0vl1
  107. - source upgrade
  108. - change spec to build with gcc-3.2.3
  109. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
  110. - source upgrade
  111. - change spec to build with gcc295
  112. - change make option for SMP and add script
  113. * Sun Jun 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.7-0vl2
  114. - rebuild with qt-3.1.2 and kde-3.1.2
  115. * Tue Mar 3 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.7-0vl1
  116. - source upgrade
  117. - build with qt-3.1.1 and kde-3.1
  118. * Mon Oct 14 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.6-0vl1
  119. - source upgrade
  120. - build with qt-3.0.5 and kde-3.0.4
  121. * Tue Aug 6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
  122. - first release