kdepim3-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596
  1. Name: kdepim3
  2. Summary: Compatibility support for kdepim3
  3. Version: 3.5.10
  4. Release: 4%{?_dist_release}
  5. URL: http://www.kde.org/
  6. Group: Applications/Productivity
  7. License: GPLv2
  8. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.bz2
  9. Patch0: kdepim-3.5.10-gcc.patch
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: bison
  12. BuildRequires: desktop-file-utils
  13. BuildRequires: flex
  14. BuildRequires: kdelibs3-devel >= %{version}
  15. BuildRequires: libart_lgpl-devel
  16. BuildRequires: cyrus-sasl-devel
  17. BuildRequires: gpgme-devel
  18. BuildRequires: libXpm-devel libXScrnSaver-devel
  19. BuildRequires: zlib-devel
  20. BuildRequires: python-devel
  21. #BuildRequires: libmal-devel
  22. #BuildRequires: pilot-link-devel >= 0.9.5
  23. %description
  24. %{summary}, including libkcal.
  25. %package libs
  26. Summary: Runtime files for %{name}
  27. Summary(ja): %{name} のランタイムライブラリ
  28. Group: System Environment/Libraries
  29. Requires: kdelibs3 >= %{version}
  30. %description libs
  31. %{summary}, including libkcal.
  32. %package devel
  33. Summary: Development files for %{name}
  34. Summary(ja): %{name} の開発用ファイル
  35. Group: Development/Libraries
  36. Requires: %{name}-libs = %{version}-%{release}
  37. Requires: kdelibs3-devel
  38. %description devel
  39. Development files for %{name}.
  40. Install %{name}-devel if you want to write or compile %{name} plugins.
  41. %prep
  42. %setup -q -n kdepim-%{version}
  43. %patch0 -p1 -b .gcc47
  44. %build
  45. unset QTDIR || : ; . /etc/profile.d/qt.sh
  46. %configure \
  47. --with-qt-libraries=$QTDIR/lib \
  48. --enable-new-ldflags \
  49. --disable-dependency-tracking \
  50. --disable-rpath \
  51. --disable-debug --disable-warnings \
  52. --enable-final \
  53. --includedir=%{_includedir}/kde \
  54. --with-gpg=%{_bindir}/gpg \
  55. --with-gpgsm=%{_bindir}/gpgsm \
  56. --with-sasl \
  57. --without-gnokii \
  58. --without-mal \
  59. --without-pilot-link
  60. for lib in ktnef libkmime libemailfunctions libkcal libkdepim; do
  61. make %{?_smp_mflags} -C ${lib}
  62. done
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. for lib in ktnef libkmime libemailfunctions libkcal libkdepim; do
  66. make install DESTDIR=$RPM_BUILD_ROOT -C $lib
  67. done
  68. #unpackaged files
  69. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  70. rm -f $RPM_BUILD_ROOT%{_libdir}/libkdepim*
  71. rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/libkdepim/
  72. rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/kdepimwidgets/
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/kde3/plugins/designer/*
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/lib{kmime,ktnef}.so
  75. rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/ktnef/
  76. rm -rf $RPM_BUILD_ROOT%{_datadir}/applications
  77. rm -rf $RPM_BUILD_ROOT%{_datadir}/icons
  78. rm -rf $RPM_BUILD_ROOT%{_datadir}/mimelnk
  79. rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/ktnef
  80. rm -f $RPM_BUILD_ROOT%{_bindir}/ktnef
  81. %post libs -p /sbin/ldconfig
  82. %postun libs -p /sbin/ldconfig
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %files libs
  86. %defattr(-,root,root)
  87. %doc README korganizer/COPYING
  88. %{_datadir}/config.kcfg/pimemoticons.kcfg
  89. %{_datadir}/apps/libical/
  90. %{_datadir}/services/kresources/kcal*
  91. %{_libdir}/libkcal.so.2*
  92. %{_libdir}/kde3/kcal*
  93. %{_libdir}/libkmime.so.2*
  94. %{_libdir}/libktnef.so.1*
  95. %files devel
  96. %defattr(-,root,root)
  97. %{_includedir}/kde/kdepimmacros.h
  98. %{_includedir}/kde/libemailfunctions
  99. %{_includedir}/kde/libkcal
  100. %{_libdir}/libkcal.so
  101. %changelog
  102. * Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.10-4
  103. - rebuild with gcc-5.4.0
  104. * Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-3
  105. - added Patch0 from fc
  106. - not link to libmal and pilot-link
  107. * Sat May 26 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-2
  108. - rebuilt with rpm-4.8.1-3
  109. - added BR: arts-devel
  110. * Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
  111. - updated to 3.5.10
  112. - built with new toolchain
  113. * Sat Sep 5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
  114. - renamed kdepim3
  115. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  116. - applied new versioning policy, spec in UTF-8
  117. - added Japnaese summary
  118. * Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  119. - rebuild for VineSeed
  120. * Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  121. - new upstream release
  122. * Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  123. - rebuild for VineSeed
  124. * Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  125. - new upstream release
  126. - remove all patches
  127. * Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  128. - new upstream release
  129. - add Patch0, 1 , 2 and 3
  130. * Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
  131. - added --with-qt-libraries and --enable-libsuffix option
  132. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  133. - rebuild for VineSeed
  134. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  135. - new upstream release
  136. * Mon Sep 4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
  137. - rebuild with pilot-link-0.12.0-0vl1
  138. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  139. - rebuild for VineSeed
  140. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  141. - new upstream release
  142. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  143. - rebuild for VineSeed
  144. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  145. - new upstream release
  146. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  147. - rebuild for VineSeed
  148. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  149. - new upstream release
  150. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  151. - rebuild for VineSeed
  152. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  153. - new upstream release
  154. - delete BuildPrereq: libmal-devel and Requires: libmal
  155. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
  156. - rebuild for VineSeed
  157. * Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
  158. - new upstream release
  159. * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
  160. - new upstream release
  161. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
  162. - new upstream release
  163. - delete all patches
  164. - add Requires: kdeaccessibility >= %%{version}
  165. - add --enable-indexlib to configure option
  166. * Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
  167. - new upstream release
  168. - remove Patch0
  169. - add Patch0 - Patch1
  170. * Tue Aug 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
  171. - rebuild for VineSeed
  172. * Tue Aug 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
  173. - new upstream release
  174. - remove Patch0
  175. - add BuildPrereq: gpgme-devel >= 0.4.5
  176. - add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
  177. * Mon Jul 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
  178. - rebuild for VineSeed
  179. - add --disable-rpath to configure option
  180. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
  181. - new upstream release (delete old patch and add new security patch)
  182. - use %%{?_smp_mflags} for make option
  183. * Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
  184. - rebuild for VineSeed
  185. * Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
  186. - new upstream release
  187. - add patch0
  188. * Fri Mar 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
  189. - new upstream release (3.4.0-rc1)
  190. * Tue Feb 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
  191. - new upstream release
  192. * Wed Feb 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
  193. - new upstream release
  194. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  195. - rebuild for VineSeed
  196. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  197. - new upstream release
  198. * Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  199. - source upgrade
  200. - update %%files
  201. - all sub-packages are integrated into main package (exclude devel)
  202. * Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
  203. - rebuild with qt32
  204. * Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
  205. - source upgrade
  206. - remove lines about vine26
  207. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  208. - source upgrade
  209. - update %%files
  210. * Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  211. - source upgrade
  212. - update %%description
  213. - add Obsoletes: kdenetwork < 3.2.0
  214. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
  215. - rebuild for VineSeedPlus
  216. * Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
  217. - source upgrade
  218. - build for VinePlus/2.6
  219. - (VinePlus/2.6) BuildPrereq: autoconf258
  220. - remove Patch
  221. * Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
  222. - build for VineSeed with new toolchain and qt-3.2.3
  223. - add configure option --with-xinerama --enable-final
  224. * Sun Nov 2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
  225. - rebuild with qt-3.2.1-0.26vl3
  226. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
  227. - rebuild with qt-3.2.1-0vl3
  228. * Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
  229. - build with gcc-3.2.3
  230. * Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
  231. - source upgrade
  232. - BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
  233. * Sat Aug 2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
  234. - rebuild for Vine2.6
  235. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
  236. - source upgrade
  237. - change spec to build with gcc295
  238. - change make option for SMP and add script
  239. - add BuildPrereq: libmal-devel
  240. - add Requires: libmal for pilot
  241. * Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  242. - source upgrade
  243. - remove Patch800 (included in this source)
  244. - built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
  245. * Sat Apr 5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  246. - source upgrade
  247. - change spec to build both VineSeed and Vine2.5/2.6
  248. - revised description and files section
  249. - remove source900
  250. - add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
  251. - add patch800 (Kdeveloper:02753)
  252. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  253. - objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
  254. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  255. - source upgrade
  256. * Wed Oct 9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
  257. - rebuild with qt-3.0.5-0vl1
  258. - BuildPrereq: autoconf253 objprelink2
  259. * Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  260. - source upgrade
  261. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
  262. - source upgrade
  263. - add BuildPrereq: autoconf252 automake15
  264. * Thu Jul 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
  265. - merged with rawhide 3.0.1-1
  266. - change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
  267. - add Requires: for each package
  268. - There is Vine's previous changes, hacked for Vine
  269. -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  270. - build for VineSeed
  271. - delete Epoch
  272. - objprelink (i386 only)
  273. * Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
  274. - 3.0.1
  275. - fixed bug #67303
  276. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  277. - automated rebuild
  278. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  279. - automated rebuild
  280. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
  281. - Rename libraries
  282. * Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
  283. - Fix #61901
  284. * Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
  285. - final
  286. * Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
  287. - Update
  288. - Fix build on ia64
  289. * Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
  290. - Update, fixes korganizer (#50006)
  291. * Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  292. - Update to get rid of abbrowser (moved to kdebase)
  293. * Thu Feb 22 2001 Than Ngo <than@redhat.com>
  294. - add missing ldconfig in %post anf %postun again
  295. - clean up specfile
  296. * Wed Feb 21 2001 Than Ngo <than@redhat.com>
  297. - 2.1-respin
  298. - fix dangling symlink
  299. - remove excludearch ia64, some hacks to build on ia64
  300. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  301. - 2.1
  302. * Mon Feb 5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  303. - Update
  304. * Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  305. - Update
  306. * Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  307. - Update to CVS
  308. - Enable building kpilot
  309. - Obsolete kpilot
  310. - Don't exclude ia64, use -O0 on ia64
  311. - Disable building kpilot on ia64 (compiler breakage)
  312. * Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  313. - 2.0 final
  314. * Wed Oct 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  315. - 2.0
  316. * Sun Oct 1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  317. - new CVS
  318. - fix installation of fonts
  319. * Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  320. - new CVS snapshot
  321. - fix up spec file
  322. * Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  323. - get rid of the 3d-screensavers package - now that qt-GL is part of qt,
  324. there's no need to keep them separate to avoid the dependency.
  325. * Mon Aug 21 2000 Than Ngo <than@redhat.com>
  326. - fix gnome-session so that KDE2 can be started from gdm
  327. - pam/kde2 instead pam/kde to avoid problem with KDE1
  328. - don't requires qt-GL, It's now in qt
  329. * Sun Aug 20 2000 Than Ngo <than@redhat.com>
  330. - fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
  331. at the same time
  332. - add missing ldconfig in %post anf %postun
  333. - fix for reading config files in /etc/X11/xdm, add Xsession to requires
  334. * Tue Aug 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  335. - Fix keytable in konsole (Bug #15682)
  336. * Sun Aug 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  337. - rebuild, now that kdelibs2 works on alpha
  338. - use the same ugly hack to get kdebase to compile
  339. - remove ksysguard on alpha (even more compiler problems)
  340. * Fri Aug 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  341. - new snapshot (fixed libGL detection in CVS)
  342. * Wed Aug 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  343. - move to /usr/lib/kde2
  344. - new snapshot
  345. * Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  346. - fix the --xdmdir arg to be correct (oops)
  347. * Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  348. - move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
  349. * Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  350. - new snapshot
  351. - some fixes to spec file
  352. * Tue Jul 18 2000 Than Ngo <than@redhat.de>
  353. - rebuilt against glibc-2.1.92-14, gcc-2.96-40
  354. * Sun Jul 16 2000 Than Ngo <than@redhat.de>
  355. - use new snapshot
  356. - disable Motif
  357. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  358. - use gcc 2.96
  359. - new snapshot
  360. * Sun Jul 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  361. - Epoch 3
  362. - Update to current
  363. - Use egcs++
  364. * Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  365. - Update (I put the fixes directly to CVS rather than collecting them
  366. in the spec)
  367. * Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  368. - remove man2html; we get that from man
  369. - new snapshot
  370. * Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  371. - new snapshot
  372. - ExcludeArch ia64 for now
  373. - remove gnome .desktop file, we get it from gnome-core now.
  374. * Wed Apr 5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  375. - remove dependency on xpm (now in XFree86)
  376. * Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  377. - new snapshot
  378. - move it to /usr, where it belongs
  379. * Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  380. - Build the OpenGL screensavers, and move them to a separate package
  381. - Improve the spec file (BuildPrereqs etc.)
  382. * Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  383. - remove patch #3 (obsoleted by kwin)
  384. * Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
  385. - 2.0 CVS snapshot
  386. - fix compilation
  387. * Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
  388. - clean up files in /tmp from startkde
  389. - mark doc files as such
  390. * Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
  391. - start autorun if present in startkde
  392. - check for configured soundcard before running sound services
  393. * Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
  394. - made kdelnks display Name property if they are of type Link
  395. * Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
  396. - moved png handling here (from kdelibs)
  397. - changed low color icon directory name to locolor
  398. * Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
  399. - added optional session management to logout dialog
  400. - include GNOME menus
  401. * Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
  402. - added link to /etc/X11/applnk, .directory file
  403. - included lowcolor icon sub-package
  404. - enable .desktop file access
  405. * Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
  406. - customized startkde script to set up user environment if not present.
  407. - mention kthememgr in description.
  408. * Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
  409. - upgraded to 1.1.2 release
  410. - kvt is back
  411. - kde icon included
  412. - linux console fonts included
  413. * Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
  414. - PAM console logout problem solved.
  415. * Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
  416. - now includes screensaver password security fix
  417. * Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
  418. - snapshot, includes kde 1.1.1 + fixes
  419. - kvt removed for security reasons. It is a steaming pile of...
  420. * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
  421. - last snapshot before release
  422. * Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
  423. - today's snapshot makes kfm a bit nicer and some other fixes
  424. - moved default rc files to kdesupport
  425. * Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
  426. - SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
  427. * Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
  428. - built with today's snapshot -- had to rebuild to fix pam problems.
  429. * Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
  430. - new snapshot fixes mimetype video/x-flic problem
  431. * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
  432. - latest stable snapshot
  433. * Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
  434. - removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
  435. - this previous connection and autoselect kdebase for upgrade).
  436. * Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
  437. - moved gdm patch
  438. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  439. - added gdm session control file
  440. * Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
  441. - added pam-console stuff to kde pam file
  442. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  443. - Injected new description and group.
  444. * Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
  445. - upgraded to KDE 1.1 final.
  446. * Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
  447. - updated macros for RPM 3.0, removed red hat logo.
  448. * Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
  449. - re-merged from Duncan Haldane's stuff