kdevplatform-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227
  1. %define kde KDE4
  2. Name: kdevplatform
  3. Summary: Libraries for use by %{kde} development tools
  4. Summary(ja): %{kde} 開発ツールが使用するライブラリ
  5. Version: 1.7.0
  6. Release: 1%{?_dist_release}
  7. Group: Development/Tools
  8. License: GPLv2
  9. URL: http://www.kdevelop.org/
  10. Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.7.0/src/kdevplatform-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: libboost-devel
  13. BuildRequires: gettext
  14. BuildRequires: kdelibs-devel >= 4.6
  15. BuildRequires: kdesdk-devel >= 4.6
  16. BuildRequires: pcre-devel
  17. BuildRequires: subversion-devel
  18. BuildRequires: apr-util-devel
  19. BuildRequires: soprano-devel
  20. BuildRequires: qjson-devel
  21. BuildRequires: grantlee-devel
  22. Requires: %{name}-libs = %{version}-%{release}
  23. Requires(postun): gtk2
  24. Requires(posttrans): gtk2
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. %{kde} Development platform, the foundations upon which
  29. KDevelop and Quanta are built.
  30. %package libs
  31. Summary: Runtime libraries for %{name}
  32. Summary(ja): %{name} のランタイムライブラリ
  33. Group: System Environment/Libraries
  34. Requires: kdelibs
  35. %description libs
  36. %{summary}.
  37. %package devel
  38. Summary: Developer files for %{name}
  39. Summary(ja): %{name} の開発用ファイル
  40. Group: Development/Libraries
  41. Requires: %{name}-libs = %{version}-%{release}
  42. Requires: libboost-devel
  43. Requires: commoncpp2-devel
  44. Requires: kdelibs-devel
  45. Requires: subversion-devel
  46. %description devel
  47. %{summary}.
  48. %prep
  49. %setup -q -n kdevplatform-%{version}
  50. %build
  51. mkdir -p %{_target_platform}
  52. pushd %{_target_platform}
  53. %cmake \
  54. -DCMAKE_BUILD_TYPE=release \
  55. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  56. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  57. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  58. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  59. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  60. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  61. ..
  62. popd
  63. make %{?_smp_mflags} -C %{_target_platform}
  64. %install
  65. rm -rf %{buildroot}
  66. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  67. %find_lang %{name} --all-name --with-kde
  68. %clean
  69. rm -rf %{buildroot}
  70. %post
  71. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  72. %posttrans
  73. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  74. %postun
  75. if [ $1 -eq 0 ] ; then
  76. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  77. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  78. fi
  79. %post libs -p /sbin/ldconfig
  80. %postun libs -p /sbin/ldconfig
  81. %files -f %{name}.lang
  82. %defattr(-,root,root,-)
  83. %doc COPYING.PLUGINS COPYING.SRC
  84. %{_bindir}/kdev_dbus_socket_transformer
  85. %{_bindir}/kdev_format_source
  86. %{_bindir}/kdevplatform_shell_environment.sh
  87. %{_libdir}/kde4/imports/org/kde/%{name}
  88. %{_libdir}/kde4/plugins/grantlee/0.3/kdev_filters.so
  89. %{_datadir}/config/kdevappwizard.knsrc
  90. %{_datadir}/config/kdevfiletemplates.knsrc
  91. %{_datadir}/kde4/apps/kdev*/
  92. %{_datadir}/kde4/apps/plasma/plasmoids
  93. %{_datadir}/kde4/services/*.desktop
  94. %{_datadir}/kde4/servicetypes/*.desktop
  95. %{_datadir}/icons/hicolor/*/*/*
  96. %files libs
  97. %defattr(-,root,root,-)
  98. %{_libdir}/lib*.so.*
  99. %{_libdir}/kde4/*.so
  100. %files devel
  101. %defattr(-,root,root,-)
  102. %{_libdir}/lib*.so
  103. %{_includedir}/kde4/%{name}/
  104. %{_libdir}/cmake/%{name}/
  105. %changelog
  106. * Sun Jan 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.7.0-1
  107. - new upstream release
  108. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.0-1
  109. - new upstream release
  110. - add BuildRequires: grentlee-devel
  111. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-2
  112. - rebuild with libboost-1.54.0
  113. * Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-1
  114. - new upstream release
  115. * Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
  116. - new upstream release
  117. - add BuildRequires: qjson-devel
  118. * Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-1
  119. - new upstream release
  120. * Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.3-1
  121. - new upstream release
  122. * Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.0-2
  123. - add BuildRequires: soprano-devel
  124. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  125. - new upstream release
  126. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.1.2-1
  127. - new upstream release
  128. - added Japanese summary
  129. * Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
  130. - removed R: kdevplatform from libs package
  131. * Sat May 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
  132. - Initial build for Vine Linux
  133. * Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-1
  134. - kdevplatform-1.0.0
  135. * Sat Apr 17 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.10.2-1
  136. - kdevplatform-0.10.2
  137. * Thu Apr 08 2010 Rex Dieter <rdieter@fedoraproject.org. - 0.10.0-1
  138. - kdevplatform-0.10.0
  139. * Mon Mar 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.99-1
  140. - kdevplatform-0.9.99
  141. * Mon Feb 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.98-1
  142. - kdevplatform-0.9.98
  143. * Sat Jan 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.97-2
  144. - rebuild (boost)
  145. - BR: kdelibs4-devel
  146. * Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> 0.9.97-1
  147. - kdevplatform-0.9.97
  148. - kdevplatform: file conflict with kdelibs (FindKDevPlatform.cmake) (#541690)
  149. * Sun Nov 22 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.95-0.6.20091015svn1035382
  150. - rebuild (fc13+, qt-4.6.0-rc1)
  151. * Thu Oct 15 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.5.20091015svn1035382
  152. - New snapshot
  153. * Sun Oct 11 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.4.beta5
  154. - Fix finding Kompare includes
  155. * Tue Sep 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.3.beta5
  156. - Use official release
  157. * Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.2
  158. - Add icon scriptlets
  159. * Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.1
  160. - Update tarball
  161. * Fri May 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.93-0.1
  162. - 1.0 Beta 3
  163. * Sat Feb 21 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.91-0.2.20090221svn929301
  164. - Post KDevplatform 1.0 Beta 1 snapshot
  165. * Fri Jan 09 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.85-1
  166. - 0.9.85 snapshot