kdf-vl.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899
  1. Name: kdf
  2. Summary: File device viewer
  3. Summary(ja): ファイルデバイスビューアー
  4. Version: 4.14.3
  5. Release: 2%{?_dist_release}
  6. License: GPLv2
  7. Group: Applications/Accessories
  8. URL: https://www.kde.org/
  9. Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: kdelibs-devel >= %{version}
  12. BuildRequires: soprano-devel
  13. # when split occurred
  14. Conflicts: kdeutils < 4.8.0
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. Kdiskfree is displays the available file devices (hard drive
  19. partitions, floppy and CD drives, USB sticks, etc) along with
  20. information on their capacity, free space, type and mount point.
  21. It also allows you to mount and unmount drives and view them in
  22. a file manager.
  23. %prep
  24. %setup -q
  25. %build
  26. mkdir -p %{_target_platform}
  27. pushd %{_target_platform}
  28. %cmake \
  29. -DCMAKE_BUILD_TYPE=release \
  30. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  31. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  32. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  33. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  34. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  35. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  36. ..
  37. popd
  38. make %{?_smp_mflags} -C %{_target_platform}
  39. %install
  40. rm -rf %{buildroot}
  41. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  42. %post
  43. /sbin/ldconfig
  44. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  45. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  46. %posttrans
  47. update-desktop-database -q &> /dev/null ||:
  48. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  49. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  50. %postun
  51. if [ $1 -eq 0 ] ; then
  52. /sbin/ldconfig
  53. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  54. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  55. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  56. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  57. update-desktop-database -q &> /dev/null ||:
  58. fi
  59. %files
  60. %doc COPYING
  61. %{_bindir}/%{name}
  62. %{_bindir}/kwikdisk
  63. %{_libdir}/kde4/*.so
  64. %{_datadir}/applications/kde4/%{name}.desktop
  65. %{_datadir}/applications/kde4/kwikdisk.desktop
  66. %{_datadir}/icons/hicolor/*/*/*
  67. %{_datadir}/icons/oxygen/*/*/*
  68. %{_datadir}/kde4/apps/%{name}
  69. %{_datadir}/kde4/services/*.desktop
  70. %{_docdir}/HTML/en/%{name}
  71. %{_docdir}/HTML/en/kcontrol
  72. %changelog
  73. * Fri Jul 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
  74. - rebuild with gcc-5.4.0
  75. * Fri Jan 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
  76. - initila build