keyutils-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define vermajor 1
  3. %define verminor 6
  4. %define version %{vermajor}.%{verminor}
  5. %define libapivermajor 1
  6. %define libapiversion %{libapivermajor}.6
  7. %define libdir /%{_lib}
  8. %define usrlibdir %{_prefix}/%{_lib}
  9. Summary: Linux Key Management Utilities
  10. Summary(ja): Linux 鍵管理ユーティリティ
  11. Name: keyutils
  12. Version: %{version}
  13. Release: 1%{?_dist_release}
  14. Group: System Environment/Base
  15. License: GPLv2+ and LGPLv2+
  16. Distribution: Vine Linux
  17. Vendor: Project Vine
  18. URL: http://people.redhat.com/~dhowells/keyutils/
  19. Source0: http://people.redhat.com/~dhowells/keyutils/keyutils-%{version}.tar.bz2
  20. ExclusiveOS: Linux
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: glibc-kernheaders >= 2.4-9.1.92
  23. Requires: %{name}-libs = %{version}-%{release}
  24. %description
  25. Utilities to control the kernel key management facility and to provide
  26. a mechanism by which the kernel call back to userspace to get a key
  27. instantiated.
  28. %package libs
  29. Summary: Key utilities library
  30. Summary(ja): 鍵管理ユーティリティのライブラリ
  31. Group: System Environment/Libraries
  32. %description libs
  33. This package provides a wrapper library for the key management facility system
  34. calls.
  35. %package libs-devel
  36. Summary: Development package for building linux key management utilities
  37. Summary(ja): Linux 鍵管理ユーティリティの開発ファイル
  38. Group: Development/Libraries
  39. Requires: %{name}-libs = %{version}-%{release}
  40. %description libs-devel
  41. This package provides headers and libraries for building key utilities.
  42. %package -n compat32-%{name}-libs
  43. Summary: Key utilities library
  44. Summary(ja): 鍵管理ユーティリティのライブラリ
  45. Group: System Environment/Libraries
  46. Requires: %{name}-libs = %{version}-%{release}
  47. %description -n compat32-%{name}-libs
  48. This package provides a wrapper library for the key management facility system
  49. calls.
  50. %package -n compat32-%{name}-libs-devel
  51. Summary: Development package for building linux key management utilities
  52. Summary(ja): Linux 鍵管理ユーティリティの開発ファイル
  53. Group: Development/Libraries
  54. Requires: compat32-%{name}-libs = %{version}-%{release}
  55. Requires: %{name}-libs-devel = %{version}-%{release}
  56. %description -n compat32-%{name}-libs-devel
  57. This package provides headers and libraries for building key utilities.
  58. %prep
  59. %setup -q
  60. %build
  61. make \
  62. NO_ARLIB=1 \
  63. LIBDIR=%{libdir} \
  64. USRLIBDIR=%{usrlibdir} \
  65. BINDIR=%{_bindir} \
  66. SBINDIR=%{_sbindir} \
  67. RELEASE=.%{release} \
  68. NO_GLIBC_KEYERR=1 \
  69. CFLAGS="-Wall $RPM_OPT_FLAGS -Werror"
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. make \
  73. NO_ARLIB=1 \
  74. DESTDIR=$RPM_BUILD_ROOT \
  75. LIBDIR=%{libdir} \
  76. USRLIBDIR=%{usrlibdir} \
  77. BINDIR=%{_bindir} \
  78. SBINDIR=%{_sbindir} \
  79. install
  80. mkdir -p %{buildroot}%{_libdir}
  81. mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %post libs -p /sbin/ldconfig
  85. %postun libs -p /sbin/ldconfig
  86. %if %{build_compat32}
  87. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  88. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  89. %endif
  90. %files
  91. %defattr(-,root,root,-)
  92. %license LICENCE.GPL
  93. %doc README
  94. %{_sbindir}/*
  95. %{_bindir}/*
  96. %{_datadir}/keyutils
  97. %{_mandir}/man1/*
  98. %{_mandir}/man5/*
  99. %{_mandir}/man8/*
  100. %config(noreplace) %{_sysconfdir}/*
  101. %files libs
  102. %defattr(-,root,root,-)
  103. %license LICENCE.LGPL
  104. %{_mandir}/man7/*
  105. %{libdir}/libkeyutils.so.*
  106. %files libs-devel
  107. %defattr(-,root,root,-)
  108. %{usrlibdir}/libkeyutils.so
  109. %{usrlibdir}/pkgconfig/*
  110. %{_includedir}/*
  111. %{_mandir}/man3/*
  112. # compat32
  113. %if %{build_compat32}
  114. %files -n compat32-%{name}-libs
  115. %defattr(-,root,root,-)
  116. %{libdir}/libkeyutils.so.*
  117. %files -n compat32-%{name}-libs-devel
  118. %defattr(-,root,root,-)
  119. %{usrlibdir}/libkeyutils.so
  120. %{usrlibdir}/pkgconfig/*
  121. %endif
  122. %changelog
  123. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6-1
  124. - new upstream release.
  125. * Mon Dec 22 2014 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.9-1
  126. - updated to 1.5.9
  127. - rebuilt on current VineSeed
  128. * Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2-4
  129. - rebuilt with new toolchains
  130. * Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-3
  131. - added compat32 package for x86_64 arch support
  132. * Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2-2
  133. - changed libs subpackage's Group to System Environment/Libraries
  134. - changed devel subpackage's Group to Development/Libraries
  135. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
  136. - initial build for Vine Linux
  137. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2-3
  138. - Autorebuild for GCC 4.3
  139. * Tue Aug 22 2006 David Howells <dhowells@redhat.com> - 1.2-1
  140. - Remove syscall manual pages (section 2) to man-pages package [BZ 203582]
  141. - Don't write to serial port in debugging script
  142. * Mon Jun 5 2006 David Howells <dhowells@redhat.com> - 1.1-4
  143. - Call ldconfig during (un)installation.
  144. * Fri May 5 2006 David Howells <dhowells@redhat.com> - 1.1-3
  145. - Don't include the release number in the shared library filename
  146. - Don't build static library
  147. * Fri May 5 2006 David Howells <dhowells@redhat.com> - 1.1-2
  148. - More bug fixes from Fedora reviewer.
  149. * Thu May 4 2006 David Howells <dhowells@redhat.com> - 1.1-1
  150. - Fix rpmlint errors
  151. * Mon Dec 5 2005 David Howells <dhowells@redhat.com> - 1.0-2
  152. - Add build dependency on glibc-kernheaders with key management syscall numbers
  153. * Tue Nov 29 2005 David Howells <dhowells@redhat.com> - 1.0-1
  154. - Add data pipe-in facility for keyctl request2
  155. * Mon Nov 28 2005 David Howells <dhowells@redhat.com> - 1.0-1
  156. - Rename library and header file "keyutil" -> "keyutils" for consistency
  157. - Fix shared library version naming to same way as glibc.
  158. - Add versioning for shared library symbols
  159. - Create new keyutils-libs package and install library and main symlink there
  160. - Install base library symlink in /usr/lib and place in devel package
  161. - Added a keyutils archive library
  162. - Shorten displayed key permissions list to just those we actually have
  163. * Thu Nov 24 2005 David Howells <dhowells@redhat.com> - 0.3-4
  164. - Add data pipe-in facilities for keyctl add, update and instantiate
  165. * Fri Nov 18 2005 David Howells <dhowells@redhat.com> - 0.3-3
  166. - Added stdint.h inclusion in keyutils.h
  167. - Made request-key.c use request_key() rather than keyctl_search()
  168. - Added piping facility to request-key
  169. * Thu Nov 17 2005 David Howells <dhowells@redhat.com> - 0.3-2
  170. - Added timeout keyctl option
  171. - request_key auth keys must now be assumed
  172. - Fix keyctl argument ordering for debug negate line in request-key.conf
  173. * Thu Jul 28 2005 David Howells <dhowells@redhat.com> - 0.3-1
  174. - Must invoke initialisation from perror() override in libkeyutils
  175. - Minor UI changes
  176. * Wed Jul 20 2005 David Howells <dhowells@redhat.com> - 0.2-2
  177. - Bump version to permit building in main repositories.
  178. * Tue Jul 12 2005 David Howells <dhowells@redhat.com> - 0.2-1
  179. - Don't attempt to define the error codes in the header file.
  180. - Pass the release ID through to the makefile to affect the shared library name.
  181. * Tue Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-3
  182. - Build in the perror() override to get the key error strings displayed.
  183. * Tue Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-2
  184. - Need a defattr directive after each files directive.
  185. * Tue Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-1
  186. - Package creation.