kmid2-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209
  1. %if %{?_dist_release} == "vl5"
  2. %define kde KDE4
  3. %else
  4. %define kde KDE
  5. %endif
  6. Name: kmid2
  7. Summary: A MIDI/karaoke player for %{kde}
  8. Summary(ja): %{kde} 向け MIDI/カラオケプレーヤー
  9. Version: 2.4.0
  10. Release: 2%{?_dist_release}
  11. Group: Applications/Multimedia
  12. # GPLv2+ for the code and the MMA examples, CC-BY-SA for the MIDI examples
  13. License: GPLv2+ and CC-BY-SA
  14. URL: http://userbase.kde.org/KMid2
  15. Source0: http://downloads.sourceforge.net/project/%{name}/%{version}/kmid-%{version}.tar.bz2
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: kdelibs4-devel
  18. #BuildRequires: kde-filesystem
  19. BuildRequires: cmake
  20. BuildRequires: alsa-lib-devel
  21. BuildRequires: drumstick-devel >= 0.3
  22. BuildRequires: soprano-devel
  23. BuildRequires: gettext
  24. BuildRequires: desktop-file-utils
  25. #{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api}}
  26. #{?_kde4_version:Requires: kdelibs4%{?_isa} >= %{_kde4_version}}
  27. Requires: oxygen-icon-theme
  28. Requires: drumstick >= 0.3
  29. Requires: %{name}-libs = %{version}-%{release}
  30. Obsoletes: kmid < 2.0-1
  31. Provides: kmid = %{version}-%{release}
  32. %description
  33. KMid2 is a MIDI/karaoke file player, with configurable midi mapper, real
  34. Session Management, drag & drop, customizable fonts, etc. It has a very
  35. nice interface which let you easily follow the tune while changing the
  36. color of the lyrics.
  37. It supports output through external synthesizers, AWE, FM and GUS cards.
  38. It also has a keyboard view to see the notes played by each instrument.
  39. %package libs
  40. Summary: Runtime libraries for %{name}
  41. Summary(ja): %{name} のランタイムライブラリ
  42. Group: System Environment/Libraries
  43. License: GPLv2+
  44. #{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api}}
  45. #{?_kde4_version:Requires: kdelibs4%{?_isa} >= %{_kde4_version}}
  46. %description libs
  47. %{summary}.
  48. %package devel
  49. Summary: Development files for %{name}
  50. Summary(ja): %{name} の開発用ファイル
  51. Group: Development/Libraries
  52. License: GPLv2+
  53. Requires: %{name}-libs = %{version}-%{release}
  54. Obsoletes: kmid-devel < 2.0-1
  55. Provides: kmid-devel = %{version}-%{release}
  56. %description devel
  57. %{summary}.
  58. %prep
  59. %setup -q -n kmid-%{version}
  60. # zap bundled copy of drumstick to guarantee it's never used
  61. rm -rf drumstick
  62. %build
  63. mkdir -p %{_target_platform}
  64. pushd %{_target_platform}
  65. %cmake \
  66. -DCMAKE_BUILD_TYPE=release \
  67. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  68. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  69. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  70. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  71. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  72. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  73. ..
  74. popd
  75. make %{?_smp_mflags} -C %{_target_platform}
  76. %install
  77. rm -rf %{buildroot}
  78. make install DESTDIR=%{buildroot} -C %{_target_platform}
  79. desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/kmid.desktop
  80. %find_lang kmid
  81. %clean
  82. rm -rf %{buildroot}
  83. %post
  84. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  85. update-desktop-database &> /dev/null || :
  86. %postun
  87. update-desktop-database &> /dev/null || :
  88. if [ $1 -eq 0 ] ; then
  89. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  90. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  91. fi
  92. %posttrans
  93. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  94. %post libs -p /sbin/ldconfig
  95. %postun libs -p /sbin/ldconfig
  96. %files -f kmid.lang
  97. %defattr(-,root,root,-)
  98. %doc ChangeLog COPYING README TODO
  99. %{_bindir}/kmid
  100. %{_datadir}/dbus-1/interfaces/*.xml
  101. %{_datadir}/kde4/apps/kmid/
  102. %{_datadir}/kde4/apps/kmid_part/kmid_part.rc
  103. %{_datadir}/applications/kde4/kmid.desktop
  104. %{_datadir}/config.kcfg/*
  105. %{_datadir}/kde4/services/*
  106. %{_datadir}/kde4/servicetypes/*
  107. %{_datadir}/icons/hicolor/*/apps/*
  108. %{_libdir}/kde4/*
  109. %doc %{_docdir}/HTML/*/kmid/
  110. %files libs
  111. %defattr(-,root,root,-)
  112. %{_libdir}/libkmidbackend.so.*
  113. %files devel
  114. %defattr(-,root,root,-)
  115. %{_libdir}/libkmidbackend.so
  116. %{_includedir}/kde4/kmid/
  117. %changelog
  118. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.4.0-2
  119. - rebuild with gcc-5.4.0
  120. * Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.0-1
  121. - update to 2.4.0
  122. - remove Patch0 (kmid-2.3.0-kde#240394.patch)
  123. - add BuildRequires: soprano-devel
  124. * Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3.0-4
  125. - removed --with-kde from %%find_lang
  126. * Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3.0-3
  127. - Initial build for Vine Linux
  128. * Fri May 28 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.3.0-2
  129. - Fix crash in ALSA backend due to reloadDeviceList (kde#240394, upstream patch)
  130. * Fri May 28 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.3.0-1
  131. - Update to 2.3.0 (new versioning scheme)
  132. - BR drumstick-devel >= 0.3
  133. - Requires: drumstick >= 0.3
  134. - Drop obsolete drumstick-version patch
  135. - Examples now partly CC-BY-SA, partly GPLv2+ (instead of CC-BY)
  136. - Use _kde4_version macro
  137. - Add -devel and -libs subpackages
  138. - Package COPYING
  139. * Tue Feb 09 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.1-2
  140. - Requires: drumstick >= 0.2.99-0.3
  141. * Tue Feb 09 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.1-1
  142. - Update to 0.2.1
  143. - Drop upstreamed timidity-pulseaudio patch
  144. - Drop dont-translate-output-names patch, should not be needed anymore
  145. - BR drumstick-devel >= 0.2.99-0.3 (0.2.1 needs the 20100208 snapshot)
  146. - relax drumstick version check in CMakeLists.txt as 0.3 is not out yet
  147. * Fri Feb 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-3
  148. - Don't translate output names, breaks autospawning sequencers
  149. * Sun Jan 31 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-2
  150. - Support PulseAudio when autospawning TiMidity++ (-OO -opulse switches)
  151. * Sun Jan 31 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-1
  152. - Update to 0.2.0
  153. - The examples with copyright issues have been dropped by upstream
  154. - BR drumstick-devel instead of aseqmm-devel
  155. * Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-4
  156. - Fix the kde4-config output parsing for 4.4 ("KDE Development Platform:")
  157. * Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-3
  158. - Correctly require at least the kdelibs version used for building
  159. * Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-2
  160. - Remove nonsense Requires: kdelibs4 >= %%{version}, as %%{version} is 0.1.1
  161. * Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-1
  162. - First Fedora package, replaces kmid