konq-plugins-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282
  1. # The 4.6.1 tarball is missing all documentation, keep the old one for now.
  2. %global docversion 4.4.0
  3. Name: konq-plugins
  4. Summary: Additional plugins that interact with konqueror
  5. Version: 4.6.1
  6. Release: 3%{?_dist_release}
  7. Group: Applications/Internet
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://extragear.kde.org
  10. Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/konq-plugins-%{version}.tar.bz2
  11. Source1: ftp://ftp.kde.org/pub/kde/stable/%{docversion}/src/extragear/konq-plugins-%{docversion}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. ## upstream patches
  14. BuildRequires: cmake
  15. BuildRequires: gettext
  16. BuildRequires: kdebase4-devel >= %{version}
  17. BuildRequires: libtidy-devel
  18. BuildRequires: soprano-devel
  19. #{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
  20. Requires: kdebase4 >= %{version}
  21. %description
  22. Some additional plugins that interact with konqueror
  23. * adblock: AdBlock plugin
  24. * akregator: Add feeds directly to akregator (kdepim is needed)
  25. * autorefresh: Refresh websites after a specifig period
  26. * babelfish: Translate a website with babelfish
  27. * crashes: Crash monitor
  28. * dirfilter: Filter the current directory in many ways
  29. * domtreeviewer: Displays the document object model in a box
  30. * fsview: Graphical Disk Usage for inode/directory
  31. * imagerotation: service menu to image operations
  32. * khtmlsettingsplugin: Enable/disable some HTML settings
  33. * kimggalleryplugin: Creates an HTML page with thumbnails of
  34. all the images in the current directory.
  35. * mediarealfolder: service menu to open a medium mountpoints
  36. * minitools: Implement bookmarklets into konqueror
  37. * rellinks: Allows access to relations defined in the header of a document
  38. * searchbar: Search Bar
  39. * sidebar: a small embedded mediaplayer, for songs/video preview
  40. * smbmounter: provides two menus items to smbmount/umount samba shares
  41. * uachanger: Change the user agent for websites
  42. * validators: Website validators
  43. * webarchiver: Web Archiver
  44. %prep
  45. %setup -q -a 1
  46. # use documentation from the old tarball
  47. mv -f %{name}-%{docversion}/doc* .
  48. tail -n 2 %{name}-%{docversion}/CMakeLists.txt >>CMakeLists.txt
  49. rm -rf %{name}-%{docversion}
  50. %build
  51. mkdir -p %{_target_platform}
  52. pushd %{_target_platform}
  53. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  54. %cmake \
  55. -DCMAKE_BUILD_TYPE=release \
  56. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  57. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  58. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  59. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  60. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  61. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  62. ..
  63. popd
  64. make %{?_smp_mflags} -C %{_target_platform}
  65. %install
  66. rm -rf %{buildroot}
  67. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  68. # don't install kwebkitpart stuff on RHEL
  69. #rm -rf %{buildroot}%{_kde4_appsdir}/kwebkitpart/
  70. #find_lang %{name}
  71. #--with-kde
  72. %clean
  73. rm -rf %{buildroot}
  74. %post
  75. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  76. touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
  77. %postun
  78. if [ $1 -eq 0 ] ; then
  79. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  80. touch --no-create %{_datadir}/icons/oxygen &> /dev/null
  81. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  82. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
  83. fi
  84. %posttrans
  85. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  86. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
  87. #-f %{name}.lang
  88. %files
  89. %defattr(-,root,root,-)
  90. %doc COPYING COPYING.DOC COPYING.LIB README
  91. %{_bindir}/fsview
  92. %{_datadir}/config/translaterc
  93. # co-owned with kdepim, since there's no shared dep
  94. %{_datadir}/kde4/apps/akregator/
  95. %{_datadir}/kde4/apps/dolphinpart/kpartplugins/*
  96. %{_datadir}/kde4/apps/domtreeviewer/
  97. %{_datadir}/kde4/apps/fsview/
  98. %{_datadir}/kde4/apps/khtml/kpartplugins/*
  99. %{_datadir}/kde4/apps/konqueror/icons/*
  100. %{_datadir}/kde4/apps/konqueror/kpartplugins/*
  101. %{_datadir}/kde4/apps/konqueror/opensearch/*
  102. %{_datadir}/kde4/apps/kwebkitpart/kpartplugins/*
  103. %{_datadir}/config.kcfg/validators.kcfg
  104. %{_datadir}/kde4/services/*.desktop
  105. %{_datadir}/kde4/services/ServiceMenus/*.desktop
  106. %{_datadir}/icons/hicolor/*/*/*
  107. %{_datadir}/icons/oxygen/*/*/*
  108. %{_libdir}/kde4/*.so
  109. %{_docdir}/HTML/*/konq-plugins
  110. %changelog
  111. * Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.6.1-3
  112. - add BuildRequires: soprano-devel
  113. * Mon Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.1-2
  114. - initial build for Vine Linux
  115. * Sat Mar 05 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.1-1
  116. - update to 4.6.1, fixes file conflict with kde-l10n
  117. - drop upstreamed patches
  118. - use documentation from 4.4.0 because it's missing in 4.6.1
  119. - drop old commented-out translation-finding code
  120. - drop no longer needed BR webkitpart-devel, code uses abstract interfaces now
  121. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.0-7
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  123. * Tue Oct 26 2010 Alexey Kurov <nucleo@fedoraproject.org> - 4.4.0-6
  124. - Fix the window.close regression in adblock (kde#253921)
  125. * Tue Sep 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-5
  126. - Embeddable Image Viewer permanently messes up status bar (kde#234624)
  127. * Tue Sep 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-4
  128. - ftbfs qt47 issues (#599830)
  129. * Tue Feb 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-3
  130. - Requires: kdebase4 (it's not multilib'd, no need for arch'd dep)
  131. * Sat Feb 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.4.0-2
  132. - backport upstream patch to fix BabelFish plugin WebKitPart support (#564552)
  133. * Fri Feb 12 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-1
  134. - konq-plugins-4.4.0 for real
  135. * Thu Feb 11 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-0.1.20100211
  136. - home-brew konq-plugins-4.4.0 (20100211 create_tarball.rb snapshot)
  137. * Thu Dec 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-5
  138. - BR libtidy-devel (Fedora only)
  139. * Thu Dec 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-4
  140. - fix build with KDE 4.3.80's version of webkitkde (upstream patch)
  141. * Wed Nov 25 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-3
  142. - rebuild for Qt 4.6.0 RC1 in F13 (was built against Beta 1 with unstable ABI)
  143. * Mon Nov 09 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.3-2
  144. - BR: webkitpart-devel >= 0.0.2
  145. * Sat Nov 07 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.3-1
  146. - 4.3.3
  147. * Mon Oct 26 2009 Than Ngo <than@redhat.com> - 4.3.1-3
  148. - rhel cleanup
  149. * Sun Sep 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-2
  150. - BR: webkitpart-devel
  151. - use %%find_lang --all-names --with-kde
  152. - Requires: kdebase4%%{_?isa} >= %%version
  153. * Tue Sep 01 2009 Sebastian Vahl <svahl@fedoraproject.org> - 4.3.1-1
  154. - 4.3.1
  155. - use scriplet for HTML docdirs
  156. * Tue Aug 11 2009 Sebastian Vahl <fedora@deadbabylon.de> 4.3.0-1
  157. * KDE 4.3.0
  158. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.3-2
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  160. * Fri May 08 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.3-1
  161. - 4.2.3
  162. * Tue Apr 7 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
  163. - KDE 4.2.2
  164. * Wed Mar 25 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-4
  165. - fixup handbook install
  166. - optimize scriptlets
  167. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-3
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  169. * Wed Feb 18 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-2
  170. - update %%description
  171. - Requires: kdebase4 >= 4.2
  172. * Fri Jan 23 2009 Than Ngo <than@redhat.com> - 4.2.0-1
  173. - 4.2.0
  174. * Mon Jan 05 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.3-4
  175. - make install/fast
  176. - jpegorient is not installed (#478736, kdebug#178612)
  177. * Sun Dec 14 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.3-3
  178. - rebuild for Python 2.6 (contains Python bytecode despite no dependencies)
  179. * Tue Nov 11 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.1.3-2
  180. - include adblock language files
  181. * Tue Nov 11 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.1.3-1
  182. - 4.1.3
  183. * Sat Oct 04 2008 Than Ngo <than@redhat.com> 4.1.2-1
  184. - 4.1.2
  185. * Fri Aug 29 2008 Than Ngo <than@redhat.com> 4.1.1-1
  186. - 4.1.1
  187. * Thu Aug 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.1.0-2
  188. - fix data files from akregator plugin not getting installed
  189. * Wed Aug 06 2008 Rex Dieter <rdieter@fedoraproject.org> - 4.1.0-1
  190. - 4.1.0
  191. - drop searchbar-crash patch (no longer needed with Konqueror 4.1)
  192. * Sun May 04 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.0.3-0.3.20080409svn
  193. - fix searchbar plugin crash (#445144)
  194. * Wed Apr 16 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.0.3-0.2.20080409svn
  195. - rebuild because of corrupt PPC RPM causing signing failure (#442761)
  196. * Wed Apr 09 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.3-0.1.20080409svn
  197. - new svn checkout
  198. - some minor spec cleanups
  199. - License: GPLv2+ and LGPLv2+
  200. - drop icons patch
  201. * Tue Apr 01 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.2-0.2.20080303svn
  202. - rebuild for NDEBUG and _kde4_libexecdir
  203. - enhance %%description a bit
  204. * Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.2-0.1.20080303svn
  205. - new svn checkout (for KDE 4.0.2)
  206. - update cmakelists patch
  207. - remove icons patch (not needed anymore)
  208. - add "svn" to release
  209. * Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.1-0.2.20080214svn
  210. - added konq-plugins-4.0.1-icons.patch
  211. - add .po files to tarball
  212. * Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.1-0.1.20080213svn
  213. - initial version